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About this document
Purpose of this document

This document is designed to guide you through the webEdition installation and 
upgrade processes.

You can use this manual to learn:
• what you need to do or have before installing or upgrading webEdition
• how to install webEdition
• how to upgrade webEdition
• how to back up and restore your webEdition files and database

Audience
This document treats the webEdition installation process; as such it is intended for 
system administrators who have a basic knowledge of the following protocols and 
systems:
• file transfer protocol (ftp)
• hypertext markup language (http)
• PHP
• MySQL

This document also contains procedures (such as backup and restore that can be 
performed by
• webEdition administrators
• webEdition editors

The webEdition customer documentation suite
The documentation team publishes new webEdition documents to support the release 
of all webEdition features, modules and enhancements. 

You can consult our documentation suite for detailed information about the modules 
you have purchased or about living-e products that you may wish to purchase in the 
future. All customer documentation is available in portable document format (PDF) on 
http://www.living-e.de/en/products/webEdition/documentation.php.
Installation, update and backup procedures
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On-line reference documentation
The webEdition customer documentation suite comprises the following books, all of 
which you can obtain at the following URLs: 

http://www.living-e.de/en/products/webEdition/documentation.php

Standard webEdition documentation
The following books support the webEdition Standard suite:
• The webEdition User Guide 
• The webEdition Installation, Update and Backup Guide
• The webEdition Tag Reference

Documentation for webEdition modules 
The following books support the webEdition modules:
• The Banner Module User Guide
• The Customer Management and Customer Management PRO Module User Guide
• The Database/Object Module User Guide
• The Export Module User Guide
• The Newsletter Module User Guide
• The Scheduler and Scheduler PRO Module User Guide 
• The Shop Module User Guide 
• The Task Messaging Module User Guide
• The User Management and User Management PRO Module User Guide
• The Voting Module User Guide
• The Workflow Module User Guide

What precautionary messages mean
webEdition documents include attention and caution messages, which are designed to 
draw your attention to important instructions.

Attention boxes
An attention box identifies information that is necessary for the proper performance of 
a specified task. For example:

ATTENTION
You must have the appropriate permissions in your user profile to 
complete this procedure. Permissions are assigned to you by your 
webEdition system administrator. Contact your webEdition system 
administrator for further details.
Standard   5.0.1   June 2007  
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Caution boxes
Caution messages indicate that there are possible risks to your software or database if 
you perform a specified task without taking the suggested appropriate precautions. For 
example:

How commands, system responses and we:tags are represented
The commands, system responses and webEdition tags (called we:tags) used in this 
document conform to the following conventions.

Web interface commands
Commands performed through a Web browser are shown in italic typeface. For 
example:

Click on the Save button.

Menu-based commands performed in a Web browser are shown in italic typeface. 
Drop-down or nested menu commands are separated by an input prompt (>). For 
example:

Select Customers > New from the main menu of the Customer Management Module. 

webEdition tags and template code
The webEdition templates use a specialized set of programming tags based on the PHP 
programming language. These webEdition tags or we:tags are displayed in courier 
typeface and in angled brackets:

Opening tags appear thus: <we:tag/>

Closing tags appear thus: </we:tag>

The programming code used in webEdition templates is also represented in this 
document by courier typeface:

<we:sessionStart/>
<we:ifRegisteredUser>
Hello: <we:sessionField Last name="user name" type="print"/><br> 
Logged in
</we:ifRegisteredUser>

Attribute variables
Attributes and variables appear in courier italic typeface. For example: 

<we:hidden name="attribute1">

CAUTION 
Database warning
If you complete this procedure, your database will be 
overwritten.
Installation, update and backup procedures
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How to check the document version and issue
The information on the title page of this document indicates the version and issue for 
this publication. The version and issue also appear in the footer on every 
even-numbered page. 

The first two digits in the document numbering scheme indicate the version. The 
version number increases each time the document is updated to support a new software 
release. For example, the first release of a document is 01.01. In the next software 
release cycle, the first release of the same document is 02.01.

The second two digits in the document numbering scheme indicate the issue. The issue 
number increases each time the document is revised and re-released in the same 
software release cycle. For example, the second release of a document in the same 
software release cycle is 01.02.

Customer service
For further information about webEdition, please consult our website, or contact our 
customer service department

For International customers, please see:
• Web Page:http://www.living-e.de/en
• E-mail:

— Technical support: support@living-e.de
— Sales: sales@living-e.de
— Information/Help: info@living-e.de

For North American customers, please see:
• Web Page:http://www.living-e.com/
• E-mail:

— Technical support: support@living-e.de
— Sales: sales@living-e.de
— Information/Help: info@living-e.de
Standard   5.0.1   June 2007  
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1  Introduction
Thank you for purchasing the webEdition content management system (CMS)! This 
booklet is designed to help you to familiarize yourself with the new features that are 
available in webEdition Version 4.0.1, and to guide you through the installation and 
upgrade procedures.

1.1  What documentation is available?
In addition to this Guide, webEdition Version 4.0.1 includes a suite of documentation 
that is available at the following URL: 
http://www.living-e.de/en/products/webEdition/documentation.php 

For a list of the available documentation, see "The webEdition customer documentation 
suite" on page 11.

1.2  Installation and upgrade overview
Table 1 outlines the procedures discussed in this guide. Select the procedure that suites 
your current situation.

Table 1  Installation and upgrade paths

If you are ..and you wish to go to 

new to webEdition install Version 5.0 for the first time Procedure 1,  "Installation 
with the webEdition 
installer" on page 25

upgrading from Version 
4.1.1.9

install Version 5.0. for the first time Procedure 3,  "Updating 
webEdition" on page 36

upgrading from Version 4.x install Version 5.0 for the first time you first have to update to 
4.1.1.9

upgrading from Version 3.x install Version 5.0 for the first time you first have to update to 
4.1.1.9

currently using Version 5.0 backup and restore version 5.0 Procedure 4,  "Backing up 
your database" on page 41
Installation, update and backup procedures
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1.3  What’s next
The remaining chapters of this document are intended to assist you in the following 
processes:
• installation
• upgrade
• backup and restore
• rebuilding webEdition pages

currently using Version 5.0 move your files to another ISP or 
database server

Procedure 4,  "Backing up 
your database" on page 41 
and after that to Procedure 
6,  "Rebuilding your web 
pages" on page 45

currently using Version 5.0 install webEdition modules Section 3.4.3,  "Installation 
of modules" on page 37

Table 1  Installation and upgrade paths

If you are ..and you wish to go to 
Standard   5.0.1   June 2007  
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2  Getting started
2.1  What does the webEdition software package contain?

The webEdition software contains the following components:
• webEdition Installer Programme
• Manual
• License Agreement

2.2  Getting started
2.2.1  Compatible operating systems and browsers

You operate the webEdition content management system using your computer and your 
browser.

Below is the list of compatible operating systems and the browsers that you can use to 
operate webEdition:
•  Microsoft Windows 95/98/Me/NT4/2000/XP/2003 Server:

— Microsoft Internet Explorer (version 4.0 or higher)
— Netscape Navigator (version 4.0 or higher)
— Mozilla from version 1 (WYSIWYG from version 1.3)

• MacOS 9
— Mozilla 1.3 (Download at webEdition.biz)

• MacOS X
— Mozilla ab version 1 (WYSIWYG from version 1.3)
— Safari (version 1.1 or higher)
— Netscape Navigator (version 4.0 or higher)

• Linux
— Mozilla ab version 1 (WYSIWYG from version 1.3)
— Netscape Navigator (version 4.0 or higher)
Installation, update and backup procedures
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•  FreeBSD 4.8+
— Mozilla 1.4

•  OpenBSD
— Mozilla 1.3

•  AIX 4.3.3+
— Mozilla 1.3

•  Open VMS
— Mozilla 1.3

•  HPUX 10.20+
—  Mozilla 1.3

•  Solaris 2.6+/7.0+/8.0+/9.0+/
— Mozilla 1.3

•  Solaris x86 9.0+
— Mozilla 1.4

•  OS/2
— Mozilla 1.3

•  Tru64 Unix (OSF 5.0)
— Mozilla 1.3

•  BeOS
— Mozilla 1.2

We cannot guarantee the functioning of webEdition with other browsers.

2.2.1.1  Browser requirements for WYSIWYG editing
If you wish to use webEdition’s what-you-see-is-what-you-get (WYSIWYG) 
text-editing feature, you must use one of the following browsers.
• Microsoft Internet Explorer, version 5.5 or higher
• Mozilla Browser (version 1.3 or higher)
Standard   5.0.1   June 2007  
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2.2.1.2  Limitations
The following limitations can occur if you use Netscape Navigator to programme your 
web site with layers (DHTML):
• WebEdition Edit window is not visible. 

— The problem occurs only with Netscape 4.X. (The application functions 
properly with Netscape 6.)

— The problem also occurs if the layer appears directly after the <body>-tag.  If 
the layers appear further down (before the closing </body-tag>), the Edit 
window functions normally.

— The problem always occurs if an entry field (<we:input...) appears within a layer 
(and also if these layers appear further down on the page). In these cases the Edit 
window is not visible.

• Graphics with the use of the Apple Macintosh operating systems
— Because of the smaller memory allocation for the browser, problems with 

graphics can occur such that the Explorer Menu is available, but not visible. 
Action: Perform a reload or increase the memory allocation for the browser.

• living-e AG cannot guarantee the operation of webEdition with Netscape 4.78.

2.3  Installation requirements
In order to install webEdition on a web server, you have to meet the following 
installation requirements:
• PC (min. Windows 95) or Mac (OS 9.x or OS X) for installation with the Installer 

Programme. Manual installation is possible with all systems, including Linux.

Note:   If you work with a Linux PC, or if the Installer Programme fails to 
function on your system, you can also install webEdition using your browser. 
Downoad the Windows version of the Installer Program and unzip the files. Go 
to the "files" directory, and copy the "weinstall" directory in binary mode to the 
root-directory of your web server.  This is the directory which contains your files 
and your index.html file. Enter the following setup script into your browser: 
http://www.yourdomain.com/weinstall/setup.php. If your webserver does not 
recognize .php as a PHP4 setting, you can complete the process using setup.php4 
or setup.phtml. Thereafter, follow the on-screen instructions.

• Installation CD-ROM or download version of webEdition
• Access to an FTP server, PHP4, and an MySQL database (either local, or from a 

service provider. With local installation, the domain name is "localhost")

Note:  At present we only guarantee 100% functionality starting from PHP 4.0.6. 
The configuration variable "register_globals" has to be set to "On". This was the 
standard setting in all versions prior to PHP 4.2. If you use PHP 4.2 you have to 
set this in the php.ini file (register_globals = On;). Likewise, the configuration 
variable "allow_url_fopen" has to be set to "On". To our knowledge most of the 
ISPs offer these as standard settings. Furthermore, the ISP has to allow 
PHP-Scripts as executables in any directory; not just within a specific directory 
(e.g. cgi-bin).
Installation, update and backup procedures
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• Your own domain (www.domainname.com) or IP-address. A local installation via 
"localhost" is also possible.

Note:  webEditon cannot be installed into a subdirectory

• The web Server (Apache or IIS) needs to have write-access permissions to the root 
directory.

Note:  The root directory is the directory which holds the index.html (and/or 
default.htm). In order to be able to install and use webEdition the web server has 
to have the write permission into the root directory. Many ISPs separate the FTP 
user and the web server in separate accounts (2 different users). Usually the root 
directory belongs to the FTP account. In that case the web server may not be able 
to write into the root directory, unless it has the neccessary permissions (chmod 
777). If so it is important to disable the "safe_mode" of PHP during the 
installation of webEdition. If you do not know how to change these settings 
please contact your ISP or system administrator.

• You require 20 MB hard disc space; the same amount of hard disc space is required 
for the MySQL database.

• Internet access during registration and installation. 

Note:  If you are not able to install webEdition because your system is protected by 
a firewall or in a private network, please contact us. We have a special webEdition 
installer ("Firewallinstaller") available.

2.4  Pre-installation checklist
Here are the things you must have at hand before beginning installation:
1. The webEdition installer (available at 

http://www.living-e.de/en/webEdition/download/download.php).
2. A little time, since the installation may take between 8 and 20 minutes, depending 

on the speed of your Internet connection.
3. Documentation from your service provider. You require information about the 

server and the software running on it.
4. Your webEdition serial number (to register the full version of webEdition).

ATTENTION
Users of Windows MySQL Servers: If the MySQL server prohibits 
the "FLUSH TABLES" function, and PHP cannot run as a 
CGI-Version, an error occurs while changing classes (in the 
Database/Object Module), and while importing a backup file with 
user data (an import without user data functions properly). If a 
MySQL server is run on UNIX, there is no problem, even if the web 
server is running on Windows. We are aware of this problem, and we 
shall find a solution as soon as possible.
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5. A little imagination, since the names given to databases, passwords, etc. differ 
greatly from provider to provider. Here is a brief summary of the names used by 
the major providers:

6. If you wish to use the thumbnail graphics function in webEdition, make sure that 
your hosting provider has included the gd library in their PHP package.

webEdition Service providers

Password password, pw, db_password (for databases)

User name user name, user, db_user (for databases)

Server host, db_host (for databases)
Installation, update and backup procedures
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3  Installing webEdition
This chapter treats the following topics:
• "Installation overview"
• "What will be installed?"
• "Installing webEdition on your web server"
• "Registration/Installation of updates and modules"
• "Starting webEdition"
• "Selecting your language"
• "Getting help"

3.1  Installation overview
Unlike software applications you use every day on your computer, webEdition is to be 
installed on a server, not on your computer. Your computer is merely the agent you use 
to install webEdition on your provider's server. The server comprises the domain you 
wish to manage using the webEdition system. After installation, webEdition is easily 
managed using your Web browser.

You will require a connection to the Internet. You must be able to establish a connection 
first to the download server, and secondly to the server on which you will install 
webEdition.

The installation process comprises the following general steps Figure 1,  "Software 
installation overview" on page 3-24: 
1. The basic installation, which involves only the Demo-version.

To perform the process you must download the webEdition Installer. You can 
download the webEdition Installer from our website at 
http://www.living-e.de/en/products/webEdition/download/download.php.

2. Registration and module installation.

CAUTION 

Read this chapter before you install webEdition on 
your server.
Installation, update and backup procedures



24   Installing webEdition 
3. FTP of files to your web server
4. Administration of your website using your browser.

Figure 1  Software installation overview

3.2  What will be installed?
The following new directories will be created in the root directory of your web server:
• /we_demo
• /webEdition

Note:  The directory /we_demo contains the example files for webEdition and can be 
deleted after installation if, for example, the space on the server is needed.

3.3  Installing webEdition on your web server
There are two ways to install webedition on your web server:
• use the webEdition Installer (see Section 3.3.1 on page 3-24)
• install webEdition manually (see Section 3.3.2 on page 3-32)

3.3.1  Installation with the webEdition Installer
For those re-installing webEdition, please read the following precautionary message:

PHP
MySQL

Web server
FTP

ISP

Web interface

3. FTP files

4. HTTP
webEdition administrator

webEdition Software 
Download server

Registration server

1. Download
software 

2. Register

CAUTION 
Database warning
With each new installation of webEdition, all previous 
installations and the contents of the database will be 
completely deleted and over-written. If you have made 
changes to the source code, you should safeguard these 
changes prior to installation.
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Procedure 1  Installation with the webEdition installer

On your local computer
1 Insert CD or open the download folder.
2 Double-click the installer logo.

The Start screen of the Installer appears. See Figure 2.

Figure 2  Installer start screen

3 Select webEdition as Application to be installed and click the Next Button
The license agreement screen opens (see Figure 7). 

4 Now, select your extension for PHP scripts. This should usually be .php, so you can keep 
the default setting

5 Enter the domain name in which webEdition is to be installed.
Installation, update and backup procedures
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Figure 3  Entering a domain name

6 Enter the FTP access data that you have received from your service provider. 
Remember that for many providers, the access to the server (Host) can be something other 
than the normal domain name (for example, ftp.yourdomain.com instead of 
www.yourdomain.com). See Figure 4

Figure 4  Entering FTP access parameters

The file OnlineInstaller.php is uploaded and the installation will now continue in your default 
browser
Standard   5.0.1   June 2007  
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7 You may now select a different installation language. Click next and accept the Online 
Installation notes

8 You may now enter the proxy server settings, if your server accesses the internet via a 
proxy server.

Figure 5  Proxy Server settings

9 After clicking Next, the connection of your server will be checked. If your server is able to 
connect to the living-e server, the installation will proceed with a check of your cookie and 
session settings. If the test are positive, procedd by clicking next
The neccessary files will now be copied to your server - the window will change to blue

Figure 6  File transfer
Installation, update and backup procedures



28   Installing webEdition 
10 Read the License Agreement.
11 Check the box beside the statement General license conditions accepted to accept the 

license agreement, and click on next.

Note:  If you do not accept the agreement, you will not be able to install webEdition.

Figure 7  License agreement

12 For many servers the DOCUMENT_ROOT must now be entered. The DOCUMENT_ROOT  
is the Root directory in which one finds the index.html file and all other directories needed 
for your Internet presence. The installer automatically recognizes whether the 
DOCUMENT_ROOT has been supplied by the server, and displays it in blue script. If the 
system displays the correct path (and generally it does), you do not have to enter anything. 
If however, the server has returned no DOCUMENT_ROOT, the correct path must be 
entered in the provided field. In this case the installer searches to find the path for you, and 
it then writes this automatically in the input field. 
Click Next to continue.
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Figure 8  Entering the DOCUMENT_ROOT

13 After clicking next, the system requirements (namely PHP version and write permissions) 
are checked.

14 Now enter your MySQL access data. Normally, these details are available from your web 
service provider. 
You can now enter a table prefix for your webEdition installation, thus making it possible to 
install multiple webEdition licenses on one database server.
Click on Next to continue.

Figure 9  Entering your MySQL access data
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15 If you have already installed webEdition on this server (that is, if a webEdition directory 
already exists), the following message appears:

Figure 10  Installation notification

16 Enter now your username and password for login in the corresponding fields.

Figure 11  Enter username and password

Note:  The user you have entered here is automatically the administrator.

Click Next You can now select additional languages and which version to install

If you have a serial number of webEdition, you can enter it now or later from within the 
system
The system installs the database and the required files. You can watch the progress in the 
blue progress bar.

Figure 12  Installation progress
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Upon completion of the installation, the following screen appears:

Figure 13  Installation complete message

17 The installation is now completed. You will always find the login screen for webEdition 
under the following URL: http://www.yourdomain.com/webEdition (or 
http://www.yourdomain.com/webEdition/index.php with the final file extension .php4 or 
.phtml).

Note:  Please note the uppercase “E” in webEdition.

Figure 14  The webEdition log in screen

18 Congratulations! You have successfully completed the installation procedure.
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3.3.2  Manual installation process
For those re-installing webEdition, please read the following precautionary message:

Procedure 2  Manual installation

On your local computer
1 Use an FTP programme to transfer the file OnlineInstaller.php from the FTP installation 

directory into the root directory of your web server.
The root directory is the directory in which the index.html and all of your 
webpages/directories are stored.

2 Enter the setup script in your browser using the following URL: 
http://www.yourdomain.com/OnlineInstaller.php
If your server does not recognize the .php extension you can also enter setup.php4 or 
setup.phtml.

3 If you install webEdition on a server on which a version of webEdition already exists, you 
will see the following screen (in contrast to what is depicted above in the automated 
procedure in Figure 10,  "Installation notification" on page 3-30):

Figure 15  Manual installation notification

4 Click Next to continue.
5 Read the License Agreement. Check the box beside the statement I agree to the licensing 

terms to accept the license agreement, then click Continue.

CAUTION 
Risk of losing data
With each new installation of webEdition, all previous 
installations and the contents of the database will be 
completely deleted and over-written. If you have made 
changes to the source code, you should safeguard these 
changes prior to installation.

ATTENTION
Make sure that the files are transferred in binary mode (regardless of the file 
extension). A file transfer using text mode can result in errors.
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Figure 16  Manual installation, License agreement

Note:  If you do not accept the agreement, you will not be able to install webEdition.
6 Continue the installation as described above from Step 12 in Section 1,  "Installation with 

the webEdition installer,".
7 You have completed the installation procedure.
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3.4  Registration/Installation of updates and modules
3.4.1  Registration

In order to register your version of webEdition, do one of the following steps:
• Either click on Help > Register....(See Figure 17)

Figure 17  Registering your software

• Or click the Register Button during the first log in (see Figure 18):

Figure 18  Register during installation

The following window opens:

Figure 19  Register during first login
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Figure 20  Entering your software serial number

Please enter the serial number that you received via email from your webEdition 
Customer Care representative. Click next.

The following window appears if you have purchased webEdition modules in addition 
to the webEdition Standard Version:

Figure 21  Selecting the webEdition modules to install

All modules purchased with your license have a checkbox beside the module name. In 
order to install these modules, you must activate these checkboxes. When all of the 
desired checkboxes have been activated, click on next.

By clicking the next button, the system begins to register webEdition and to install the 
selected modules.
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Figure 22  Requesting a backup prior to installation

If you have already saved some data in webEdition, it is advisable that you make a back 
up before registering. By clicking on the yes button, a backup will be carried out; if you 
click on the no button, the system will take you directly to the Information screen.

Information about the number of installations which have been completed with your 
serial number and all specifications about the modules you have licensed are listed in 
our database and are associated with your serial number. This means that you always 
have to be online during an installation. If you purchase a license for an additional 
domain or an additional module, we add the respective element in our database. All you 
have to do is to be online, start the installer anew, enter your serial number and select 
the option you want.

3.4.2  Update
If you have already registered your version of webEdition, you will see the menu option 
Update... under the Help menu. (If you have not registered your version of webEdition, 
you will see the menu option Register.)

Figure 23  Update/Module installation option

If a new version of webEdition is available, an update is recommended. You can 
determine whether an update is required by examining the second and third part of the 
version number (for example, 3.0.0.1, 3.1). Updates can only be completed if the 
version number is higher than that which you have already installed. 

Procedure 3  Updating webEdition

in the webEdition main screen
1 Click on the Update....

The following screen opens: 
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Figure 24  The Update/Module installation screen

2 In order to search for a new version of webEdition, click on the search button. If there is a 
new version, a window will open in which all available updates are indicated. Click the next 
button in this window. 

Note:  If you have already worked with webEdition and its update function, and have 
placed data in the database, it is recommended that you make a backup before the 
update. Should the connection be broken during the update or another error occur, your 
existing data can be restored from your backup files. Without a backup, you have no way 
of reproducing the current state of your work.

The update process starts

3 After the completion of the update process, the following window appears:

Figure 25  The webEdition information screen: update completed

4 Click the OK button at the bottom of the window. Thereupon, webEdition will shut down. 
Please log in once again.

5 The update process is finished.

3.4.3  Installation of modules
If you have already installed and registered webEdition, and if at a later date you 
purchase modules, you must likewise install the modules using the Live Update tool. To 
install modules, you click Modules > Module Installation in the Modules menu.

ATTENTION
If, after an update, your pages do not function properly, perform a 
rebuild on all of your pages, including templates.
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Figure 26  The module installation menu

The module installation window opens. All modules appear in a list in the Module 
installation window. There is a checkbox beside each module name. Activate the 
checkboxes beside the modules that you would like to install and then click next.

Figure 27  Module Installation Window

The module installation process from this point follows the same steps as the Update 
process.

3.4.3.1  Editor-Plugin
The installation of the Editor-Plugin will be described in a separate document because 
the Editor-Plugin cannot be installed using the webEdition Installer. For further details, 
see the README.pdf document accompanying the Editor-Plugin module.

3.4.4  Using a proxy server
If your web server requires a proxy server to create a connection to the Internet (as in 
the case of a corporate network, or intranet for example), select Options > Preferences 
> Proxy Server. The Proxy server settings screen opens, in which you can enter the 
necessary data.

ATTENTION
If the registration, update, or module installation process is 
interrupted for any reason, begin the process again. The system will 
remember the status of the update.
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Figure 28  Proxy server settings

3.5  Starting webEdition
To access your website in webEdition, enter the following URL (where yourdomain is 
the name you selected during the installation process): 
http://www.yourdomain.com/webEdition.

Note:  Please note that there is an uppercase "E" in webEdition.

Enter the user name and password that you created during the installation process.

On the left, you will see the explorer menu in its usual location. If you look in the 
we_demo directory, you will find our sample Web site. This site will help you to 
understand how webEdition works. All the examples in this manual are based on our 
sample website.

3.6  Selecting your language
Choose Options > Preferences... or Preferences from the Quickstart menu and choose 
your language under the user interface tab.

Figure 29  Selecting your language
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Select your desired language.

Save your preferences. After saving your preferences, the webEdition display changes 
to the language you selected.

3.7  Getting help
Having problems? Consult our support forum and our frequently asked questions 
(FAQs) page at http://www.living-e.de/en/support/index.php or. If you still cannot find 
the answer, complete the support form that is available on our website. Please remember 
to include your telephone number so that we can contact you.
Standard   5.0.1   June 2007  



 41
4  Backup, recover and rebuild
The following chapter treats the backup, recover and rebuild processes, which are 
designed to protect the contents of your database. We strongly recommend that you read 
and follow these procedures.

Use these processes when you are 
• upgrading your webEdition software
• performing routine maintenance
• moving your web site to another ISP
• for the safety of your data

4.1  Backup functions
Backup functions are divided into two parts:
• Create Backup.... Use this function to save the contents of your existing data either 

on your local hard disc or on your web server
• Recover Backup.... Use this function to recover your backup files to webEdition

The webEdition CMS offers you a wizard that will guide you through each process. 

4.1.1  Using the Create Backup function
Use the following procedure to save your existing data in a backup file.

Procedure 4  Backing up your database

On the webEdition main page
1 Open the Backup Wizard by clicking on File > Backup > Create Backup....

The Backup Export Wizard opens.
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Figure 30  The Backup Export Wizard

2 Specify where the backup file is to be stored. You can choose to save your file on your local 
computer, on the server, or in both locations.
a If you select On server checkbox, the file will be saved on the server in the 

/webEdition/we_backup directory.
b If you select On the local hard disk, a file download manager opens. Select Save files 

on my computer and then identify the location on the hard disk to which the backup file 
will be sent.
The system generates a filename for the backup. The file name will appear as 
weBackup_timestamp.xml, where timestamp is generated by your server.

Note:  You can, of course, specify a filename. Activate the checkbox Compress to 
compress the backup file with gzip. This will take a little more time for the backup 
process but reduces the required space.

3 Select which files you wish to backup. Choose from the following options:
a Save document and templates saves your webEdition templates and documents.
b Save binary data saves images, pdf files and such.
c Save settings creates a backup of your preferences, but also, if installed, of your 

settings from the user management module.
d Save temporary data saves unpublished documents and objects.
e Save extern file/ folders saves files which were not produced with webEdition.
f Create log the log will be safed in /webEdition/we_backup/tmp/lastlog.php
g If you wish to backup data from your installed modules, select the checkboxes that 

correspond to the modules you wish to back up. 

Note 1:  Because modules often share data in the database, webEdition will 
automatically back up associated modules. If, for example, you activate the 
checkbox for the Shop, webEdition will automatically activate its related module, 
Customer Management. Such is also the case for the Workflow and User 
Management modules, the Newsletter and the Customer data module, and the 
Task/Messaging and User Management modules.
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Note 2:  Only modules that are installed on your system will be visible in this list.
4 Click on the Backup button

The backup process starts. The process can last several minutes depending on the speed 
of your internet connection.

5 When the backup is completed, the system informs you that the operation was successful.
a If you choose to save the backup to your local drive, you will have to enter the location 

for the backup file to be stored.
6 Close the Backup wizard. You have completed this procedure.

4.1.2  Using the Recover function
The "Recover Wizard" will help you to restore your system from your backup file.

Procedure 5  Recovering your backup files

On the webEdition main page
1 Open the Recover Wizard by clicking on Edit > Backup > Recover Backup...

The Recover Wizard opens.

Figure 31  The Recover Wizard

2 The system asks whether you wish to save your existing files before you restore the backup 
files.

3 Choose the source for the import process. Indicate here whether your previously backed-up 
files are to be imported from the server or from your local hard disk, then click the next 
button.
If you select Import data from the server, go to Step 4. If you select import from local file go 
to Step 5.

If Do

you click on 
"yes"

the "Create Backup Wizard" opens. (Follow the 
procedure as described in Procedure 4).

you click on 
"no"

continue with Step 3.
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Figure 32  Recover backup process

4 Indicate which files are to be imported. If you have selected Import data from the server, 
then all files that are found in the /webEdition/we_backup directory will be shown in the 
select box. If you cannot see the backup files that you have imported, select the Show all 
files checkbox. 
a If you wish to recover files which were not produced with webEdition, select the 

Recover webEdition external files and folders checkbox.
b If you wish to recover data from your installed modules, select the checkboxes that 

correspond to the modules you wish to back up. 

Note 1:  Because modules often share data in the database, webEdition will 
automatically back up associated modules. If, for example, you activate the 
checkbox for the Shop, webEdition will automatically activate its related module, 
Customer Management. Such is also the case for the Workflow and User 
Management modules, the Newsletter and the Customer data module, and the 
Task/Messaging and User Management modules.
Note 2:  Only modules that are installed on your system will be visible in this list.

c If you wish to restore temporary data, that is, data which has been saved but not 
published, activate the Recover temporary data checkbox.

d If you choose Import preferences, the preferences (see Edit > Preferences) for the 
import of the backup files will be the same as those that were exported with the backup 
files.

e If you select Recover user data, the user data will be recovered.

CAUTION 
Risk of lock out
Your old user data will be overwritten. If you do not know the 
user data (username and password) from the files to be imported, 
you will have no way of logging yourself into webEdition.
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f If you activate the Automatic rebuild checkbox, the rebuild process begins automatically 
after the import.
The rebuild process overwrites the files on the web server.

5 If you have selected Import saved files from local hard disk you have the option of uploading 
a backup file to the server. 

Note:  Important: Each provider sets a time limit for PHP scripts (for example Puretec is 
set to 8 seconds; Strato is set to is 30 seconds). After this time the script will be stopped 
and it will not be completed any further. If the upload of the backup file requires a longer 
time than this time span, the import feature will not function in this instance. Copy the 
backup files into the /webEdition/we_backup directory and choose Import data from the 
server (as in Step 2).

6 Click on the Recover button
The recover process starts. The process can last several minutes depending on the speed 
of your internet connection.

7 When the recover process is completed, the system inform you that the operation was 
successful.

8 Close the Recover wizard. You have completed this procedure.

Note:  You must now rebuild your website. To do so, go to Procedure 6.

4.2  Rebuilding your web pages
4.2.1  What is the rebuild feature?

After updating your webEdition software, or after making substantial changes to a static 
web page, you must synchronize the content of your database with the content of the 
directories on your web server . When you use the rebuild feature, the new contents or 
new features in the webEdition interface will be regenerated and then made visible to 
visitors to your site. You can regenerate either your entire website or only sections of it. 

4.2.2  When to use the rebuild feature
Use the rebuild feature in the following circumstances:
• if you have updated your webEdition software and you wish to make available the 

contents that you have saved using the backup procedure of your previous version
• if a document changes that you have included in many static pages using the 

we:include tag
• if there has been a change made to the name or path of a page linked to a template 

using the we:a or the we:url tag
• if you have manually deleted or changed a page or directory by accident and you 

wish to restore your page.

Note:  After updating from webEdition 3.x to 4.0 you have to perform a rebuild.

4.2.3  How to use the rebuild feature

Procedure 6  Rebuilding your web pages

In the webEdition main screen
1 Select the File > Rebuild... command from the main menu.

The Rebuild page opens.
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Figure 33  Rebuilding a page

2 In the Rebuild page, specify which type of files you would like to rebuild.
• Documents: The documents are re-written into the filesystem. This is e.g. necessary 

after templates have been changed if the option automatic rebuild was not activated. 
Proceed with Step 3

• Index-table: If some documents are found twice or not at all during a query after having 
performed changes to the site, the index-table has to be re-written. This rebuild function 
will be performed immediately. Proceed to Step 5

• Generate thumbnails: Re-writes your thumbnails, e.g. after having changed the size or 
quality.

3 After haviing selected Documents in the Rebuild window, the following window opens (see 
Figure 34):

Figure 34  Documents Rebuild

Select all documents and templates to re-write all documents and templates. This is 
necessary after a recovery.
Two further sub steps are available to administrators:
a Resave main table 
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b  Resave temporary table

c Select All objects to resave your object tables. 

Note:  This option is only available if the Database/Object Module is installed.
d Select Static documents to rewrite all static documents. If you use the we:include tag 

with static web documents, you must rebuild your site for these pages to be visible.
e You can refine your rebuilding process by choosing categories to be re-written.

Note:  if you wish to change a published document from the static to the dynamic state 
(and vice versa), you must park the page, change it and republish it.

4 If you chose Generate thumbnails, a window opens, where you can select the size of your 
thumbnails (see Figure 35.)

Figure 35  Rebuilding thumbnails

5 Click OK
The rebuild starts

CAUTION 
Risk of loss of data
Do not forget to activate Save templates in advance. If Resave 
temporary documents is activated, the documents that were not 
yet published but which were changed will be rewritten on the 
basis of the published documents.  All changes which you made 
between saving and publishing will be lost. If Resave main 
database-table has been activated, the main table of the database 
will be rewritten.

CAUTION 
Risk of loss of data
If, during the write-process, the server fails or the action is 
interrupted because of a timeout, your data will be lost. Therefore, 
this option should only be 
selected in an emergency. 
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Figure 36  Rebuild progress

After completeing the rebuild, the following message appears

Figure 37  Rebuild finished

6 Click Ok
The rebuild process is finished
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