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About this document
Purpose of this document

This document treats the webEdition Editor PlugIn and how to use it.

You can use this manual to learn:
• what the Editor PlugIn is
• how to register the module
• how to use the PlugIn to create webEdition pages and templates using an HTML 

editing program of your choice

Audience
This document is intended for personnel in the following groups: 
• Web administrators
• Web editors

The webEdition customer documentation suite
The documentation team publishes new webEdition documents to support the release 
of all webEdition features, modules and enhancements. 

You can consult our documentation suite for detailed information about the modules 
you have purchased or about webEdition products that you may wish to purchase in the 
future. All customer documentation is available in portable document format (PDF) on 
the webEdition documentation Web page.

On-line reference documentation
The webEdition customer documentation suite comprises the following books, all of 
which you can obtain at URL: http://www.living-e.de

Standard webEdition documentation
The following books support the webEdition Standard suite:
• The webEdition User Guide 
• The webEdition Installation Guide
• The webEdition Tag Reference
Editor Plug-in
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Documentation for webEdition modules 
The following books support the webEdition modules:
• The Customer Management and Customer Management PRO Module User Guide
• The Database/Object Module User Guide
• The Editor-PlugIn User Guide
• The Newsletter Module User Guide
• The Scheduler and Scheduler PRO Module User Guide 
• The Shop Module User Guide 
• The Task Messaging Module User Guide
• The User Management and User Management PRO Module User Guide
• The Workflow Module User Guide

What precautionary messages mean
webEdition documents include attention and caution messages, which are designed to 
draw your attention to important instructions.

Attention boxes
An attention box identifies information that is necessary for the proper performance of 
a specified task. For example:

Caution boxes
Caution messages indicate that there are possible risks to your software or database if 
you perform a specified task without taking the suggested appropriate precautions. For 
example:

How commands, system responses and we:tags are represented
The commands, system responses and webEdition tags (called we:tags) used in this 
document conform to the following conventions.

ATTENTION
You must have the appropriate permissions in your user profile to 
complete this procedure. Permissions are assigned to you by your 
webEdition system administrator. Contact your webEdition system 
administrator for further details.

CAUTION 
Database warning
If you complete this procedure, your database will be 
overwritten.
Standard   4.1.1   October 2006  
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Web interface commands
Commands performed through a Web browser are shown in italic typeface. For 
example:

Click on the Save button.

Menu-based commands performed in a Web browser are shown in italic typeface. 
Drop-down or nested menu commands are separated by an input prompt (>). For 
example:

Select Customers > New from the main menu of the Customer Management Module. 

webEdition tags and template code
The webEdition templates use a specialized set of programming tags based on the PHP 
programming language. These webEdition tags or we:tags are displayed in courier 
typeface and in angled brackets:

Opening tags appear thus: <we:tag/>

Closing tags appear thus: </we:tag>

The programming code used in webEdition templates is also represented in this 
document by courier typeface:

<we:sessionStart/>
<we:ifRegisteredUser>
Hello: <we:sessionField Last name="user name" type="print"/><br> 
Logged in
</we:ifRegisteredUser>

Attribute variables
Attributes and variables appear in courier italic typeface. For example: 

<we:hidden name="attribute1">

How to check the document version and issue
The information on the title page of this document indicates the version and issue for 
this publication. The version and issue also appear in the footer on every 
even-numbered page. 

The first two digits in the document numbering scheme indicate the version. The 
version number increases each time the document is updated to support a new software 
release. For example, the first release of a document is 01.01. In the next software 
release cycle, the first release of the same document is 02.01.

The second two digits in the document numbering scheme indicate the issue. The issue 
number increases each time the document is revised and re-released in the same 
software release cycle. For example, the second release of a document in the same 
software release cycle is 01.02.
Editor Plug-in



14    About this document
Customer service
For further information about webEdition, please consult our Web page, or contact our 
customer service department:
• Web Page:http://www.webedition.biz/
• E-mail:

— Technical support: technik@living-e.de
— Sales: sales@living-e.de
— Information/Help: info@living-e.de
Standard   4.1.1   October 2006  
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1  Editor PlugIn: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Editor Plug-in Module. This chapter treats what the module does and how to install it. 
You can also find information here about the basic layout and command features for the 
Editor Plug-in Module. These topics are treated in the following sections:
• Section 1.1,  "What is the webEdition Editor Plug-in Module?" on page 15.
• Section 1.2,  "Requirements, installation and licensing" on page 15.
• Section 1.3,  "User preferences for the Editor Plug-in" on page 17.

1.1  What is the webEdition Editor Plug-in Module?
The Editor Plug-in enables you to create webEdition pages and templates using an 
HTML editing program of your choice. You can choose either to create your 
webEdition documents entirely in webEdition or to use another HTML editor. The 
entries/changes you make in your HTML editor will be automatically implemented by 
webEdition, eliminating the need to copy and paste them using the clipboard.

1.2  Requirements, installation and licensing
You must meet or exceed the following requirements to use the Editor Plug-in:
• PC with Microsoft Windows 95 or higher
• webEdition, version 2.0 or higher
• Microsoft Internet Explorer 4.x or higher
• Internet access during the installation

After purchasing a licence for the Editor Plug-in from the webEdition on-line shop, you 
must register your version online the first time it is run on your computer (see Figure 1,  
"Initial registration window" on page 16).
Editor PlugIn
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Figure 1  Initial registration window

Note:  You do not have to download the Editor Plug-in separately. The first time you 
use webEdition, it will automatically download the Plug-in from our server.

Once you have registered and you have received confirmation that the registration was 
successful (see Figure 2), the Editor Plug-in will be available for your browser.

Figure 2  Successful registration of the Editor Plug-in

The first time you access the Editor Plug-in, you will be asked to choose your preferred 
editing application (see Figure 3).
Standard   4.1.1   October 2006  
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Figure 3  Choosing a supported editing application

1.3  User preferences for the Editor Plug-in
After registering the Editor Plug-in, you can adjust the user preferences to change the 
behavior of the module. Go to the Options drop-down menu in the webEdition main 
page and select Preferences... (see Figure 4).

Figure 4  The Options menu

The system opens the Preferences screen. Click the 
Editor tab on the Preferences screen to access the 
Editor view (see Figure 5):
Editor PlugIn
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Figure 5  Editor preferences 
view

There are three options you 
can use to modify the 
behavior of the Editor 
Plug-in. The following 
checkboxes appear in the 
Editor view:
•Use it. Activate this option 
if you wish to use the 
Plug-in. The Plug-in must 
be registered before it can 
be used.
•Start automatically. 
Activate this option if you 
generally use your HTML 
editor rather than 
webEdition to edit your 
templates. If you have 
already specified your 
preferred HTML editing 
program, it will be launched 
automatically whenever 
you wish to edit any 
templates.
•Ask on startup which 

editor should be used. Activate this option if you use more than one HTML editing 
program and wish to switch between editors. Activating this option will open a 
dialog box whenever you start the editing program, asking you which HTML editor 
you wish to work with. If this option is not activated, webEdition will always start 
the editing program you last selected.

Note:  If you are not using Internet Explorer 4.x or higher (see Section 1.2,  
"Requirements, installation and licensing" on page 15), the Editor Plug-in options 
will appear greyed-out. You will also see the following message: These settings 
cannot be changed. The Editor PlugIn operates only with the Windows version of 
Internet Explorer.

1.3.1  Setting a default editing program
To set a default editing program, select the option Ask on startup which editor should 
be used and select your preferred editing program.

You can also re-set your default editor by selecting the ask for editor checkbox that 
appears next to the Start editor button directly under the text editing area of the 
Templates > Edit view (see Figure 6). 
Standard   4.1.1   October 2006  
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Figure 6  The Start editor and Ask for editor options

Once you have re-set your default editor, when you click the Start editor button in the 
Templates > Edit view, the last editing program that you selected will automatically 
start. (You must, however, make sure that the Ask on startup which editor should be 
used checkbox is not activated). For further details, see Chapter 2,  "How to use the 
Editor Plug-in" on page 21.
Editor PlugIn
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2  How to use the Editor Plug-in
You can either create your webEdition documents entirely in webEdition or you can use 
the Editor Plug-in to access another HTML editing program of your choice. 

2.1  Starting the Editor Plug-in
Depending on the preferences you have selected, your default HTML editing program 
can be started manually or automatically. You can also select a preferred editing 
program. (see Section 1.3.1,  "Setting a default editing program" on page 18). Whenever 
you edit templates (File > New > Template, then click the Edit tab), you will see the 
start editor button under the code entry window (see Figure 7).

Figure 7  The Start editor button

There is also an Ask for editor checkbox that allows you to specify your preferred 
editing program. This box will have a check mark if you have already selected the Ask 
on startup which editor is to be used option in the Options > Preference > Editors view. 
If you have not activated the Ask on startup... check box, the editing program selected 
during the installation will start.
Editor Plug-in
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2.2  Using an HTML editor
Your preferred HTML editor operates seamlessly with webEdition. After activating the 
Editor Plug-in and chosing an editor, whenever you open a webEdition template, any 
webEdition code already contained in the entry window will appear automatically in 
your editing program entry window.

In the following example (see Figure 8), the Microsoft Notepad application has been 
selected as the default editor.

Figure 8  Using a third-party HTML editor

You can then use your editing program in the usual manner (see your vendor 
documentation for details). Whenever you save any entries or changes in your editing 
program, those changes are automatically imported to the Edit window in webEdition.
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