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About this document
Purpose of this document

The webEdition User Guide provides an overview of webEdition's features and an 
introduction to all the processes you will use to operate the Standard Version of 
webEdition. This manual has been designed to include a complete description of how 
to use webEdition to create new Web sites, and how to adopt and modify existing Web 
sites.

This User Guide has the following sections:
• Introduction to webEdition
• User controls and description of the webEdition interface
• Role of the webEdition editor
• Role of the webEdition administrator
• List of important terms

For additional information about the installation process and the suite of webEdition 
modules, see the webEdition Installation, Update and Backup Procedures. This 
document is available on the webEdition documentation Web page.

Audience
This document is intended for personnel in the following groups: 
• Web administrators
• Web editors

The webEdition customer documentation suite
The documentation team publishes new webEdition documents to support the release 
of all webEdition features, modules and enhancements. 

You can consult our documentation suite for detailed information about the modules 
you have purchased or about webEdition products that you may wish to purchase in the 
future. All customer documentation is available in portable document format (PDF) on 
the webEdition documentation Web page.

On-line reference documentation
The webEdition customer documentation suite comprises the following books, all of 
which you can obtain at URL: 
http://www.webedition.de/english/downloads/Documentation.html
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Standard webEdition documentation
The following books support the webEdition Standard suite:
• The webEdition User Guide 
• The webEdition Installation, Update and Backup Procedures
• The webEdition Tag Reference

Documentation for webEdition modules 
The following books support the webEdition modules:
• The Customer Management and Customer Management PRO Module User Guide
• The Database/Object Module User Guide
• The Editor Plug-in User Guide
• The Newsletter Module User Guide
• The Scheduler and Scheduler PRO Module User Guide 
• The Shop Module User Guide 
• The Task/Messaging Module User Guide
• The User Management and User Management PRO Module User Guide
• The Workflow Module User Guide

What precautionary messages mean
webEdition documents include attention and caution messages, which are designed to 
draw your attention to important instructions.

Attention boxes
An attention box identifies information that is necessary for the proper performance of 
a specified task. For example:

Caution boxes
Caution messages indicate that there are possible risks to your software or database if 
you perform a specified task without taking the suggested appropriate precautions. For 
example:

ATTENTION
You must have the appropriate permissions in your user profile to 
complete this procedure. Permissions are assigned to you by your 
webEdition system administrator. Contact your webEdition system 
administrator for further details.

CAUTION 
Database warning
If you complete this procedure, your database will be 
overwritten.
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How commands, system responses and we:tags are represented
The commands, system responses and webEdition tags (called we:tags) used in this 
document conform to the following conventions.

Web interface commands
Commands performed through a Web browser are shown in italic typeface. For 
example:

Click on the Save button.

Menu-based commands performed in a Web browser are shown in italic typeface. 
Drop-down or nested menu commands are separated by an input prompt (>). For 
example:

Select Customers > New from the main menu of the Customer Management Module. 

webEdition tags and template code
The webEdition templates use a specialized set of programming tags based on the PHP 
programming language. These webEdition tags or we:tags are displayed in courier 
typeface and in angled brackets:

Opening tags appear thus: <we:tag/>

Closing tags appear thus: </we:tag>

The programming code used in webEdition templates is also represented in this 
document by courier typeface:

<we:sessionStart/>
<we:ifRegisteredUser>
Hello: <we:sessionField Last name="user name" type="print"/><br> 
Logged in
</we:ifRegisteredUser>

Attribute variables
Attributes and variables appear in courier italic typeface. For example: 

<we:hidden name="attribute1">

How to check the document version and issue
The information on the title page of this document indicates the version and issue for 
this publication. The version and issue also appear in the footer on every 
even-numbered page. 

The first two digits in the document numbering scheme indicate the version. The 
version number increases each time the document is updated to support a new software 
release. For example, the first release of a document is 01.01. In the next software 
release cycle, the first release of the same document is 02.01.

The second two digits in the document numbering scheme indicate the issue. The issue 
number increases each time the document is revised and re-released in the same 
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software release cycle. For example, the second release of a document in the same 
software release cycle is 01.02.

Customer service
For further information about webEdition, please consult our Web page, or contact our 
customer service department:
• Web Page:http://www.webedition.biz/
• E-mail:

— Technical support: technik@webEdition.de
— Sales: sales@webEdition.de
— Information/Help: info@webEdition.de
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1  Introduction
This introduction is intended to help new users familiarize themselves with the 
webEdition content management software. If you have used previous versions of 
webEdition and are already familiar with the software, you can skip to Section 1.4,  
"What’s new in webEdition 3.0?" on page 36.

This chapter treats the following topics:
• Section 1.1,  "What is webEdition?" on page 33
• Section 1.2,  "How does webEdition work?" on page 33
• Section 1.3,  "webEdition users: template administrators and Web page editors" on 

page 35
• Section 1.4,  "What’s new in webEdition 3.0?" on page 36
• Section 1.5,  "What’s next..." on page 37

1.1  What is webEdition?
webEdition is a database-grounded Web content management system (CMS). A CMS 
is a software application that allows you to develop, administer and control the 
information and the format of your Web page. Unlike file-based systems, which write 
new content to new HTML pages and then manipulate the content using a complex 
management system, webEdition stores all content information (such as text, images, 
graphics, Flash movies, style sheets) in a central database.

The webEdition program only has to be installed once on the server of your service 
provider. This is done using a simple installation program run on a computer with 
Internet access. All operations thereafter are performed through a standard Web 
browser. There is no need for you to install any additional software on your local 
terminal.

The architecture of webEdition reflects the philosophy of separating content and layout. 
Your web content (text, images, etc.) is stored in a database; the layout of your web 
pages is controlled by templates.

1.2  How does webEdition work?
The following subsections describe how the webEdition CMS operates from the point 
of view of content architecture, layout and management. These concepts are integral to 
understanding how webEdition works.
webEdition User Guide



34   Introduction 
1.2.1  About webEdition database architecture and content storage
webEdition uses MySQL, a database system that is supported by almost all major 
Internet service providers. There are several advantages to this architecture. Because all 
of your content is stored in a database, the HTML-coded web page itself does not have 
to be edited if the content has to be changed. An editor only has to change the database 
entry using the simple WYSIWYG webEdition interface and then re-save the 
corresponding page. In addition, the content stored in the database can be rapidly 
searched (and modified) or used in other ways (for example, as a central data 
repository). Moreover, the database runs primarily in the background, and once 
installed, its operation is transparent to the front-end user. 

1.2.2  About webEdition templates and web page layout
webEdition works with templates. Templates are pages programmed using HTML and 
PHP that act as a guide to form the structure of a Web page. These pages contain the 
basic layout for your Web pages. Templates impose a consistent format upon your Web 
site, and permit only certain areas of the page to be edited.

Templates are normally created using HTML and expanded using we:tags. 
Non-variable areas of your page are coded in HTML. The areas you wish to edit or 
change (such as text, images, graphics) are marked with we:tags. The we:tags will act 
as placeholders for variable data. 

If you are setting up a new web site, you can either create the templates yourself or you 
can have them created by your internal design department or by an agency. You can set 
up your entire Web site in webEdition, since it also acts as a completely functional 
HTML editing program. Templates developed using other HTML editing programs can 
be imported directly or merely copied and pasted to webEdition. Importing an existing 
Web site is also possible by merely inserting the appropriate we:tags where the 
hard-coded text, images, link lists etc. are located.

1.2.2.1  About graphics and images
webEdition differentiate between layout images and images/graphics that are dependent 
on content. Layout images have no connection to the content and only affect the 
appearance of the page. Layout images that are already present in the templates do not 
have to be imported to webEdition, since they do not have to be managed using the 
database. If, however, something in the layout needs to be modified, the template must 
be changed and re-saved. 

Unlike layout images, content-related images or graphics (such as product photos or 
charts) are managed and edited with the webEdition system in the same way as texts.

1.2.3  About we:tags and content management
Web site content is managed using webEdition tags (we:tags). They comprise a syntax 
based on XML that stores functions in an actions library and then integrates them when 
the page is called. This system makes creating text areas, summary pages, or images a 
matter of entering a few we:tags. The we:tags are very simple in structure and are easily 
understood by anyone with a basic understanding of HTML. To make finding, 
understanding and using we:tags easy, webEdition also provides a Tag Wizard along 
with an on-line Tag Reference Guide.
Standard   3.5.1   December 2005  



Introduction   35
The we:tags are only used by the administrator when a template is being created. 
Thereafter, the editor who will work with the templates to enter or edit data for the web 
pages does not have to be familiar with the we:tags. 

1.3  webEdition users: template administrators and Web page editors
webEdition differentiates between the role of the editor and that of the administrator. 
Each role requires a different skill-set, and the tasks assigned to each role are governed 
by different webEdition user permissions. Depending on the size of your company or 
organization, the editor and the administrator can be one and the same person.

1.3.1  The role of template administrators
The template administrator is responsible for the design and creation of the templates. 
He or she is required to have a basic understanding of HTML, since the webEdition tags 
(we:tags) have to be inserted in a pages created using HTML. 

Administrators also perform the following system-level tasks:
• Installing modules
• setting user permissions
• performing backup and restore functions

Note:  The first person to install webEdition automatically has administrative rights 
for the system. For details regarding installation procedures and system-level 
permissions, see the webEdition Installation, Update and Backup Procedures. For an 
overview of the user-level controls available in the extended webEdition suite, see 
the User Management Module User Guide.

1.3.2  The role of Web site editors
Editors are generally involved in creating and updating Web documents. The editor 
only has to know what the input boxes look like on the webEdition templates in order 
to fill the fields with text. Their tasks can also include such things as integrating images 
or generating link lists, but these tasks do not require any programming knowledge. The 
webEdition editors need not concern themselves with the database; they work directly 
with their Web sites using the input boxes on their actual Web pages.

If editors want to create a new page, they simply call up the template to be used for the 
page (so they do not have to worry about the layout), enter the desired text and/or 
images, and then save the new page. This process does not require editors to be familiar 
with HTML editing programs, or FTP.

1.3.3  The workflow within webEdition
A “workflow” refers to the activities a page must to pass through before it can be 
published. Figure 1 shows a diagram portraying a simplified workflow with webEdition 
and the roles played by both the administrator and the editor.
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Figure 1  The webEdition workflow

1.4  What’s new in webEdition 3.0?
If you have upgraded to webEdition 3.0, you will find the following changes and 
enhancements to the user interface:
• Revised menus on the webEditon main screen. The commands available from the 

drop-down menus have been reorganized. For further details, see Chapter 2,  "User 
controls,".

• Super-Easy-Edit-Mode (seeMode). See Section 2.5.2,  "The editing screen in 
Super-Easy-Edit Mode" on page 59.

• XML Import/Export.
• Extended full text search: the content of Word (.doc and .rtf), Excel and Powerpoint 

(.xls and .ppt /.pps) documents are fully searchable.
All non-webEdition documents (such as PDF, Word, Excel, Powerpoint, .rtf, etc.), 
can be assigned a title, description, keywords and categories to facilitate the search 
feature. See Section 4.4.6,  "Search feature" on page 137.

• Copy directories feature. You can copy all of the contents of a selected directory 
(including sub directories) to the currently active directory in one step. For details, 
see Section 3.2.8,  "Copying the contents of one directory to another" on page 73
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Administrator Editor
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1.4.1  What’s new in webEdition 3.2?
webEdition Version 3.2 introduces features for the production and care of accessible or 
"barrier-free" Web site contents. Some of the new features are:
• The WYSIWYG editor includes extended language settings, an acronym reader, 

and table and cell summaries that impart information about the structure of tabular 
data that would otherwise be lacking in voice output. For details, see Section 
3.7.5.3,  "Accessibility functions of the WYSIWYG Editor (Version 3.2)" on page 
103

• Version 3.2 integrates services to check the validity and/or the accessibility of web 
sites in accordance with the rules of the World Wide Web Consortium (W3C). For 
information on validating your site, see Section 2.2.9,  "Validation view (from 
Version 3.2)" on page 48, and Section 3.1.5,  "The Documents Validation view" on 
page 67.

• Fields have been added to the hyperlink dialog boxes that provide the opportunity 
to enter alternative text strings that will describe the links. See Section 3.7.7.1,  
"Accessibility enhancements for links in Version 3.2" on page 111

1.5  What’s next...
The rest of this Guide is written with a user-based workflow model in mind. The next 
chapter provides a description of the user interface. Thereafter, one chapter has been 
written for editors, who will be working with the finished templates and who do not 
need to be able to use we:tags. The other chapter is intended for administrators, who 
create the templates and are responsible for ensuring the integrity of their Web sites.
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2  User controls
This chapter describes the webEdition user interface and how to use its basic controls. 
It is intended for both editors and template administrators. This chapter treats the 
following topics: 
• Section 2.1,  "Starting webEdition" on page 39
• Section 2.2,  "Preferences" on page 42
• Section 2.3,  "The webEdition menu structure" on page 51
• Section 2.5,  "Viewing modes: standard and Super-Easy-Edit Mode" on page 58

For information on installing webEdition, see The webEdition Installation, Update and 
Backup Procedures.

Specific information about how to create and maintain webEdition documents is found 
in Chapter 3,  "Working with documents – the role of the editor" on page 63. 
Information on how to create and use templates is found in Chapter 4,  "Creating 
templates—the role of the administrator" on page 117.

2.1  Starting webEdition
In your browser enter www.yourdomain.com/webEdition/. The login screen appears 
(see Figure 2). Enter your User name and Password in the designated fields.

Figure 2  The webEdition login screen
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The first time you enter your user name and password, you always enter "admin" and 
"admin". After entering you user name and password, click Login.

At the bottom of the screen under the word Mode there are two radio buttons where you 
are given the option of choosing the viewing mode you wish to use, either Normal or 
seeMode. For more information about the two viewing modes in webEdition, see 
Section 2.5,  "Viewing modes: standard and Super-Easy-Edit Mode" on page 58.

2.1.1  Selecting your language
Choose Options > Preferences.... The Preferences window opens. Click on the User 
Interface tab. The User Interface view appears (see Figure 3).

Figure 3  Preferences: selecting your language from the User interface view

In the Languages area, select your language from the select box. Click the Save button 
at the bottom of the window. After saving your language preference, the webEdition 
display changes to the language you have selected.

Note:  Information about other functions in the Preferences window is presented in 
Section 2.2.

2.1.2  The webEdition main screen
The controls for webEdition can be found on the webEdition main screen in the 
drop-down menus File, Options, Modules and Help, located at the top of your browser 
window (see Figure 4). To the right of the menus, are the navigational control icons 
Home, Reload, Back and Forward. Below the drop-down menus on the left side of the 
screen, is the explorer menu which displays the structure of your Web site. To the right 
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of the explorer menu is the editing screen (which is explained in Section 2.5.1,  "The 
editing screen in standard mode" on page 58).

Figure 4  webEdition main screen showing menus, tabs and Quickstart screen

Note 1:  For your browser to be able to display the menu bar, it must be 
Java-compliant. If you do not have Java installed on your browser and do not plan to 
install it, the webEdition menus will be displayed as three individual drop-down 
menus. They will appear in the same order, but will only have one level. 
Note 2:  If you have only just installed webEdition, the menu will only display the 
we_demo directories with our sample Web site. All examples in this manual are 
based on we_demo. Your own pages will be set up in the root directory and not in the 
we_demo directory.

2.1.2.1  The Quickstart options
The Quickstart options are displayed in the middle of the editing screen (see Figure 4,  
"webEdition main screen showing menus, tabs and Quickstart screen" on page 41). You 
can start by performing one of the following basic actions:
• Open document. Opens a document or template
• New document. Creates a new document
• New template. Creates a new template
• New directory. Creates a new directory
• Unpublished pages. Shows an overview of unpublished pages
• Preferences. Opens the Preferences dialogue box

You can return to the webEdition main screen by selecting File > Quickstart.
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2.2  Preferences
Select Options > Preferences... to open the Preferences screen (see Figure 3,  
"Preferences: selecting your language from the User interface view" on page 40).

Note:  Some preferences are restricted to administrators. The preferences that are 
visible are dependent upon the User Management Module that you have installed.
• If you have installed either the User Management or the User Management PRO 

Module, the following preferences are available only to the administrator: Proxy, 
Advanced, Modules.

• If you have installed the User Management Module, the following preferences 
are available only to the administrator: seeMode, File Extensions, Formmail 
recipients.

• If you have installed the User Management PRO Module, the following 
preferences can be set by users if special permissions have been granted by the 
administrator: seeMode, File Extensions, Formmail recipients. 

The Preferences screen has the several tabs (see Figure 3,  "Preferences: selecting your 
language from the User interface view" on page 40); the functions of which are 
described in the following subsections.

2.2.1  The User interface view
The User interface view has the following areas (see Figure 3,  "Preferences: selecting 
your language from the User interface view" on page 40):
• Language. Use this select box to choose the language of the user interface.
• seeMode start document. When you login into seeMode, webedition needs to know 

what document it should display at startup. If no start document is set and you login 
into seeMode, webEdition automatically asks you for the start document. 
You can deactivate the seeMode by clicking on the Deactivate seeMode checkbox. 
If you do so, the seeMode option will not be available to you on the login screen

• Treemenu. Define the maximum number of items being displayed in the left 
navigation. 

• Window dimension/Predefined dimensions. These settings allow you to manipulate 
the appearance of the webEdition interface. Select the Maximize radio button and 
the main webEdition window always opens as large as possible. If you prefer to 
have the window open in a different size, select Specify and set the pixel values or 
use the Predefined dimensions area to choose from commonly used pixel values.

2.2.2  The File extension view
The File extensions view has the following areas (see Figure 5):
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Figure 5  File extensions view

• webEdition extensions. In this section, you can specify the default extension for 
static and dynamic pages. 
— Static pages. Choose the default extension for static pages from the select box. 

This value is generally .html or .htm for HTML pages. You can also set .asp for 
Active Server Pages or .jsp for Java Server Pages, if necessary. However, this 
should only be done if the appropriate code has been implemented in the 
template. If you wish to use PHP code in your template, you will have to store 
the page as a dynamic page (see the next item).

— Dynamic pages. Specify the extension for dynamic pages (generally .php or 
.PHP4). This extension will cause the Web server to execute PHP4.

• HTML extensions: Specify the default setting for HTML pages. If you primarily use 
PHP scripts or other similar scripts, you can also select the corresponding extension.

2.2.3  Editor view
The Editor view has the following areas:
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Figure 6  The Editor view

• Editor-Plug-in. This feature is only available if you use Microsoft Windows with 
the Internet Explorer, and if you have purchased a licence from webEdition to use 
the Plug-in. Activate the Start automatically checkbox to load the Plug-in every 
time you click the Edit tab in a template. Activate the Ask on start... checkbox, and 
webEdition will ask you which editor to use every time the Plug-in is started.

• Editor dimensions/Predefined dimensions. These controls operate like the windows 
dimensions described under the User interface view. 

2.2.4  Formmail recipients view
With the Formmail recipients view, you can enter the addresses to which formmail can 
be sent. If no addresses are specified, the formmail function is blocked. If you have used 
the formmail function in prior versions of webEdition, you must enter the addresses 
which are defined in the template (<we:form type="formmail" ....> under "recipients") 
in the formmail recipients function. For further details, see Section 4.4.7,  "E-Mailing a 
form" on page 138.
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Figure 7  The Formmail recipients view

2.2.5  Proxy server view
 Set the Proxy server view preferences if your Web server requires a proxy server to 
create a connection to the Internet (as in the case of a corporate network, or intranet).

Figure 8  The Proxy server view

2.2.6  Advanced view
The Advanced view has the following areas:
• Default settings for the PHP attribute in we:tags. You can assign whether or not the 

editor ought to be given the right to enter PHP code in an entry field (for example, 
<we:input type="text/>, <we:textarea/>). Generally the setting (default = false) is 
such that the editor is prohibited from writing PHP code in the entry field. In order 
to override this restriction, set the value in the drop-down menu to "true". It is also 
possible to override this restriction by using the we:tags (for example: <we:input 
type="text" php="true"/>).

• Default value for the inlineedit attribute in <we:textarea>. If you select true, you 
can edit the textarea directly on the same Web page.  If you select false, you have to 
click first on the Edit button. A new window will open where you can edit the 
textarea. If there are many textareas, the value false is recommended, as the web 
page will load much faster.
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• Type of database connections. Select the method in which you will connect to the 
MySQL database. There are two types:
— connect. Normal connection to the database. The system will connect to the 

database using the server address, MySQL account name and password that has 
been entered into webEdition by the administrator when the program was 
installed. If the connection fails, the program will stop running.

— pconnect. Persistent database connection. This type of connection behaves 
similarly to normal connections with two exceptions. Before a new connection 
is made to the database, the system attempts to use an existing persistent 
connection to the same database with the same user name and password. If no 
such idle connection exists, a new connection is established. Second, the 
connection to your MySQL server is not closed when the PHP script exits. It 
remains idle to be used at a later stage.

Note:  If you are unsure about what type of connection to use, choose 
connect.

• HTTP authentication. Activate the checkbox if your server uses HTTP 
authentication. Thereafter, enter your username and password in the required fields. 

• Thumbnail directory. Select a directory for thumbnails.

Figure 9  The Advanced view

2.2.6.1  Options in the Advanced view from Version 3.2
The following options appear in the Advanced view from Version 3.2 on:
• Max Upload Size displayed in mouse-over “hints” (see Figure 10 on page 47). In 

order to ensure that when uploading files to their Web site, editors do not exceed the 
maximum upload limits set for your PHP server, webEdition allows the 
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administrator to enter a value that will be displayed in the hint (or mouse-over) text 
as guidance for editors. 

Figure 10  “Hint” text about the maximum upload size

Note:   The values provided by the server and PHP are not changed here; here the 
administrator defines a maximaum value (that is, a value less than that prescribed 
by the server) which is intended to help the editors.

• Default value for the showinputs attribute in <we:img>. Set this attribute to true to 
display to your web site editors the Alt (alternative text) and Title fields for images 
if they are wrking with accessible or barrier-free sites. The show inputs field can be 
toggled to false (off), if you are not working with an accessible web site and want 
to keep unneccessary fields from the view of your editors.

Figure 11  Showinputs

• Behaviour of the document type selection. Use this field to define the document 
types available to your users.

Figure 12  Behaviour of the document type selection

2.2.7  Error handling view
This view gives you the opportunity to control what system-generated messages are 
displayed.
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Figure 13  Error handling 
view

•Error handling. If you want 
webEdition to display 
notices, warnings and/or 
errors, activate the error 
handling.
•Handle these errors.These 
options allow you to select 
what error messages the 
system is to treat.
•Displaying of errors. These 
options allow you to view 
error messages immediately 
on-screen, in an error log, 
and as an E-mail message.
•Expert settings: Show 
debug frame. You can turn 

the debug frame on or off in either normal or seeMode by selecting the designated 
checkbox. When activated, a frame where debugging information can be seen 
appears at the bottom of your screen. The debugging frame can be used to diagnose 
problems.

2.2.8  Modules view
The Modules view allows you to set preferences for the modules you have installed. 
This view and its corresponding tab only appears if you have installed one of the 
webEdition modules.

2.2.9  Validation view (from Version 3.2)
Beginning in webEdition Version 3.2, the Preferences dialogue includes a Validation 
from which you can enter the Validation view.

The Validation view offers tools that are designed to assit you in the creation and 
maintenance of accessible or “barrier-free” Web sites.
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Figure 14  Validation preferences

• Default value for the attribute xml in we:Tags: You can set the attribute xml=true 
globally for all tags (instead of having to do it for every tag). This command makes 
it possible to create valid XHTML-code.

• XHTML debugging: If you activate the checkbox, every we:tag will be checked for 
validity before output.

Note:  The debugging tool requires resources from your server and can affect 
perfomance of your site. Activate the debugging feature only during the testing 
of your site.

• Notification of invalid attributes: Activate this checkbox during testing to let the 
system display error messages either in an error log, a JavaScript alert box or in a 
text file.

2.2.10  The System tab (from Version 3.4)
In Version 3.4, a new Tab, System, has been added to the preferences.
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Figure 15  System tab

The areas Max Upload Size displaying in hints, Type of database connections, HTTP 
authentication and Thumbnail directory are taken off the Advanced tab to improve the 
clarity. You can now set the Acess rights for new directories. The default value is 755. 
For more information about access permissions in Unix file systems, please ask your 
system administrator.

Note:  The permissions set in the Systems view only apply to newly created 
directories, not to directories already existing!

2.2.11  System settings for pageLogger
From Version 3.4.0.8 on, the pageLogger area has been added to the System tab: 
pageLogger-directory (see Figure 16). Please select here the directory, where 
pageLogger is installed.

Figure 16  pageLogger-directory in system tab
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As soon as the pageLogger directory is set here correctly, you are able to start 
pageLogger simply by clicking on Modules > pageLogger. Pleas note, that you have to 
restart webEdition for the changes to take effect.

Note:  For the Single Login feature to work correctly, a pageLogger user with the 
same name as the webEdition user has to be established. Furthermore, the user has to 
be marked as a webEdition user in the user preferences of pageLogger! For further 
information about webEdition users in pageLogger please consult the pageLogger 
documentation.

2.2.11.1  adding pageLogger to webEdition pages
To make the integration of pageLogger in webEdition-pages as easy as possibly, from 
webEdition Version 3.4.0.8 on, the new Tag <we:pagelogger> was created. This tag 
gives you the opportunity, besides using the code generated by the pageLogger Code 
Wizard, to easily integrate pageLogger into existing webEdition projects.

Further informationen about <we:pagelogger> can be found in the webEdition Tag 
Reference and the pageLogger userguide.

2.3  The webEdition menu structure
2.3.1  The File menu

The File drop-down menu has the following items (see Figure 17).

Figure 17  The File menu

• New. This item allows you to create a new webEdition page, to load an image, to 
create other documents (HTML page, Flash movie, Quicktime movie, JavaScript, 
CSS style sheet, and plain text documents, and others such as *.doc, *.pdf, *.zip, and 
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*.txt files) or a new template (see Figure 18). Furthermore, you can create new 
directories in both explorer menu views—Documents and Templates.

Figure 18  The File > New sub menu

• Open. This command allows you to open documents (webEdition pages, images, 
etc.) and templates (see Figure 19). If you have installed the Database/Object 
Module, this menu item also allows you to open objects and object classes.

Figure 19  The File > Open sub menu

• Save. This item allows you to save the file that you currently have open in the edit 
view.

• Delete. This item allows you to delete a document or a template (as well as objects 
and classes if you have installed the Database/Object Module; see Figure 20).

Figure 20  The File > Delete sub menu

• Unpublished pages. This item opens a new window in which all unpublished pages 
are listed in a tabular format.

• Unpublished objects. If you have installed the Database/Object Module, you can use 
this command to display a tabular overview of all unpublished pages.
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• Import/Export. webEdition currently offers the following import functions (see 
Figure 21,  "Import Wizard" on page 53):
— File import. There are two file import options:

– Import local files
– Import files from server

— Data import. There are two data import options:
– Generic XML Import. Use this generic extensible markup language (XML) 

import function to import flat XML files.
– CSV Import. Use the comma separated values (CSV) import function to 

import csv files or modified text formats.

Figure 21  Import Wizard

• Rebuild. This command allows you to re-write either all documents or those 
documents that meet specified criteria. The rebuild process is necessary to keep the 
links consistent whenever the linking structure changes, or if you have pages that 
are not generated dynamically and if you have edited a page which includes 
elements and/or sections using the we:include tag. See Section 3.2.9,  "Rebuilding 
static and dynamic Web pages" on page 74.

• Backup. The backup function has two parts: 
— The Create Backup command allows you to create a local backup of your host 

database. and/or to restore this image on your host. 
— The Recover Backup command allows you to restore your backup image on 

your host. For further details, see The webEdition Installation, Update and 
Backup Procedures.

• Browse Server. This command opens a file management window containing a 
complete overview of the root directory ("/") on your server. It displays all the 
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directories and files created in webEdition in blue letters. Any other directories and 
files are displayed in black letters. 
The file manager helps you to work with and manage your files and directories. 
After selecting a file or directory, you can add, move or delete the item(s) using the 
file manager by clicking one of the icons at the top-right of the screen. (see Figure 
22).

Figure 22  The file manager

• Quickstart. Returns you to the Quickstart menu (see Section 2.1.2.1,  "The 
Quickstart options" on page 41).

• Quit. Select this command to log out of webEdition.

2.3.2  The Options menu
The Options menu has the following items (see Figure 23,  "The Options menu" on page 
54):

Figure 23  The Options menu

•Document types. This command allows you to create a new 
document type.The Document types feature allows you to 
group documents with similar characteristics, or to assign 
characteristics to a new document that are similar to existing 
documents. You can also select an existing document type and 
delete it or modify its properties, which might entail assigning 

a template to it or specifying default values. See Section 3.6.1,  "Document types" 
on page 97.

• Categories. This command allows you to create a new category or to delete 
categories you no longer need. The Categories feature offers an alternate method of 
generating page summaries, and of organizing your documents. See Section 3.6.2,  
"Categories" on page 99.

• Thumbnails. Here you can do the settings for thumbnails.
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• Change user name/User management. This command allows you to change your 
user name. If the User Management Module is installed, User Management appears 
in the menu. See Section 3.6.3,  "Changing user name and/or password" on page 
100.

• Change password. This item allows you to change your password. See Section 
3.6.3,  "Changing user name and/or password" on page 100.

• Preferences. Use this item to modify the default webEdition preferences. See 
Section 2.2,  "Preferences" on page 42.

2.3.3  The Modules menu
The Modules menu lists all webEdition modules installed in your version of webEdition 
(see Figure 24,  "The Modules menu" on page 55). You can open a module by clicking 
on the corresponding menu item.

Note:  The Modules menu will vary depending on the modules you have installed.

Figure 24  The Modules menu

For further details about a specific webEdition module, 
see the supporting documentation at 
http://www.webedition.de/english/downloads/Docume
ntation.html

2.3.4  The Help menu
The Help menu contains the following items (see Figure 25,  "The Help menu" on page 
55):

Figure 25  The Help menu

•The Help menu contains an extensive help program. You must be 
connected to the internet. The help program is on our server.
•Update. There are three items: 

— Update. Here you can check which version of webEdition you have installed. 
The version number appears at the top of the view. You can use the Search 
button to check if there is a newer available version. If so, you can update to a 
newer version using the online installer. In addition, all new modules are 
installed using this menu item.

— Module installation.
— Log.

• Info. This item contains information on webEdition, and the version you are using.
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2.3.5  The explorer menu
The explorer menu appears on the left side of the webEdition main screen, and it 
displays the contents of your Web site as a series of folders and files. Adjacent to the 
explorer menu are either two or four vertical tabs, depending on whether or not you have 
installed the Database/Object Module (see Figure 26,  "The explorer menu" on page 
56). When you click on a vertical tab, you can view the corresponding editing view in 
the explorer menu:

Figure 26  The explorer menu

•Documents tab. This editing view shows a list of the available 
documents (Web pages, style sheets, images, etc.) and the 
document directories
•Templates tab. This editing view shows all the templates
•Objects tab. This editing view (visible only if you have 
installed the Database/Object Module) shows a list of available 
objects
•Classes tab. This editing view (visible only if you have 
installed the Database/Object Module) shows a list of available 
object classes

Documents, templates or objects displayed in red in the 
explorer menu have been saved, but have not yet been 

published, while those displayed in black have been both saved and published. See also 
Section 3.2.2,  "Saving, “unpublishing”, and deleting documents" on page 70.

By clicking on one of the view icons, you can open, change or publish a desired file in 
edit mode. By double-clicking one of the entries in the Documents view, you will launch 
a new browser window showing you the document as it will be displayed online. 

2.3.5.1  Identification numbers (IDs)
If you pass the mouse pointer over the icon of an individual document or template, a 
number appears below the explorer menu. The same number appears on the screen 
below your mouse pointer (see Figure 27).

Figure 27  webEdition ID numbers

IDs are unique numbers allocated to a document or a template. 
webEdition uses the ID to access the document internally. The ID 
allocated to a document is needed for some we:tags (such as we:a 
or we:url). The document ID is designed to make it easier for you 

to link documents.

2.3.5.2  Explorer menu icons
The various file types used in and with webEdition are identified in the explorer menu 
by the distinctive icons:

Directories and sub directories are identified by folder icons:
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Figure 28  directory icon

webEdition pages (.php and .html files) are identified by “e” icons:

Figure 29  webEdition page icon

Templates, JavaScript, CSS (.tmpl, .js, .css files) appear thus:

Figure 30  Template icon

Images (.gif, .jpg, jpeg, .png files) appear thus:

Figure 31  Image icon

Movie files (.mov, .swf ) appear thus:

Figure 32  movie icon

Plain text (.txt) files appear thus:

Figure 33  Plain text icon

If you have installed the Database/Object Module, the following icons appear in the 
Objects and Classes views:
• objects

Figure 34  Objects icon

• object class icon

Figure 35  Object class icon
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2.4  webEdition control elements
To the right of the drop-down menus there are the following navigation control 
elements:

Figure 36  webEdition navigation control elements

• Home. If you click on the symbol which looks like a house, the seeMode start 
document opens. You can define the seeMode start document in Options > 
Preferences. 

• Reload. Click the icon adjacent to the Home icon to reload the Web site.
• Back. Click on the left-pointing arrow icon to navigate to the page opened last. 
• Forward. Click on the right-pointing arrow icon to navigate to the next open page.

2.5  Viewing modes: standard and Super-Easy-Edit Mode
There are two viewing modes available in webEdition: normal mode and 
Super-Easy-Edit Mode (seeMode) 

2.5.1  The editing screen in standard mode
The editing screen is where you can create, edit, preview your individual webEdition 
documents and templates. If you are an editor and you click File > New > webEdition 
Page > Empty Page, the Documents editing screen opens. Four tabs are visible, a fifth 
is visible in the document editing view if you have installed the Scheduler Pro Module 
(see Figure 37,  "The webEdition Edit view (normal mode)" on page 59). Likewise, if 
you are an administrator and you click File > New > Template, the Templates Edit view 
opens. Each tab, when clicked, opens a specified view.
• Properties. This view allows you to assign all the necessary properties to the file 

such as name, directory, document type, etc.
• Edit. This view displays the Edit view, document you wish to edit in edit mode. You 

make all your entries to the page in this mode.
• Information. This view displays all relevant information on the current document.
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• Preview. This view allows you to check how your page will actually appear in the 
browser.

• Scheduler PRO. If you have installed the Scheduler Pro Module, when you are 
working with a document, you can use this view to access the settings for the 
module.

Figure 37  The webEdition Edit view (normal mode)

The editing screens and the available views are different for documents and templates. 
Each will be discussed, in turn, in subsequent chapters.

2.5.2  The editing screen in Super-Easy-Edit Mode
In contrast to the normal editing mode, which serves the administration of the entire 
Web site, the seeMode is ideal for editing content.

The seeMode is characterized by simplified navigation and a removal of the more 
complex functions that are better suited to the skills of an administrator. The seeMode 
is designed for the simple maintenance of existing Web site content. 

Note:  The seeMode feature in webEdition 3.0 cannot be used with Web sites that use 
HTML frames.

When in Normal mode, an editor must select each of his/her documents from a file tree; 
in seeMode an editor can navigate to all the documents for a Web site using the 
navigation of the web page that they must edit. In contrast to working with a file tree, 
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which presupposes a certain understanding of where and how documents are stored on 
a Web server, the desired document can be accessed easily and directly. An editor using 
seeMode does not need to know how the documents for a Web site are distributed on 
the server; when an editor logs in, webEdition can be configured so that the Web page 
that they have to maintain automatically appears. The editor can navigate through the 
Web site and modify the contents of the associated pages using a WYSIWYG editor and 
then published the revised pages. An editor can perform all of the same tasks in 
seeMode as in normal mode, except template and class editing.

Figure 38 shows how the view of an editor, administrator and end visitor will perceive 
a Web page.

Figure 38  What editors, administrators and visitors see

The first time you log into webEdition in seeMode, you will see the following message 
(see Figure 39), asking whether you wish to choose a default web page which will open 
each time you log in to seeMode:

Figure 39  The No start document warning
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If you click OK, the preferences screen opens in the User interface view. In the seeMode 
start document area you can choose a start document by clicking the Select button and 
browsing the server for a document.

Thereafter, every time you log into webEdition in seeMode, the page you have selected 
will automatically appear on screen. This page is your seeMode home page. See, for 
example, Figure 40.

Figure 40  The webEdition editing screen (seeMode)

2.5.2.1  seeMode user interface
The menu structure and functions for the seeMode are the same as what is described in 
Section 2.3,  "The webEdition menu structure" on page 51, with the following 
exceptions pertaining to navigation and file creation:

2.5.2.1.1  explorer menu    The file tree that one sees in Normal mode does not 
appear in seeMode. All navigation can be carried out using the links inherent in your 
seeMode start page. You do, nevertheless, have the option of opening files from the 
server by using the File > Open menu. 

2.5.2.1.2  File menu    All functions are available to the user. If you have installed 
the User Management Module, user activities can be restricted (see Section 2.5.2.1.4,  
"Interactions with the User Management Module" on page 62).
webEdition User Guide



62   User controls 
2.5.2.1.3  Home menu    When you are editing your web pages in seeMode, you can 
click the Home menu to return to your designated seeMode start page.

For details on how to edit documents while using the seeMode, see Section 3.8,  
"Editing documents in seeMode" on page 113.

2.5.2.1.4  Interactions with the User Management Module    The User 
Management Module gives administrators additional flexibility in designating what a 
user will see when he/she logs into webEdition using seeMode. There are three control 
features for seeMode, which are accessed from the User Management Permissions view 
(see Figure 41):
• The user is allowed to see the menu. If this checkbox is not activated, for a given 

user, that person will see only the Quit and Home menus. Hence the person will be 
limited only to editorial tasks associated with an existing document.

• The user is allowed to work outside the seeMode. Here an administrator can restrict 
access to files that were not created in webEdition.

• The user is allowed to change his/her start document. If this checkbox is not 
activated, the user will only be able to modify the seeMode start page (and its 
internally linked pages).

Figure 41  Permissions for the seeMode in the User Management Module
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3  Working with documents – the role of 
the editor

The webEdition content management system differentiates between the role of the 
editor and the role of the administrator. Each role requires a different skill-set. 
Moreover, the tasks assigned to each role are governed by different webEdition user 
permissions.

This chapter describes the activities that are performed when working with webEdition 
documents. This role is normally carried out by a Web page editor. These tasks include:
• creating new documents
• saving/parking/deleting documents
• modifying/updating documents
• importing files
• working with other documents: graphical and non graphical files
• creating new document directories
• defining categories
• rebuilding static and dynamic Web pages
• changing user names and/or passwords
• editing preferences

By "documents", we mean all types of files that are used in the presentation of a Web 
page. Such files can include webEdition pages, normal HTML pages, cascading style 
sheets, JavaScript pages, images and Flash movies.

Note:  This manual always refers to the sample pages supplied with the software. 
Sample pages can be accessed from the we_demo directory, found in the webEdition 
explorer menu.

3.1  The four views when working with documents in normal mode
In Chapter 2, we discussed how the editing screens and the available views are different 
depending on whether you are working with a document or a template. The following 
sub-sections describes each of these views as they pertain to documents.
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3.1.1  The Documents Properties view
You use the Properties view to define the name, type, location, and ownership of your 
webEdition documents. The Properties view has the following areas: Path, Document, 
Meta Tags and (under the More properties button) Categories, Owners (see Figure 42).

Figure 42  The Documents Properties view

• Path. This area allows you to enter the name of the document, its extension and the 
directory in which it is to be saved. Select the directory by clicking the Select button 
and using the file manager. To avoid input errors, the directory cannot be entered by 
hand.
The extension determines how the server will react to the document. The extension 
for static pages is either .html or .htm, whereas the extension for dynamic pages is 
.php.

Note:  If you allocate an .html extension to a dynamic document, it will not 
execute and the viewer of the document will be able to see the source code, unless 
your administrator has configured your server to have the PHP parser execute 
documents with an .html or .htm extension. If you are using other script 
languages such as ASP or JSP in your templates, always save pages as "static" 
pages and select the appropriate extension (for example .asp for ASP pages)

• Document. In the Document area you can select the document type and the template 
on which you wish to base the new page.
If you choose to select a document type, your selection will be limited to the 
template allocated to this document type. For additional information on document 
types, consult Section 3.6.1,  "Document types" on page 97. If you do not select a 
document type, you will be able to use any of the available templates. The checkbox 
located at the bottom of the Document area allows you to determine if the page 
should be created dynamically. If you do not activate the checkbox, the page will be 
created statically. You can find more information on the difference between static 
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and dynamic pages in Section 3.2.9,  "Rebuilding static and dynamic Web pages" 
on page 74.
To make a document searchable, activate the Is document searchable? checkbox. 

• Meta Tags. In the Meta Tags area, enter in the Title field the title you want to appear 
in the browser bar when the page is viewed by an end user. This is equivalent to an 
entry in the <title> HTML tag as long as the we:tag is in the template. In the 
Description field, enter the description of the Web page that you wish to be 
displayed by, for example, a search engine. This is equivalent to an entry in the 
<description> meta tag, as long as the we:tag is in the template. In the Keywords 
field, enter the keywords that characterize the content of the document. These words 
will be found by search engines and other such programs. This is equivalent to an 
entry in the meta tag <keywords> as long as the we:tag is in the template.

• Category. In the Category area, you can select the category to which you want your 
document to belong. To do so, click on the Add button to make a selection from the 
available categories. For additional information on categories, please consult 
Section 3.6.2,  "Categories" on page 99.

3.1.2  The Documents Edit view
You use the Edit view to create or modify the content of your document by entering text, 
creating link lists, adding images, etc. (see Figure 37,  "The webEdition Edit view 
(normal mode)" on page 59). With the exception of the areas that still have to be edited, 
the layout you see in the Edit view shows how this page will look on your Web site. The 
areas in which you can work appear as entry fields and are pre-defined by the 
template(s) created by your webEdition administrator. (More information on how this 
is done can be found in Section 6, "The role of the administrator – creating templates".) 

Figure 43  The Documents Edit view
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3.1.3  The Documents Information view
The Information view provides you with read-only information about your document, 
such as the file type, the size of the file, the date created, the date when it was last 
modified and when it was last published. This view also provides information on the 
local host path where the file has been saved and the HTTP path (the URL) where the 
page can be accessed online (see Figure 44).

Figure 44  The Documents Information view

3.1.4  The Documents Preview view
You can use the Preview view to display how your finished page will look online when 
viewed in a browser. Use this feature to check the contents of the page before saving or 
publishing it (see Figure 45).
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Figure 45  The Documents Preview view

3.1.5  The Documents Validation view
Click on the Validation Tab to access the validation view.

Figure 46  The Documents Validation view
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Note:  This feature is only available beginning in Version 3.2.

On the Internet there are public services intended to help you to verify the validity of 
your code and the accessibility of your web page. Beginning in Version 3.2, webEdition 
includes the Validation view so you can validate your webEdition documents for 
barrier-free compliancy from within the CMS system either via URL transfer or file 
upload. The response of the service is displayed unmodified in webEdition (see Figure 
46 on page 67).

To have your page checked by one of the preset services, select the service from the 
Service dropdown menu and click OK. In Figure 46, you can see the response for a 
successful validation according to the rules of the World Wide Web Consortium (W3C).

You can add other services by clicking on the Edit button and then adding a new service 
(see Figure 47).

Figure 47  Adding a new service

You can subscribe to additional services such as:
• Validome (http://www.validome.org)
• Accessibility Bobby (http://bobby.watchfire.com)
• Cynthia Says (http://www.contentquality.com/)
• Checky (http://checky.sourceforge.net/) offers a list of validation services.
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3.2  Working with webEdition pages
3.2.1  Creating a new webEdition document

Use the following procedure to create a new document.

Procedure 1  Creating a new document

At the webEdition main screen
1 Select File > New > webEdition Page > Empty Page.

The webEdition Page Properties view appears (see Figure 48).

Figure 48  Creating a new document: Properties view

2 In the Path area of the Properties view, enter a name for the new document in the Filename 
field.

3 In the Path area of the Properties view, choose a directory for the new document by clicking 
the Select button adjacent to the Directory field.
a Navigate through the directory menus until you find the location for the new file.
b Click on the name of the target directory, then click OK.

4 Click the Save button located at the bottom of the screen.
webEdition opens a read-only information box informing you that the new file has been 
successfully saved.

5 Click the OK button.
The newly created file is now listed in red letters in the explorer menu and you can now start 
editing your new document. When a page is displayed in red, this indicates that it has been 
saved but not yet published.
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6 You have completed this procedure.

3.2.2  Saving, “unpublishing”, and deleting documents
After creating or modifying a document, you must save your files.

3.2.2.1  Saving and publishing a page
When working with a document, you can save a file while in any of the four views 
(Property, Edit, Information, Preview). webEdition differentiates between two 
situations: saving a new page and saving an existing page that has been changed.
• Saving a new page. You will be given the following options when saving a new 

page:
— Without publishing it. If you click the Save button without activating any of the 

check boxes, the page will be saved in the system, but will not yet be published. 
It will appear in the explorer menu in red.

— Publishing it. Before saving, activate Publish after saving and then click the 
Save button. The page will be saved and published at the same time so that it can 
be accessed from outside webEdition. Published pages appear in the explorer 
menu in black font.

— If you wish to have a new, empty document of the same type available for 
editing immediately after saving a document, activate the New page after saving 
checkbox.

• Saving an existing page. 
— Without publishing it. If you change an existing page and want to save it without 

changing the published page, make sure that the Publish after saving checkbox 
is not activated, then click Save. The document will appear in the explorer menu 
in blue, indicating its new status in "temporary storage" without being 
published—the old page will remain published.

— Publishing it. If you wish to publish an existing page immediately after 
changing it, or after having saved it temporarily, activate the Publish after 
saving checkbox and click on the Save button. If the page has been in temporary 
storage, the blue letters denoting its status will then become black in the explorer 
menu. You can check whether the page has been published by double-clicking 
on the document in the explorer menu. If it has been published, the new browser 
window will open displaying the page. If you try to double-click on a page that 
has not been published (red), a new browser window will appear informing you 
that the document has not been published.
If you wish to have a new, empty document of the same type available for 
editing immediately after saving a document, activate the New page after saving 
checkbox.

3.2.3  "Unpublishing" a file
If you wish to “unpublish” (or “park”) a published page without delete it, you can use 
the Unpublish function to place the file in temporary storage. Click on the page in the 
explorer menu to bring up the page in Edit mode. Instead of clicking Save, click 
Unpublish. The page will no longer be live and will appear in red letters in the explorer 
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menu. If you wish to re-publish this page, just activate the Publish after saving 
checkbox and click the Save button.

Note:  If a document has already been published, you can only change whether it is 
generated statically or dynamically by unpublishing it, making the change and 
re-publishing it.

3.2.4  Deleting documents, templates, objects, or classes
In this section, by way of example, we describe the deletion process for a document. To 
delete a template, object, or class, you proceed in a manner similar to the steps described 
here.

You can delete a document by clicking File > Delete > Documents (see Figure 49).

Figure 49  Deleting a document

A checkbox appears beside each document and directory in the explorer menu (see 
Figure 50).

Figure 50  Marking files for deletion
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Activate all of the checkboxes for the entries that you would like to delete.

3.2.5  Overview of all unpublished pages
You can access an overview of all unpublished pages or objects, in two ways:
• After logging in to webEdition, you can go directly there by clicking on the 

Unpublished pages (or Unpublished objects) button on the Quickstart screen (see 
Figure 51).

Figure 51  Quickstart-unpublished pages

• You can also select File > Unpublished pages (or Unpublished objects) from the 
File drop-down menu on the webEdition main screen (see Figure 52).

Figure 52  Accessing unpublished pages from the File menu

On this page you can view a table with all of the unpublished pages or objects that exist 
in the system (see Figure 53,  "Table of unpublished pages" on page 73). The following 
information is displayed about the pages or objects:
• Path. Where in the system is the document/object?
• Author. Who is the creator of the document/object?
• Created. When was the document /object created?
• Changed by. Who had modified the document /object in the course of the 

workflow?
• Changed. When was the change made?

CAUTION 

When you delete a directory, all documents and 
subdirectories contained within it will be lost. In order 
to exit from the delete mode, click the Cancel button. 
Click on the OK button to delete the file.
.
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• Last published. When was the document /object last published?
• Workflow step. Where in the workflow is the document /object currently found? 

(This column exists only if the Workflow Module is installed.)
If you click on a criterion (that is, a value found underlined in the header row of the 
table), the table will sort the output according to the selected criterion. If you click 
on the actual path of a document /object, the system will take you directly to the 
unpublished document /object.

Figure 53  Table of unpublished pages

3.2.6  Modifying and updating a document
If you want to modify an existing document, select File > Open > Document from the 
File menu on the webEdition main screen, or single-click the icon in the explorer menu 
that represents the document you wish to change. (If you double-click an item, a new 
browser window opens, displaying the page.) Go to the Edit view and enter the 
new/updated text. You can view the changes in the Preview view. If everything is 
correct, save (and/or publish) the document.

3.2.7  Creating a new document directory
You can create a new directory within webEdition by selecting File > New > Directory 
> Document directory (see Figure 54). The new directory will be saved in the database 
and will therefore be displayed in the webEdition explorer menu. Any directory created 
on the server without using webEdition will not be displayed in the webEdition explorer 
menu. For more information about the Browse Server feature, see page 53.

Figure 54  Creating a document directory

3.2.8  Copying the contents of one directory to another
All the contents of a webEdition directory (including sub directories) can be copied to 
your currently active directory in one step. While in the Documents view, if you click 
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on a folder in the explorer menu, the Document Directory Properties view opens (see 
Figure 55):

Figure 55  Directory Properties view

In the Copy directory area, click on Select. A browser opens from which you can choose 
the directory whose contents are to be copied to the current one.

3.2.9  Rebuilding static and dynamic Web pages
After making substantial changes to a static Web page, you must synchronize the 
content of your database with the content of the directories on your Web server. When 
you use the rebuild feature, the new contents or new features in the webEdition interface 
will be regenerated and then made visible to visitors to your site You can regenerate 
either your entire Web page or only sections of it. 

You can rebuild web pages using the File > Rebuild... command. Detailed instructions 
regarding how to use this feature are found in The webEdition Installation, Update and 
Backup Procedures.

3.3  Using the Import feature
webEdition allows you to import different types of files and data, and it offers an Import 
Wizard to help you with such actions (see Figure 56). The Import Wizard has two parts:
• File import. You can import files from two locations:

— from your local hard drive
— from your server

• Data import. You can import the following data files
— generic XML files
— CSV files
Standard   3.5.1   December 2005  



Working with documents – the role of the editor   75
Figure 56  The Import Wizard

The following sub sections descibe procedures for importing files into webEdition.

3.3.1  Importing local files

Procedure 2  Importing local files

In the webEdition main screen
1 Open the Import Wizard by clicking File > Import/Export > Import.

The Import Wizard opens.

2 Activate the Import local files radio button.
3 Click the Next button.

The Import local files window opens (see Figure 57).

4 Choose a destination directory by clicking the Select button adjacent to the Path field.
5 Instruct webEdition on what to do if the file name exists, then click the Next button

Figure 57  Importing local files

6 Choose a file (or files) from your local directory by clicking on the Browse button, then click 
Next.
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A progress bar appears at the bottom of the screen to tell you that upload is in progress. 
When the import has completed, the system will tell you the outcome of the action. Click OK.

7 You have completed this procedure.

3.3.2  Importing files from your server

Procedure 3  Importing files from your server

In the webEdition main screen
1 Open the Import Wizard by clicking File > Import/Export > Import.

The Import Wizard opens.

2 Activate the Import files from server radio button.
3 Click the Next button.

The Site Import window opens (see Figure 58).

4 In the Directories area, choose a source and destination directory by clicking the Select 
buttons.

5 Use the checkbox in the Import area to indicate the type of file you wish to import.
6 From the two select boxes in the Limits area, choose the depth and maximum file size for 

the import. 
The Depth select box allows you choose the number of recursive directories that are to be 
imported. For example, if you have the following directory structure /news/images/gifs, and 
you you import files from the news directory with depth = 0, webEdition will only import files 
from the news directory. Files from "images" will not be imported. If you set the depth to 
depth = 1, webEdition will also copy files from the images directory. If you set the depth to 
depth = 2, files from the gifs directory will be imported.

7 Instruct webEdition on what to do if the file name exists, then click the Next button.

Figure 58  Importing files from a server

A progress bar appears at the bottom of the screen to tell you that upload is in progress. 
When the import has completed, the system will tell you the outcome of the action. Click OK.

8 You have completed this procedure.
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3.3.3  Importing generic XML data

Procedure 4  Importing generic XML data

In the webEdition main screen
1 Open the Import Wizard by clicking File > Import/Export > Import.

The Import Wizard opens.

2 Activate the Generic XML Import  radio button.
3 Click the Next button.

The Generic XML Import window opens (see Figure 59).

4 In the importing area, choose a source file by clicking the Select button.
5 Use the radio buttons to select whether the import is a document or object.

a If you choose documents, select the document type, template, target directory, 
extension and category for the import.

b If you choose objects, select the object class and category for the import.
6 Click the Next button.

Figure 59  Generic XML Import

A progress bar appears at the bottom of the screen to tell you that upload is in progress. 
When the import has completed, the system will tell you the outcome of the action. Click OK.

7 You have completed this procedure.

3.3.4  Importing CSV files

Procedure 5  Importing CSV files

In the webEdition main screen
1 Open the Import Wizard by clicking File > Import/Export > Import.

The Import Wizard opens.

2 Activate the CSV import radio button.
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3 Click the Next button.
The CSV Import window opens (see Figure 60).

4 In the importing area, choose a source file by clicking the Select button.
5 In the Settings area, choose the type of separator and text separators used in your 

document, and indicate if the first line in the file uses a fieldname.
6 Click the Next button.

Figure 60  CSV Import

A progress bar appears at the bottom of the screen to tell you that upload is in progress. 
When the import has completed, the system will tell you the outcome of the action. Click OK.

7 You have completed this procedure.

3.3.5  webEdition XML import
This function is available to you from version 3.3 ofwebEdition; it serves exclusively 
the import of XML files which were generated with the webEdition Export module.

Procedure 6  webEdition XML import

In the webEdition main screen
1 Open the Import Wizard with File > Import / Export > Import
2 Activate webEdition XML Import radiobutton
3 Click on Next

The webEdition XML Import window opens (see Figure 61)
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Figure 61  webEdition XML Import

4 Select in the Importing area the file to be imported. It can be located on the server, as well 
as on your local hard disk

5 In the File collision area you determine how the system should behave, if already files of the 
same name should exist.

6 After you have dripped your choice, click on the Next button.
The Import options window opens (see Figure 62)

Figure 62  webEdition XML import options
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7 In this window are, depending on your installed modules and the data contained in the 
exported file, several areas:
• Documents / templates: Activate these checkboxes, so the documents and/or 

templates from the file to be imported are imported. With activated check box you can 
determine with the Select button a destination directory

• Objects / classes: Activate these check boxes to import objects and/or classes. This 
area is only displayed if the DB/OBJECT module is installed and objects or classes 
exist in the file to be imported.

• Doctype / category: These check boxes must be activated if you want to import 
document types and/or categories

• Owners data: Here you find the check boxes Restore owner's data and Overwrite 
owner's data. This area is only displayed if the user administration (PRO) is installed 
and user's data were coaccepted in the export.
— Activate the check box Restore owner's data, around the user to whom the data 

"belonged" originally to assign the rights also on the target system. If the data User1 
belonged, is also on the target system User1 of the owners. The user User1 must 
exist for it of course on the target system. Should this not be the case, the files are 
imported general-accessibly. This also applies to several users: If the data belongs 
to User1, User2 and User3, these rights on the target system are recovered, 
provided that these users also exist there.

— Activate the check box Overwrite owner's data and select a new user, while you 
click on the Select button to associate a new owner to the imported files. If both 
check boxes are activated, the rights are associated in the imported data to the 
same-being users, provided that these exist. Should the users not exist in the 
webEdition instance in which is imported, the rights go over to the user selected 
under Overwrite owner's data.

Click on Next
The details window opens (see 

Figure 63  Import details

8 Click after successful end of the import, whose progress you can read in the beam at the 
bottom on the left, on the Cancel button
Herewith the import of the webEdition XML data is concluded successfully
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3.4  Working with graphical documents
webEdition allows you to access not only webEdition pages, but also other graphical 
documents, which you can select from the File > New > Image drop-down menu.

webEdition differentiates between layout images, which are stored centrally on the host 
server in an image directory, and the images that vary depending on the accompanying 
content. The latter images are used by the editor and have to be inserted in the pages. 
Content images have to be uploaded before importing them to the webEdition database. 
If you wish, you can also import all the layout images to the database.

3.4.1  Uploading an image
Click File > New > Image. The Upload image dialog box opens in the Edit view (see 
Figure 64).

Figure 64  Uploading an image

If you wish to upload an image from your hard drive to the webEdition database, click 
on the Upload button. A window appears in which you can browse your hard drive (see 
Figure 65).

Figure 65  Browsing your files for an image

Click Browse. You will see the select window, in which you can browse for an image 
on your computer (see Figure 66).
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Figure 66  Selecting an image to upload

After you have found the image that you want, double-click it and it will appear in the 
search window. Click Upload in this window to display the selected image in the Edit 
view (see Figure 67).

Figure 67  Viewing an image in the Edit view

Use the Properties view to enter the name and directory in which you want to save the 
file. If you do not enter a new name, the image will be saved with its original name 
(default setting). If you clicked Save, you will be able to view the uploaded image in the 
directory you selected in the explorer menu and will be able to include it in webEdition 
pages. To learn how this is done, please consult Section 3.7.9,  "Image field 
(<we:img>)" on page 113.
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3.4.2  Importing more than one image
In webEdition you have the option of importing several images at once. Choose the item 
File > Import/Export > Import.... An import file dialog box opens (see Figure 56,  "The 
Import Wizard" on page 75). 

Activate the Import local files radio button, and click Next. The following Import local 
files screen opens (see Figure 68):

Figure 68   Import local files - step 1 of 2

Click on the Select button in the Destination directory area. The webEdition file 
manager opens, allowing you to choose the directory to which the images are to be 
imported. In this file manager, all directories within the root directory (/htdocs) of the 
Web server are displayed, therefore directories that are not managed with webEdition 
are also shown. The following window appears (see Figure 69):
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Figure 69  Import local files - step 2 of 2

webEdition asks you What to do if a file exists? in the lower area of the window. You 
must choose from one of three options. If, for example, you have modified an image and 
you wish to replace the old image, activate the Overwrite the existing file radio button 
to replace the old image. If the filename already exists in the target directory and you 
wish to rename the new file select Rename the new file. webEdition renames files by 
adding a number to the file name (for example, bg.gif becomes bg_0.gif). You can also 
instruct webEdition not to import a file if its file name already exists.

Click the Next button. Click the Browse... button to find an image on your local drive. 
You can repeat this action to import additional files.

Click Next to start the import. When the process is complete, the following message 
appears (see Figure 70):
Standard   3.5.1   December 2005  



Working with documents – the role of the editor   85
Figure 70  Import confirmation screen

Click OK to complete the procedure.

3.4.3  The image Properties view
The Properties view allows you to define the display parameters for an image. There 
are three areas, Path, Attributes, and Hyperlink.
• Path area. The Path area allows you to give (or change) a file name, select a 

directory, or choose a file extension for your graphic.
• Attributes area. Use this area to modify the appearance of your image file (see 

Figure 71).

Figure 71  The Properties view, Attributes area

The default settings are the values of the unchanged, original image.
— Width. Image width in pixels.
— Height. Image height in pixels.
— Border. You can have the browser draw a border around the image. The entry is 

calculated in pixels and specifies how thick the border will be
— Align. Entering left or right will cause the browser to align the image left or 

right. Accompanying text on the Web page is displayed to the left or right of the 
image and above and below it.

— Hspace. This field allows you to specify how far (to its right and left) the image 
is to be from other elements.

— Vspace. This field allows you to specify how far the image is to be from other 
elements above and below it.
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— Alt Text. This is the text that is displayed while the image is loading.
— Name. Image name.

• Hyperlink. In this area the image can be linked to a URL (see Figure 72):

Figure 72  The Properties view, Hyperlink area

— No link. Image is not linked.
— Extern. External link, e.g. www.webEdition.de, can be selected using the select 

button. 
— Intern. Internal link, can be selected using the select button.
— Target: Target denotes the location where the linked Web page should appear:

– empty field, Web page will open in the same window or frame
– _blank, a new browser window will open
– _top, the page will be loaded in the same window on the uppermost level, 

even if it has been called up from a frame.
– or you can specify the exact name of the frame or window in which the Web 

page will be displayed.
— Roll Over. If this checkbox is activated, you can choose a graphic using the 

select button which will appear to replace an image on a Web page as soon as 
one moves the mouse pointer over the original image. (This Web page feature is 
commonly called a roll-over or mouse-over effect)

3.4.4  The image Edit view
The image Edit view allows you to upload a new image from your local hard disk, or to 
overwrite an existing image. Click File > New > Image to open the Image Edit view (see 
Figure 74).

To select a file, click the Upload button, then click Browse to choose your file. (See also 
Figure 65,  "Browsing your files for an image" on page 81 and Figure 66,  "Selecting an 
image to upload" on page 82.)
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Figure 73  Uploading a new image

Once your new file has been uploaded, you can use the select box shown in Figure 74 
to perform the following editing functions:

Figure 74  Editing an image

• Resize. Define the size of the image. If the image is a JPEG, you can also choose the 
kind of compression. 

Figure 75  Resizing an image

• Rotate image. You can rotate the image here. If the image is a JPEG, you can also 
choose the kind of compression.
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Figure 76  Rotating an image

• Convert. Use this command to change the format of the image. If the image is a 
JPEG, you can also choose the amount of file compression.

Figure 77  Converting and image

3.4.5  The images Information view
For a description of this view, see Section 3.1.3,  "The Documents Information view" 
on page 66.

3.4.6  The images Thumbnails view: thumbnail formatting
webEdition allows you to create thumbnails from your existing images so that they can 
be displayed on your Web site in a picture gallery.

Creating thumbnails expends considerable processing resources, which can lead to 
latency. webEdition does not create thumbnails from your original images in real time 
each time your Web page is viewed by a visitor. To ensure that your thumbnails will load 
efficiently, you must pre-define the size and output format for your thumbnails using the 
Options > Thumbnails menu. By pre-defining your thumbnail formats, you can ensure 
that webEdition will automatically upload all of your thumbnails in the same size and 
format.You can pre-define, store and edit multiple thumbnail formats.

To create a new thumbnail format, click Options > Thumbnails. The Thumbnails format 
dialogue box opens. See Figure 78. Click the Add button. A dialog box opens and asks 
you to enter a name for your thumbnail format. Enter a unique and descriptive name and 
click OK. The name of your new format will appear in the text box on the Thumbnails 
formats dialog box.
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Figure 78  Defining thumbnail formats

Below the text box shown in Figure 78 are the following areas that you can use to define 
the characteristics of each thumbnail format:
• Name. If you have defined more than one thumbnail format, the Name field 

indicates which format you are viewing. You can also use this field to change the 
name of an existing thumbnail format.

• Properties. Use the Width and Height fields to define the size of the thumbnails.  
If you activate Keep aspect ratio, the proportions of the image will be retained. If 
the aspect ratio of the original image is different than the defined aspect ratio, the 
width and/or the height of the created thumbnail will never be larger than one of the 
adjusted values.

Example 
The original image has a width of 100 and a height of 80.
The defined values for the thumbnail are 50 (width and height) and Keep aspect 
ratio => The thumbnail will be 50 x 40. 
The defined values for the thumbnail are 50 (width), 20 (height) and Keep 
aspect ratio => The thumbnail will be 25 x 20.

If you indicate only one of the two values or if you indicate 0 as a value, the missing 
value (and/or the value 0) is computed proportionally.

Example 
The original image has a width of 100 and a height of 80.
The defined values for the thumbnail are 50 (width) and 0 (height) => The 
thumbnail will be 50 x 40.

If you activate Maximize if required, the thumbnail will be scaled up if the original 
image is smaller than the defined values for the thumbnail.
If you activate Maximize if required and the original image is smaller than the 
thumbnail, the original images will be used as thumbnail.
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3.4.7  Associating an image with a thumbnail format
Click File > New > Image. The Image: Edit view opens.

Figure 79  Uploading a new image

After uploading an image from your server or computer, click the Thumbnails tab. Click 
on the add image (the plus “+” icon).

Figure 80  Thumbnails tab

The formats that you pre-defined (see Section 3.4.6,  "The images Thumbnails view: 
thumbnail formatting" on page 88) appear in a select box above the image you have 
uploaded. Select the format for the image and click Add. 

Figure 81  Formatting a thumbnail

After formatting your image, it will appear in your Thumbnails list. (See Figure 82). 
Click the Save button to complete the formatting.
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Figure 82  Thumbnails list

3.4.8  Displaying your photo album 
Before you can upload images to a photo album, the template administrator must create 
a photo album template in which the thumbnails can be displayed. For details see 
Section 4.4.3,  "Creating a photo album" on page 131.

Create a directory for your thumbnail image files. This directory will contain the images 
for your photo album. Move your image files into the designated directory (or 
directories). You can do so by clicking on your image and opening the Properties view. 
In the Path area, choose the directory for your image by clicking Select and browsing 
your directories.

Create a new document by clicking File > New > webEdition Page > Empty page. Give 
the file a name in the Path area. In the Document area, use the Select button to browse 
your system for the album template created by your template administrator. Select the 
template, then click Save. Click on the Edit tab. Use the Album: Select option to choose 
what photo album (directory) will be displayed (see Figure 83). You can preview your 
thumbnails by clicking the Preview tab. Save and publish your photo album.

Figure 83  Choosing a photo album directory
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3.5  Working with non-graphical documents
webEdition allows you to work with a the following non-graphical document types, 
which you can select from the File > New > Other drop-down menu:
• HTML Page
• Flash movie
• Quicktime movie
• JavaScript
• CSS Stylesheet
• Other Files (*.doc, *.pdf, *.zip, *.txt)

3.5.1  Editing HTML pages
3.5.1.1  HTML document Properties view
You can use the HTML Properties view to program your own HTML pages (see Figure 
84). You cannot integrate webEdition features into this page. However, document types 
and categories can be selected in order to include these pages in summaries or in the 
"Find" feature. To make this possible, you must activate the Is searchable? check box. 
Since simple HTML pages do not have fields for a title or a description, you can have 
summary pages or search results pages display the path for the page or its content (either 
in its entirety or logically reduced to a certain number of characters) instead of 
displaying a field.

Figure 84  HTML Properties view

3.5.1.2  HTML document Edit view
You can enter HTML code in the Edit view (see Figure 85). In this case, webEdition 
acts as a simple text editing program. You can also program PHP scripts, Active Server 
Pages (.asp) or Java Server Pages (.jsp) in this view. To do this, you also have to select 
the corresponding extension when setting the properties for the page.
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Figure 85  Editing an HTML page

3.5.2  Using Flash movies
3.5.2.1  Flash movie Edit view
You can use the Edit view to upload Flash movies. Follow the same procedure for 
uploading Flash movies that you followed when uploading images (see Section 3.4.1,  
"Uploading an image" on page 81). 

Note:  You cannot allocate a hyperlink to a Flash movie because the attributes for 
Flash movies differ from those for images.

3.5.2.2  Flash movie Properties view
The Properties view has the following areas (see Figure 86,  "Flash movie Edit view" 
on page 94):
• Path area. The file name of the original movie is used as the default name.
• Attributes area. Several of the attributes are the same as those for images (). 

Additional attributes are:
— Scale:

– With the default setting, (Omit Attributes or Show All) the complete movie 
will be displayed in the area specified. Furthermore, the aspect ratio for the 
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movie is also retained. This means that the film will not appear distorted. 
Occasionally, bars will also appear on either side of the movie.

– No Border. scales the film to fit the entire area specified while still 
maintaining the film's original aspect ratio. The film will not appear 
distorted. Sections of the film might occasionally be cut off.

– Exact fit. displays the film exactly within the area specified. However, this 
setting doesn't retain the film's original aspect ratio, which might cause the 
film to appear distorted.

— Play. If you wish the file to begin playback immediately, do not set this attribute. 
However, if you do not wish the file to begin playback until the user performs 
an action, set this attribute. This is equivalent to a STOP action in the first frame 
of your movie.

— Quality. Here you can specify the quality of your movie.
— Backgroundcolor. This is the background color of your movie. Flash doesn't 

offer many options, but you can manually set the background color in this field.
— Align: Left, Right, Top, Bottom.
— Scaled Align:

– Left, Right, Top, Bottom aligns movies with the edge of the browser window 
you specify and, if necessary, cuts off the edges of the remaining three sides.

– Top left, Top right, Bottom left, Bottom right aligns movies with the corner 
of the browser window you specify and, if necessary, cuts off the edges of 
the remaining two sides.

— Loop. Replays the Flash movie once it finishes. Select Yes or No.
• Other area

— Pluginspage.
— Codebase.

Figure 86  Flash movie Edit view
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3.5.3  Using Quicktime movies
Follow the same procedure for Flash movies. Most attributes are the same with the 
exception of the following:
• Scale.
• Autoplay.
• Show Controller.
• Volume.
• Hidden.

See the vendor documentation for more details on Quicktime movie attributes.

3.5.4  Editing JavaScripts
3.5.4.1  JavaScript Properties view
You can use webEdition to create or edit JavaScripts. If you click on a JavaScript (.js) 
document or you select File > New > Other > Javascript, the Java script Properties view 
opens.

If you wish to copy an existing JavaScript from your directories, click the Select button 
in the Copy Javascript area. Thereafter you can rename the file by using the Filename 
field and then saving the document.

3.5.4.2  JavaScript Edit view
You can write your own JavaScripts (or modify an existing one) in the Edit view. 
Thereafter you can include your JavaScript in a template by using the <we:js> tag. For 
example: <we:js id="34"/>. This code includes the JavaScript with the ID 34 in the 
template. The views are the same as those shown in Section 3.5.5,  "Creating a 
cascading style sheet (CSS)" on page 95.

3.5.5  Creating a cascading style sheet (CSS)
You can use webEdition to create or edit a CSS. To do so click File > New > Other > 
CSS Stylesheet.

Figure 87  Creating a CSS

You can include a style sheet in the template by using the <we:css> tag. For example: 
<we:css id="89"/>. This code includes the style sheet with the ID 89 in the template.
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Figure 88  Cascading style sheet in the Edit view

3.5.6  Other files
The following additional documents can be imported into webEdition so that they are 
available to be downloaded by visitors to your Web site:
• Microsoft Office documents (.doc, .xls, .ppt)
• PDF documents (.pdf)
• Zip files (.zip)
• Stuffit files (.sit)
• Programs (.exe)
• Mac Binhex files (.hqx)
• BIN files (.bin)

3.5.6.1  Uploading other files in the Edit view
To import a file, select the menu item File > New > Other > Other Files. The Edit view 
opens. Then follow the same procedure as you would when uploading an image (see 
Section 3.4.1,  "Uploading an image" on page 81). The file name of the original file is 
used as the default name.

3.5.6.2  Other files Properties view
Select the directory in which you wish the document to be saved in the Path area of the 
Property view.

To make the file available to visitors to your site, link the document to a text entry or to 
a link list.

Note:  The size of the upload can be limited. The default settings for MySQL are such 
that you can save up to a maximum of 1 MB of data per SQL-instruction. For PHP 
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the default setting for the maximum upload capacity is set to 8 MB. If you wish to 
upload larger files, change the settings in your MySQL and PHP configuration files, 
or speak with your service provider about increasing these default values.

3.6  Features in the Options menu
For details about the items available in the Options menu, see Figure 23,  "The Options 
menu" on page 54.

3.6.1  Document types
The Document types feature is accessed from the Options menu. The Document types 
feature allows you to group documents with similar characteristics, or to assign 
characteristics to a new document that are similar to existing documents. Document 
types are intended to ease your workload by enabling you to set collective default 
attributes for documents. When you create a new page you will be asked to assign the 
document to a document type. When you do so, the new document will inherit the 
default values of the chosen document type.

The default values that you set will pre-define the location, template, and file extension. 
Once these values have been set as defaults, you will not need to set them again 
whenever you create a new webEdition page and assign it to a document type.

Secondly, because a document type can be allocated to any number of webEdition 
pages, you can use this feature to create a summary page that lists (and links to) of all 
pages based on a selected document type.

For example, you could create a "News" document type. You then allocate it a default 
storage directory, in this case "news", and a template called news_template.tmpl. Now, 
whenever you wish to create a new news page, you only need to select the "News" 
document type – both the template and the default storage directory for news pages will 
be selected automatically.

3.6.1.1  Creating a new document type
In the Options drop-down menu, select Document Types... The Document types dialog 
box appears (see Figure 89).
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Figure 89  Creating a new document type

To create a new document type, click the New document type button.

A response box opens where you are asked for the name of the new document type. 
Enter the name and select OK (see Figure 90).

Figure 90  Naming a new document type

The new document type will appear in the list box as shown in Figure 91.

Figure 91   New document type/delete document type
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The Templates area allows you to allocate the appropriate template(s) to the active 
document type, displayed in the Name area. Click on the Add button to browse your files 
for a template (see Figure 92).

Figure 92  Selecting a template for a document

In the Default values area, specify the default settings for the document type. 
• Directory. Use the Select button to choose a directory for all webEdition pages 

based on this document type.
• Subdirectory. Use the pick list to create a subdirectory which is identified in your 

explorer menu by the date of creation. Thereafter all documents in this document 
type will be associated with the default creation date.

• Default extension. Use the pick list to select the default extension for all documents 
in this document type. 

• Template. Use the pick list to select or de-select a default template. 
• Generate dynamic page. Use this checkbox to choose whether or not you want the 

page to be dynamically created.
• Is searchable? Use this checkbox if you wish your page to appear on summary 

pages. 

Note:  If a page is not searchable, it will not appear on summary pages.

• Category.

Once you have specified all the settings, click Save.

3.6.1.2  Deleting a document type
You can delete a document type by clicking an item in the list box located in the 
Document type dialog box and then clicking the Delete document type button (see 
Figure 91,  "New document type/delete document type" on page 98).

3.6.1.3  Editing Document types
In the Document types section, select the document type you want to edit and follow the 
procedure described in Section 3.6.1.1,  "Creating a new document type" on page 97.

3.6.2  Categories
The Categories feature is accessed by selecting Options > Categories in the main menu 
(see Figure 93). The Categories feature offers an alternate method of generating 
summaries. You can also use Categories together with Document types to generate 
sub-summaries. 
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Figure 93  The Categories feature

For example, if you have a "News" document type, you could subdivide it into “Sports”, 
“Politics”, “Computing” and “General” so that you can generate summary pages such 
as “Sports News”. Thereafter, you could create sub-categories that are subordinate to 
the Sports category such as “Football”, “Baseball”, “Hockey”, etc.

3.6.2.1  Creating a new category
Select Options > Categories. A file management window opens that allows you to 
create or delete categories and folders containing categories. This dialog box and its 
icons operate in the same manner as the Browse Server dialogue box (see Section 2.3.1,  
"The File menu" on page 51, for further details on how to use webEdition’s file 
management windows).

3.6.3  Changing user name and/or password
You can change your user name by clicking on Options > Change user name. The 
Change user name screen appears (see Figure 94):

Note:  If you have installed the User Management Module, you will see User 
Management in the menu. Click on this item to access the module and to perform user 
management functions. For details see The User Management Module User Guide.

Figure 94  Change user name screen

To modify your password, select Options > Change password. Enter your old and new 
passwords in the designated fields, then click on the Save button (see Figure 95).
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Figure 95  Change password screen

3.7  How an editor works within a template: using template input fields, 
lists and menus

Whether you are creating a new document or modifying an existing one, you will be 
working within a structure that is defined by a template. When you open or create a 
document in the Edit view, you see various fields, pick lists, or menus which you can 
fill with text, images, etc. This editing mode is your working interface; what you see in 
this view is not what the finished page will look like. To see how your page will look to 
visitors to your Web site, select the Preview tab. The following table summarizes the 
fields that commonly appear in the templates you will be using. The sub sections 
thereafter describe the fields in detail. 

3.7.1  Single-line input box (<we:input type="text">)
This field is used for single-line text blocks such as headers. You can also write HTML 
code in the input box (see Figure 96).

Field Description we:tag

Text input A single input box. we:input (text)

Date selection A drop-down menu to enter date and 
time. 

we:input (date)

Check box A check box. Toggles a field on or off we:input (checkbox)

Input choice box A normal single-line input box with a 
drop-down menu beside it.

we:input (choice)

Text block A multi-line input box. we:textarea

Select box A select box (also called a pick-list). we:select

List block Used to repeat blocks of fields we:block

List of links An expandable list of all your links. we:linklist

Images Allows you to insert images we:img

Movies Allows you to insert Flash or 
Quicktime movies

we:flashmove 
we:quicktime
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Figure 96  Sample page of single-line input box in the Edit view

Sample page: /we_demo/news/2004/finnland.html

3.7.2  Date (<we:input type="date">)
By clicking on these fields, you can set the date you want to appear on the Web page 
(see Figure 97).

Figure 97  Sample page showing date fields

Sample page: /we_demo/news/2004/finnland.html

3.7.3  Checkbox (<we:input type="checkbox">)
This field is used as a switch to insert or remove an area of a template.

3.7.4  Input choice box (<we:input type="choice">)
This feature allows you to create a single-line input box beside a drop-down menu (see 
Figure 98).

Figure 98  Using an input choice box

When you select an entry in the drop-down menu, the system copies your choice to the 
input box (on the left). You also have the option of typing your own value in the input 
box, if you require a value different from those in the pre-defined drop-down menu. The 
values available in the drop-down menu are pre-defined by your template administrator. 
For example, the template code seen in Figure 98 is as follows: 

<we:input type="choice" name="City" size="40" 
values="Berlin|Madrid|Ottawa|Washington"/>

3.7.5  Text box (<we:textarea>)
The appearance of this text box is determined by the browser version you are using. We 
recommend using Internet Explorer 5.5 or higher, since it displays the text area as a 
WYSIWYG editing program if the dhtmledit attribute in the template is set to ON.

3.7.5.1  Normal input screen
This text box is intended to be used for relatively long texts. The text can be formatted 
or links can be inserted using HTML commands (see Figure 99).
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Figure 99  Using a text box

If the autobr (automatic line break) attribute has been specified (true or false), a 
checkbox will be displayed at the top of the input box. You can turn the autobr feature 
on or off using this checkbox. If autobr has been activated, all forced line breaks (return 
key) will be translated as HTML line breaks (<br>). If autobr has been set to false, the 
return key is equivalent to a space. For information on the .rtf function, see Section 
3.7.5.4,  "Importing Rich Text Format files (*.rtf)" on page 108. The code for Figure 99 
is as follows:

<we:textarea name="Content" width="250" height="100" autobr="true" 
wysiwyg="false" importrtf="true"/>

3.7.5.2  WYSIWYG input screen
If your template administrator has included a WYSIWYG editing screen in your 
template (by setting the we:tag attribute wysiwyg to true), the text box appears in the 
form of a WYSIWYG (What you see is what you get) text editor (see Figure 100).

Figure 100  Using a WYSIWYG input screen

You can edit texts in this field just as you would in a standard word processing program.

If you wish to work directly with HTML tags in the input box, you can do so by clicking 
the toggle that appears as a pencil icon directly above the input box. If you do so, the 
pencil icon will toggle to an eye icon, and the input box will allow you to enter HTML 
code (see Figure 101).

Figure 101  WYSIWYG toggle buttons

3.7.5.3  Accessibility functions of the WYSIWYG Editor (Version 3.2)
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Beginning in webEdition Version 3.2 functions have been added to the WYSYWIG 
editor that make it easier for you to create Web pages that are accessible to the visually 
impaired. (see Figure 102).

Figure 102  WYSIWYG textfield in Version 3.2

3.7.5.3.1  Features for screen readers    The following functions appear in 
Version 3.2:
• Expanded abbreviations for screen readers: 

In order for a screen reader to read an abbreviation aloud, the abbreviation must be 
expanded. Highlight the abbreviation that appears in the text area, and click the 
“eg.” button from the WYSIWYG editor. The following window opens:

Figure 103  Define abbreviation for 
a screenreader

After highlighting the abbreviated 
term, the expression is entered in 
full in the title field. The language 
of the expression is defined by a 
2-character country code in the 
language field. In our example, the 
definition for the abbreviation 
“HTML” is shown.

• Language selection for screen reader:
To enable screen readers to read foreign words correctly (that is, those that are not 
in the default language of the document), highlight the respective word and click on 
the language button (which appears as a group of flags). The following dialogue 
opens:
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Figure 104  Language selection for 
screenreader

From the dropdown menu, select 
the two character international 
countrty code representing the 
language of the foreign term (for 
example, “de” for German, or “en” 
for English).

• Edit Hyperlink dialogue enhancements for screen readers
Additional fields appear in the Edit Hyperlink dialogue box beginning in Version 
3.2 (see Figure 105 on page 106). To activate the hyperlink dialogue box, highlight 
the text that you wish to link, and click on the insert/edit link button (the chain icon). 
You can now set the language of the linked text as well as the language of the linked 
page (Link and linked page fields under language). These fields correspond to the 
HTML attributes lang and hreflang. 
The fields title, accesskey and tabindex have been added. Under accesskey a 
character or a figure can be entered with which a link can be activated. The link can 
also be activated with ALT+ character/figure. 
For Tabindex, a figure can be entered defining the order in which the links are 
navigated by pressing the tab key. Enter the title of the link in the title field. When 
the mouse is placed over the link, this title will be displayed in text (as a 
mouse-over) in most browsers.
webEdition User Guide



106   Working with documents – the role of the editor 
Figure 105  Edit Hyperlink in WYSIWYG

• Table Summary field for screen readers
If you click on the Insert table button in the WYSIGYG editor, you can add a 
summary for a table in the Summary field of the Insert table dialogue box (see 
Figure 106). A screen reader will read the summary as a description of the table.

Figure 106  Insert table - table summary
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• Editing table cells for screen readers
By clicking the Edit table cell button, table cells can be defined as headline cells (th 
instead of td) in the Edit cell dialogue box (see Figure 107). To identify a cell as the 
header, activate the is headline checkbox. Additionally, the attributes id and headers 
have been added for non-visual output (such as screenreaders), so you can explicitly 
reference a data cell to one or multiple headline cells. The sytem is thus able to 
repeat the content of the headline cell(s) for every data cell. Otherwise, it would be 
very difficult to establish a relationship between a data cell and a headline cell for 
the voice output, as voice output lacks the the visual cues inherent in a table. To set 
these references, you must set a unique name for the id of the headline cell. In the 
data cells, you must enter this id in the headers field. Multiple ids are separated with 
spaces.

Figure 107  Edit table cell dialogue box

• Table captions for screen readers
After creating a table, a table caption can be added (or removed) by clicking the 
caption buttons. The caption will appear in the WYSIWYG editor field above the 
table.

Figure 108  Table caption
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3.7.5.4  Importing Rich Text Format files (*.rtf)
You can import RTF files directly to either the normal or the WYSIWYG text input 
boxes. This means that you can write and format your text in a standard word processing 
application. Therafter, you can import your text using the RTF import function and 
webEdition will retain your original formatting. 

Note:  The import button appears only if the importrtf attribute has been set to true 
in the template by the template administrator.

Figure 109  Import .rtf file button

By clicking on the Import .rtf file button (Figure 109), you open the following 
dialogue box (see Figure 110):

Figure 110  The Import RTF file dialogue box

Locate the file you wish to import from your local hard drive by clicking the Browse 
button and then upload it to the preview field by clicking the Import button. All the 
formatting will be applied. Since there are many different RTF formats, only the font, 
font size and font color are not automated and thus optional.

Figure 111 shows an example of text to be imported from a word processing program.

Figure 111  Example of an RTF file

Thereafter, the following content is seen in the Preview area (see Figure 112):
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Figure 112  RTF text in Preview mode

Click OK to inserted the imported text into the text box. 

Figure 113  RTF text imported into webEdition

Note:  RTF formats may differ from one application to another. Such differences may 
distort the way the text is displayed in webEdition. Such errors can be corrected in 
the Edit view.

3.7.6  Lists (<we:block>)
Lists are blocks of code which can be modified using the editing controls. You can 
duplicate a list item by clicking on the plus button. By clicking on the arrow icons, you 
can move a block up or down within the list. You can delete a block by clicking on the 
adjacent trash can icon. An example of a list block is shown in Figure 114.
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Figure 114  Example of a list block

When viewed in the preview view, the list block looks thus:

Figure 115  Example of a list block in Preview view

3.7.7  Link list (<we:linklist>)
You can use the link list feature to create link lists (see Figure 116). A plus button will 
appear, which you can click to add a new link to the list. Links can be deleted by clicking 
the trash can icon.

Figure 116  Example of a link list (we_demo/includes/navigation.php)

When viewed in the preview view, the list block looks thus:

Figure 117  Example of a link list in Preview view

The following procedure describes how to create and edit hypertext links. For the 
purpose of this procedure, see we_demo/links/links.html on the webEdition demo page.
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Procedure 7  Adding and Editing links

In the Documents Edit view
1 Open the file we_demo/links/links.html, and click on the edit hyperlink button (see 

Figure 118). 

Figure 118  Edit hyperlink button

The Edit link dialog box opens (see Figure 119). 

Figure 119  Edit link dialogue box

2 In the URL area, specify whether the link is to be to an internal or external page or object 
by ckicking one of the radio buttons. 

3 Click the corresponding Select button to launch the file manager, where you can 
browse for and select your target document.

4 If you use frames, you can specify the target frame (_name-targetframe) in the Link 
target field. The select box to the right contains some standard target designations.

5 In the Content field, enter a text string that will appear as the link on your Web page. 
If you would rather link to an image, you can specify either an internal or external 
image as well as where it is to be positioned and the alternative text. You can also 
select an internal image using the file manager, which can be launched in the Content 
area by clicking the select button.

6 You have completed this procedure.

3.7.7.1  Accessibility enhancements for links in Version 3.2
In version 3.2, the link dialogue has been expanded (see Figure 120). The new fields 
improve your ability to create accessible Web sites. For more information about thes 
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fields, see Section 3.7.5.3,  "Accessibility functions of the WYSIWYG Editor (Version 
3.2)" on page 103. 

Figure 120  Edit Link from Version 3.2 on

When linking images, you can also enter Alternative Text as well as a Title that will be 
read by screen readers.

Figure 121  Linking images in version 3.2

3.7.8  Select box (<we:select>)
A select box (or pick-list) allows you to choose one item from a list of pre-defined 
values (see Figure 122).

Figure 122  Select box
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When working in the Edit view, click the arrow beside the box to view the values that 
are available to you. The value you choose will be displayed on the finished Web page. 
The template code is thus:

<we:select name="Cities" size="1">
  <option>London</option>
  <option>Paris</option>
  <option>New York</option>
  <option>Toronto</option>
</we:select>

3.7.9  Image field (<we:img>)
An image field allows you to insert an image in the page content (see Figure 123).

Figure 123  The image field

By clicking on the edit button, you will launch a file manager in which you can select 
an image that has been uploaded to webEdition. For further details, see Section 3.4,  
"Working with graphical documents" on page 81.

The code for Figure 123 is: <we:img name="Picture"/>

3.7.10  Movie fields (<we:flashmovie> and <we:quicktime>)
The movie fields allow you to insert a Flash or Quicktime movies in the page content 
(see Figure 124).

Figure 124  The Flash and Quicktime movie fields

By clicking on the edit button, you will launch a file manager in which you can select a 
Flash movie that has been created or uploaded to webEdition. The template code for 
Figure 124 is: 

<we:flashmovie name="MyFlash" width="100" height="100" 
user="editor1,editor2"/>

For more information on Flash movies, see Section 3.5.2,  "Using Flash movies" on 
page 93; for Quicktime movies, see Section 3.5.3,  "Using Quicktime movies" on page 
95.

3.8  Editing documents in seeMode
seeMode is designed to make the editing of Web pages simple and efficient. This mode 
offers you a WYSIWYG view of your Web site. You can navigate through your site just 
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as you would with your regular browser (see Figure 125). When you get to the page you 
wish to edit, you simply click the Edit button at the bottom of the page.

Note:  The seeMode feature in webEdition 3.0 cannot be used with Web sites that use 
HTML frames.

Figure 125  The seeMode preview

Those fields on your page which represent included files that can be navigated to and 
then modified are identified by a seeMode edit icon.

Figure 126  The seeMode included file list
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The following procedure describes how you can use the seeMode to edit a document.

Procedure 8  Editing a document using seeMode

At the main webEdition login screen
1 Select the seeMode radio button, enter your user name and password (see Figure 127).

Figure 127  Login to seeMode

2 Click Login.
webEdition opens in seeMode at your designated home page (see, for example, Figure 
125,  "The seeMode preview" on page 114). The start page is determined in the Preferences 
screen (see Section 2.2.1,  "The User interface view" on page 42). Your ability to change 
this start page is dependent on the permissions that you have been given by your 
administrator.

3 You have two choices. You can select Edit or In Workflow.
a If you have installed the Workflow Module, you have the option of placing your 

document into the workflow. 
Consult the documentation for the Workflow Module, then go to Step 6.

b If you wish to edit the page, click the Edit button.
The page opens in the seeMode edit view and you can modify the fields (such as those 
described in Section 3.7,  "How an editor works within a template: using template input 
fields, lists and menus" on page 101; see also Figure 128).
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Figure 128  seeMode edit view

4 Edit your content by changing the data in the available fields.
5 Choose one of the following options:

a Return to the preview screen (by clicking the Preview button).
b Edit the properties of the page by clicking the Properties button (See Section 3.1.1 for 

further details).
c Place your document into the workflow.
d Save your changes (with or without selecting the Publish after saving option).

After saving your file, webEdition will confirm the action, the edit window closes, and 
you are returned to your designated home page.

6 You have completed this procedure.
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4  Creating templates—the role of the 
administrator

The webEdition content management system differentiates between the role of the 
editor and the role of the administrator. The following chapter describes how 
administrators can use webEdition to create templates, as well as some of the features 
included in webEdition that can assist in this task. An administrator must have a 
knowledge of HTML and PHP programming to create a template.

4.1  What is a template?
Templates form the framework for a Web page. In a content management system, 
content is separated from the layout. The layout is created with templates designed by 
an administrator, while the content is created by editors in documents based on 
templates. Templates are normally created using HTML and expanded using we:tags.

Note:  This manual always refers to the sample pages supplied with the software. 
Sample pages are located in the we_demo directory within the explorer menu.

4.1.1  What are we:tags?
we:tags comprise a tag language based on XML which contain HTML, JavaScript and 
PHP functions. They always begin with "we:". All webEdition features are defined by 
these tags. Like HTML tags, we:tags can have attributes. Although there are we:tags 
that require an end tag (such as <we:block></we:block>), most do not require an end 
tag.

4.1.2  How do I use we:tags?
There are many we:tags that serve many functions. All we:tags are described in detail 
in The webEdition Tag Reference Manual, which is available on the webEdition Web 
site. Some of the most commonly used we:tags are listed in the following table:

we:tag Description

we:input (text) Creates a single input box.

we:input (date) Creates a drop-down menu to enter date and time. 

we:input (checkbox) Creates a check box.

we:input (choice) Creates a normal single-line input box with a 
drop-down menu beside it.

we:textarea Creates a multi-line input box.
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4.1.2.1  The Tag Wizard
webEdition provides you with a Tag Wizard when you are creating or editing a template 
so that you do not need to memorize the functions and names of all of the we:tags. (The 
Tag Wizard can be accessed from the template Edit view; see Section 4.2.2,  "The 
Templates Edit view" on page 120). The scroll box on the left contains all available 
we:tags, listed in alphabetical order (see Figure 129). Select a we:tag and double click 
or click on the arrow between the two boxes.

Figure 129  The Tag Wizard

If this we:tag allows or requires you to assign attributes to it, a new window will open 
with a brief description of the tag and fields for all the attributes you can assign to it (see 
Figure 130). Any attribute you are required to assign are marked with an asterisk (*).

we:keywords Creates input boxes for the meta tags.

we:description Creates input boxes for the meta tags.

we:title Creates input boxes for the meta tags.

we:search (textinput) Creates a single-line input box (also on the 
finished page) that can be used for queries.

we:search (textarea) Creates a multi-line input box for queries.

we:select Creates a select box.

we:category Assigns the page / site to a category (important for 
summary pages).

we:linklist This tag is used to generate expandable link lists.

we:link  Defines the link in link lists.

we:tag Description
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Figure 130  Assigning attributes using the Tag Wizard

After saving your attributes, the window closes and the we:tag (complete with the 
selected attributes and correct syntax) will appear in the Tag Wizard text box to the right 
of the arrow button. Using copy and paste, insert the we:tag into the source code that 
appears in the text input box. You can also use the Select all, Prepend or Append buttons 
to insert the tag at the beginning or the end of the template code.

4.2  The four views when working with templates
In Chapter 2, we discussed how the editing screens and the available views are different 
depending on whether you are working with a document or a template. The following 
sub-sections describes each of these views as they pertain to your webEdition templates.

4.2.1  The template Properties view
You use the Properties view to define the name, location of your webEdition template 
(see Figure 131).
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Figure 131  The Templates Properties view

The properties view has two areas: Path and Copy template.
• Path. This area allows you to enter the name of the template and the directory in 

which it is to be saved. Select the directory by clicking the Select button and using 
the file manager. To avoid input errors, the directory cannot be entered by hand. The 
file extension has been pre set to .tmpl.

• Copy template. You can also import an existing webEdition template by clicking the 
select button in the Copy template area. Select the template you wish to import from 
the file manager and click OK (see Figure 132).

Figure 132  Copying a template using the file manager

4.2.2  The Templates Edit view
The Edit view displays the HTML code for the template (see Figure 133). The Edit view 
provides a text editing programme in which you can change or expand the standard 
HTML code and insert various we:tags.
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Figure 133  The Templates Edit view

Below the text-editing area, you will find the webEdition Tag Wizard. The wizard 
assists you in finding and entering the we:tags and assigning the proper attributes to 
them. For more details on how the we:Tag Wizard works, consult Section 4.1.2.1,  "The 
Tag Wizard" on page 118.

4.2.3  The Templates Information view
The Information view provides you with general information on the storage path, the 
size of the template and when it was created or changed (see Figure 134).

Figure 134  The Templates Information view

4.2.4  The Templates Preview view
The Preview view displays the layout of the template as it will appear in edit mode when 
used by the editor (see Figure 135).
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Figure 135  The Templates Preview view

4.3  Creating templates
webEdition allows you to create new templates, or to import existing ones.

4.3.1  Creating templates using webEdition
If you wish to use webEdition to create a template, you enter the necessary HTML code 
in the text/code editing area in the template Edit view (see Section 4.2.2,  "The 
Templates Edit view" on page 120). 

A template must contain all of the standard HTML tags: <html>, <head> and <body> 
with their end-tags. In contrast, if you wish to include this template as a document using 
the <we:include> tag, you do not use these HTML tags.

When linking references (images, links, etc.) that determine the design of several pages 
(that can be spread out over different directory levels), that is the layout images, you 
must create an absolute link to the images. The URL is based on the root directory on 
the Web server (of your host). This is the only way to ensure that a layout image can 
always be found, no matter where the files using that image have been saved.

Sample template:
<html>
<head>
<we:title>CMS Channel</we:title>
<we:description>Demo-Website for the CMS 
webEdition</we:description>
<we:keywords>cms,webEdition</we:keywords>
<style media="screen" type="text/css"><!--
#menu1 { position: absolute; z-index: 5; top: 63px; left: 131px; 
width: 122px; height: 10px;visibility: hidden  }
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#dummy{ position: absolute; z-index: 1; top: 0px; left: 0px; width: 
400px; height: 400px;visibility: hidden  }
--></style>
<link href="<we:url id="89" />" rel="styleSheet" type="text/css">
</head>
<body  background="/root/layout_images/bg.gif" bgcolor="white" 
leftmargin="0" marginwidth="0" topmargin="8" marginheight="8">
<we:form id="114" method="get"><table border="0" cellpadding="0" 
cellspacing="0" width="620">
<tr>
<td width="27"></td>
<td width="50"><img src="/root/layout_images/we_logo.gif" 
width="50" height="50" border="0"></td>
<td width="54"></td>
<td><span class="headline">&nbsp;CMS Channel - </span><span 
class="headline_small">News</span></td>
<td class="normal" width="74"><we:date type="js" 
format="m/d/Y"/>&nbsp;</td>

4.3.2  Creating a new template
Use the following procedure to create a new template.

Procedure 9  Creating a new template

At the webEdition main screen
1 Select File > New > Template.

The webEdition Template Properties view appears.

2 In the Path area of the Properties view, enter a name for the new template in the Filename 
field.

3 In the Path area of the Properties view, choose a directory for the new template by clicking 
the Select button adjacent to the Directory field.
a Navigate through the directory menus until you find the location for the new file.
b Click on the name of the target directory, then click OK.

4 If you wish to copy an existing template, click on the Select button in the Copy template 
area.
a Navigate through the directory menus until you find the location for the new file.
b Click on the name of the target directory, then click OK.

5 Click the Save button located at the bottom of the screen.
webEdition opens a read-only information box informing you that the new file has been 
successfully saved.

6 Click the OK button.
The newly created file is now listed in the explorer menu and you can now start editing your 
template, or using it as the basis of a new document. 

7 You have completed this procedure.

4.3.3  Saving a template
You can save the template while working in any of the four views by clicking the Save 
button at the bottom of the screen (see Figure 135,  "The Templates Preview view" on 
page 122).

If you change an existing template that is being used by documents, you will be asked 
whether you want to re-save the corresponding documents. If you select yes, the 
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template and all documents that use the template will be re-saved. If you select no, only 
the template will be saved and any documents based on this template will continue to 
use the old template. The option Automatic rebuild causes an automatic re-save of all 
documents which are based on this template.

4.3.4  Updating/modifying a template
To update or modify a template, either single-click the template in the explorer menu or 
select your template from the file browser by clicking on File > Open > Template... in 
the webEdition main screen. Make your changes in the Edit view and then save the 
template.

4.3.5  Deleting a template
You can delete a template by selecting menu item File > Delete > Templates. The 
application will then switch to delete mode. Use the explorer menu to select the 
template you wish to delete and click the OK button. Confirm or cancel your action.

Note:   If a template is being used by one or more documents, you cannot delete it. If 
you try to do so, an error message will be displayed to this effect. If you still wish to 
delete the template, you will have to delete or modify all the documents that use the 
template before you can delete the template itself. 

4.3.6  Adopting an existing Web site
4.3.6.1  Adopting an entire page
Determine how many HTML pages your current Web site uses. Group your pages 
according to their basic layouts in order to identify the pages that share the same layout 
but differ in their content. You can use these pages to create your new templates. 

Procedure 10  Adopting an existing page

In the webEdition main screen
1 Create a new template, by clicking File > New > Template. (see Procedure 9,  "Creating a 

new template" on page 123).
2 Click on the Edit tab to access the Edit view. 
3 Copy the source code from the old HTML page you wish to use as a template into the 

code/text-editing area in the Edit view.
4 Replace the hard-coded HTML tags, text and images with their we:tag equivalents.

Example 
To replace an HTML image tag:
Old code:

<tr> 
<td><img scr="example1.jpg" width="100" height="30" 
border="1"></td>

HTML tag we:tag

images (<img src="...>) <we:img>

Text <we:textarea>

Heading <we:input type="text">
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  <td><img src="example2.jpg" width="120" height="30" 
border="1"></td>
</tr>

New code:
<tr>
<td><we:img name="example1"></td>
  <td><we:img name="example2"></td>
</tr>

And now instead of seeing images in the template preview, you will see a placeholder.

Example 
To replace a text tag:
Old code:

<strong>>This is a sample heading in bold and italics</strong>

New code:
<strong><we:input type="text" name="sample" 
size="20"></strong>

5 Create a new webEdition page based on the new template.
6 Copy the content from your original page(s) into the input boxes in the template(s) using 

copy and paste and/or import the images to the database. See Section 3.4,  "Working with 
graphical documents" on page 81.

7 Save each page. 
The new webEdition page is saved in the same location as the old page, thereby overwriting 
it.

8 You have completed this procedure.

You can find further information about the we:tags, their attributes, and their functions 
in The webEditionTag Reference that is available from the webEdition home page.

4.3.6.2  Adopting portions of a page
If you only want to manage portions of specific pages with webEdition, replace these 
portions with their we:tag equivalents and then save the page as a template. The 
template can be used to recreate the page.

4.3.7  Creating templates from documents made in HTML editing programs
You can create templates using an HTML editing program (such as Macromedia 
Dreamweaver or Adobe GoLive). For more information, see Section 4.3.6.1,  
"Adopting an entire page" on page 124.

Procedure 11  Creating a template from an HTML editor

Begin in your preferred HTML editor
1 Create a page in your preferred editing program.
2 Move all the layout images you need for the page to a folder called images.
3 Upload the images via FTP to your Web server in the directory you have chosen (such as 

layout_images in the root directory).
4 On your web server, use the global search and replace feature to replace all images/ with 

/images/.
5 Use the copy and paste feature to copy the source code for the HTML page to the 

webEdition template Edit view (See Templates > Edit view, upper text box).
6 Replace the text, images, Flash movies etc. that you wish to edit with the appropriate 

we:tags.
webEdition User Guide



126   Creating templates—the role of the administrator 
7 Define the functions you wish to include in the page using the appropriate we:tags.
8 Save the template.
9 You have completed this procedure.

4.4  Features for developing webEdition templates
The sub sections that follow describe the features that are available in webEdition to 
assist in the development of templates.

4.4.1  Link lists (<we:link> and <we:linklist>)
The <we:linklist> tag allow you to include expandable and editable link lists in your 
templates. You can change the appearance of these link lists using HTML commands. 
For example, you can design the link to be flanked by non-linked text or images. You 
can create both image links and text links. You can use almost all tags within a link list. 
To add a link to the linklist, use the <we:link> tag.

When using your template, the editor will be able to edit any link by clicking the Edit 
button or delete a link using the trash can icon. The editor can also add a link at the very 
end of the link list or can place it before any existing link. See Section 3.7.7,  "Link list 
(<we:linklist>)" on page 110 for examples.

You can also use the <we:prelink> and <we:postlink> we:tags to ensure that all the 
characters or commands between <we:postlink> and </we:postlink> or those between 
<we:prelink> and </we:prelink> will not be displayed in the first or last instance. For 
example, if you separate the links with a <p>, then you want the <p> to appear only 
between the links and not directly before or after the link list. To keep this from 
happening, you would have webEdition skip the first instance of <p>, for example:

<we:linklist name="linklist">
  <we:prelink><p></we:prelink>
  <we:link/>
</we:linklist>

would produce for the first instance:
<a href="link">Linktext</a>

for two instances:
<a href="link">Linktext</a><p><a href="link">Linktext</a>

without the prelink tag, one instance would produce the following:
<p><a href="link">Linktext</a>

and for two instances:
<p><a href="link">Linktext</a><p><a href="link">Linktext</a>

Here is an example from a sample Web site:
<we:linklist name="Linklist"/>
<tr><td class="link" valign="top"><nobr><we:link></nobr></td>
<td><img src="/root/layout_images/pixel.gif" width="20" height="2" 
border="0"></td>
<td valign="top" class="normal"><we:textarea name="Erklaerung" 
rows="2" 
cols="40"/></td></tr>
<we:postlink>
<tr>
<td colspan="3"><img src="/root/layout_images/pixel.gif" width="2" 
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height="6" border="0"></td>
</tr>
</we:postlink>
</we:linklist>

This code generates the following output:

Figure 136  Example of output for a link list

To allocate a stylesheet to the we:link tag, do this:
<we:link name="MyLink" class="foo"/>

4.4.2  Summary pages/areas
Summary pages provide an overview of all pages or areas that belong to a document 
type and/or category. (For example, all “news” or all news belonging to the “Sports” 
category). In addition, summaries can provide an overview of an entire Web site. 
Summary pages are also used to generate a results page for searches.

4.4.2.1  Creating a summary page
You use the <we:listview> we:tag to create summary pages. This tag must enclose all 
the other we:tags needed for summary pages (start-tag and end-tag). The <we:listview> 
tag must contain a <we:repeat> tag that defines the appearance of the entries listed in 
the summary. Everything bracketed by the we:repeat tags—including normal HTML 
(such as lines in a table) or the we:tag <we:field/>, which displays the content of a given 
field— will be repeated. 

For example, assume that you have defined input boxes <we:input type="text" 
name="Header"/> and <we:input type="date" name="Date"/> in a news template 
belonging to the "newsArticle" document type. To generate a summary in which every 
line contains the date, header and a link to the news page, you would require the 
following code:

<we:listview doctype="newsArticle" rows="10">
  <we:repeat>
    <we:field type="date" name="Date"/>
    <we:field type="text" name="Header">
  </we:repeat>
  <we:back>back</we:back> <we:next>next</we:next>
</we:listview>

The <we:back> and the <we:next> tags, which create an automatic link to the 
previous/next page for entries listed within the summary, can also be placed within 
<we:listview>, although they cannot be placed within a <we:repeat> tag. However, this 
is only possible if the number of entries has been limited by the rows attribute in 
<we:listview>. If this attribute has not been specified, all the pages found will be 
displayed. If the rows attribute has been set to 10, only 10 entries will be displayed. Any 
<we:next> tag that has been included will create another link.

Here is an example from a sample Web site:
<we:listview rows="6" doctype="newsArticle" order="Date" 
desc="true">
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<table border="0" cellpadding="0" cellspacing="0" width="500">
<we:repeat>
<tr>
<td class="normal"><we:field type="date" name="Date" 
format="m/d/Y"/></td>
<td><img src="/root/layout_images/pixel.gif" width="10" height="2" 
border="0"></td>
<td class="normal"><b><we:field type="text" name="Headline" 
hyperlink="on"/></b></td>
</tr>
<tr>
<td><img src="/root/layout_images/pixel.gif" width="90" height="6" 
border="0"></td>
<td><img src="/root/layout_images/pixel.gif" width="10" height="6" 
border="0"></td>
<td><img src="/root/layout_images/pixel.gif" width="400" 
height="6" border="0"></td>
</tr>
</we:repeat>
<we:ifNotFound><tr>
<td colspan="3" class="normal">No News available!</td>
</tr>
<we:else/><tr>
<td colspan="3" class="normal">
<table cellpadding="0" border="0" cellspacing="0" width="100%">
<tr>
<td colspan="2"><img src="/root/layout_images/pixel.gif" 
width="10" height="6" border="0"></td>
</tr>
<tr>
<td class="normal"><we:ifBack><we:back>&lt;&lt; 
Back</we:back></we:ifBack></td>
<td class="normal" align="right"><we:ifNext><we:next>weiter 
&gt;&gt;</we:next></we:ifNext></td>
</tr>
</table>
</td>
</tr>
</we:ifNotFound>
</table>
</we:listview>

Figure 137 shows the output from this code:

Figure 137  Sample summary page

4.4.2.2  Creating a summary of all your pages
Summaries of all the pages in a Web site are generally needed for search results pages. 
These summaries are also useful if you have a small Web site with only a few pages and 
would like to create an automatic navigation facility.

If you want to create a summary of all your pages, do not specify any conditions in 
<we:listview>. Make sure that either all the pages have the same field names (such as 
header and date) or that an alternative field has been specified by means of the alt 
attribute in the <we:field> tag. For example: <field name="Title" alt="Headline"/>. In 
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this case, if the title field in the Property view is empty, the content of the Headline field 
will be displayed. 

There are two reserved field names that you can use: we_path and we_text. we_path 
will cause the path of the page to be displayed, while we_text will cause the text content 
of the page to be displayed. You can limit the text content using the max attribute. If no 
entries have been made in any of the fields, or if the template does not have any input 
boxes, we_text will not produce any results.

Note:  The syntax is we_path, not we:path; we_text, not we:text.

Here is an example from a sample Web site:
<we:listview rows="6">
<table border="0" cellpadding="0" cellspacing="0" width="500"> 
<we:repeat> 
<tr><td class="normal"><b><we:field name="Title" alt="we_path" 
hyperlink="on"/></b><br><we:field name="Description" alt="we_text" 
max="200"/></td>
</tr>
<tr><td><img src="/root/layout_images/pixel.gif" width="500" 
height="6" 
border="0"></td>
</tr> 
</we:repeat>
<we:ifNotFound> 
<tr><td colspan="3" class="normal">Leider nichts gefunden!</td>
</tr> 
<we:else/> 
<tr>
<td colspan="3" class="normal">
<table cellpadding="0" border="0" cellspacing="0" width="100%">
<tr><td colspan="2"><img src="/root/layout_images/pixel.gif" 
width="10" 
height="6" border="0"></td>
</tr>
<tr><td class="normal"><we:ifBack><we:back>&lt;&lt; 
Back</we:back></we:ifBack></td>
<td class="normal" align="right"><we:ifNext><we:next>Next 
&gt;&gt;</we:next></we:ifNext></td>
</tr>
</table>
</td>
</tr>
</we:ifNotFound> 
</table> 
</we:listview>

Figure 138 shows the output from this code:
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Figure 138  Sample of all summary pages

Calling up a summary page using this feature will display all relevant pages. The entry 
consists of the title and the description of the page (for webEdition pages, the latter is 
listed in Properties). If the page does not have a title or if it is an HTML page, the path 
will be displayed (alt="we_path") instead of the title. Likewise, if the page does not 
have a description, the first 200 characters of content on the page will be displayed.

4.4.2.3  Creating a summary of a specified area
If you wish to display a summary of a specified area, you must limit the output in the 
<we:listview> tag either by specifying the doctype attribute or the categories attribute.

The following code, for example, displays only those pages that belong to the "News" 
document type and the "Sports" and "Politics" categories.

<we:listview doctype="News" categories="Sport,Politics">

4.4.2.4  Using summaries to archive pages
You can use the offset attribute as an archiving feature for your news. First, create two 
summary pages. The <we:listview> tag on the first summary page (current news) might 
look something like this:

<we:listview doctype="News" order="Date" desc="true" rows="10">

This page displays the ten most recent news pages, assuming, of course, that your news 
articles all contain a date field. Don't add the <we:next> and <we:back> tags on this first 
page. Instead, insert a link to the second summary page (the archive page). The 
<we:listview> tag on the second summary page will also contain the offset attribute. 
The <we:listview> will then look something like this:

<we:listview doctype="News" order="Date" desc="true" rows="10" 
offset="10">

Next, insert the <we:next> and the <we:back> tags on this second page. The offset 
attribute ensures that the first entry listed is, in reality, the tenth news entry. This method 
allows you to keep the ten most recent news items on the first summary page and to 
archive the older items on the second summary page. Here is a sample first page (current 
news) displaying the ten most recent news items:

<we:listview doctype="News" rows="10" order="Date" desc="true">
  <we:repeat>
    <we:field type="date" name="Date"/>
    <we:field type="text" name="Headline" hyperlink="true"/><br>
  </we:repeat>
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</we:listview>

Here is a sample second page (archive) listing all the other news items (beginning with 
the tenth news item):

<we:listview doctype="News" order="Date" desc="true" offset="10">
  <we:repeat>
    <we:field type="date" name="Date"/> 
    <we:field type="text" name="Headline" hyperlink="true"/><br>
  </we:repeat>
</we:listview>

4.4.3  Creating a photo album
Before the editor of your Web Page can upload images to a photo album, you must 
create a photo album template in which the thumbnails can be displayed.

A photo album consists of summaries of thumbnails of photos (see Section 3.4.6,  "The 
images Thumbnails view: thumbnail formatting" on page 88). If a visitor to your page 
clicks on a thumbnail, an enlarged image is displayed either in a separate popup window 
or in the same window.

A summary is created with the <we:listview> tag:
<we:listview contenttypes="img" searchable="false" rows="5" 
cols="5">
  <we:ifBack><we:back>back</we:back>&nbsp;&nbsp;</we:ifBack>
  <we:ifNext><we:next>next</we:next></we:ifNext><br>
  <table border="2">
    <we:repeat>
      <we:tr>
        <td>
          <we:field name="Title"><br>
          <we:field border="0" thumbnail="100x70" id="505" type="img" 
hyperlink="true" winprops="width=900,height=650,left=-1,top=-1">
          <br><br>
        </td>
      </we:tr>
    </we:repeat>
  </table>
</we:listview>

Use the attribute contenttypes to indicate which kind of document should be 
displayed. You can use the following values: 
"img" = images 
"wepage" = webEdition documents 
"binary" = other documents

Use the attribute searchable to define which documents are to be displayed. If you 
wish only to display documents which are labeled as searchable, set the the value to 
searchable="true". If you wish to display documents which are not labeled as 
searchable, set the value to searchable="false".

To display a HTML table with a listview, the attribute cols and the tag <we:tr> are 
available. If "cols" is set, rows * cols entries are displayed. The tag <we:tr> creates 
the HTML tag <tr> at the beginning of a new row; the tag </we:tr> creates the HTML 
tag <tr> at the end of a row.

You can access the meta information of an image (title, description, key words) with the 
tag <we:field> in a listview:
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<we:field name="Title" />
<we:field name="Description" />
<we:field name="Keywords" />

With the attribute winprops you can define the properties of the photo that is to appear 
in a new popup window. (The syntax is equivalent to the windowFeatures of 
window.open in Javascript.) To center the window set a value of -1 for both left and 
top.

Example 
winprops=”width=900,height=650,left=-1,top=-1”

To display the image, the tag <we:field> with the attribute type="img" can be used 
(among other tags), but only without indicating a name. If you want to display a 
thumbnail instead of the original image, indicate the name of the thumbnail at the 
attribute thumbnail. If hyperlink="true" is set, the field will be linked as always. 
Usually it is linked directly to the image. If that is not preferable, you can set the 
attribute id. Here you enter the ID of a webEdition document. This webEdition 
document is used for the detailed view of the image. The image will be displayed with 
a listview with rows="1" in the template of such a webEditon document. All necessary 
settings (such as "offset", "name" of the listview, "workspaceID", and "contenttype"), 
will be transfered to the document and thus to the listview automatically. The code of 
the listview appears thus:

<we:listview rows="1">
  <we:ifBack><we:back>back</we:back></we:ifBack>&nbsp;&nbsp;
  <we:ifNext><we:next>next</we:next></we:ifNext>
  <p>
    <we:repeat>
      <we:field name="Title"><br>
      <we:field type="img"><br><br>
    </we:repeat>
  </p>
</we:listview>

4.4.3.1  Creating multiple photo albums
With the tag <we:href> you can allow editors to choose between different photo albums 
or to create new albums. Each photo album requires its own directory. The editors can 
put all their photos into their respective directories. Below is a sample of the code: 

<we:ifEditmode>
  Album:<br>
  <we:href reload="true" directory="true" file="false" type="int" 
name="album" output="id">
  <br>
</we:ifEditmode>
<we:setVar to="global" nameto="album" from="top" 
namefrom="album_we_jkhdsf_intID" />
<we:listview contenttypes="img" searchable="false" rows="5" 
cols="5" workspaceID="\$album">

In this example the value which is choosen in <we:href> is written in a global value 
with <we:setVar>. This value is then transfered to the listview i, attribute 
workspaceID. If reload="true" is indicated at the tag <we:href>, the page will be 
reloaded after choosing the directory. If you set the attributes directory="true" and 
file="false" directories, not files, will be choosen.
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If the attribute useparent="true" is used in the detailed view at <we:ifBack> and 
<we:ifNext>, it can only be scrolled to the last entry of the summary listview. 
Example: If image 11 to 20 are displayed in the summary listview and you have chosen 
an image, you can only scroll forward to entry 20 and back to entry 11.

<we:listview rows="1">
  <we:ifBack 
useparent="true"><we:back>back</we:back></we:ifBack>&nbsp;&nbsp;
  <we:ifNext 
useparent="true"><we:next>forward</we:next></we:ifNext>
  <p>
    <we:repeat>
      <we:field name="Title"><br><we:field type="img">
      <br><br>
    </we:repeat>
  </p>
</we:listview>

4.4.4  Producing and changing pages and objects from the front end
webEdition offers tags which enable the visitor of a Web site to produce and change 
webEdition documents and objects. With webEdition, one can easily produce such 
things as a guestbook, or some other type of page in which visitor input is solicited. The 
<we:form> tag serves as the foundation of this feature. 

The <we:form> tag has been extended with two new types: <we:form 
type="document"> and <we:form type="object"> which can be used depending upon 
whether one wishes to produce a webEdition document or object. For webEdition 
documents, the document type must be entered as a value of the attribute doctype; for 
objects, the ID of the class must be entered as a value of the attribute "classid".

You cannot produce or change webEdition documents without the document type. The 
individual fields are depicted through the <we:userInput/> tag between the start and the 
end tag of the <we:form>. The value which one allocates to the attribute type, will 
determine which type it handles. For a full description of these tags and their attributes, 
see the webEdition Tag Reference.

<we:form type="document" id="56" doctype="Guestbookentry">
  <table width="500" border="0" cellspacing="0" cellpadding="5" 
align="center">
    <tr>
      <td class="t4"><strong>Guestbook entry</strong></td>
      <td align="right" nowrap>
        <img src="/images/pixel.gif" width="1" height="1">
       </td>
     </tr>
     <tr>
       <td class="t3" colspan="2">
         <p>
           <strong>Your name:</strong><br>
           <we:UserInput name="Name" type="text" size="60"/>
          </p>
          <p>
            <strong>Your address:</strong><br>
            <we:UserInput name="Ort" type="text" size="60"/>
          </p><we:userInput name="Datum" type="date" hidden="true"/>
        </td>
      </tr>
      <tr>
        <td class="t3" colspan="2">
          <strong>Your comments:</strong><br>
          <we:userInput type="textarea" name="Text" width="500" 
height="200" autobr="true" wysiwyg="true" 
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commands="prop,list,link,color"/></td>
      </tr>
      <tr>
        <td class="t3" colspan="2"><input type="submit" 
value="Submit">&nbsp;<input type="reset" value="Reset">
      </td>
    </tr>
  </table>
</we:form>

For the attribute id of the <we:form> tag, the ID of the webEdition document is entered 
as a value, where the form is to be sent. This can be a connecting page on which one 
shows the input again, or similarly a page that saves and publishes the input if 
applicable. Two possibilities are described below:
• The <we:write> tag is placed at the very beginning of the template in order to save 

the data transferred from the form. For example:
<we:write type="document" publish="true" 
doctype="Guestbookentry"/>

After the <we:write> tag one can detect with the <we:ifWritten> or 
<we:ifNotWritten> tags, whether or not the write-process was successful for the 
webEdition document or object. For example: 

<we:ifWritten type="document">
Thank you for the entry in our guestbook!
<we:else/>
Unfortunately there is an error in the entry in our guestbook!
</we:ifWritten>

• If you would like to send the given data first to a connecting page, use the 
<we:form> tag in combination with the <we:userInput> tag once again. In contrast 
to the input-page, one now sets the entry field to "non-editable". You can cause this 
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to happen by setting the "editable" attribute in the <we:userInput/> tag  to the value 
"false". 
For example:

<we:form type="document" id="57" doctype="Guestbookentry">
  <p>Enter your comments here:</p>
  <table width="500" border="0" cellspacing="0" cellpadding="5" 
align="center">
    <tr>
      <td class="t4"><strong>Guestbook entry</strong></td>
      <td align="right" nowrap>
        <img src="/images/pixel.gif" width="1" height="1">
      </td>
    </tr>
    <tr>
      <td class="t3" colspan="2">
        <p>
          <strong>Your name:</strong><br>
          <we:UserInput name="Name" type="text" editable="false"/>
        </p>
        <p>
          <strong>Your address:</strong><br>
          <we:UserInput name="address" type="text" 
editable="false"/>
        </p>
        <we:userInput name="Datum" type="date" hidden="true"/>
      </td>
    </tr>
    <tr>
      <td class="t3" colspan="2">
        <strong>Your comments:</strong><br>
        <we:userInput type="textarea" name="Text" 
editable="true"/>
      </td>
    </tr>
    <tr>
      <td class="t3" colspan="2">
        <input type="button" value="Back" 
onclick="history.back()">&nbsp;
        <input type="submit" value="Submit">&nbsp;
        <input type="reset" value="Reset">
      </td>
    </tr>
  </table>
</we:form>

In order to allow a visitor to a Web site to change a webEdition document or object, use 
the <we:a> tag and set the attribute edit to the value document or object. If the tag is 
used in a <we:listview> tag, the proper listview entry is used automatically as a 
reference for it. In order to ensure that only the creator of a webEdition document or 
object can change them, a field must be set in the webEdition document or object in 
which the ID of the creator is stored. 

ATTENTION
If you give a value to the attribute "name" in the <we:form> tag, you 
must also enter the name of the form as a value of the attribute 
"formname" in the <we:write> tag.
webEdition User Guide



136   Creating templates—the role of the administrator 
If you have installed the Customer Management Module, you can set the name of the 
aforesaid field as a value of the userid attribute in the <we:write> tag. In addition, you 
can give the name of a field from the Customer Management Module as a value for the 
attribute admin. If a value (except 0) is entered in this field for a customer, this user is 
allowed likewise to change the webEdition document or object. By using the 
<we:ifRegisteredUserCanChange> tag, you can determine whether or not a customer is 
allowed to edit a webEdition document or object. The two attributes userid and admin 
have the same meaning as with the <we:write> tag.

If you wish to enter a category, you can use the <we:categorySelect> tag. This is 
accomplished using an easy drop-down menu with which you are able to choose the 
desired category. An end tag must be used with this tag, even if you have set no 
<option> tags.

The input can also be saved in a PHP session. This means that the input will not be lost, 
even if you refer to another page from time to time. The only conditions are that the 
form must be sent to a webEdition document that contains a <we:form> tag in which 
either document or object has been set as a value of the attribute edit, and that the 
<we:sessionStart> tag appears at the beginning of every template. The data of the 
session will be deleted automatically by a <we:write> tag.

4.4.5  Including documents (<we:include>)
If there are components on your Web site that appear on all templates/pages (such as a 
navigation system), you can use webEdition to store them in a file and then to include 
the file using the <we:include> tag.

Create a template for the document (i.e. a simple link list) that you wish to include in 
another document. Create the source code as an HTML document using the template 
you just created. Let's assume that the document you wish to include has the ID 100. 
Next, write <we:include id="100"/> at the point in the main template where you want 
the document to be inserted. Any change you might make now to the document will be 
automatically applied to the documents that use the main template, assuming that the 
documents are dynamic. If you have static documents, you must perform a rebuild 
before the change can be applied. This feature allows you to create all kinds of dynamic 
navigation features—even using DHTML—which can then be expanded by an editor, 
even if he or she does not know any programming languages.

The left-hand navigation system on all our sample pages was created using the 
<we:include> tag.

Example:
<td class="normal" width="27"></td>
<td colspan="2" class="normal" valign="top">
<we:include id="90"/></td>
<td bgcolor="white" colspan="2" valign="top">

Here is the code for the finished file navigation.html (ID=90) that you want to insert:
<p><a href="/root/index.php" 
style="text-decoration:none">News</a></p>
<p><a href="/root/filmberichte/all.php" style="text-
decoration:none">Filmberichte</a></p>
<p><a href="/root/programm/programm.html" style="text-
decoration:none">Programm</a></p>
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<p><a href="/root/links/links.html" style="text-
decoration:none">Links</a></p

Here is the result in /root/index.php:
<td class="normal" width="27"></td>
<td colspan="2" class="normal" valign="top"><p><a 
href="/root/index.php" 
style="text-decoration:none">News</a></p>
<p><a href="/root/filmberichte/all.php" style="text-
decoration:none">Filmberichte</a></p>
<p><a href="/root/programm/programm.html" style="text-
decoration:none">Programm</a></p>
<p><a href="/root/links/links.html" style="text-
decoration:none">Links</a></p></td>
<td bgcolor="white" colspan="2" valign="top">

4.4.6  Search feature
The webEdition database architecture makes it easy to create a search feature for all 
your pages. You do not need to index the entire Web site, as you have to do for most 
search tools. 

Begin by creating a results page where the search results can be displayed. This page is 
a normal summary page (see Section 4.4.2.2,  "Creating a summary of all your pages" 
on page 128). Let's assume that the ID for the results page is 100. Next, insert the 
<we:form> tag with the following attribute <we:form id="100"> into your template at 
the point where you want the search input box to appear. Afterwards, write in the we:tag 
for the search field itself: <we:search type="textinput" size="50"/>. Now you can insert 
a normal HTML submit button: <input type="submit" value="suchen">, followed by 
the <we:form> end tag: </we:form>. For example:

<we:form id="100">
  <we:search type="textinput" size="50"/>
  <input type="submit" value="search">
</we:form>

If you enter something in the search field on the finished page and then click the Search 
button (or pressing RETURN on your keyboard), the system directs the search query to 
the results page you created earlier, which will display the search results.

Below is a sample from our sample Web site (/news/news.tmpl):
<td colspan="2" align="right">
<we:form id="114" method="get"><span 
class="normal"><b>Search:</b><span 
class="normal">&nbsp;</span>
<we:search type="textinput" size="15"/><span 
class="normal">&nbsp;</span><input type="submit" value="OK"><span 
class="normal">&nbsp;</span>
</we:form></td>

Figure 139 shows the input box created by this code:

Figure 139  Sample input box
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4.4.7  E-Mailing a form
You can use webEdition to create forms that can be sent to an E-mail address. The basic 
component of this feature is the <we:form> tag. Begin by creating a form using HTML 
tags. However, instead of inserting the HTML <form> tag, use the <we:form> tag. 
Insert the type="formmail" attribute in the <we:form> tag. You also must insert the 
recipient attribute to specify where the E-mail address will be sent. You can also use the 
required attribute to specify which of the fields in the form have to be filled in. For this 
attribute, separate the names of the fields using commas. The order attribute determines 
in which order the fields will be listed in the E-mail to be sent. Delimit the names of the 
fields using commas for this attribute. Use the onerror and onsuccess attributes to 
provide the IDs of the pages you want to display if there are any erroneous entries (for 
example, not all the required fields were filled in), or if all the entries are correct. If you 
want the E-mail to use a specific subject, enter it using the subject attribute. If you 
choose to use the mimetype="text/html" attribute, the mail will be sent in HTML 
format. Only use this attribute if you know that the recipient of the E-mail has an E-mail 
program that can display HTML E-mails. If you create a form field with the name 
"E-mail", this value will be written to the sender address field in the E-mail. webEdition 
can only write to the sender address field if the address has been entered properly. To 
ensure that the address is correct before sending the E-mail, webEdition tests the 
address field and issues a warning if the address is incorrect. For example:

<we:form type="formmail" recipient="email@domain.com" 
required="email,name,forname" order="name,forname,email" 
subject="Form from 
my web site" onerror="66" on success="23" mimetype="text/html"> 
<p>Email: <input type="text" name="email"></p>
<p>Name: <input type="text" name="name"></p>
<p>Forname: <input type="text" name="forname"></p>
<p><input type="submit" value="Send"></p>

Note:  webEdition has a security feature that prevents the sending of unsolicited 
E-mail (spamming). By selecting Options > Preferences > Formmail recipients, a 
view opens in which you can enter the E-mail addresses to which formmails are to be 
sent. All other addresses will be blocked.

Figure 140  The Formmail recipients view
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New addresses can be entered by clicking on the add button. To edit addresses, click the 
appropriate address, then click the Edit button. To delete an address, click the 
appropriate address, then click Delete.

4.4.8  Working with HTML frames
If your Web site uses HTML frames, you can use webEdition to display the content of 
each individual frame set. You can either directly upload the frame sets to the server 
yourself (without using webEdition) or you can program them as HTML pages in 
webEdition. You can use the <we:ifNotWebEdition> tag within the webEdition editing 
program to eliminate any JavaScripts that load a frame set that belongs to a page or that 
remove frame sets that do not belong to a page. The code located between the start tag 
and the end tag will not be executed or displayed when you edit the page in webEdition.
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5  Banner/Statistics: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Banner/Statistics Module. This chapter treats what the module does and how to install 
it. You can also find information here about the basic layout and command features for 
the Banner/Statistics Module. These topics are treated in the following sections:
• Section 5.1,  "What is the webEdition Banner/Statistics Module?" on page 141
• Section 5.2,  "Installation" on page 142
• Section 5.3,  "General information and navigation" on page 142

5.1  What is the webEdition Banner/Statistics Module?
The webEdition Banner/Statistics Module allows webEdition users to create and 
administer banners on Web pages. Detailed statistics can be created for every banner so 
that users can track the effectiveness of their banner campaigns. 

The Banner/Statistics Module conforms to the basic layout and programming principles 
of webEdition. The Banner/Statistics Module can only be used with webEdition 
(although you can also show banners on "external" sites, that is, sites that were not 
created using webEdition).

This module can be used by anyone who has a basic knowledge of how webEdition 
functions.

The Banner/Statistics Module allows you to perform the following functions:
• define banners from webEdition images
• order your banners in groups
• include as many banners you like in your site
• weight your banners
• show banners on static and dynamic pages (internal and external pages)
• view the statistics for each banner on each site (views, clicks and click rate)
• view statistics on the number of times your pages have been visited by using a 

transparent .gif file instead of a banner

If you have purchased the webEdition Customer Management Module an additional 
feature is available to you. You can set one or more customers as the owner of every 
banner or group of banners. You can also provide customers with detailed statistics 
about their banners.
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5.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

5.3  General information and navigation
The following sections describe the general layout of the Banner/Statistics Module and 
how you navigate through the screens.

5.3.1  Opening the Banner/Statistics Module
After installing the Banner/Statistics Module, Banner/Statistics Module will appear as 
an option in the Modules drop-down menu (see Figure 141).

Figure 141  Module menu showing the Banner/Statistics Module

To open the module, select Banner/Statistics Module from the Modules drop-down 
menu on the main webEdition page. The Banner/Statistics Module main screen opens 
showing the Quickstart screen (see Figure 142).
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Figure 142  Banner/Statistics Module main screen with Quickstart 

Using the Quickstart screen, you have the option of going directly to a new banner or 
to a new banner group.

5.3.2  The Banner/Statistics Module main page: drop-down menus
There are three drop-down menus on the Banner/Statistics Module main page:
• Banner
• Options
• Help

5.3.2.1  The Banner menu items
The Banner drop-down menu has the following items (see Figure 143):

Figure 143  The Banner menu items

•New. The New command has two sub-items:
—Banner. Use this option to create a new banner.
—Banner group. Use this option to create a new banner 
group.

• Save. Use this item to save a banner or banner group.
• Delete. Use this item to delete a banner or banner group.
• Quit. Use this item to close the modules window.
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5.3.2.2  The Options menu items
The Options drop-down menu has the following items (see Figure 144):

Figure 144  The Options menu items

•Default banner. Use this option to select a default 
banner. This banner will be shown if no other banner 
has been selected.

• Create Banner Code. Use this option to create the banner code for non (external) 
webEdition pages.

5.3.2.3  The Help menu itemss
The Help drop-down menu has the following items (see Figure 145):

Figure 145  The Help sub-menus

•Info. This item provides information about the application.
•Help. This item provides Help screens.

5.3.3  The banner explorer menu and main page
The banner explorer menu appears on the left side of the screen. It contains a list of your 
banner files (see Figure 142,  "Banner/Statistics Module main screen with Quickstart" 
on page 143).

The banner main page has three available views, one for Properties in which you define 
your banners, one for Placement in which you define on which pages the banner will be 
shown, and one for Statistics in which you can see the views, clicks and click rate for 
the banner. The banner group main page has only the Properties view.

5.3.4  The banner Properties view
The Properties view allows you to set up your banner files. You can access the 
Properties view by clicking on the Properties tab, or by using the Banner > New > 
Banner drop-down menu on the main page. The Properties view is divided into three 
areas: Path, Banner and Period. If you have purchased the webEdition Customer 
Management Module, a forth area, Customers, is also available (see Figure 146).
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Figure 146  The Properties view

5.3.4.1  The Path area
The Path area has the following functions:
• Name. Use this field to give a name to your banner.
• Group. Use this field to put the banner in a banner group.

5.3.4.2  The Banner area
The Banner area has the following functions:
• Image Path. Use this field to select a webEdition image which will be used for the 

banner.
• External URL. Use this field to enter a webEdition external URL to which the user 

will be redirected when clicking the banner.
• Internal URL. Use this field to enter a webEdition internal URL to which the user 

will be redirected when clicking the banner.
• Active. When this checkbox is not checked, the banner will never be shown (except 

if it is defined as a default banner).
• Maximum views. Use this field to enter the maximum number of times that the 

banner will be shown.
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• Maximum clicks. Use this field to enter the maximum number of clicks. If the value 
is reached the banner will not be shown anymore.

• Weight. Here you can enter the weight of the banner. A higher weight means that the 
banner will be shown more often than a banner with a lower weight.

5.3.4.3  The Period area
The Period area has the following functions (click on the More properties icon to 
display the Period area):
• From. If this checkbox is checked, the banner will be displayed from the entered 

date.
• To. If this checkbox is checked, the banner will be displayed until the entered date.

5.3.4.4  The Customers area
The Customers area appears under the Period area only if you have purchased and 
installed the webEdition Customer Management Module. Here you can select one or 
more customers who will be the owner of the banner.

5.3.5  The banner Placement view
The Placement view allows you to place the banner on different pages (see Figure 147).

Figure 147  The Placement view
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The Placement view has the following areas:
• Banner name. Use this area to enter the name of the <we:banner> tag where the 

banner is to be shown. You can choose the available banners from the select box.
• Pages. Use this area to select one or more pages on which the banner is to be shown. 

If one or more pages are set, the banner will only be shown on the page(s) you have 
specified. Use the Add button to access the browse server window, from which you 
can select a page. Use the Delete all button to delete the placement of a banner on 
all selected pages. Click the trash can icon to delete the placement on a single page.

• Directories. Use this area to select (or delete) one or more directories on which the 
banner is to be shown. The banner will only be shown on pages which resides in the 
directories you have specified.

• Categories. Use this area to select (or delete) one or more categories. The banner 
will only be shown on pages that belong to the categories you have specified.

• Document Types. Use this area to select one or more document types. The banner 
will only be shown on pages that belong to one of the selected document types.

5.3.6  The banner Statistics view
In the Statistics view you can see the statistics of a particular banner (see Figure 148):

Figure 148  The Statistics view

The checkbox Filter by date allows you to select the beginning and the end of a 
time-span with the fields from and to. 

The Statistics view displays a table with the following features:
• Page. The first column of the table indicates the page or pages upon which a 

specified banner appears. The first row of the table shows the summary of all pages.
• Views. This column represents the number of times that the page on which the 

banner appears has been viewed.
• Clicks. this column represents the number of times that the banner has been clicked.
• Click rate. This column represents the clicks per view, expressed as a percentage.

Note:  For more information about filtering and sorting your statistical data, see 
Section 6.3,  "Viewing and sorting banner statistics" on page 155.
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5.3.7  The banner group Properties view
The Properties view allows you to set up your banner groups. You can access the 
Banner Group Properties view by using the Banner > New > BannerGroup drop-down 
menu on the main page. The Properties view for a banner group has only the Path area. 
If you have purchased the webEdition Customer Management Module, a second area, 
Customers, is also available (see Figure 149).

Figure 149  The Properties view of banner groups

The Path area has the following functions:
• Name. Use this field to give a name to your banner group.
• Group. Use this field to put the banner group into another banner group.

The Customers part appears only if you have purchased and installed the webEdition 
Customer Management Module. Here you can select one or more customers who will 
be the owner of the banner group and the banners the group contains.
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6  Creating banners
This chapter describes how you can create and manage banners for your Web site. The 
following topics are treated in this chapter:
• Section 6.1,  "Setting the properties for a banner" on page 149
• Section 6.2,  "Placing a banner on a Web page" on page 152
• Section 6.3,  "Viewing and sorting banner statistics" on page 155

6.1  Setting the properties for a banner
Use the following procedure to set the properties for a banner.

Procedure 12  Setting the properties for a banner

In the Banner/Statistics Module main screen
1 Click Banner > New > Banner to manage a new banner.

webEdition opens the Properties view (see Figure 150).

Figure 150  Naming a new banner

2 In the Path area of the Properties view, type the name of your banner in the Name field.
3 Choose the group in the Group field in which you want to place the banner. (For more 

information on creating banner groups, see Section 6.4,  "Creating banner groups" on page 
156).
If you click the Select button, a dialog box opens that allows you to browse your system for 
an existing group. See Figure 151,  "Searching and selecting a banner group" on page 150.
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Figure 151  Searching and selecting a banner group

4 In the Banner area of the Properties view, enter in the Image Path field the directory path to 
the image file that you want to use as your banner.
If you click the select button, a dialog box opens that allows you to browse your system for 
an existing image (see Figure 152).

Figure 152  Searching and selecting an image

5 Select an image from your existing files, and press the OK button.
The name of the image file appears in the Image path field in the Banner area of the 
Properties view. The image itself appears below the field(see Figure 153).
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Figure 153  Banner selection

6 To create a hyperlink from your banner to another page, type the URL of an external Web 
page in the External URL field or select an internal page by clicking the select button next 
to the Internal URL field.
The banner will be linked to the URL you enter. When a visitor clicks on your banner, they 
will be taken to the designated URL.

7 Type the number of times the banner should be shown in the Maximum views field.

Note:  If the field is not filled, the banner will be shown without limit.
8 Type the maximum number of clicks in the Maximum Clicks field.

Note:  If the field is not filled, the banner can be clicked without limit.
When the banner has been clicked as many times as the entered value, the banner will no 
longer be displayed.

9 Select the weight of the banner in the Weight field. A higher weight means that the banner 
will be displayed more often than a banner with less weight.

10 If you want the banner to be shown automatically from a given date, check the From 
checkbox and select the date and time with the date selectors under the From checkbox.

11 If you check the To checkbox, the banner will only be shown until the date entered in the 
date selectors under the To checkbox.

12 If you have purchased the webEdition Customer Management Module, you can now select 
one or more customers by clicking the add button in the Customers area.
A dialog box opens that allows you to browse your system for an existing customer (see 
Figure 154).
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Figure 154  Searching and selecting a customer

13 Press the ok button.
The system returns to the Properties view. Notice that the name of the selected customer 
now appears in the Customers field.

14 Save the banner by clicking the save button at the bottom of the screen or by selecting the 
save from the banner menu.
The system displays a dialogue box saying that the banner was succesfully saved. Click 
OK. Thereafter an icon for your new banner appears in the Banner/Statistics Module 
explorer menu (see Figure 155).

Figure 155  New banner icon in the explorer menu

15 You have completed this procedure. If you wish to place your banner on a Web page, go to 
Section 6.2,  "Placing a banner on a Web page" on page 152.

6.2  Placing a banner on a Web page
The webEdition Banner/Statistics Module allows you to place a banner on one or more 
Web pages.

To display a banner on a Web page, the page must have at least one <we:banner> tag or 
a special HTML banner code for non-webEdition pages. (The <we:banner> tag and the 
special HTML banner code are described in Section 7.1,  "What tags are required to 
display a banner on a webEdition page?" on page 159). Each <we:banner> tag has a 
name attribute which you use to identify the banner.

You can specify exactly what pages are to display a given banner by using the fields in 
the Placement view. These fields act as filters for your selection. You can use one or 
more filters to refine your selection.

Use the following procedure to place a banner on a Web page.
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Procedure 13  Placing a banner on a Web page

In the Banner/Statistics Module main screen
1 To access the Placement view, click on the Placement tab on the Banner/Statistics main 

screen (see Figure 156).

Figure 156  The banner Placement view

2 Because webEdition allows you to have more than one <we:banner> tag on your template, 
you must tell the Banner/Statistics Module which of the tags you want to use. You identify 
the name of the banner by using either the Banner Name field (on the left) or the select box 
with <we:banner> tags (on the right).The Banner Name field is associated with the name 
attribute of the <we:banner> tag.
a If you know the name of the tag, type the name directly into the input field (on the left).

Note:  If you want to display the banner on pages that were not produced in 
webEdition, you must type the name of the banner directly into the text field. The 
webEdition software cannot display the name in the picklist because no 
<we:banner> tag exists for an external page. For more details on placing a banner 
on external pages, see Chapter 7, Procedure 15,  "Creating banners on external 
Web pages" on page 161.

b Choose the <we:banner> tag by using the select box (on the right). The select box 
shows the names of all <we:banner> tags which are used in your templates. If you 
select a tag, its name will be copied in the text field.

Note:  If you do not specify a name, the banner will be shown on every page that has 
a <we:banner> tag.

3 Identify the pages that are to display the banner. To do so, complete one or all of the 
following substeps:
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a To place a banner on one or more individual Web pages, use the Pages field.
i Click on the add button to access your list of files.

A dialogue box opens showing your directories from which you can choose your file 
(see Figure 157).

ii Select the target page(s) on which the banner is to appear.

Figure 157  Selecting a target page for your banner

iii Press the OK button.
The name of the target page appears in the Pages area of the Placement view (see 
Figure 158).

Figure 158  Target page selected

b To place a banner on all pages in one or more directories, use the Directories field.
i Click on the add button to access your list of directories.

A dialogue box opens showing your directories.

ii Select the directory that stores the pages in which the banner is to appear.
iii Press the OK button.

The banner will only be shown on pages which are stored in the specified 
directories.

c To place a banner on all pages assigned to one or more categories, use the Categories 
field.
i Click on the add button to access your list of categories.
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A dialogue box opens showing the categories you have defined.

ii Select the category associated with the pages in which the banner is to appear.
iii Press the OK button.

The banner will only be shown on pages which are associated with the specified 
categories.

d To place a banner on all pages assigned to one or more document types, use the 
Document types pick list.
i Click on the item in the pick list that represents the document type with which your 

target pages are associated.
The banner will only be shown on pages which are associated with the specified 
document types.

4 Click the Save button at the bottom of the Placement page to save your selections.
5 Verify that your banner has been properly placed on your designated Web page. (To do so 

you must leave the Banner/Statistics module and go to the webEdition main screen.)
a Go to the webEdition main screen.
b In the explorer menu, click on the file that you associated with the banner in Step 3 on 

page 153.
c Select the Preview tab to display your Web page (see Figure 159).

Figure 159  Verifying your banner placement

6 You have completed this procedure.

6.3  Viewing and sorting banner statistics
The webEdition Banner/Statistics Module allows you to see the statistics about a banner 
and every Web page on which that banner appears. To access the Statistics view, click 
on the Statistics tab on the main page (see Figure 160).
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Figure 160  The banner Statistics view

The Statistics view displays a table which shows the Views, Clicks and Click rate for the 
banner. The first row of the table shows the summary of all pages. The following rows 
show the statistics for each page displaying the banner.

6.3.1  Sorting statistics
You can sort the table by clicking the headline of a column. A second click sorts the 
table in descending order. If the checkbox Filter by date is checked, you can select the 
beginning and the end of a span with the fields from and to. The statistics for this span 
will be shown. If you want to delete (reset) the statistics data, you can do this by clicking 
the delete button.

6.4  Creating banner groups
Banner groups are designed to allow you to manage your banners.

Procedure 14  Creating a banner group

In the Banner/Statistics Module main screen
1 Click Banner > New > Banner group.

webEdition opens the Properties view (see ).

Figure 161  The New Banner Properties view

2 In the Path area of the banner group Properties view, type the name of your banner group 
in the Name field.

3 If you wish to create a subgroup, you can choose an existing group in the Group field by 
clicking the Select button.
If you click the Select button, a dialog box opens that allows you to browse your system for 
an existing group. 
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4 If you have purchased the webEdition Customer Management Module, you can now select 
one or more customers by clicking the add button in the Customers area.
A dialog box opens that allows you to browse your system for an existing customer (see 
Figure 154).

Figure 162  Searching and selecting a customer

5 Press the ok button.
The system returns to the Properties view. Notice that the name of the selected customer 
now appears in the Customers field.

6 Save the banner group by clicking the Save button at the bottom of the screen or by 
selecting the Save from the banner menu.
The system displays a dialogue box saying that the banner group was succesfully saved.

7 Click OK to close the dialogue box.
An icon for your new banner group appears in the banner explorer menu.

Figure 163  new banner group icon

8 You have completed this procedure.
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7  Practical examples for template 
developers

This chapter provides a variety of scripts and examples designed to assist administrators 
in developing webEdition code for the banner templates.

This chapter treats items such as how to
• use <we:banner> tags
• use JavaScript or iframe banners
• display banners on non-webEdition pages 
• gather statistics about your pages—whether with or without banners
• use the Customer Management Module to provide banner statistics for 

customers.

7.1  What tags are required to display a banner on a webEdition page?
To display a banner on a webEdition page, the template of the page needs to have a 
<we:banner> tag. You can have more than one <we:banner> tag in your template, but 
each tag must have a different name. For example:

<we:banner name="banner1"/><br>
<we:banner name="banner2"/>

7.2  What format is used to display banners?
There are two ways to display a banner:
• Displaying a banner with JavaScript
• Displaying a banner in an iframe

7.2.1  Displaying a banner with JavaScript
JavaScript is the default setting for all banners if you do not set the type attribute in the 
<we:banner> tag. Banners will be displayed using JavaScript when the Web page is 
static. If JavaScript is disabled in the browser, the banner will be displayed as normal 
HTML (with an <a> and an <img> tag). The browser uses a cookie to store the reference 
for the previously shown banner so that a user will be redirected to the correct page 
when clicking on the banner.

If the Web page is dynamic, the banner is displayed as normal HTML (with an <a> and 
an <img> tag). The reference for the banner will be passed with the URL. For example: 

<we:banner name="banner1" type="js"/> or
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<we:banner name="banner1"/>

7.2.2  Displaying a banner in an iframe
You can display a banner using an iframe (or an ilayer in Nestcape 4). On browsers that 
cannot understand an iframe or ilayer, the banner will be displayed as normal HTML 
(with an <a> and an <img> tag). The browser uses a cookie to store the reference for 
the banner so that a user will be redirected to the correct page when clicking on the 
banner. For example:

<we:banner name="banner1" type="iframe"/>

7.3  How can I display specific banners on a page?
To show one or more specific banners on a page, you can write the banner paths 
separated by a comma in the paths attribute of the <we:banner> tag. You can also write 
the path of a banner group to display the banners of that group. For example:

<we:banner name="banner1" 
paths="/banner1,/group1/banner2,/group2"/>

7.4  How can I display a banner without a link?
To show a banner without a link, you can add the link attribute to the <we:banner> tag 
and set its value to false. For example:

<we:banner name="banner1" link="false"/>

7.5  How can I use files other than /webEdition/getBanner.php and 
/webEdition/bannerclick.php?

Normally webEdition uses the file /webEdition/getBanner.php as the src attribute for 
the <img> and <iframe> tag and the file /webEdition/bannerclick.php for the href 
attribute of the <a> tag. If you want to protect the webEdition directory with an htaccess 
password, or if you do not want to use the original scripts, you can make two php scripts 
(external or as internal HTML page with extension .php), which include the appropriate 
file. In this case, the path of the scripts has to be entered in the attributes getscript and 
clickscript of the <we:banner> tag. For example:

<we:banner name="banner1" getscript="/get.php" 
clickscript="/click.php"/>

The code of the two scripts must look like the following example:
get.php:
<?php 
include($_SERVER["DOCUMENT_ROOT"]."/webEdition/getBanner.php"); ?>

click.php:
<?php 
include($_SERVER["DOCUMENT_ROOT"]."/webEdition/bannerclick.php"); 
?>

7.6  How can I display webEdition banners on external Web pages?
With webEdition you can display banners on pages which were not made with 
webEdition—here referred to as "external Web pages"—such as sites on another 
domain. To do so, you have to insert a special piece of code in the page on which you 
want to display the banners. The required code can be created in webEdition by using 
the following procedure:
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Procedure 15  Creating banners on external Web pages

In the Banner/Statistics Module main screen
1 Click on Options > Create banner code to open the code generation wizard (see Figure 

164).

Figure 164  Creating banner code for external Web pages

2 In the Type select box, choose to use either a JavaScript or an iframe to display the banner.
3 Type a banner name in the Banner Name field. This field is similar to the name attribute of 

the <we:banner> tag.
4 In the URL of Page field (for example, http://www.webedition.biz/index.html), type the URL 

of the page where the banner should be displayed.
5 Type the target of the banner link in the Target field. If you leave the field empty, the next 

page will open in the same window when the banner is clicked. This field is similar to the 
target attribute of the <we:banner> tag.

6 Specify the width and the height of the banner in the Width and Height fields. These fields 
are similar to the width and height attributes of the <we:banner> tag.

7 If you want to show one or more specific banners on a page, you can write the banner paths, 
separated by a comma, in the Banner Paths field. You can also write the path of a banner 
group to display the banners of that group. This field is similar to the paths attribute of the 
<we:banner> tag. (See also Section 7.3,  "How can I display specific banners on a page?" 
on page 160.)

8 If you want to use scripts other than the normal webEdition get and click scripts, you can 
type the URLs of the scripts in the fields Get Script and Click Script. These fields are similar 
to the getscript and clickscript attribute of the <we:banner> tag. (See also Section 7.5,  
"How can I use files other than /webEdition/getBanner.php and 
/webEdition/bannerclick.php?" on page 160.)

9 Click the ok button.
A text area with the created code will be displayed.

10 Copy and paste the code from Step 9 onto your Web page where the banner should be 
shown.

11 Close the window by clicking the close button.
12 You have completed this procedure.

7.7  How can I use the Banner/Statistics Module to gather statistics 
about pages that do not display a banner?

You can also use the Banner/Statistics Module to gather statistics that indicate the 
number of times your pages have been viewed. In this case you do not need to display 
a banner. The following procedure will help you to enable the statistics gathering 
feature of the module:
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Procedure 16  Gathering statistic about your site

1 Insert a <we:banner> tag into your template(s). Give the tag an appropriate name (such as, 
"stat") and set the type to "pixel". For example:

<we:banner name="stat" type="pixel"/>

2 Create a banner using a transparent .gif as its image. (For information on creating banners, 
see Chapter 6,  "Creating banners" on page 149.

3 Type the name you entered in Step 1 in the Banner Name field in the Placement area. In 
the example in Step 1, "stat" is the name of the banner.

4 You have finished this procedure. To view the statistics for the banner you have created, go 
to the Statistics area by clicking on the Statistics tab.

7.8  How can I provide banner statistics for my customers?
If you have purchased the webEdition Customer Management Module, you can create 
a statistics page that only displays the statistics of the banners which are owned by the 
logged in customer. You create a statistics page using the <we:listview type="banner"> 
tag in combination with the <we:bannerSelect> tag. For a detailed description of these 
we:tags, see "The webEdition Tag-Reference" at the following URL: 
http://tags.webedition.de/index.html?go=TagReference&Language=en. 

The following example shows how you can provide statistics for your customers:
<we:form id="self" method="get">
<we:processDateSelect name="from"/>
<we:processDateSelect name="to" endofday="true"/>
<we:setVar to="global" nameto="filter" from="request" 
namefrom="filter"/>
<input 
type="checkbox" 
name="filter" 
value="true"
<we:ifVarNotEmpty match="filter" type="global">
checked
</we:ifVarNotEmpty>
> Filter<br>
<we:dateSelect name="from" class="normal"/><br>
<we:dateSelect name="to" class="normal"/><br>
<we:bannerSelect customer="true" name="bannerpath" showpath="true" 
firstentry="Please select a banner"/>
<input type="submit">
<we:listview type="banner" customer="true" path="\$bannerpath" 
rows="10" 
order="views desc" usefilter="\$filter" filterdatestart="\$from" 
filterdateend="\$to">
<table cellpadding="0" cellspacing="0" border="0" width="400">
  <tr>
    <td>Path</td>
    <td>Shown</td>
    <td>Clicked</td>
    <td>Rate</td>
  </tr>
  <tr>
    <td>all</td>
    <td><we:bannerSum type="views"/></td>
    <td><we:bannerSum type="clicks"/></td>
    <td><we:bannerSum type="rate"/></td>
  </tr>
  <we:repeat>
    <tr>
      <td><we:field name="path"></td>
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      <td><we:field name="views"></td>
      <td><we:field name="clicks"></td>
      <td><we:field name="rate"></td>
    </tr>
  </we:repeat>
</table>
<we:ifBack><we:back>back</we:back></we:ifBack>&nbsp;&nbsp;
<we:ifNext><we:next>next</we:next></we:ifNext>
</we:listview>
</we:form>
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8  Customer Management: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Customer Management and Customer Management PRO Modules. This chapter treats 
what the modules do and how to install them. You can also find information here about 
the basic layout and command features for the Customer Management Module. These 
topics are treated in the following sections:
• Section 8.1,  "What is the webEdition Customer Management Module?" on page 

165
• Section 8.2,  "Installation" on page 165
• Section 8.3,  "General information and navigation" on page 166

The PRO Module builds upon the standard Customer Management Module and 
therefore the information in this book pertains to both webEdition applications. 
Supplementary material describing the particular features of the Customer Management 
PRO Module is found in Chapter 9,  "The Customer Management PRO Module" on 
page 171.

8.1  What is the webEdition Customer Management Module?
The webEdition Customer Management Module is a database that allows you to register 
and manage external visitors to your web site. (These visitors are called "customers" in 
this document.) The Customer Management Module can manage customer data in two 
ways:
• You can enter customer data manually yourself.
• With the help of a registration form that you have designed for your Web site, 

customers can enter their data themselves. In this case, customers will log in by 
entering their user name and password. This feature allows you to offer registered 
customers an extended selection of information or give them access to areas from 
which non-registered users are barred.

8.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.
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8.3  General information and navigation
After installation, you will find a new menu item in the main menu called Modules, 
which contains all the modules in your installation of webEdition (see Figure 165).

Figure 165  Modules drop-down menu

8.3.1  Opening the module
To open the module, select Customer Management from the Modules drop-down menu 
on the webEdition main screen. The Customer Management Quickstart screen opens as 
seen in Figure 166.

Figure 166  Customer Management Module: mainscreen with Quickstart option

Using the Quickstart screen, you have the option of going directly to a new customer 
configuration screen.
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8.3.1.1  Customer Management explorer menu
The explorer menu displays a list of icons representing the customer data you have in 
your customer database (see Figure 167). You can access and modify the profile for a 
particular customer by double clicking on the icon for that customer.

Figure 167  Customer Management explorer menu

8.3.1.2  Permissions to modify the customer database
The default user has all of the permissions to create, modify and delete the data and data 
fields in the Customer Management database. Additional flexibility is available with the 
User Management Modules.

8.3.1.2.1  Interaction with the User Management Modules    If the Standard 
User Management Module is installed, permission to set up new customers (registered 
visitors to your site), or to modify the fields in the customer database are limited to the 
administrator. If you have installed the User Management PRO Module, the 
administrator can assign to any user the permission to create, delete, edit customer or 
edit customer fields. For more information on the User Management Module, see the 
User Management Module User Guide from the webEdition web site.

8.3.2  The Customer Management menus
The Customer Management Module main screen (as seen in Figure 166,  "Customer 
Management Module: mainscreen with Quickstart option" on page 166) has two 
drop-down menus: Customer and Help, each of which is described in the subsections 
that follow.

8.3.2.1  The Customer drop-down menu
The Customer drop-down menu has the following items (see Figure 168,  "Customer 
drop-down menu" on page 167):

Figure 168  Customer 
drop-down menu

•New. This option opens a 
window that allows you to 
enter data about a new 
customer.
•Save. Use this command to 
save your data.
•Delete. Use this command 
to delete your data.

• Administration > Fields administration. This item opens a window that allows you 
to modify the database parameters used to define your customers.

• End. Use this command to exit the application.
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If you have installed the Customer Management PRO Module, you will see additional 
items in the Customer menu. For details, see Chapter 9,  "The Customer Management 
PRO Module" on page 171.

8.3.2.2  The Help drop-down menu
The Help drop-down menu has the following items (see Figure 169,  "Help pull-down 
menu" on page 168):

Figure 169  Help pull-down menu

•Info. This command provides information about the application.
•Help. This command gives you access to the webEdition help system.

8.3.3  About fields and views in the customer database
You can use the customer database to store and maintain all of your data about your 
customers. Typically such a database would include information under such categories 
as customer name, E-mail address, street address, telephone number, etc. 

8.3.3.1  About views
The webEdition Customer Management Module software is pre-programmed to 
provide you with the following default categories, which are displayed in the module’s 
interface in the following views: General, Other, and All. You are not limited to the 
foregoing default settings. You can modify the database to meet your own needs by 
adding new types of information. You can add, for example, a view for a salutation or 
contact information (see Section 10.4,  "Working with customized views" on page 181). 
In this manner you are free to customize the database to meet the needs of your business 
or organization.

8.3.3.1.1  The General view    The General view provides the basic interface to 
your customer database. You use this view to enter user data about a new customer.

Select Customer > New from the Customer Management Module menu to access the 
default General view (see Figure 170):

The General view has the following fields, each of which allows you to enter a 
customer’s basic data:

Figure 170  General view

•Username
•Password
•Forename
•Surname
•Member since. This is a 
read only-field which tells 
you the date and time the 

user was created in the system.
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• Last login. This is a read only-field which tells you the date and time the user was 
last logged into the system.

• Last access. This is a read only-field which tells you the date and time the user last 
accessed data from the system.

8.3.3.1.2  Other view    This view is included so that you can add miscellaneous field 
types to a default view without having to create additional views.

8.3.3.1.3  All view    This view displays all your views in succession.

8.3.3.2  About fields
Within each of these categories (views) are the data fields which contain specific 
information about your customer. You can customize these fields to meet your own 
needs. You have the option of expanding all fields and views (with the exception of the 
General data). You can give names to your field, define the field type, and assign default 
values to those fields. (These activities can be performed using the Fields 
administration command, which is discussed in detail in Section 10.3,  "Working with 
fields in the customer database" on page 178).

8.3.3.2.1  Field types    There are five default field types from which you can 
choose. Each can be assigned default values:
• input. This field type creates a text input field suitable for short text entries. You can 

enter a default value in the Default field.

Figure 171  Input text field

• select. This field type creates a select box. The default values that you enter in the 
Default field must be separated by a comma. Each of the comma-separated values 
will appear as an item in your select list.

Figure 172  select field type

• textarea. This field type creates a box in which text can be written. 
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Figure 173  text area field type

• date. This field type creates date and time select boxes.

Figure 174  Date field type

• password. This field type creates a text input box. For reasons of security, characters 
typed by a user in this field are masked. 

Figure 175  Password field type
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9  The Customer Management PRO 
Module

The webEdition Customer Management PRO Module builds upon the standard 
Customer Management Module. The information in this book pertains to both of these 
webEdition applications (thus users of the PRO module must read the previous chapters 
of this manual for basic information about the features in the standard Customer 
Management Module). This chapter provides supplementary material describing the 
particular features of the Customer Management PRO Module.

9.1  What is the webEdition Customer Management PRO Module?
The Customer Management PRO Module allows you to perform all of the same 
functions as the Customer Management Module. In addition to the basic functions, the 
PRO module gives you enhanced abilities to manage your database by allowing you to:
• Sort your customers 
• Search for customers

9.2  General information and navigation
After installation, you will find a new menu item in the webEdition main screen called 
Modules, which contains all the modules in your installation of webEdition (see Figure 
176).

Figure 176  Modules drop-down menu

9.2.1  Customer Management PRO explorer menu
Like the standard Customer Management Module, the explorer menu in the PRO 
Module displays a list of icons representing the customer data you have in your 
customer database. There are two additional features visible in the PRO Module 
explorer menu (see Figure 177):
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Figure 177  Customer Management PRO explorer menu

•Sort feature. At the top of the explorer menu is the sort 
feature. The sort feature has a select box where you can 
choose from your defined sort profiles, and a pencil icon 
where you can create and/or edit the your parameters for 
your existing sort profiles. 
•Search feature. At the bottom of the explorer menu is 
the search feature which consists of a search field, and a 
search icon.

9.2.2  The Customer drop-down menu
Click on Modules > Customer management to open the Customer Management Module 
main screen (see Figure 178).

Figure 178  Customer Management main screen

In addition to those items described in Section 8.3.2.1,  "The Customer drop-down 
menu" on page 167, The Customer menu in the PRO Module has the following items 
(see Figure 179):
• Administration. The PRO Module offers two administrative features.

— Fields administration.
— Sort administration.

• Search. Use this item to access the module’s search engine 
• Settings. This item allows you to set your default sort view and your Start year for 

date sorting.
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Figure 179  Customer drop-down menu in the PRO Module

9.2.3  Using the Search function
The Customer Management PRO Module offers advanced search capabilities, allowing 
you to find and manage the data for your customers.

You can access the search feature in the following ways:
• Click on Customer > Search
• Use the simple search option at the bottom of the explorer menu.

Procedure 17  Using the search feature

In the Customer Management Module main screen
1 Click on Customer > Search or enter a name for a customer in the search field at the bottom 

of the explorer menu and click the search icon (represented by a magnifying glass).
The Search window opens (see Figure 180).

Figure 180  Search window

2 Two types of searches are possible. Do one of the following steps:
a Simple search. 

To perform a simple search, enter the text string in the Search for field.
b Advanced search.

i Click the right arrow icon beside Advanced search.
The Advanced search fields appear as seen in Figure 181.

Figure 181  Advanced search

ii Select your search parameters from the select boxes. 
• In the first select box, choose one of the views that you have defined.
• In the second select box, choose from the fields that you have defined within 

the view.
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• In the third select box, choose a search operator.
• Enter a parameter in the text field.

3 Click the search icon (magnifying glass).
If the system finds a match for your search, the item will appear in the Result box (see 
Figure 182).

Figure 182  The Search Result box

4 To access or edit the data for an item found in the Search Result box, double click on the 
item.
webEdition opens the editing area for the customer, where you can modify the data in the 
General, Other and All views, and also those additional views (such as Salutation or 
Contact) that you have created.

5 You have completed this procedure.

9.2.4  Using the Sort function 
The Customer Management PRO Module offers advanced sorting capabilities, allowing 
you to create and save multiple sort profiles so that you can manage the data for your 
customers.

You access the sort feature by selecting an item from the sort select box at the top of the 
explorer menu. You can edit your sort parameters by clicking the edit (pencil) icon 
adjacecnt to the sort select box, or by clicking Customer > Administration > Sort 
administration.

Note:  The first time you log in to the system, there are no sort parameters defined. 
The select box has —No Sort—.

Procedure 18  Using the sort feature

In the Customer Management Module main screen
1 Click Customer > Administration > Sort administration.

The Sort administration screen opens. The first time that you use this feature, the system 
displays a plus icon.

Figure 183  Sort administration screen

2 Click on the plus (+) icon to activate Insert new group. 
The Sort area opens (see Figure 184).
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Figure 184  Sort area

3 Type a name to identify your sort group in the Name field.
4 Click the plus (+) icon to add your sort parameters. Choose the sort parameters in 

accordance with the way you wish to arrange and access your customer data.There are 
four areas, each is represented by a select box. The views, fields and functions that are 
available are determined by the views and fields that you have defined for your Customer 
Management database (see Section 10.4.1,  "Creating a new view" on page 181).
a View. Sort according to view.
b Field. The available fields are determined by the view you have chosen.
c Function. The available functions vary depending on the field type that characterises 

the field you have chosen. For example text, can be sorted by alphabetical order; dates 
by day, moth, year (etc.). 

d Order. Use this command to choose to display your sort results in ascending (ASC) and 
descending (DESC) order.

Figure 185  Sort parameters selected

5 Click Save.
The system shows you a confirmation message.

6 Click OK.
The sort group you have created appears in the sort select box in the explorer menu.

7 Click on your newly created sort group.
Your customers appear in folders that coform to the parametes you have set.
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Figure 186  New sort group

8 You have completed this procedure.
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10  Using the customer database
This chapter describes how to use the Customer Management and Customer 
Management PRO Modules to create and manage a customer database. This chapter 
describes how to modify the database to meet the needs of your business or organization 
by adding new fields and views to accomodate different types of customer information.

This chapter describes how to work with the customer database under the following 
sections:
• Section 10.1,  "Creating a new customer using the Customer Management Module" 

on page 177
• Section 10.2,  "Modifying customer data" on page 178
• Section 10.3,  "Working with fields in the customer database" on page 178
• Section 10.4,  "Working with customized views" on page 181

10.1  Creating a new customer using the Customer Management Module
Use the following procedure to create a new customer.

Procedure 19  Creating a new customer

In the Customer Management Module main screen
1 Click Customer  > New.

The system opens the General view , where you can enter basic data about your customer 
(see Figure 187).

Figure 187  New customer: General view
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2 Enter all the customer data in the prescribed fields.
3 Save the data by clicking on the Save button at the bottom of the page.

webEdition confirms that the customer data was saved. Click OK. An icon representing the 
newly created customer appears in the explorer menu. The customer can now log onto the 
home page using the login you have assigned.

Figure 188  New customer icon in the explorer menu

Note:  To find out how to create the login mask, go to our documentation page at 
http://www.webedition.de/english/downloads/Documentation.html, and consult the 
publication titled The webEdition User Guide. 

4 You have completed this procedure.

10.2  Modifying customer data
You can modify the data for a customer by double clicking the icon listed in the explorer 
menu that signifies your customer. Thereafter, you can toggle among the tabs on the 
main screen to add or access information about the customer.

10.3  Working with fields in the customer database
The Customer Management Module allows you to change fields using the Fields 
administration feature. The following sections describe procedures for working with 
fields.

10.3.1  Adding fields to the customer database
The following procedure shows you how to add new field names to the default customer 
management database so that you can customize it for your own needs.

Procedure 20  Adding field names to the default customer database

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 189).

ATTENTION
Once you insert (or delete) field names, they will be accessible (or 
deleted) for all customers. 
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Figure 189  Fields administration screen

2 You must associate a field with an existing view. Use the Select view  select box to choose 
a view. (If you wish to create a new view first, see Section 10.4,  "Working with customized 
views" on page 181).

3 Click the Add button adjacent to the Fields area.
The Add field dialogue box appears.

Figure 190  Add field dialogue box

4 Enter a field name, select a field type from the select box, and enter a default value. (For 
information about field types, see Section 8.3.3.2.1,  "Field types" on page 169).

5 Click on the Save button.
The new field appears in the Fields list on the Fields administration screen.

Figure 191  New customer field
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6 You have completed this procedure.

10.3.2  Modifying fields in the customer database

Procedure 21  Changing the properties of a field

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 189,  "Fields administration screen" on 
page 179).

2 Use the Select view select box to choose the view which has the field you wish to change.
3 In the Fields area, highlight the name of the field you wish to change. See, for example, 

Figure 191,  "New customer field" on page 179.
4 Click the Edit button adjacent to the Fields area.

The Edit field dialogue box appears.

Figure 192  Edit field dialogue box

5 Change a field name, field type or default value.
6 Click on the Save button.

The modified field appears in the Fields area on the Fields administration screen.

Figure 193  Edited customer field

7 You have completed this procedure.
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10.3.3  Deleting a field

Procedure 22  Deleting the name of a view

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 189,  "Fields administration screen" on 
page 179).

2 Use the Select view select box to choose the view which has the field you wish to change.
3 In the Fields area, highlight the name of the field you wish to delete.
4 Click the Delete button.

webEdition asks you if you want to delete the chosen field.

5 Click the OK button to delete the field(s).
The system confirms the action. Click the OK button again.

Note:  If you delete the last field in a selected view, you will also delete the view.

6 Click on the Close button.
7 You have completed this procedure.

10.4  Working with customized views 
The Customer Management Module allows you to manage field types arranged in 
views. Using the Fields administration feature, you can create new views and new 
fields for each view. The following views are predefined and cannot be changed or 
deleted: General, Other, All.

10.4.1  Creating a new view 

Procedure 23  Creating a new view

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 189,  "Fields administration screen" on 
page 179).

2 To create a new view, enter a name for the new view in the View  field.
3 Click the Add button adjacent to the Fields area.

The Add field dialogue box appears.

4 Enter a field name, field type and default value and click OK.

Note:  You must create at least one field for your view.
A new view has been created. The new view name appears in the View field and also in the 
Select view select box (see Figure 194).
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Figure 194  Creating a new view

5 Click on the Close button.
A new tab for the view appears on the Customer Management main screen.

Figure 195  New customer tab and view

6 You have completed this procedure.

10.4.2  Editing a view

Procedure 24  Editing the name of a view

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 189,  "Fields administration screen" on 
page 179).

2 Click the pencil icon adjacent to the Select view select box.
The Edit view dialogue box appears.
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Figure 196  Edit view dialogue box

3 Enter a new name in the Name field.
4 Click the Save button.

A new name for the view appears in the View field and in the Select view select box.

Figure 197  Edited customer view tab

5 Click on the Close button.
The newly-named tab for the view appears on the Customer Management main screen.

Figure 198  Renamed customer view tab

6 You have completed this procedure.

10.4.3  Deleting a view

Procedure 25  Deleting a view

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 189,  "Fields administration screen" on 
page 179).

2 Highlight each of the fields in the Fields area.
3 Click the Delete button.

webEdition asks you if you want to delete the chosen field.

4 Click the OK button to delete the field(s).
The system confirms the action. Click the OK button again.

5 Click on the Close button.
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Once you have removed all fields associate with the view, the view and its tab disappear 
from the Customer Management main screen.

6 You have completed this procedure.
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11  Designing templates for the Customer 
Management Modules

In order to make your website accessible to registered users (or customers as we refer 
to them), you must insert the appropriate we:tags into your templates. This chapter 
shows you how to use webEdition tags (we:tags) to do the following actions:
• create registration forms so that external users can register as "customers"
• create login areas for your customers on your web site
• make information accessible only to logged-in users or customers.

The we:tags discussed in this chapter pertain to both versions of the Customer 
Management Module, hence this chapter is intended for users of both the Customer 
Management and the Customer Management PRO modules.

Those using this chapter are expected to have a knowledge of template development and 
we:tags. Moreover, webEdition users must have either administrative priveleges, or 
have the permissins to create and deploy templates in order to manage customer access.

11.1  Creating registration forms
You use a registration form to create registered users (or customers) on your web site. 
By registering visitors to your web site, you can make information available to them that 
unregistered users cannot see or access.

To create a registration form, you use the <we:sessionField/> tag. This we:tag works 
closely with the Customer Management Module. The <we:sessionField> tag draws 
fields from the Customer Management Module and places them on a Web page. 

For example, in your Customer database, if you have the field "Contact_Email", which 
is designed for the E-mail addresses of your customers, you can display this field value 
with the <we:sessionField tag> by adding the following variables: <we:sessionField 
name="Contact_Email" type="textinput"/>. This tag will produce one input box for the 
customer E-mail on the page. All field names that are in the Customer Management 
database can be used as variables with the <we:sessionField/> tag. These variables can 
be initially entered, changed or deleted by using a form containing the 
<we:sessionField..../> tag with the corresponding variable(s).

Procedure 26  Creating a registration form

In the Templates view of the webEdition main screen
1 If you are not already in the Templates view, go there by clicking on the Templates tab.
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2 Open a new template by selecting File > New > Template.
3 Go to the Properties view by clicking on the Properties tab (see Figure 199).

Figure 199  The Properties view

4 In the Path area, enter a name for the file in the Filename field, and a select a directory. 
5 Click Save.

Your new template appears in the explorer menu.

Note:  Your template will have a .tmpl file extension.

6 Click the Edit tab to open the Templates Edit view (see Figure 200).

Figure 200  Template Edit view

7 Click on the Show Tag Wizard arrow. In the Tag Wizard area, use the scroll bar to find 
sessionField tag (see Figure 201). Click the sessionField tag to highlight it.
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Figure 201  we:Tag Wizard: sessionField

8 Click the arrow to the right of the select box to open a dialogue box for the 
<we:sessionField> tag.
A "we:sessionField" dialogue box opens (see Figure 202).

Figure 202  we:sessionField dialogue box

9 Choose a value from the name attribute select box. You will see all the default field names 
(and any that you have added in the Customer Management Module) that are available for 
your form (see Figure 203).

Figure 203  Available field names for your form
Customer Management and Customer Management PRO Modules



188   Designing templates for the Customer Management Modules 
10  Choose the type of input field from the type select box.
11 Click Save.

The dialogue box closes and you are returned to the Edit view. The <we:session> tag with 
your newly defined attribute appears in the right -hand portion of the Tag Wizard (see Figure 
204).

Figure 204  The sessionField tag with defined attributes

12 Using your mouse, cut the newly defined tag from the right side of the Tag Wizard and paste 
it into your template. (You can also edit and add any accompanying text to the template at 
this time.)

Figure 205  The sessionField tag used in a template

13 Click Save.
14 Click on the Preview tab to view the changes to your template. 

Figure 206  Preview of 

15 You have completed this procedure.
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11.2  Creating a form to register a new customer
To allow visitors to your site to register as a new customer, you need to create a link on 
your Web site that points to a form where all required fields (or all fields listed in the 
customer management database) are called up with the <we:sessionField/> tag. Once 
the visitor has entered all the required information, the form can be saved so that all data 
will be written to the database. Thereafter the visitor becomes a “customer” and can log 
in with a user name and password. From this point on, you can view and change the data 
associated with this customer using the Customer Management Module. 

11.2.1  Designing registration forms: code example
You can design registration forms with the following we:tags:

<we:sessionStart/>
<we:saveRegisteredUser/>
<html>
<head>
  <we:title>webEdition Default-template</we:title>
  <we:description>Form</we:description>
  <we:keywords>webEdition, cms, </we:keywords>
</head>
<body>
Please enter your personal data:<br>
<we:form id="self">
  Username: <we:sessionField name="Username" type="textinput"/><br>
  Password: <we:sessionField name="Password" type="password"/><br>
  Forename: <we:sessionField name="Forename" type="textinput"/><br>
  Surname: <we:sessionField name="Surname" type="textinput"/><br>
  <we:sessionField name="ID" type="hidden"/>
  <input type="submit" value="go">
</we:form>
</body>
</html>

Figure 207 shows the output from the code noted above.

Figure 207  Example of form output

11.2.2  Explanation of code
It is essential that forms in which changes are to be made to the data always contain the 
following type of hidden field: <we:sessionField Last name="ID" type="hidden"> This 
field ensures that the session created by the <we:sessionStart/> tag is also transmitted 
and the customer is uniquely identified. The data cannot be assigned without this 
session. The following page must begin with: 
<we:sessionStart/><we:saveRegisteredUser/>. Aside from these tag conventions, you 
have complete freedom with the layout of your form.
Customer Management and Customer Management PRO Modules



190   Designing templates for the Customer Management Modules 
11.3  Creating a login area for your customers
The webEdition Customer Management Module gives you the capability to create a 
section on your Web site where your customers can log in to your site. By doing so, you 
can make whole pages or entire sections of your site accessible only to registered users.

The following sub-sections describe how to 
• generate a login section where a user can log in
• make information accessible only to logged-in users

11.3.1  Generating a login section: code example
The following code is an example of how to design a template to allow customers to log 
in to your Web site:

<we:sessionStart/>
Please log in with your user name and password
<we:a id="self">New user</we:a>
<br>
<we:form id="self">
Username: <we:sessionField name="Username" type="textinput"/><br>
Password: <we:sessionField name="Password" type="password"/><br>
<input type="submit" value="go">
</we:form>

Figure 208 shows the output from the code noted above.

Figure 208  Example of login form

11.3.2  Making information accessible only to logged-in users: code example
You can make whole pages or entire sections accessible only to registered users. You 
can implement this function by using the <we:ifRegisteredUser/> tag:

<we:sessionStart/>
<we:ifRegisteredUser>
Hello: <we:sessionField Last name="user name" type="print"/><br>
Logged in
</we:ifRegisteredUser>

11.3.2.1  Explanation of code
For all functions that you wish to control from the Customer Management Module, you 
must always include the <we:sessionStart/> tag. This tag must appear at the very 
beginning of every page that has anything to do with the Customer Management 
Module, before any other (html) tag (e.g.<html> or <body>).

The code queries whether a user is registered. If so, the user will be greeted with "Hello, 
user name". User name is a placeholder for the visitor’s actual user name as entered in 
the system.
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You can decide what is written between the <we:ifRegisteredUser> and 
</we:ifRegisteredUser> tags. It can be individual information, features, links to other 
pages, navigation or any other functions.

11.4  Creating a form to allow a customer to modify their existing 
registration data

In order to allows a customer to modify their existing registration data, you need to 
create a form that is identical to the one described in Section 11.2,  "Creating a form to 
register a new customer" on page 189, but which is located in an area of your site that 
can only be accessed by registered customers. Because this user is already registered, 
the registration information will always be called up via the <we:sessionStart/> tag. 
When the customer accesses the form, the existing data in the database will 
automatically be written to the form fields. Thereafter the customer can modify and save 
his/her registration information.
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12  Database/Object Module: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Database/Object Module. This chapter treats what the module does and how to install 
it. These topics are treated in the following sections:
• Section 12.1,  "What is the webEdition Database/Object Module?" on page 193
• Section 12.2,  "Interactions with other webEdition modules" on page 195
• Section 12.3,  "Installation" on page 195

You can also find information in this chapter about the basic layout and command 
features for the Database/Object Module: 
• Section 12.4,  "General information and navigation" on page 195
• Section 12.5,  "Understanding the automatic naming policies" on page 208
• Section 12.6,  "Understanding field types" on page 210
• Section 12.7,  "Creating/editing vs. displaying objects/classes" on page 216

12.1  What is the webEdition Database/Object Module?
The Database/Object Module allows you to organize your web content using 
object-oriented programming. This module alleviates the problem of maintaining 
similar items on multiple pages by simplifying the tasks of selecting, distributing, 
maintaining, modifying and reusing many different data objects (such as addresses or 
events) that share a similar data structure.

12.1.1  Intended users
The Database/Object Module is intended for advanced users of webEdition, and those 
with a knowledge of Web site architecture and design. A working knowledge of the 
webEdition template development processes, and webEdition tags (we:tags) is required 
in order to use this module.

12.1.2  What is an object?
An object is any kind of data (such as texts, headings, images, numbers, select field), 
which can be stored in a structured format, connected relationally with other objects, 
and selected and displayed in templates and/or documents. Objects have no layout 
information. An object is a unique instance of a data whose structure is defined 
according to a “template” provided by its class. Each object has its own values for the 
variables belonging to its class.
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12.1.3  What is an object class?
A class is the structural definition of an object. An object class defines what fields are 
available for a particular object. A class may also be defined as a set of objects that share 
a common structure and behavior. For example, a customer security database may have 
the following classes: last name, first name, address, passport photo etc.

12.1.4  What the Database/Object Module can do
The Database/Object module has many possible uses and applications designed to 
streamline your web content management and maintenance. Below are just a few of the 
possible uses. With the Database/Object Module, you can manage
• addresses
• events and addresses
• an image database
• a publications database
• contacts
• news
• a web portal

12.1.4.1  Managing addresses
The management of addresses is a typical application for the Database/Object Module. 
You can define a class called Addresses with all the information you wish to have 
(street, number, postal code, etc.). The editors can enter all the necessary addresses. You 
can arrange the addresses in different listviews (by postal code, metadata, last names, 
etc.). You can define two different templates for different areas (such as Internet and 
intranet), and display the address in each area using the template allocated to this 
workspace. All information could be displayed on the intranet, while only part of the 
information would be visible on the Internet.

12.1.4.2  Managing events and addresses
The connecting of events and addresses is an example of the relational linking of 
objects. Suppose that you have an editorial staff that publishes new events every day. 
You have defined a link to the Addresses object class in the Events object class via the 
Object field type. The events keep changing but the addresses of the event organizers 
remain the same. After entering a new event, editors can select an address already 
available in the Database/Object Module and allocate it to the new event. If the address 
changes, everything will still remain up-to-date.

12.1.4.3  Image database
A small image database can also be realized using the Database/Object Module. You 
can create an object class called "images" in which you can define different field types 
for a thumbnail of the image, the image itself, or a link to the image (if you prefer not 
to maintain large images in the database), as well as all keywords and the text 
descriptions. The object listviews allow you to search this small image database, view 
different descriptions and thumbnails and download the image itself.

12.1.4.4  Publications database
A publication database operates along the same lines as the image database. You can 
have publications in different formats (*.doc, *.pdf, etc.). You define an object by 
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defining all descriptions and metadata for these publications and a download link in the 
class. The object listview can be used to search and download the publications.

12.1.4.5  Managing contacts
See Section 12.1.4.1,  "Managing addresses" on page 194, but with modified fields.

12.1.4.6  Managing news
In this application, you not only use the Database/Object Module, but also the Scheduler 
Module. You can manage all news items as objects so that you can monitor which news 
items are included on your page, which have not been published yet, which are online, 
and which are no longer live.

12.1.4.7  Portal manager
If we assume that you have three portals running at one domain, each one of these 
portals is a defined workspace in webEdition. The editors from the individual 
workspaces can create news, information and articles as objects for their workspace. If 
they have objects they would like to make available to the other workspaces, they can 
select an additional workspace – that was defined with a fixed template in the class 
definition – that they can use to make this object available to editors in other 
workspaces. Editors in other workspaces just have to click on the object to be able to 
use it for their own portals.

12.2  Interactions with other webEdition modules
The Database/Object Module operates and interacts with all of the webEdition modules 
you have installed. The User Management PRO, Workflow, and Scheduler PRO 
modules all have advanced features which enhance the use of the Database/Object 
Module. If you have not installed these modules, you will not be able to see the 
advanced feature options.

12.3  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

12.4  General information and navigation
When you install the Database/Object Module, its user functions are integrated into the 
structure and the File menu of the webEdition main screen.
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Figure 209  webEdition main screen

12.4.1  Main menu functions
12.4.1.1  New Object/Class menu
You can create a new object or class of object by selecting the appropriate button from 
the Quickstart screen, or by clicking File > New > Object (or Class), (see Figure 210).

Figure 210  Create a new object or class

12.4.1.2  Open Object/Class menu
You can open an existing object or class of object by selecting File > Open > Object (or 
Class), (see Figure 211).
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Figure 211  Open an object or class

12.4.1.3  Delete Object/Class menu
You can delete an existing object or class of object by selecting File > Delete > Object 
(or Class), (see Figure 212).

Figure 212  Delete an object or class

12.4.2  Tab functions and the explorer menu
After installing the module, two new tabs, Objects and Classes, appear along the 
right-hand side of the explorer menu. The (blue) highlighted tab indicates your present 
view (see Figure 209,  "webEdition main screen" on page 196).

12.4.3  The Objects tab
If you click on the Objects tab, the tab colour turns to blue, and a list of directories 
(folders) appears in the objects explorer menu. The "directories" in the objects view 
represent the object classes. Within each folder are the objects assigned to that object 
class (see Figure 213).

You can open a folder by clicking the plus “+” symbol. The objects appear in the 
directory. Objects are identified by an icon with the letter “o”. If you click on an object 
itself, webEdition opens an Edit screen, which appears in the right part of your screen. 
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Figure 213  Objects in the explorer menu

12.4.3.1  Views accessible with the Objects tab
The Objects tab allows you to view and edit all the characteristics of an object. If you 
click on the (vertical) Objects tab, four horizontally-arranged tabs appear. Each tab 
opens a view.

12.4.3.1.1  Objects Properties view    The Properties view has the following 
areas:

Figure 214  Objects Properties view

• Path. This area shows the name of the object and its directory location (or address).
• Class. This area identifies the class to which the object belongs.
• Categories. The categories area allows you to create sub structures so that you can 

manage your objects.
• Owners. The username of the main owner of the object appears in the Owners 

section. (This area is only available if the User Management or User Management 
PRO Modules have been installed.) If a new object is created, the current user will 
be the main owner.
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• The Restrict access checkbox allows you to limit user access to the object. If you 
activate this checkbox, a dialogue box opens in which you can add those users who 
are to be allowed to access the object (see Figure 215).

Figure 215  Restricting user access

• Copy object. The Copy object function helps you to create new objects in a simple, 
quick manner. Because objects share characteristics defined by their class, you can 
copy an existing object using the Select button, then modify and save it under a new 
name.

12.4.3.1.2  The Objects Edit view    Edit. The Edit view is designed to allow a user 
to enter data in the fields that have been defined by the selected object class (see Figure 
216).

Figure 216  The Edit view for objects

12.4.3.1.3  Objects Workspace view    Workspace. A workspace is simply a 
directory to which access rights can be assigned. A workspace contains documents and 
templates. The term “workspace” has been adopted because it represents the 
environment in which a user, such as a content editor, performs their editing tasks.
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There are two areas to the Workspace view:
• Workspace, you can see the workspaces specified in the class definition. These are 

the only areas where the object can be displayed using the corresponding 
documents. 
Only the first workspace defined in the class will be displayed in the Workspaces 
view. You can select any other workspaces defined in the object class in the 
drop-down menu Add workspace (Figure 217).

Figure 217  The Objects Workspace view

• Extra workspaces. This area permits you to display an object in an additional 
workspace.

12.4.3.1.4  Objects Information view    Information. The Information view 
supplies information about the object identification (ID), file type, the creator, the last 
change made and the last publication (see Figure 218).

Figure 218  The Objects Information view

12.4.3.1.5  Objects Preview view    Preview. Use this view to view the appearance 
of your object (see Figure 219).
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Figure 219  The Preview view

12.4.3.1.6  Scheduler PRO view    Scheduler PRO. This tab is available only if 
you have installed the Scheduler PRO Module. For details, see the Scheduler PRO 
Module User Guide.

12.4.3.2  Save options
If you wish to save a new or modified object, you have the following options (see Figure 
220,  "Save options" on page 201):
• Save. Select the save button to store an object in the system without publishing it. 

An object that has been saved but not published appears in red font in the explorer 
menu.
— Publish after saving. Select this checkbox before saving if you want to save the 

object in the system and publish it immediately. It will be immediately visible 
in the corresponding listview.

— New object after saving. Select this checkbox before saving if you want a new, 
empty object from the same class to appear after the save process is complete. 
This function facilitates the creation of many objects of the same type.

• In Workflow. Select this button to place an object into a workflow. 

Note:  This option is available only if you have installed the Workflow Module. 
For further details, see the webEdition documentation page at 
http://www.webedition.de/english/downloads/Documentation.html

• Unpublish (Park). use the unpublish function to undo the publication of an object. 
By doing so you can return an object that has been saved and published to the 
"saved, but not yet published" status. 

Figure 220  Save options
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12.4.3.3  Object class summary
If you click on a folder in the explorer menu (while still in the Objects view), you can 
access summary information about the object class. Three tabs appear as shown in 
Figure 221,  "Object workspace view" on page 202:
• Workspace
• Field
• Search

Figure 221  Object workspace view

12.4.3.3.1  The Workspace view    The Workspace view shows a summary of all 
objects contained in a class together with all of the assigned workspaces and additional 
workspaces.

The top portion of the Workspace view shows the following items:
• Directory (field). This selector field allows you to select the directory whose 

workspace you wish to view.
• View. This pick list allows you to change the number of objects to display on your 

screen.
• Show visible objects only. Select this checkbox if you wish only to view objects that 

are visible.
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The workspace summary table has the following information and functions:
• Directory (checkbox). The square checkboxes in the first column allow you to select 

different workspaces. A directory checkbox is used only to determine what objects 
can be displayed in a given workspace.

• Show. The circles in the second column of the table indicate which objects can be 
displayed in the selected workspace and which cannot.
— If the circle is gray, the object cannot be displayed.
— If the circle is blue, the object can be displayed.

• Object. This column lists the objects in the selected class. If you click on the word 
Object in the table heading, the list will automatically be sorted alphabetically by 
object name.

• Workspace. This column shows the workspace allocated to an object.
• Extra workspaces. This column shows the additional workspaces allocated to an 

object.
• Published. This column identifies the publication status of an object (published, 

parked or saved) and the date and time of the last operation performed on the object. 
If you click the word Published in the table heading, the list will be sorted by 
publication date. If an object has not been published or parked, nothing will be 
entered in the column. 

Beneath the table are the following buttons/functions:
• Select all. This button allows you to select all directories in the table.
• Delete selected objects. The trash can icon allows you to delete the objects you have 

selected from the table.
• Search. You can perform a full-text search by entering a word in the search field. 

You can also use the adjacent select box to filter your search according to field types.

12.4.3.3.2  The Fields view    The Fields view looks and operates in the same 
manner as the Workspace view, except that it displays all the fields of the object instead 
of the workspaces (seeFigure 222 ). (Scroll to the right, using the scroll bar at the bottom 
of the page, in order to see all fields). If you click on the field name in the table heading, 
the list will be sorted alphabetically according to the entries of that field.
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Figure 222  The Fields view
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12.4.3.3.3  The Search view    In this view, you can search individual fields using 
specific criteria (see Figure 223,  "The Search view" on page 205).
• Search. Enter a keywords into the Search field. Next to it is a drop-down menu in 

which you can select the condition you wish to attach to the keyword.
• Search operator pick list. Use this list to select one of the following search operators:

— CONTAIN. The keyword matches a freely definable combination of characters 
within the term being searched. Example: "s_t" – returns "news_today" and all 
other terms that contain this combination of characters.

— IS. 100% match with the keyword, no variation allowed. Example: Keyword: 
"news_today" – returns: "news_today"

— START. The keyword matches the beginning of the term being searched. 
Example: Keyword: "news" – returns "news_today" and all other terms that 
begin with "news".

— END. The keyword matches the end of the term being searched. Example: 
Keyword: "today" – returns "news_today" and all other terms that end with 
"today".

— For numbers:
– < is less than.
– > is greater than
– <= is less than or equal to
– >= is greater than or equal to

• Select field. In the last pick list on the right side, you can select which field should 
be searched.

• Delete. If you want to start a new search, click the Delete button to reset the search 
function.

• Add. Click the add button if you want to search additional fields simultaneously. 

Figure 223  The Search view

12.4.4  The Classes tab
If you click on the Classes tab, the tab colour turns to blue, and a list of files appears in 
the classes explorer menu. The entries in the class view represent the object classes. A 
class is identified by an icon with the letter "c".
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12.4.4.1  Views accessible with the Classes tab
You can access the Classes views by clicking on a class icon in the explorer menu. The 
edit mode has four views:

12.4.4.1.1  Classes Properties view    Properties. This view has two areas, Path 
and Default (see Figure 223).
• Path. This area shows the name of the class.
• Default. This area has the following fields:

— Automatic name. If you wish to use the automatic naming feature, select an item 
from the Automatic name drop-down menu. Each type is described in detail in 
Section 12.5,  "Understanding the automatic naming policies" on page 208.

— Categories. See page 198
— Restrict access. See page 199

Figure 224  The class Properties view

12.4.4.1.2  Classes Edit view    Edit. The actual structure of the object class is 
created in the Edit view (see Figure 225). The structure of an object class consists of 
different types of data fields. These fields do not contain any layout information. 
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Figure 225  The class Edit view

Click the plus button to create the first field of the new object class. 
• Name. Use this area to specify the name of the field. The following characters are 

permitted: all letters from a to z and A to Z, numbers, underscore (_), minus (-) and 
dot (.). No other characters are allowed. Do not use accented letters. You will always 
be given a default name (input0).

• Type. Use this area to specify the field type using this drop-down menu. The 
available field types are described in Section 12.6,  "Understanding field types" on 
page 210.

• Length. Enter a value in this text box that represents the length of the field in the 
database. For example, if you set the value to 20 for a text input field type, the 
content can only have 20 characters. It is useful for saving memory.

• Default. Enter the default value for the corresponding field. When creating a new 
object, the value that you enter will be filled automatically in the object field.

• Title.
• Description.
• Required field.
• Users. Select which users are allowed to access the object by clicking the Add 

button.

12.4.4.1.3  Classes Workspace view    Workspace. In the Workspace view, you 
can pre-set the environment(s) in which the objects based on this object class are visible 
(see Figure 226,  "The Workspace view" on page 208). Because the object is stored 
without any layout information, you must also allocate a template with which to view 
of the object.

You can also use the radio buttons in the Display area to determine whether or not you 
want to display the object class in the selected workspace.
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By clicking the add button, you will open the file manager in which you can select a 
directory (workspace). If you do not define a workspace, the object can be displayed 
anywhere. The object will always be displayed using a document (listview, detailed 
view). 

Figure 226  The Workspace view

12.4.4.1.4  Classes Information view    Information. The Classes Information 
view supplies read-only information about the file ID and type, the creation date, 
creator, and the last changes made to the class (see Figure 227).

Figure 227  Class Information view

12.5  Understanding the automatic naming policies
The following subsections describe in detail the automatic naming policies. The 
Automatic name options pertain to object classes. The controls are found in the Default 
area of the Properties view.

Figure 228  Automatic naming select box
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If you fill in the Automatic name field, all objects created later with this class will be 
named uniformly and in order without requiring you to enter a new name each time.

12.5.1  Unique
The unique option allows you to instruct webEdition to identify an object with a 
randomly selected and unique alpha-numeric name. 

After clicking unique, a number field appears beside the Automatic name drop-down 
menu (see Figure 229,  "Automatic naming policy: unique" on page 209). This number 
indicates the number of characters the unique identifier will have. The default value is 
16 characters.

Figure 229  Automatic naming policy: unique

12.5.2  Day
The Day option allows you to specify the portion of the name that will have the current 
date as its identification. "01" will be displayed if the current date is 09/01/2003.

12.5.3  Month (01-12)
The Month (01-12) option allows you to specify the portion of the name that will have 
the date of the current month as its identification. "09" will be displayed if the current 
date is 09/01/2002.

12.5.4  Month (1-12)
As above in Month (01-12), except without the "0" for the months from January ("1" 
instead of "01") to September ("9" instead of "09"). "9" will be displayed if the current 
date is 09/01/2003.

12.5.5  Year (02)
Clicking this option allows you to specify the portion of the name that will have the date 
of the current year as its identification. "02" will be displayed if the current date is 
09/01/2002.

12.5.6  Year (2002)
As above in Year (02), except the full year will be displayed (2002). "2002" will be 
displayed if the current date is 09/01/2002.

12.5.7  Hours
The Hours option allows you to specify the portion of the name that will have the 
current hour as its identification. If, for example, the system clock is currently 11:23, 
"11" will be displayed. If you set the North American time format (am/pm), this option 
will still display the hours 0-23.

12.5.8  ID
Click the ID option and you can specify the portion of the name that will have the ID of 
the corresponding object as its identification. Like all documents, all objects have a 
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unique ID. This is also a unique identifier. If the ID of the newly created object is "566", 
"566" will be displayed.

12.5.9  Text
The Text option allows you to specify the portion of the name that will have a text of 
your choice as its identification (see Figure 230).

This identifying text can contain upper and lower-case letters and numbers. The 
following characters are permitted: all letters from a to z and A to Z, numbers, 
underscore (_), minus (-) and dot (.). No other characters are allowed. Do not use 
accented letters such as ä or ö.

Figure 230  Automatic naming policy: Text

12.6  Understanding field types
The following subsections describe in detail the field types that area available from the 
Classes > Edit view.

Figure 231  Field Types

12.6.1  Select 
The Select field type allows you to create a select box or pick-list. Editors can choose 
an entry from the select field when creating a new object (see Figure 232).

Figure 232  Select field type

The Default settings are as follows:
• Key. Should begin with 0. Permits future changes to the individual select items 

under Value.
• Value. Name of the select item
• Title. Fetches the title for search function
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• Description. Fetches the description for search function
• Required field. This field must be filled in; if it is not filled in you will not be able 

to save the object.

To define a new entry in the select field, click the plus “+” icon next to the Value field. 
To delete an existing entry, click the trash can icon.

The add button underneath the user field allows you to set the permissions for 
individual users and/or groups to edit this field.

The two option buttons Title and Description can only be clicked once per object class. 
They allow you to define the title and description displayed in a listview (title and 
description) for each object class. These fields will then be the only ones displayed in 
the listview.

12.6.2  Date
The Date field type allows you to generate a date field. The default setting is always the 
current date and time. The editor can change this field.

All other aspects are like Select.

12.6.3  Textinput
The Textinput type permits you to define one-line text entry fields (see Figure 233).

Figure 233  Textinput field type

• Length. The maximum number of characters that can be entered.
• Default. Entry of a default text.

All other aspects are like Select.

12.6.4  Textarea
The Textarea field type allows you to generate a textarea (that is a textbox with several 
rows).
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Figure 234  Textarea field type

• Name: Give the settings a name.
• Type: Select Textarea.
• Default setting- Attributes...  When you click on the button Attribute..., a new 

dialogue window for the attribute settings opens (see Figure 235).

Figure 235  Textarea Attribute

— wysiwyg:on/off (de)activates the WYSIWYG mode.
— forbidhtml:on/off allows or permits to code HTML in the textarea.
— forbidphp:on/off allows or permits to code PHP in the textarea..
— xml: If xml is true, XML conform source code is generated.
— removefirstparagraph: If removefirstparagraph is true, the first paragraph is 

removed.
— inlineedit: If inlineedit is true, the WYSIWYG Editor is deactivated in the 

normal edit mode. Instead of the WYSIWYG editor, the text is displayed with a 
Edit button. If you click on that, the WYSIWYG editor appears in a separate 
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window. Loading a page with a lot of WYSIWYG textareas is much faster this 
way.

— showmenus:on/off (de)activates the drop-down menus (dhtmledit has to be “on” 
for that function).

— classes:Enter the classes, for which the settings apply.
— commands:Choose the commands in the select box, for which the settings apply. 

Than the selected commands are displayed automatically in the textbox 
underneath. You can also write the commands directly in the textbox.

• Default setting- Title/Description:Here you can input a title or a description of a 
textarea.

• Default setting- Obligational field:Choose if text has to be input in the textarea 
(Obligational field activated) or not (Obligational field not activated).

• User: Define with the button Add, which users may input or edit text in the textarea.

12.6.5  Image
This field type permits you to define image fields (see Figure 236).

Figure 236  Image field type

Default setting:If you wish, you can define a default image.

All other aspects are like Select.

12.6.6  Integer
This field type allows you to define a number field for integer values (whole numbers) 
as seen in Figure 237.

Figure 237  Integer field type

• Length. The maximum length of number
• Default setting. If you wish, you can define a default value.

All other aspects are like Select.
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12.6.7  Float
This field type allows you to define a number field for float values (decimal numbers) 
as seen in Figure 238.

Figure 238  Float field type

• Default setting. If you wish, you can define a default value.

12.6.8  Object
This field type allows you to link another object to the newly created relational one. The 
editors will then be able to select objects from an object class whenever they create new 
objects. For example, if you create objects of the "Contact person" class, you can 
connect these objects with objects of the "Addresses" class so that contact people are 
always displayed alongside their addresses (see Figure 239).

Figure 239  Object field type

• Default setting. Select the desired class.

All other aspects are like Select.

12.6.9  Link
The Link field type permits you to define an external link (URL) on another Web page, 
an internal link or a document to be downloaded (see Figure 240). This field has the 
same functionality as the <we:link> tag. The output is a link.

Note:  External links have to be entered with "http://…".

Figure 240  Link field type

All other aspects are like Select.

12.6.10  Href
This field type permits you to define an external link (URL) on another web page, an 
internal link or a document to be downloaded (see Figure 241,  "Href field type" on page 
215). This field has the same functionality as the <we:href> tag. The Select button for 
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ext.href launches the "Browse server" function so that you can easily link files that are 
stored outside of the webEdition database on the server. The output is a link.

Note:  External links have to be entered with "http://…".

Figure 241  Href field type

Default: Desired internal or external URL

All other aspects are like Select.

12.6.11  Binary
The Binary field type allows you to insert a binary file to be downloaded (see Figure 
242). This file first has to be imported using File > New > Others > Other files in 
webEdition. The output is a link.

Figure 242  Binary field type

Default: Desired file.

All other aspects are like Select.

12.6.12  Combining fields, sorting and deleting fields
You can combine, sort, or delete fields using the add button (plus icon), as seen in Figure 
243.
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Figure 243  Combining fields

Click the plus button to insert an additional field in front of a field. Click the trash can 
icon to delete the field.

Click the plus button on the bottom left of the page to add a field.

12.7  Creating/editing vs. displaying objects/classes
In the chapters that follow we shall differentiate between creating and editing 
objects/classes (see Chapter 13) and displaying them in the front end system (see 
Chapter 14).

12.7.1  Creating/editing objects/classes: permissions
In general, creating new classes or objects is a privilege that depends on the permissions 
granted to each webEdition user by the administrator. As such, it can be assigned and 
withdrawn. You can define in User Management PRO whether someone can create a 
new class or a new object based on an existing class.

When creating a new class, the administrator can define who can create objects within 
this new class in the Properties view of the object classes. If the administrator does not 
restrict access, everyone who principally has this privilege will be able to create new 
objects based on this class. However, an administrator can also restrict access so that 
only a selection of users will be entitled to create new objects based on this class. 

12.7.2  Displaying objects in the front end
The display of objects in the front end as a list or in the detailed display, is always done 
by means of templates and documents. If you want to display stored objects, you must 
create a document based on a template that contains the corresponding listview or fields 
for a detailed display.

ATTENTION
The permissions assignment function in the User Management PRO 
Module is the only way to manage the privilege to create object 
classes. If you have not installed this module, all users will be able to 
create classes and objects.
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Unlike creating or changing objects, displaying the objects in the front end system (via 
listview or the detailed display) is not organized by users, but by workspaces. A 
workspace is a directory to which access rights can be assigned when you set up your 
object classes. 

For example, if you have a workspace called "PR" and have allocated the "Press 
releases" object class exclusively to this workspace, objects of the "Press releases" class 
can only be displayed by a document stored in this area with the corresponding listview. 
If the same document with the same listview is stored in another directory (workspace), 
the listview will not display any objects.
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13  Creating classes and objects
The following procedures will guide you through the process of creating an object class, 
and an object. In addition, at the end of the chapter you will find exercises to help you 
use workspaces. 

13.1  Creating an object class
Before you can create any objects, you must create an object class. A class is the 
structural definition of an object. An object class defines what fields are available for a 
particular object. 

Procedure 27  Creating a new object class

In the webEdition main menu
1 In the main menu, click File > New > Class.

The Classes Properties view opens (see Figure 244).

Figure 244  Creating object classes

2 In the Path area, enter the name that you wish to give to the new object class in the Class 
name field.

3 If you wish to use the automatic naming feature, select an item from the Automatic name 
drop-down menu. Each type is described in Section 12.4.4,  "The Classes tab" on page 205.
If you fill in this field, all objects created later with this class will be named uniformly and in 
order without requiring you to enter a new name each time.

4 If you wish to assign a category to your object class, click the Add button.
A dialog box opens in which you can choose a category for the object class.
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5  If you wish to limit user access to the object class, activate the Restrict access checkbox.

Note:  The Restrict access feature is only available if the User Management or User 
Management PRO Modules has been installed.

Figure 245  Restrict access: user name pick list

a Select which users are allowed to access the object by clicking the Add button.
A dialog box opens in which you can choose the users who will have access rights to 
the object class.

b Select the users that are to have access and click on the OK button.
c If you wish to allow read-only access to the selected users, activate the Read only 

checkbox adjacent to the user name (see Figure 246).

Figure 246  Restricting users to Read only access

d Save the user setting by selecting the Save button at the bottom of the page.
An information box opens and webEdition informs you that your changes have been 
saved. 

e Select the OK button on the information box to continue.
6 Click on the Edit tab.

The Edit view opens. The first time you create an object class, webEdition displays an 
empty data field icon.

7 Click on the plus “+” icon to open the Edit view for the first field of the object class.
webEdition opens the Edit view (see Figure 247).
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Figure 247  Object Classes Edit view

8 Specify the name of the field in the Name text box.

Note:  The following characters are permitted: All letters from a to z and A to Z, numbers, 
underscore (_), minus (-) and period (.). Do not use accented letters.

9 Choose the field type using the Type drop-down menu. Each field type has different default 
settings that you must define. For details about each field, see Section 12.6,  
"Understanding field types" on page 210.

10 You can add, sort or delete fields by doing the following sub-steps:
a To add a new field in front of your current field, click the plus button. 
b To add a second field after your current field, click the plus button on the bottom left of 

the page.
c To move a field within the field list, click the up or down arrow. 
d To delete a field, click the trash can symbol to delete this field.

11 Click the Workspace tab to open the Workspace view.
12 Assign the workspace(s) for which the objects in this object class are to be visible by clicking 

the Add button.
The file manager opens in which you can select a directory (workspace), as seen in Figure 
248.
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Figure 248  Assigning a workspace for an object class

Note:  If you do not specify a workspace, you can choose from the buttons in the Display 
area whether or not to display an object. The object will always be displayed using a 
document (listview, detailed view).

13 After choosing a directory, you must also allocate a template with which the object (which 
is stored without any layout information) can be displayed. Select a template from the 
Template: pick list that appears under the directory name.

14 Click the Save button.
15 You have completed this procedure.

13.2  Creating an object
After creating an object class, you can create an object. An object is a unique instance 
of a data whose structure is defined according to its class. Each object has its own values 
for the variables belonging to its class.

Procedure 28  Creating a new object

In the webEdition main menu
1 In the main menu, click in the menu File > New > Object > “name of a selected object class”.

Note:  You cannot create an object without first defining an object class. If you have not 
defined any classes, you will not see any object classes listed in the menu after Object. 
In this case you must return to Procedure 27,  "Creating a new object class" on page 219.

The Properties view opens.

2 In the Properties view, enter a name for the object in the Object name field (see Figure 249).
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Figure 249  Creating a new object

Note:  If you selected the automatic naming feature when defining the object class, you 
do not have to enter a new name. The automatic naming feature automatically creates a 
name for your new object, ensuring that all objects within this class are named uniformly 
and in order. For details on the automatic naming feature, see Procedure 27,  "Creating 
a new object class," Step 3 on page 219.

3  Click on the More properties icon.
a If you wish to associate the object class with an existing Category, select the Add button 

under the categories field.
A list of available categories appears in a dialog box from which you can choose a 
category.

b If you wish to define an owner, enter the name in the Owners area
The user name of the owner of the object appears in the Owners area. (This area is 
only available if the User Management or User Management PRO modules have been 
installed.) If a new object is created, the current user is the main owner.

c For users of the User Management and User Management PRO modules:
i If you wish to limit access to the object, you can activate the Restrict access 

function. There, you can select which users are allowed to access the object.
ii You can also activate the Read only checkbox that appears to the right of the user 

name option so that they can read the object but not change it. 
d If you wish to create a long series of objects that are only slightly different from one 

another, use the Copy object function. The Copy object function allows you to import an 
existing object with all its settings. Thereafter you can make the necessary minor 
changes in the Edit view (see the following step) and then save the new object.

4 Save your entries by clicking the Save button.
5 Click on the Edit tab.

The Edit view opens.

6 Fill in the individual fields that appear in the Edit view for the object and save the new object. 
Depending on the method used to save it, the object will then be displayed either in all the 
corresponding summaries (listviews) or in the detailed view. 

7 Assign the workspace(s) for which the objects in this object class are to be visible.
The file manager opens in which you can select a directory (workspace), as seen in Figure 
250.
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Figure 250  Assigning a workspace to an object

Note:  If you do not specify a workspace, you can choose from the buttons in the Display 
area whether or not to display an object. The object will always be displayed using a 
document (listview, detailed view).

8 Verify the details about your object by clicking on the Information tab.
9 Click on the Save button.

Your new object will appear in the explorer menu under its object class.

10 You have completed this procedure.

13.3  Using workspaces
The following examples show how you can assign different workspaces to selected 
objects. 

13.3.1  Assigning a new workspace
The purpose of this exercise is to show you how to create an object directory and an 
object, and to assign a new workspace to it.

Procedure 29  Assigning a new workspace, and deleting an old one

In the Objects view
1 Create a subdirectory with the name events_2004 under the events class on the webEdition 

demo page by selecting File > New > Directory > Object directory ‘(see Figure 251).

Figure 251  Creating a subclass

2 In the Path area, enter the name events_2004 in the Filename field.
3 Click on the Select button adjacent to the Directory field.

The file manager opens, from which you can choose a directory.

4 Select the events directory and click the OK button.
5 Click the Save button at the bottom of the Properties view.
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The system confirms that the new directory has been saved. After you close this dialog box, 
your new directory appears in the explorer menu as a subfolder under the events folder.

6 Create a subdirectory called events_2004 under the Documents view by selecting File > 
New > Directory > Documents directory.
The system opens the Documents Properties view (see Figure 252).

7 Repeat Step 2 through Step 5.

Figure 252  New documents subdirectory

8 Create a new object called 2004_01_01_01 in the newly created subclass object folder 
events_2004. To do so, click File > New > Object > events, type 2004_01_01_01 in the 
Object name field, and choose the events_2004 directory using the Select button adjacent 
to the Directory field.

9 While still in the Objects view, click the Edit tab, and enter values into the required fields. 

Note:  The required fields are noted with an asterisk (*).
10 Save and publish the new object in the subclass object folder events_2004. 

You will see the following display in the explorer menu:

Figure 253  New object

11 Click on the new object 2004_01_01_01 and select the Workspace view (see Figure 254).

Figure 254  Workspace for the new object

12 Add a new workspace /we_demo/events/events_2004 from the Add workspace drop-down 
menu (see Figure 255). (This workspace is actually the new subdirectory that you created 
in the document view in Step 6 and Step 7 of this procedure). 
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Figure 255  Add a new workspace

13 Delete the old workspace /we_demo_events by clicking the trash can icon adjacent to the 
field, and click the Save button.
You are be left with the new workspace /we_demo/events/events_2004.

14 In the Objects view, click on the events class folder in the explorer menu to view an overall 
summary of all objects contained in the events class.
The Workspace view appears as seen in Figure 256,  "Summary of all objects in the events 
class" on page 226.

Note:  If you have not selected a directory and are still in the root directory, all the circles 
in the Show column will be gray because none of the objects can be displayed in the root 
directory.

Figure 256  Summary of all objects in the events class

15 In the Workspace view, choose the /we_demo/events directory by clicking the Select button 
adjacent to the Directory field.
The circles next to the object (except for the new one) in the Show column turn blue, 
indicating that the object can be displayed in the assigned workspace (see Figure 257). If 
you select the /we_demo/events/events_2004 directory, the circle next to the new object will 
also become blue, indicating that it can be displayed in this workspace.
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Figure 257  Display properties for objects in a workspace

16 You can now view the object by clicking on it in the explorer menu, then clicking the Preview 
view.

Figure 258  Viewing an object with the Preview view

17 You have completed this procedure.

13.3.1.1  Assigning an extra workspace
The following procedure builds upon what was discussed in Section 13.3.1,  "Assigning 
a new workspace" on page 224. In this procedure you will learn how to create extra 
workspaces for your objects.

Procedure 30  Assigning an extra workspace

In the Objects view
1 Click the new object 2004_01_01_01 in the Object view, that you created in Procedure 29,  

"Assigning a new workspace, and deleting an old one" on page 224.
2 Select the Workspace view.
3 In the Extra workspaces area, select the /we_demo/events from the Add workspace 

drop-down menu.
4 Activate the Publish after saving check box, and click the Save button.
5 In the Objects view, click on the events class directory.

A summary of all objects in the events class appears in which you see an entry in the Extra 
workspaces column in the row assigned to the object 2004_01_01_01 (see Figure 259):

Figure 259  Summary of objects
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6 You can share the object for this workspace by activating the checkbox in the Extra 
workspaces column. 
If this workspace contains a document with a listview of the "Events" objects, the new object 
will not be visible until this checkbox has been checked. The object will become visible once 
the checkbox has been checked.

7 You have completed this procedure.
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14  Displaying objects and including 
objects in templates

In Chapter 13 we described how to create object classes, how to assign a template to a 
class, and how to create objects. In this chapter we shall discuss the template code and 
we:tags that you can use to include objects in your templates so they can be published 
on a web page.

The display of objects as a list or in a detailed display in the front end is always done by 
means of templates and documents. If you want to display stored objects, you will have 
to create a document based on a template that contains the corresponding listview or 
fields for a detailed display.

The following list draws upon what was treated in Chapter 13 and it outlines a suggested 
order for performing the procedures required to create and publish objects.
1. Create an object class
2. Assign a detail template to the class
3. Create a detail template (to display the object when linked to/from a listview)
4. Create an object
5. Create a template that can search for an object. (listview)
6. Create a web page from the template made in step 5

In this chapter we shall focus on Steps 3 and 5. For details on Step 6, see the webEdition 
User Guide. 

14.1  Displaying objects: an overview
Objects themselves do not contain any layout information or other display options, 
therefore, you must always link an object to a webEdition document. If you want a 
summary of the objects, you first must create a template that contains a corresponding 
listview. Thereafter you can use the template to create a document.

If, for example, you want to display an object in the "Events" workspace, you first must 
save a corresponding document (summary.php) with a listview of all objects of the 
"Events" class in a directory within this workspace. If the document (summary.php) is 
saved outside of this workspace, the listview will not find any objects.
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To display an object in detail, you must link the object to an appropriate template. You 
can do so in the Workspace view. Once the workspace has been assigned, you can select 
the template for the detailed view of the object (see Figure 260).

Figure 260  Selected template

Once you have selected a template, the object will always be displayed in the frontend 
with this template whenever the link is clicked in the listview. You can select a different 
template for each selected workspace.

Figure 261 is a schematic diagram of workspaces and assigned templates for objects. In 
this case, only the "Events" workspace has been assigned to the "Events" object class.

Figure 261  Diagram of workspaces and templates

For more information, see Section 14.4,  "Displaying an object in a document using the 
<we:listview> tag" on page 232.
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14.2  Database/Object Module we:tags
There are four tags that you can use for including objects in your templates:
• <we:author>

• <we:ifNotObject>

• <we:ifObject>

• <we:object>...</we:object>

The Database/Object Module also expands the capability of existing we:tags to include 
new attributes:
• <we:field type="select">

• <we:input type="select">

• <we:listview type="search">

• <we:listview type="object">

• <we:var type="select">

For information about these tags, see The webEdition Tag Reference Manual, which is 
available on-line at the following URL: http://www.webedition.biz

14.3  Creating an object summary
webEdition allows you to create object summaries by using the <we:listview> tag. After 
installing the Database/Object Module, the object attribute can assist you in creating 
summaries of objects. The following code example shows you how to use the 
<we:listview type = object> tag. The template output appears in Figure 262,  "Template 
output" on page 232.

<we:listview type="object" classid="2" rows="4" order="EventDate">
  <we:repeat>
    <p>
      <we:field type="date" name="EventDate"> - 
      <we:field name="EventName" hyperlink="true"/>
      <br>
      <we:field name="EventDescription">
    </p>
  </we:repeat>
</we:listview>

This code generates a summary of all objects from the "Events" object class. The 
"Events" object class has the ID=2. The list will be sorted by the "EventDate" class 
field.

The list will display:
• the "EventDate" field
• a hyphen "-"
• the "EventName" field
• the "EventDescription" field

The "Event Name" (hyperlink="true") field is linked to the template that has been 
assigned to the object class in the Workspace view. 
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Figure 262  Template output

14.4  Displaying an object in a document using the <we:listview> tag
To display an individual object in a document, you first have to assign a template to the 
object class. This can be done when defining the object classes in the Workspace view 
in Edit mode. As described in Section 12.7.2,  "Displaying objects in the front end" on 
page 216, a workspace is allocated to an object class in which the objects can be 
displayed. A default template for the detailed display of the object is also allocated. If 
you have assigned several workspaces to an object class, you can also assign several 
default templates so that the object can have different templates, that is, layouts or levels 
of information, depending on which workspace it is displayed in.

The link is always created in conjunction with a listview as seen in the sample code in 
Section 14.3,  "Creating an object summary" on page 231.

Because of the hyperlink="true" attribute, the Event Name is defined as a link that 
points to the default template defined in the Workspace view of the object class for the 
workspace where the document with the listview has been stored. It also points to the 
object listed in the listview. Clicking on this link will combine and display the object 
data and the template as shown in Figure 263.

Figure 263  Example: hyperlink="true" 

The variable of the name attribute in the we:tag <we:field> must be absolutely identical 
with the desired field name of the object. (This tag is case-sensitive.)

14.5  Displaying an object in a document using the <we:object> tag
You can include individual objects directly in documents without listing them in a 
listview. This is advisable, for instance, if you have an "Events" template in which your 
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editors manually enter the event details and then insert the address where the event is to 
be held. You must insert the we:tag <we:object> below the text entry fields for the 
event. With this tag, you can give editors the ability to select certain objects in a class. 
You must always specify an object class. Defining both the class and the specific object 
will cause this object to be shown in this document. This is done using the we:tags 
<we:object> and <we:field>. For more information, see the descriptions of the 
<we:object> and <we:field> tags in The webEdition Tag Reference Manual.

<we:object name="myObject" classid="77" id="324">
  <p>
    <we:field name="name1" hyperlink="true"/><br>
    <we:field name="text"/>
  </p>
</we:object>

This code always displays the same object in the class that possesses the classid="77" 
and the object that has the id="324" without permitting the editor to change anything.

<we:object name="myObject" classid="77">
  <p>
    <we:field name="name1" hyperlink="true"/><br>
    <we:field name="text"/>
  </p>
</we:object>

In this case, the editor can select any object from all objects that exist under the object 
class that has the classid="77". The editor will see the following display in the front end 
(see Figure 264):

Figure 264  Displaying an object

Clicking the select button will cause the file manager to open so that the editor can select 
an object of classid="77".

The <we:field> tag can be used to define which object field should be displayed. The 
variable of the name attribute in the we:tag <we:field> must be absolutely identical to 
the desired field name of the object. (This tag is case-sensitive.)
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15  Editor PlugIn: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Editor Plug-in Module. This chapter treats what the module does and how to install it. 
You can also find information here about the basic layout and command features for the 
Editor Plug-in Module. These topics are treated in the following sections:
• Section 15.1,  "What is the webEdition Editor Plug-in Module?" on page 235.
• Section 15.2,  "Requirements, installation and licensing" on page 235.
• Section 15.3,  "User preferences for the Editor Plug-in" on page 237.

15.1  What is the webEdition Editor Plug-in Module?
The Editor Plug-in enables you to create webEdition pages and templates using an 
HTML editing program of your choice. You can choose either to create your 
webEdition documents entirely in webEdition or to use another HTML editor. The 
entries/changes you make in your HTML editor will be automatically implemented by 
webEdition, eliminating the need to copy and paste them using the clipboard.

15.2  Requirements, installation and licensing
You must meet or exceed the following requirements to use the Editor Plug-in:
• PC with Microsoft Windows 95 or higher
• webEdition, version 2.0 or higher
• Microsoft Internet Explorer 4.x or higher
• Internet access during the installation

After purchasing a licence for the Editor Plug-in from the webEdition on-line shop, you 
must register your version online the first time it is run on your computer (see Figure 
265,  "Initial registration window" on page 236).
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Figure 265  Initial registration window

Note:  You do not have to download the Editor Plug-in separately. The first time you 
use webEdition, it will automatically download the Plug-in from our server.

Once you have registered and you have received confirmation that the registration was 
successful (see Figure 266), the Editor Plug-in will be available for your browser.

Figure 266  Successful registration of the Editor Plug-in

The first time you access the Editor Plug-in, you will be asked to choose your preferred 
editing application (see Figure 267).
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Figure 267  Choosing a supported editing application

15.3  User preferences for the Editor Plug-in
After registering the Editor Plug-in, you can adjust the user preferences to change the 
behavior of the module. Go to the Options drop-down menu in the webEdition main 
page and select Preferences... (see Figure 268).

Figure 268  The Options menu

The system opens the Preferences screen. Click the 
Editor tab on the Preferences screen to access the Editor 
view (see Figure 269):
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Figure 269  Editor 
preferences view

There are three options you 
can use to modify the 
behavior of the Editor 
Plug-in. The following 
checkboxes appear in the 
Editor view:
•Use it. Activate this option 
if you wish to use the 
Plug-in. The Plug-in must 
be registered before it can 
be used.
•Start automatically. 
Activate this option if you 
generally use your HTML 
editor rather than 
webEdition to edit your 
templates. If you have 
already specified your 
preferred HTML editing 
program, it will be launched 
automatically whenever 
you wish to edit any 
templates.
•Ask on startup which 

editor should be used. Activate this option if you use more than one HTML editing 
program and wish to switch between editors. Activating this option will open a 
dialog box whenever you start the editing program, asking you which HTML editor 
you wish to work with. If this option is not activated, webEdition will always start 
the editing program you last selected.

Note:  If you are not using Internet Explorer 4.x or higher (see Section 15.2,  
"Requirements, installation and licensing" on page 235), the Editor Plug-in 
options will appear greyed-out. You will also see the following message: These 
settings cannot be changed. The Editor PlugIn operates only with the Windows 
version of Internet Explorer.

15.3.1  Setting a default editing program
To set a default editing program, select the option Ask on startup which editor should 
be used and select your preferred editing program.

You can also re-set your default editor by selecting the ask for editor checkbox that 
appears next to the Start editor button directly under the text editing area of the 
Templates > Edit view (see Figure 270). 
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Figure 270  The Start editor and Ask for editor options

Once you have re-set your default editor, when you click the Start editor button in the 
Templates > Edit view, the last editing program that you selected will automatically 
start. (You must, however, make sure that the Ask on startup which editor should be 
used checkbox is not activated). For further details, see Chapter 16,  "How to use the 
Editor Plug-in" on page 241.
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16  How to use the Editor Plug-in
You can either create your webEdition documents entirely in webEdition or you can use 
the Editor Plug-in to access another HTML editing program of your choice. 

16.1  Starting the Editor Plug-in
Depending on the preferences you have selected, your default HTML editing program 
can be started manually or automatically. You can also select a preferred editing 
program. (see Section 15.3.1,  "Setting a default editing program" on page 238). 
Whenever you edit templates (File > New > Template, then click the Edit tab), you will 
see the start editor button under the code entry window (see Figure 271).

Figure 271  The Start editor button

There is also an Ask for editor checkbox that allows you to specify your preferred 
editing program. This box will have a check mark if you have already selected the Ask 
on startup which editor is to be used option in the Options > Preference > Editors view. 
If you have not activated the Ask on startup... check box, the editing program selected 
during the installation will start.
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16.2  Using an HTML editor
Your preferred HTML editor operates seamlessly with webEdition. After activating the 
Editor Plug-in and chosing an editor, whenever you open a webEdition template, any 
webEdition code already contained in the entry window will appear automatically in 
your editing program entry window.

In the following example (see Figure 272), the Microsoft Notepad application has been 
selected as the default editor.

Figure 272  Using a third-party HTML editor

You can then use your editing program in the usual manner (see your vendor 
documentation for details). Whenever you save any entries or changes in your editing 
program, those changes are automatically imported to the Edit window in webEdition.
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17  Export Module: Introduction
This chapter is intended to help you familiarize with the webEdition Export Module and 
its features. This chapter treats what the module does and how to install it. You can also 
find information here about the basic layout and command features for the Export 
Module. These topics are treated in the following sections:
• Section 17.1,  "What is the webEdition Export Module?,"
• Section 17.2,  "Installation,".
• Section 17.3,  "General information and navigation,".

17.1  What is the webEdition Export Module?
The Export Module allows webEdition users more control over the exporting of 
documents, templates, objects and classes from webEdition.
Contrary to the export function of the standard version of webEdition, you can define 
exactly, which individual parts of your project should be exported.
The import of the content that is exported with the Export Module is possible with every 
version of webEdition (from version 3.3), no separate module is required.
Importing new templates, objects or content is easily accomplished without interfering 
with existing content.

The Export Module is intended for users who want to maintain several webEdition web 
sites within one webEdition installation, as it enables the advanced user to export and 
import objects, document, classes and templates without interfering with the existing 
data.

17.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

17.3  General information and navigation
After the installation, a new menu item appears in the webEdition Modules menu. See 
Figure 273.
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Figure 273  Modules Dropdown Menu

17.4  Start Module
To open the Export Module, click on Export Module... from the Modules 
Dropdownmenu on the webEdition mainscreen. The Quickstart screen will appear, as 
shown in Figure 274.

Figure 274  Export Module: Quickstart Screen

In the Quickstart screen, you can directly create a new export-profile or a group.

17.4.1  Export Module explorermenu
The explorermenu on the left hand of the screen shows a list of your exportprofiles and 
groups (see Figure 275).
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Figure 275  Export Module explorermenu

17.5  The menus
By selecting Modules > Export Module, you open the module view (see Figure 274). 
Here, you can find the dropdown-menus Export and Help.

17.5.1  The Export-dropdownmenu
In the dropdownmenu Export, the following items are located (see Figure 276).

Figure 276  Export dropdownmenu

• New (Export/Group) Click New >Export / Group to define a new exportprofile resp. 
a new exportgroup.

• Save Click Save to permanently save your export or exportgroup.
• Delete Deletes the currently selected export or group.
• Quit Leave the module window and return to the webEdition main screen.

17.5.2  Help-dropdownmenu
In the help-dropdownmenu you will find the following items (see Figure 277).

Figure 277  Help-dropdownmenu

•Help. This item provides Help screens.
•Info. This item provides information about the application.

17.6  Export Module views
The export module has the following views which can be accessed by clicking on the 
corresponding tabs: Property, Options and Details.

17.6.1  The property view
The basic settings for your export are defined in the property view.

Choose Export > New > Export to enter the property view (see Figure 278):
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Figure 278  The Property view

The Property view consists of the areas Property, Export to and Selection.
• Property: Here, you give your export profile a unique name. You can also assign 

your export to a group by clicking on the select button. The name given here is the 
name by which the export profile is saved within the webEdition export module, not 
the file name by which the export is saved on the server or your local disc!

• Export to: Enter a filename for your export-file. This is the name by which the file 
is saved on your server or harddisc. If you choose Server from the dropdownmenu, 
you can select a directory on your server, where the exported file will be saved.

• Selection: Here, you can select the documents or objects to be exported. Choose 
Automatic Selection to define the export using the document- or objecttype. When 
using the Manual Selection, documents, templates, objects or classes can be 
selected individually from the tree.

17.6.2  The Options view
The Options view consists of the areas Documents/Templates, Objects/Classes, 
Doctypes/Categories, Export Depth and Owners Data (see Figure 279). These areas are 
explained in the following.
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Figure 279  The Options view

17.6.2.1  The Documents/Templates area
In this area, the following checkboxes are located:
• Export default templates: Activate this checkbox to add the templates, on which the 

documents to be exported are based by default (this is set in the document 
preferences), to the export. 

• Export included documents: Activate this checkbox to add so-called included 
documents to the export. Included documents are included in the document to be 
exported using the we:tags we:include, we:form, we:url, we:linkToSeeMode, we:a, 
we:href, we:link, we:css, we:js, we:addDelNewsletterEmail. This checkbox has to 
be activated, e.g., if the navigation of your site was integrated using an include and 
you want it to be in the export.

• Export included objects: This checkbox works like the checkbox Export included 
documents, but for objects. It affects included objects using the we:tags we:object 
or we:form.

• Export linked documents: Activate this checkbox to add internal documents to the 
export; internal documents are linked to the document to be exported by using the 
HTML-Tags body, a, img, table, td.

Note:  These functions only apply to the export of documents and templates.
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17.6.2.2  The Objects/Classes area
These two checkboxes are located in this area:
• Export default classes: Activate this checkbox to also export the class defined in the 

object properties.
• Export embedded objects: Activate this checkbox to also export objects which are 

included in the object to be exported.

Example 
You included images as objects into an object of the class “articles”.

Note:  These functions only apply to the export of objects and classes.

17.6.2.3  The Doctypes/Categories area
In this area you will find the following checkboxes:
• Doctypes: Activate this checkbox to add the doctypes of the exported documents to 

the export. This function only applies to the export of documents.
• Categories: If this checkbox is activated, the categories of the elements to be 

exported are also added to the export. This function applies to document- as well as 
to object categories.

17.6.2.4  The Export depth area
In this area, you can define, using a numerical value, the export depth of included, 
linked or template-based elements. If, e.g., you set the export depth to a value of “1”, at 
the export of a document with the checkbox Export default templates activated, will 
result in the template being included in the export. An included navigation (and its 
template), on the other hand, would not be included, even with the option Export 
included documents activated. To export the navigation, too, you would have to set the 
depth to “2”; setting it to “3” will also include the template of the navigation.

17.6.2.5  The Owners data area
Activate the checkbox Export owners data, to integrate permissions and rights on 
documents, objects etc. in the exported file.

Note:  The webEdition User Management (PRO) has to be installed for this function 
to work.

17.6.3  The Details view
In this view, the progress of the export will be displayed. All exported documents, 
templates, objects and classes are displayed here during the export process. The 
progress bar at the bottom of the screen indicates the export´s progress.
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Figure 280  Details view
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18  Using the Export Module
In this chapter, you will learn how to perform an export with the webEdition Export 
Module.

18.1  Define a new export
Exports with the webEdition Export Module are performed using so-called export 
profiles. Click Export > New > Export or just New Export in the Quickstart screen, to 
create a new export profile.

Procedure 31  Performing an export

In the Export Module mainscreen
1 Choose names for your export profile and the export file. Enter them in the corresponding 

fields in the Property view.
2 Choose a target location for your export file using the dropdownmenu in the Export to area: 

Server or local Harddisc.
3 Now you decide in the Selection area, whether you prefer automatic or manual Selection. 

The manual Selection lets you select documents, templates, objects and classes from the 
webEdition tree-view. Using the automatic selection lets you choose by “type”.

Note:  Objects and classes can only be exported if the webEdition DB/Object Module is 
installed.

4 When you feel comfortable with your selections, proceed by clicking on the Options tab.
The Options view opens

5 Now select your preferred options. Further information about the Options view can be found 
in Section 17.6.2,  "The Options view" on page 246.

6 Click on the Save button
The successful saving of your export profile is confirmed

Note:  Your export profile has to be saved before the export can processed.

7 Click on the Export button
The Details view opens (see Figure 280)

8 According to your selections made in 2, the generated export XML-file will be saved by the 
filename you choose either on the server, or you will be prompted to define a target location 
on your local harddisc.

9 The Export thus has finished successfully.
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18.2  Exportgroups
Exportgroups are used to organize recurring export tasks; the parallel development for 
multiple webEdition websites from one developer license can be made much easier by 
using this feature.

Procedure 32  Create Exportgroup

In the Export Module window
1 Select Export > New > Group from the Export Dropdownmenu or New Group from the 

Quickstart
The Exportgroup window opens

2 Enter a name for the new exportgroup; you might e.g. name the groups after the websites 
in development.

3 Click the Save button
The system acknowledges the success. The new group is now displayed in the explorer 
menu (see Figure 281)

Figure 281  New group in the explorermenu

4 The new exportgroup has been successfully created. You can now assign export profiles to 
this group. The procedure is finished.
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19  Newsletter Module: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Newsletter Module. This chapter treats what the module does and how to install it. You 
can also find information here about their basic layout and command features. These 
topics are treated in the following sections:
• Section 19.1,  "What is the webEdition Newsletter Module?" on page 253
• Section 19.2,  "Installation" on page 254
• Section 19.3,  "General information and navigation" on page 254

19.1  What is the webEdition Newsletter Module?
The webEdition Newsletter Module allows webEdition users to create, maintain, and 
send newsletters to a targeted audience.

The Newsletter Module conforms to the basic layout and programming principles of 
webEdition. The Newsletter Module can only be used with webEdition (although you 
can import/export mailing lists from third-party E-mail applications).

This module can be used by anyone who has a basic knowledge of how webEdition 
functions.

The Newsletter Module allows you to perform the following content management 
functions:
• create, change, copy and send newsletters
• define content from a variety of sources
• create customized receiver lists for individual newsletters 
• filter your customer selection for refinement of your target audience
• preview each mailing list
• import/export E-mail addresses from/to other E-mail applications
• establish and maintain a Black list
• search E-mail
• maintain multiple directories (called newsletter groups) where you can store a 

variety of newsletters, allowing you to create and organize several newsletters and 
mailing campaigns
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The Newsletter Module also allows you to perform the following diagnostic functions:
• test your mailing process before sending your newsletter
• test your mail by sending it to a test address
• check the syntax and domain names for each address in your mailing lists
• recover an interrupted mailing campaign if a network or connection failure occurs
• view details about your newsletter campaign in log reports.

If you have purchased the webEdition Customer Administration Module an additional 
feature is available to you. You can reuse the customer data stored in your customer 
administration database to create your mailing lists.

19.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

19.3  General information and navigation
Once you have installed the Newsletter Module, Newsletter will appear as an option in 
the Modules drop-down menu (see Figure 282).

Figure 282  Modules drop-down menu

19.3.1  Opening the module
To open the module, select Newsletter from the Modules drop-down menu on the main 
webEdition page. The Newsletter Quickstart screen opens as seen in Figure 283.
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Figure 283  Newsletter Module: main screen with Quickstart options

Using the Quickstart screen, you have the option of going directly to a new newsletter 
or to a new newsletter group. You can return to the Quickstart screen at any time by 
clicking on the Newsletter Module tab.

19.3.2  The Newsletter Module main page: drop-down menus
There are three drop-down menus on the Newsletter Module main page: Newsletter, 
Options, and Help.

19.3.2.1  The Newsletter menu items
The Newsletter drop-down menu has the following items (see Figure 284):

Figure 284  Newsletter menu items

•New. Use this command to create a new newsletters or 
group.
—Newsletter. Use this command to create a newsletter.
—Group. Use this command to create a new newsletter 
group.

• Save. Use this command to save a newsletter.
• Delete. Use this command to delete a newsletter.
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• Send. Use this command to send a newsletter.
• Quit. Use this command to exit the application.

19.3.2.2  The Options menu items
The Options drop-down menu has the following items (see Figure 285,  "The Options 
menu items" on page 256):

Figure 285  The Options menu items

•Domain check. Use this option to test your mailing list before 
starting your newsletter campaign.
•Lists overview. Use this option to see the contents of your 
mailing lists.
•Show logbook. Use this option to display newsletter campaign 
logs.
•Test. Use this option to test a newsletter campaign.
•Preview. Use this option to view a newsletter before you send 
it.

• Send test mail. Use this option to test your newsletter campaign.
• Search Email. Use this option to search an E-mail address.
• Edit CVS file. Use this option to edit a comma separated values (CSV) file.
• Black list. Use this option to edit the Black list.
• Clear logbook. Use this option to clear the newsletter campaign logs.
• Settings. Use this option to set default parameters and mailing addresses.

19.3.2.3  The Help sub menus
The Help drop-down menu has the following items (see Figure 286,  "The Help menu 
items" on page 256):

Figure 286  The Help menu items

•Info. Information about the application.
•Help. Help screens.

19.3.3  The newsletter explorer menu and main page
The explorer menu appears on the left side of the screen. It contains a list of your 
newsletter files and newsletter groups. See Figure 283,  "Newsletter Module: main 
screen with Quickstart options" on page 255.

The Newsletter main page has three available views:
• Properties. Use this view to set up your newsletter files.
• Mailing list. Use this view to create your newsletter mailing lists
• Edit. Use this view to define the layout of your newsletter.
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19.3.3.1  The newsletter Properties view
The Properties view allows you to set up your newsletter files and to define your 
newsletter mailing lists. The Properties view is divided into three areas: Path, 
Newsletter and Copy newsletter, as seen in Figure 287.

Figure 287  The Properties view

19.3.3.1.1  The Path area    The Path area of the Properties view has the following 
functions:
• Name. Use this field to give a name to your newsletter.
• Directory. Use the Select button adjacent to this field to select a directory or group 

for your newsletter.

19.3.3.1.2  The Newsletter area    The Newsletter area of the Properties view has 
the following functions:
• Subject. Use this field to describe the subject of the newsletter.
• Sender. Use this field to enter the default E-mail address of the newsletter sender.
• Reply-to. Use this field to enter the default E-mail address for replies to your 

newsletter.
• Test email. Use this field to enter the default test mail E-mail address.

Note:   If you do not complete the fields for the sender, reply-to, or test E-mail 
address, the corresponding value for these fields will be generated automatically 
from your default settings. (For further information see Section 19.4,  "Defining 
and changing user settings" on page 261.)
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19.3.3.1.3  The Charset newsletter area    The Charset newsletter area of the 
Properties view allows you to define the charset of the newsletter.

19.3.3.1.4  The Copy newsletter area    The Copy newsletter area of the 
Properties view allows you to copy and re-use an existing newsletter.

19.3.3.2  The Mailing list view
The layout of the Mailing list view varies depending on the webEdition modules that 
you have installed.

Figure 288  The Mailing list view

19.3.3.2.1  The Customers area    The top portion of the Mailing list view, the 
Customers area, appears only if you have purchased and installed the webEdition 
Customer Management Module. The following check boxes allow you to modify the 
recipients of your newsletter:
• Send to all. This button tells the Newsletter Module application to selects all the 

E-mail addresses in your Customer Management database.
If this checkbox is not activated, two buttons appear that have the following 
functions:
— Delete all. Click this button if you wish to delete all customers from your list.
— Add. Click this button if you wish to add customers to your list.

• Filter. This button allows you to define filters for your current Customer 
Management Module database.
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19.3.3.2.2  CSV Files area    You can use the CSV Files field to enter a 
comma-separated values (csv) file into your mailing list. The newsletter will be sent to 
all of the E-mail addresses which are recorded in your selected csv file. The csv file 
must have the following format: E-mail address, HTML flag, salutation, title, first 
name, last name.

Under the list are two buttons which have the following functions:
• Delete all. Click this button if you wish to delete all customers from your list.
• Add. Click this button if you wish to add customers to your list.

If you have an entry in the CVS File field, two buttons will appear next to the filename:
• the pencil icon button. By clicking on this button, a new area will open in which you 

can edit a csv file.
• trash can icon button. If you click on this button, you will remove the csv file from 

your list. 

19.3.3.2.3  Emails area    Below the CSV Files area in the Mailing list view is the 
Emails area. The Emails text box is the area which displays the E-mail addresses 
associated with your mailing list. This area allows you to create multiple mailing lists 
in which you enter the E-mail addresses of your newsletter subscribers. You can use the 
buttons to the right of the Emails text box to perform the following operations on the 
subscriber list:
• Add. Adds an E-mail address to your mailing list.
• Edit. Edits an existing E-mail address in your mailing list.
• Delete. Deletes an E-mail address from your mailing list.
• Delete all. Deletes all E-mail addresses from your mailing list.

Directly below the E-mails text box are the following items:
• Import. Import E-mail addresses from a csv file.
• Export. Export E-mail addresses to a csv file.

19.3.3.2.4  Additional features in the Mailing list view    Below the Mailing 
list are the following items:
• The plus icon "+" allows you to open another Mailing list area so that you can create 

additional mailing lists.
• The trash can icon allows you to delete an entire mailing list.

At the bottom of the page are the following buttons:
• Save button. Use this button to save the properties data that you have entered on the 

screen.
• Mail List Number select box. This pick list shows all of your mailing lists. (You can 

have several.) Use this pick list to navigate to an existing mailing list.
• HTML checkbox. The default setting for newsletters is plain text. Use this check box 

to change the format of the newsletter to HTML.
Newsletter Module



260   Newsletter Module: Introduction 
• Preview button. The preview button allows you to see a newsletter before you send 
it.

Note:  You must save your settings before you can preview a newsletter.

• Send button: Use this button to send a newsletter.

19.3.3.3  The newsletter Edit view
The Edit view allows you to create and edit the layout of your newsletter (see Figure 
289). The webEdition Newsletter Module uses "blocks" to help you build the content of 
your newsletter. A newsletter can be composed of one block or several blocks, 
depending on the type of content you wish to include.

Figure 289  The Edit view

Each block of the Edit view has the following fields:
• Name. This select box allows you to choose the type and style of the content for your 

newsletter. More information about block types is available later in this chapter.

Note:  The fields below the block type name will change depending on the type 
of block you choose.

• Mailing lists. All block types must be associated with a mailing list. The Mailing 
lists box shows the mailing lists associated with the block you have defined.

Below each block are the following items:
• The plus icon "+" allows you to open another Block area, so that you can create 

additional blocks.
• The trash can icon allows you to delete an entire block.
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19.4  Defining and changing user settings
Before using the Newsletter Module, you must complete the information requested on 
the Settings screen. These settings define parameters such as the default mail accounts 
associated with your mailing campaign, address verification checking, and the default 
mailing format. These settings also tell the Newsletter Module what information you 
wish to draw from the Customer Management Module database.

Note:  After entering your initial settings, you will also be able to change the 
information at a later time.

Use the following procedure to define your initial settings.

Procedure 33  Defining initial newsletter settings

In the Newsletter Module main screen
1 Go to the Settings screen by clicking on the Options > Settings.

The Settings screen appears (see Figure 290).

Figure 290  The Newsletter Module Settings screen

2 webEdition sends out newsletters via E-mail using an automated batch process that runs 
on a PHP server. There are limits set by your ISP to govern the length of time a PHP script 
can run on the server. Therefore you must limit the number of E-mails per batch, otherwise 
you may encounter time-out errors. Set the Number of emails per load field to 150.

3 The Test account field allows you to define the address of your default test account. Type 
the address of your test account in the dialogue box.
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4 The Default sender field allows you to define the default address of the sender of the 
newsletter. Type the address of your default sender account in the dialogue box.

5 The Default reply setting allows you to define the default address for receiving replies to 
your newsletters. Type the address of the account which will receive replies to your 
newsletter.

6 The Newsletter Module allows you to address your recipients with a female salutation by 
using the Female Salutation field. Enter the exact value (such as Ms. or Ms) that you have 
used to define a female customer in the Customer Management database.

7 The Newsletter Module allows you to address your recipients with a male salutation by 
using the Male Salutation field. Enter the exact value (such as Mr. or Mr) that you have used 
to define a male customer in the Customer Management database.

8 Cust. Email field. Use this select box to choose the customer E-mail field from the Customer 
Management Module database.

9 Customer HTML field. Use the select box to choose the customer HTML field from the 
Customer Management Module database.

10 Cust. Salutation field. Use the select box to choose the customer salutation field from the 
Customer Management Module database.

11 Cust. Title field. Use the select box to choose the customer title field from the Customer 
Management Module database.

12 Cust. Firstname field. Use the select box to choose the customer firstname field from the 
Customer Management Module database.

13 The Cust. Lastname field. Use the select box to choose the customer lastname field from 
the Customer Management Module database.

14 Use the Do not send if address is malformed check box to prevent the system from 
attempting to send a newsletter to erroneously configured E-mail addresses.

15 Use the Do not send if address can not be verified check box to prevent the system from 
attempting to send a newsletter to an unverifiable E-mail addresses.

16 Use the Create log when sending mail check box to capture a report.
17 Use the Default mail format is html check box to select HTML format as the default setting 

for your newsletter campaigns.
18 Check box: English title format (without salutation). In English usage, unlike in German, a 

salutation such as Mr. or Mrs. does not precede a title (such as Dr.). If you have activated 
this checkbox and you have defined an E-mail address, a salutation, last name and a title, 
the contents enclosed within the <we:ifMale> or <we:ifFemale> tags will not be sent. In this 
case, rather, the salutation is sent with a neutral title and can be delivered enclosed with the 
<we:ifTitleAndLastName> tag.

19 You can use the optional Default mailing list (CSV file) to enter the path to a comma 
separated values (CSV) file that can be used as the default file for your mailing list.

20 Save your changes by selecting the Save button.
21 You have completed this procedure.
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20  Creating newsletters
The webEdition Newsletter Module gives users great flexibility in creating and 
modifying newsletters and defining their target audiences. Use the following sub 
sections and procedures to create your mailing lists and newsletters.

20.1  Setting the properties for a newsletter
Use the following procedure to set the properties for a new newsletter.

Procedure 34  Setting the properties for a newsletter

At the Newsletter Module main page
1 Click on Newsletter > New to create new newsletter. 

webEdition opens the Properties view (see Figure 291).

Figure 291  The Newsletter Properties view

2 Type the name of your newsletter in the Name field.
3 Type the subject of your newsletter in the Subject field.
4 Type the default E-mail address of the sender of the newsletter.
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5 Type the default E-mail address to which you wish your newsletter recipients to reply.

Note:  If you wish the reply address to be the same as that of the sender, select the 
Same as the sender check box.

6 Type the default E-mail address of your test account.
7 Select the charset of the newsletter.
8 If you would like to use a copy of an existing newsletter, select the Copy newsletter button, 

otherwise, go to Step 9 on page 264.
If you select the Copy newsletter button, a dialogue box opens that allows you to browse 
your system for an existing newsletter (see Figure 292).

Figure 292  Searching and copying a newsletter

a Choose the newsletter you would like to copy.
b Save the newsletter under a new name.

9 You have completed this procedure.

20.2  Creating and modifying mailing lists
The webEdition Newsletter Module allows you to create mailing lists in the following 
ways:
• use the E-mail data from your webEdition Customer Management Module

Note:  This feature is available only if you have purchased and installed the 
Customer Management Module.

• use an existing CSV file
• create a mailing list manually
• import an existing address book (as a CSV file) from your current E-mail 

application (such as Microsoft Outlook, or Netscape Mail)

The sections that follow describe procedures that you can use to create mailing lists.

20.2.1  Creating a mailing list
Use the following procedure to define one or more mailing lists.
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Procedure 35  Creating a mailing list

In the Newsletter Module main screen
1 Click on the Mailing list tab to go to the Mailing List view (see Figure 293).

Figure 293  Mailing list view

2 To add a new name to the mailing list, go to the Emails area, and select the add button. 
webEdition opens the Add email address dialogue box (see Figure 294).

Figure 294  Add email address dialogue box

3 Type the E-mail address of the recipient of your newsletter in the Emails field.
4 Select the Receive HTML email checkbox if you want this person to receive your newsletter 

in HTML format.
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5 Enter the salutation, title, first name and last name of your customer in the corresponding 
fields.

6 Click on the Save button.
7 Repeat the steps above to add more E-mail addresses to your mailing list.
8 You have completed this procedure.

20.2.2  Modifying the contents of a mailing list
Use this procedure to edit or delete E-mail addresses from your mailing list.

Procedure 36  Modifying the contents of a mailing list

In the Mailing list view
1 Go to the Emails area in the lower half of the Mailing list view (see Figure 293,  "Mailing list 

view" on page 265).
2 In the Emails box, select the E-mail address that you wish to change.
3 Select the Edit, Delete or Delete all button, depending on which operation you wish to 

perform.
a If you select Edit, webEdition opens the Edit email address dialogue box (see Figure 

295). Save the newsletter (and its associated maiing list) by clicking on the Save button 
at the bottom of the Mailing list view, then go to Step 4

Figure 295  Edit email address dialogue box

b If you select Delete or Delete all, webEdition asks you to confirm your choice. Confirm 
or reject your choice.

4 You have completed this procedure.

20.2.3  Importing an existing E-mail address book
The webEdition software allows you to create a mailing list by importing an existing 
address book from your current E-mail application (such as Microsoft Outlook, or 
Netscape Mail). Use the following procedure to import your address book.

Note:  The following procedure assumes that you have already used the export utility 
in your E-mail application to save your existing address book as a comma separated 
values (CSV) file. If you need assistance working with CSV files, consult the 
documentation provided with your E-mail software by its vendor.
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Procedure 37  Importing an existing E-mail address book

In the Mailing list view
1 Go to the Emails area in the lower half of the Mailing list view (see Figure 293,  "Mailing list 

view" on page 265).
2 Click the Import button.

After clicking the import button, webEdition opens additional fields below the Import button 
(see Figure 296).

Figure 296  Importing an existing E-mail address book

3 Click on the Select button to browse your files for the location of your CSV file.
4 In the delimiter dialogue box, type a comma "," to indicate that you wish to use comma 

separated values.
5 In the email col. dialogue box, type the column number in which the E-mail address appears 

in the CSV file.
6 In the HTML col. dialogue box select 0 for plain text E-mail or select 1 for HTML mail format.
7 In the Salutation col. dialogue box, type the column number in which the salutation appears 

in the CSV file.
8 In the Title col. dialogue box, type the column number in which the title appears in the CSV 

file.
9 In the Firstname col. dialogue box, type the column number in which the first name appears 

in the CSV file.
10 In the Lastname col. dialogue box, type the column number in which the last name appears 

in the CSV file.
11 Press the OK button.

webEdition imports the addresses into the E-mails field of your mailing list.

12 Alternatively, E-mail addresses can be imported from a file that is placed on your local disk. 
To upload a local file, click on the Upload  button. 
webEdition opens the upload CSV dialogue box (see Figure 297).
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Figure 297  Uploading a CSV file from local disk

13 Click the Browse button to locate your file, then click Upload.
14 Click the Save button on the bottom of the Mailing list view.
15 You have completed this procedure.

20.2.4  Exporting an E-mail list
webEdition allows you to export a mailing list to your current E-mail application (such 
as Microsoft Outlook, or Netscape Mail). Use the following procedure to perform 
export your mailing list.

Note:  Your mailing list will be saved as a comma separated values (CSV) file. If you 
need assistance working with CSV files, consult the documentation provided with 
your E-mail software by its vendor.

Procedure 38  Exporting an E-mail list

In the Mailing list view
1 Go to the Emails area in the lower half of the Mailing list view (see Figure 293,  "Mailing list 

view" on page 265).
2 Select the Export button.

webEdition openes additional fields below the Export button (see Figure 298).

Figure 298  Exporting a CSV file

3 Click on the Select button to browse your files for a location for your CSV file.
4 Press the OK button.

webEdition exports the addresses to the specified location. Then webEdition opens a 
dialogue box with a link to the location of the CSV file.
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Note:  You can also save the CSV file on the local disk.
5 You have completed this procedure.

20.2.5  Creating a mailing list using the Customer Management Module
The following procedure allow you to take advantage of the webEdition Customer 
Management Module to produce easy-to-manage mailing lists.

If you have installed the Customer Management Module, the Customers area appears in 
the top portion of the Mailing list view (see Figure 299,  "Defining a mailing list using 
the Customer Management Module" on page 269). This feature allows you to reuse the 
customer information and E-mail addresses that you have defined in the Customer 
Management Module.

Figure 299  Defining a mailing list using the Customer Management Module

Procedure 39  Creating a mailing list using the Customer Management Module

In the Customers area of the Mailing list view
1 Select the Send to all checkbox if you wish all the customers defined in your Customer 

Management Module to be added to your newsletter mailing list (see Figure 300).

Figure 300  Send newsletter to all customers

2 In the Customers area you can choose to send your newsletter to all your customers or filter 
the list. If you wish to filter the recipients, select the Filter checkbox.
webEdition opens the customers filter options (see Figure 301).

Figure 301  The Customers filter options

3 Define the parameters for your filter. There are three portions:
a a select box of variables (such as name, company, E-mail address, E-mail format) that 

have been used in the Customer Management Module database to describe your 
customer data.

b a search operator filter (such as "=", that is, "the same as").
c a text entry box.
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4 If you wish to add more filters for your search, select the plus "+" button and choose AND 
or OR to define how this added filter reacts in relation to the former one.

5 Click on the save button.
6 You have completed this procedure.

20.2.6  Working with CSV files
Use the following procedure to create a recipients list from an existing CSV file.

Procedure 40  Working with CSV files

In the Mailing list view
1 Go the CSV Files area (see Figure 302).

Figure 302  CSV Files area

2 Establish a link to a CSV file by clicking the add button under the CSV Files field.
A window opens in which you can select a file from the server browser.

3 Click on the .cvs file that you wish to use as your receiver list from the list of files (see Figure 
303).

Figure 303  Choosing a CSV file

After clicking on the file, the name of the file appears in the Name field at the bottom of the 
seach browser window .

4 Confirm your selection by clicking the OK button.
The window closes and the selected cvs file appears in your list of cvs files (see Figure 304).

Figure 304  List of selected CSV files

5 If you wish to modify your CSV file, you can perform the following operations, otherwise go 
to Step 6:
a If you click on the trash can icon, you remove the CSV file from your list.
b If you click on the pencil icon, a new window opens in which you can edit a CSV file 

(see Figure 305).
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Figure 305  Modifying a CSV file

c Beside each entry in your mailing list there are two icons, a pencil icon and a trash can 
icon.
i If you click on the trash can icon, you remove the address from your mailing list.
ii If you click on the pencil icon, you can edit an individual entry. 

6 You have completed this procedure.

20.2.7  Creating multiple mailing lists
The webEdition Newsletter Module allows you to create and save multiple mailing lists. 
Use this procedure to create additional mailing lists.

Procedure 41  Creating multiple mailing lists

In the Mailing list view
1 Go to the Emails area in the lower half of the Mailing list view (see Figure 293,  "Mailing list 

view" on page 265).
2 Select the plus "+" button on the bottom left side of the page.

A new Mailing list section appears.

3 To add addresses to your mailing list, see Procedure 35,  "Creating a mailing list" on page 
265.

4 You have completed this procedure.

20.2.8  Creating newsletter groups
The Newsletter Module allows you to create groups to organize your newsletters. These 
groups act as directories; they appear as folders in the explorer menu.

Procedure 42  Creating a newsletter group

In the Newsletter Module main screen
1 Click Newsletter > New > Group. 

The Properties view opens, in which you can create a new group.

2 Enter the name of your new group in the Name field.
3 Select a directory
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a If you wish to create a new directory at the root level “\”, select Save.
b If you have an existing group and you wish to create a sub group, click the Select button 

adjacent to the Directory field. 
A screen opens from which you can select the appropriate group folder, as seen in 
Figure 306.

Figure 306  Creating a new newsletter group

4 Click Save.
The new group appears as a folder in the explorer menu. You can now create new 
newsletters for this group, or copy existing newsletters to it.

Figure 307  New group in the explorer menu

5 You have completed this procedure.
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21  Newsletter layout: working with blocks
The webEdition Newsletter Module uses "blocks" to help you to "build" the layout of 
your newsletters. This chapter describes these building blocks and how to use them.

21.1  Newsletter block types
You build your newsletter in the Edit view of the Newsletter Module. To access the Edit 
view, click on the Edit tab on the main page. See Figure 308.

Figure 308  The new newsletter Edit view

In the Block area of the Edit view, you can choose from the following block types using 
the Name select box:

Figure 309  Block types

•Document-based
•Document field-based
•Object-based
•Object field-based
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• File-based
• Text
• Attachment
• URL

You can use one or more blocks to create your newsletter. You can also use different 
block types—in any combination—to create sophisticated newsletters. Moreover, you 
can associate selected blocks of your newsletter with the mailing lists of your choice. 
By doing so, you can create one newsletter that has its content customized for specific 
readers.

The following sections describe procedures to help you use each type of building block.

21.2  Document-based block
Use the following procedure to define the layout of your newsletter using an existing 
webEdition document and template.

Procedure 43  Document based block

In the Block section of the Newsletter Module Edit view
1 Select Document based from the Block Name select box.

webEdition displays the following dialogue box (see Figure 310).

Figure 310  Document based block

2 In the Mailing lists field, select the mailing list that you wish to associate with the current 
block.

3 To choose the existing webEdition document you want to use, click on the Select button to 
browse your directories for the file.

4 Select the Use default template check box if you wish to apply the default template to the 
document. Otherwise, click on the Select (template) button to browse your directories for 
the template file.

5 To add more blocks to your newsletter, click on the plus "+" icon, and fill in the information 
associated with the block type.

6 Save the document by clicking on the Save button at the bottom of the page.
7 Preview your changes by clicking on the Preview button at the bottom of the page. (Close 

the Preview view).
8 Make further modifications to your newsletter (if required), then save the changes.
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9 You have completed this procedure.

21.3  Document field-based block
Use the following procedure to define the layout of your newsletter using an existing 
webEdition document field.

Procedure 44  Document field-based block

In the Block section of the Newsletter Module Edit view
1 Select Document field-based from the Block Name select box.

webEdition displays the following dialogue box (see Figure 311).

Figure 311  Document field-based block

2 In the Mailing lists dialogue box, select the mailing list that you wish to associate with the 
current block.

3 To choose the existing webEdition document you want to use, click on the Select button to 
browse your directories for the file.

4 Select the Document Field that you wish to use. 
5 Complete the procedure using Step 5 on page 274 through Step 9 on page 275 of 

Procedure 43,  "Document based block".

21.4  Object-based block
Use the following procedure to define the layout of your newsletter using a webEdition 
object.

Procedure 45  Object-based block

In the Block section of the Newsletter Module Edit view
1 Select Object-based from the Block Name select box.

webEdition displays the following dialogue box (see Figure 312).
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Figure 312  Object-based block

2 In the Mailing lists dialogue box, select the mailing list that you wish to associate with the 
current block.

3 To choose the object you wish to use, click on the Select button to browse your directories 
for the location of the object.

4 Click on the Select (template) button to browse your directories for the template file you 
wish to use.

5 Complete the procedure using Step 5 on page 274 through Step 9 on page 275 of 
Procedure 43,  "Document based block".

21.5  Object field-based block
Use the following procedure to define the layout of your newsletter using a webEdition 
object field.

Procedure 46  Object field-based block

In the Block section of the Newsletter Module Edit view
1 Select Object field-based from the Block Name select box.

webEdition displays the following dialogue box (see Figure 313).

Figure 313  Object field-based block

2 In the Mailing lists dialogue box, select the mailing list that you wish to associate with the 
current block.

3 To choose the object you want to use, click on the Select button to browse your directories 
for the location of the object.

4 Complete the procedure using Step 5 on page 274 through Step 9 on page 275 of 
Procedure 43,  "Document based block".

21.6  File-based block
Use the following procedure to define the layout of your newsletter using a webEdition 
file.
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Procedure 47  File-based block

In the Block section of the Newsletter Module Edit view
1 Select File-based from the Block Name select box.

webEdition displays the following dialogue box (see Figure 314).

Figure 314  File-based block

2 In the Mailing lists dialogue box, select the mailing list that you wish to associate with the 
current block.

3 To choose the file you want to use, click on the Select button to browse your directories for 
the location of the file.

4 Complete the procedure using Step 5 on page 274 through Step 9 on page 275 of 
Procedure 43,  "Document based block".

21.7  Text-based block
Use the following procedure to layout a newsletter using plain text or HTML.

Procedure 48  Text-based block

In the Block section of the Newsletter Module Edit view
1 Select Text from the Block Name select box.

webEdition displays the following dialogue box (see Figure 315).

Figure 315  Text-based plain text block

2 In the Mailing lists dialogue box, select the mailing list that you wish to associate with the 
current block.

3 Type the text of your newsletter in the Plain text box.
4 Type the text of your newsletter in the HTML box.
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Figure 316  Text-based HTML block

5 Add a CSS style and HTML formatting to your page.
6 Complete the procedure using Step 5 on page 274 through Step 9 on page 275 of 

Procedure 43,  "Document based block".

21.8  Attachment block
Use the following procedure to add an attachment to your newsletter.

Procedure 49  Attachment block

In the Block section of the Newsletter Module Edit view
1 Select Attachment from the Block Name select box.

webEdition displays the following dialogue box (see Figure 317).

Figure 317  Attachment block

2 In the Mailing lists dialogue box, select the mailing list that you wish to associate with the 
current block.

3 Select the attachment you wish to add to your newsletter.
4 Complete the procedure using Step 5 on page 274 through Step 9 on page 275 of 

Procedure 43,  "Document based block".

21.9  URL block
Use the following procedure to add an existing web page to your newsletter.

Procedure 50  URL block

In the Block section of the Newsletter Module Edit view
1 Select URL from the Block Name select box.

webEdition displays the following dialogue box (see Figure 318).
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Figure 318  URL block

2 In the Mailing lists dialogue box, select the mailing list that you wish to associate with the 
current block.

3 Enter the URL of the page you wish to add to your newsletter.
4 Complete the procedure using Step 5 on page 274 through Step 9 on page 275 of 

Procedure 43,  "Document based block".
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22  Testing, saving and sending a 
newsletter

The following sections describe routine diagnostic tests that you can perform before 
sending your newsletter. It also describes how to save and how to send your newsletter 
to your designated audience.

22.1  Using diagnostic tools
The webEdition Newsletter Module includes a suite of diagnostic tools. You can use 
these tools to verify your newsletter campaign, that is, to test your newsletter and your 
receiver lists before actually sending your newsletter. You can perform the following 
tasks:
• test your E-mail lists
• test the sending process
• preview the contents of your mailing lists
• view log reports

You can access these tools from the Options drop-down menu on the Newsletter Module 
main page (see Figure 319). 

Figure 319  Diagnostic tools in the Options drop-down menu

The procedures in the following sections describe how to test your mailing lists and the 
sending process.
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22.1.1  Testing your mailing lists
Use this procedure to examine the contents of a mailing list, and to verify the validity 
of the addresses in it.

Procedure 51  Testing your mailing lists

On the Newsletter Module main screen
1 Click on Options > Lists overview.

webEdition opens the Lists overview screen, showing you a list of the mailing lists that you 
have created, and the mailing addresses recorded in those lists (see Figure 320).

Figure 320  Testing your E-mail lists: Lists overview screen

2 Perform a check on the domain names associated with your E-mail lists, by clicking on the 
Options drop-down menu and selecting Domain check.
webEdition opens the Domain check log (see Figure 321).

Figure 321  Testing your E-mail lists: Domain check

The domain check log reports any domain names found in your mailing list that are not 
registered on your domain name server (DNS). Such an address is likely erroneous.

3 If an error appears in the domain check log, verify the address and edit your mailing list 
accordingly. To edit an address in your mailing list, see Section 20.2.2,  "Modifying the 
contents of a mailing list" on page 266.

4 You have completed the verification process for your mailing list.

22.1.2  Testing the build process
The webEdition Newsletter Module can also test the newsletter building process itself. 
You can run a diagnostic routine in which the Newsletter Module will build your 
newsletter together with its associated E-mail list(s) to verify that all the processes are 
complete.
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Procedure 52  Testing the building process

In the Newsletter Module main screen
1 Select Options > Test....

webEdition asks you if you wish to proceed. If you click OK, the system opens the Details 
log showing the results of the test (see Figure 322 and Section 22.1.2,  "Testing the build 
process" on page 282).

Figure 322  Testing the building process

The Details screen reports that no E-mail will actually be sent during this test. It lists any 
E-mail addresses that cannot be verified by a DNS server, and also those whose syntax is 
malformed. Note also that the status bar on the bottom of the screen shows the progress of 
the process.

2 You have completed the verification of the sending process.

22.1.3  Previewing a newsletter and sending a test E-mail
Before actually sending out your newsletter, you must preview its layout and ensure that 
your recipients will receive the newsletter in its intended format.

The following procedure describes how to preview your newsletter—to view how your 
newsletter will look when you send it—and how to test that it will be received in its 
proper format.

Procedure 53  Previewing a newsletter and sending a test E-mail

In the Newsletter Module main screen
1 Click Options > Preview.

You will see the layout and the structure of the Newsletter in the same form as your 
recipients will see it. If the layout is correct, close the Preview area.
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Figure 323  Example of a newsletter in Preview mode

2 Adjust the layout (if necessary).

Note:  If you have used an HTML formatted newsletter, make sure that you have 
selected the HTML checkbox at the bottom of the Edit view when previewing your 
newsletter.

3 To verify that the newsletter will be received by your recipients, you can send a test 
newsletter to the test E-mail address that you have defined in your initial settings. The 
E-mail will be sent in either HTML or plain text format, according to what you have selected 
from the HTML checkbox at the bottom of the Edit view.
a Activate the checkbox to send the test E-mail in HTML format.
b Do not activate the checkbox to send the test E-mail in text format.

4 To send a test newsletter, in the Newsletter main menu, click on Options > Send test E-mail.
This action will send a newsletter only to your test E-mail account.

If Do

the layout is correct close the Preview screen and go to 
Step 3.

the layout is not correct go to the appropriate procedure in 
Chapter 21,  "Newsletter layout: 
working with blocks" on page 273, 
then return to this procedure.
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5 Open the E-mail from your test account to verify the layout of the newsletter.

6 You have completed this procedure.

22.1.4  Viewing a log report
webEdition allows you to view a log report that captures the processes behind your 
newsletter campaign.

Procedure 54  Viewing a log report

In the Newsletter Module main screen
1 Select Options > Show logbook.

The following screen appears (see Figure 324):

Figure 324  Viewing a log report

The log shows all of the operations associated with the newsletter campaign.

2 Once you have viewed the data, click the Close button at the bottom of the Show logbook 
screen.

3  If you wish to empty the log, click Options > Clear logbook, otherwise, go to Step 7.
The Clear logbook dialogue box opens.

If Do

the layout is correct close the E-mail and go to step 
Step 6.

the layout is not correct go to Chapter 21,  "Newsletter 
layout: working with blocks" on 
page 273, then return to this 
procedure.
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Figure 325  Clear logbook dialogue box

4 If you wish to save a record of the log, right-click on the Download CSV file link and save 
the link (the csv file) in a directory of your choice.
After saving the csv file, you are returned to the Clear logbook dialogue box. Thereafter, you 
can open the csv file in a text editor as seen in Figure 326.

Figure 326  Logbook saved as a csv file

5 If you wish to clear the logbook, click OK.
The system opens an information box, telling you that the logbook has been cleared.

6 Click OK.
7 You have completed this procedure.

22.1.5  Saving and sending your newsletter
After running your diagnostic routines, you must re-save your work before you send 
your newsletter. Use the following procedure to save your newsletter and to send it to 
the addresses in your designated mailing lists.

Procedure 55  Saving and sending your newsletter

In the Properties view
1 Select the Save button on the bottom of the page.
2 Select the Send button.

A window opens showing the details and progress of your mailing campaign (see Figure 
327).
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Figure 327  Sending a newsletter: Details window

3 Monitor the progress of the campaign by watching the progress meter at the bottom of the 
page.

4 When the system reports that the campaign has finished, close the Details window.
5 You have completed this procedure.

22.1.6  Barring E-mail addresses using a Black list
webEdition allows you to create a list of E-mail addresses that will never receive a 
newsletter. Such a list is referred to in webEdition as a Black list.

Procedure 56  Creating a Black list

In the Newsletter main screen
1 ClickOptions > Black list... 

The Black list screen appears (see Figure 328).

CAUTION 
Risk of termination of campaign
You must leave the Details window open until the campaign is 
finished. 
If you close the window, the mailing campaign will be terminated!
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Figure 328  The Black list screen

2 To add an E-mail address to the Black list, click the Add button
The following additional operations are available:
a Select the Edit, Delete or Delete all button, depending on which operation you wish to 

perform.
b An E-mail address can be imported from a csv file or exported to the csv file. To import 

a csv file, press the Import button. To export a local file, press the Export button.
3 Save the Black list by clicking on the Save button at the bottom of the page.
4 You have completed this procedure.

22.1.7  Searching E-mails
webEdition allows you to search though the mailing lists for specified E-mail addresses. 
This feature is helpful if you have a long mailing list, and you need to modify an E-mail 
entry.

Procedure 57  Searching for an E-mail address

In the Newsletter main menu
1 To access the search function, open the newsletter that you wish to search, and click on the 

Options > Search Email...
The input box appears where an E-mail address can be entered (see Figure 329).

Figure 329  Search E-mails

2 Enter an E-mail address.
3 Click OK.

If the system finds a corresponding E-mail address, a screen appears in which you are 
notified, and the address will be highlighted in the mailing list (see Figure 330).
Standard   3.3.1   02 May 2005  



Testing, saving and sending a newsletter   289
Figure 330  Search results

4 You have completed this procedure.
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23  Designing newsletter templates
This chapter treats items such as how to design newsletter templates, and how to use the 
Newsletter Module's features and we:tags.

23.1  How do I design a template which I can use for the salutation block 
for my newsletters?

To add a personal salutation to your newsletter, you must design a template using 
we:tags, and from this template, you must generate a page. This template contains 
special Newsletter we:tags to differentiate male, female and gender neutral salutations. 
Using the editor view, you then select the generated page as the first block in the 
Newsletter. For example:

<we:ifHtmlMail>
  <we:ifFemale>
    Dear Mrs.<we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname" />,<br><br>
  <we:else/>
    <we:ifMale>
      Dear Mr.<we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname"/>,<br><br>
    <we:else/>
      <we:ifTitleAndLastName>
        Dear <we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname"/>,<br><br>
      <we:else/>
        Dear customer,<br><br>
      </we:ifTitleAndLastName>
    </we:ifMale>
  </we:ifFemale>
<we:else/>
  <we:ifFemale>
    Dear Mrs.<we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname"/>,
  <we:else/>
    <we:ifMale>
      Dear Mr.<we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname"/>,
    <we:else/>
      <we:ifTitleAndLastName>
        Dear <we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname"/>,<br><br>
      <we:else/>
        Dear customer,
      </we:ifTitleAndLastName>
    </we:ifMale>
  </we:ifFemale>
</we:ifHtmlMail>
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23.2  How do I define an "unsubscribe link" so that people can remove 
themselves from a mailing list?

In order to place a link directly in a newsletter (as a concluding block, for example) in 
which one must only click to cancel registration, you use the 
<we:newsletterUnsubscribeLink> tag. This tag produces a link which points to a 
webEdition document whose ID is set as the value of the attribute "id". At the same 
time, the E-mail address to be deleted will be passed on with the URL. The 
<we:addDelNewsletterEmail> tag must appear in the webEdition document. For 
example:

<we:ifHtmlMail>
  To unsubscribe from this newsletter click:
  <a href="<we:newsletterUnsubscribeLink id="310"/>">here</a>
<we:else>
  To unsubscribe from this newsletter click the following link:
  <we:newsletterUnsubscribeLink id="310"/>
</we:ifHtmlMail>

23.3  How do I make a "subscribe page" so people can enroll themselves 
in a newsletter list?

You require a field where one can register an E-mail address, as well as a send button. 
A <we:form> tag is used and linked with the attribute "id" to the subsequent page such 
as <we:form id="99"> or <we:form id="self">.

Within the form, an entry field for the E-mail address is represented with the 
<we:subscribe> tag. It is followed by a submit button that sends the form. For example:

<we:form id="self">
  E-Mail: <we:subscribe type="email"/>
  <input type="submit" value="subscribe"/>
</we:form>

On the template of the page to which the form is sent, you must have the tag 
<we:addDelNewsletterEmail> so that the input in the <we:subscribe> field can be 
stored. If you offer more than one newsletter, you must ensure that the order of the 
mailing lists which you gave as a value in the attribute path has the same order as the 
webEdition document in which the party interested in the newsletter had registered.

<we:addDelNewletterEmail path="newsletter.txt">

If you have more than one mailing list and you would like to enable the visitor of a Web 
site to choose which of the lists he/she wishes to join, you can give the visitor a choice 
by using the <we:subscribe type="listCheckbox"> tag or the <we:subscribe 
type="listSelect"> tag.

The following example uses the <we:subscribe type="listCheckbox"> tag.

Note:  The order of the newsletters must be the same as what was given as a value in 
the attribute "path" of  the <we:addDelNewletterEmail> tag. For example:
<we:form id="self">
  <we:subscribe type="listCheckbox"/>Sports<br>
  <we:subscribe type="listCheckbox"/>Politics<br>
  <we:subscribe type="listCheckbox"/>Computer<br>
  E-Mail: <we:subscribe type="email"/>
  <input type="submit" name="Submit" value="send">
</we:form>
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The following example uses the <we:subscribe type="listSelect"> tag.

Note:  The order of the newsletters must be the same as what was given as a value in 
the attribute "path" of  the <we:addDelNewletterEmail> tag.
<we:form id="self">
  <we:subscribe type="listSelect" 
values="Sports,Politics,Computer"/>
  <br>E-Mail: <we:subscribe type="email"/>
  <input type="submit" name="Submit" value="send">
</we:form>

Although you can send out a personalized newsletter with only a salutation and a title, 
it is advisable to insert a salutation, title, first name, and last name field into the 
template.

<we:form id="self" method="post">
  E-Mail-Address:<br>
  <we:subscribe type="email" size="40"/><br>
  Salutation:<br>
  <we:subscribe type="salutation" values="Mr.,Mrs."/><br>
  Title:<br>
  <we:subscribe type="title" values="Dr.,Prof."/><br>
  Firstname:<br>
  <we:subscribe size="40" type="firstname"/><br>
  Lastname:<br>
  <we:subscribe size="40" type="lastname"/><br>
  Mailinglist:<br>
  <we:subscribe type="listSelect" 
values="Sports,Politics,Computer"/>
  <br><br>
  <input type="submit" name="Submit" value="send">
</we:form>

The following code example shows how you can offer to your subscribers the 
possibility of choosing whether he/she wants to receive the newsletter in HTML or text 
format. You can use either a drop-down menu or a checkbox.

Select box:
Format:<br>
<we:subscribe type="htmlSelect" values="Text-EMail,HTML-EMail" 
value="1"/><br>

Checkbox:
Format:<br>
<we:subscribe type="htmlCheckbox"/>&nbsp;HTML-Mail

23.4  How do I differentiate between single and double opt-in?
The formula is the same whether you wish to create a single opt-in or a double opt-in 
process. The difference consists in the <we:addDelNewsletterEmail> tag. If the value 
of the attribute doubleoptin is "true" in this tag, the enrollment will be stored 
temporarily, and an E-mail will be sent to the designated address. In the attribute mailid, 
you must provide the ID of a webEdition document which contains the mail text. This 
must be a webEdition document that is based on a template in which you have used 
we:tags to represent the salutation and the confirmation links. Using the attribute from 
you can set a value for the E-mail address of the sender; and by using the attribute 
subject you can enter a value for the subject of the E-mail. The attribute 
expiredoubleoptin controls how many minutes an entry will remain in the temporary 
table before it is deleted. If no value is entered, the entry will be deleted in 1440 minutes 
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(24 hours). This means that the recipient of the newsletter must confirm their enrollment 
within this time period; if the recipient does not confirm in time, he/she must enroll 
again. The ID of the page associated with the confirmation link is set using the attribute 
ID of the <we:addDelNewsletterEmail> tag. The <we:addDelNewsletterEmail> tag 
must appear again on the template for this page. If you omit the attribute, it will be 
linked to the subscribe form on the same page.

If you have more than one mailing list, you must ensure that the order of the mailing 
lists which you gave as a value in the attribute path has the same order as the webEdition 
document in which the party interested in the newsletter had registered.

<we:addDelNewsletterEmail 
path="we_demo/newsletter/sport.txt,we_demo/newsletter/politics.txt
,we_demo/
newsletter/computer.txt" doubleoptin="false" mailid="488" 
subject="Register 
for CMS Newsletter" 
from="newsletter@mydomain.com"/>

You can check whether a  subscription or cancellation has functioned by placing various 
<we:if> tags after the <we:addDelNewsletterEmail>-tag.

<script language="JavaScript">
<!--
  var msg = "";
  <we:ifSubscribe>
    <we:ifDoubleOptIn>
      msg = 'An email was sent to <we:var type="global" 
name="WE_NEWSLETTER_EMAIL">. To confirm your enrollment in our 
newsletter, 
you must click on the confirmation link included in that email.';
    <we:else/>
      msg = 'The E-Mail <we:var type="global" 
name="WE_NEWSLETTER_EMAIL"> 
was successfully entered!';
    </we:ifDoubleOptIn>
  </we:ifSubscribe>
  <we:ifNotSubscribe>
    <we:ifMailingListEmpty>
      msg = 'Please select at least one of the mailing lists!';
    <we:else/>
    <we:ifEmailExists>
      msg = 'This email address is already entered in our mailing 
list!';
    <we:else/>
      <we:ifEmailInvalid>
        msg = 'The email address ist not valid!';
      <we:else/>
        msg = 'Attention: there is an error in the format of the email 
address <we:var type="global" name="WE_NEWSLETTER_EMAIL">! Please 
use the 
format mailaddress@mydomain.com!;
        </we:ifEmailInvalid>
      </we:ifEmailExists>
    </we:ifMailingListEmpty>
  </we:ifNotSubscribe >
  if(msg)
   alert(msg);
//-->
</script>
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23.5  How do I design a template which I can use to confirm enrollment 
for my newsletter?

You can perform this function with coding similar to the salutation block noted above, 
except that the confirmation link must appear after the dispatched E-mail. To create the 
confirmation function, you use the <we:newsletterConfirmLink> tag. For example:

<we:ifHtmlMail>
  <we:ifFemale>
    Dear Mrs.<we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname"/>,<br><br>
  <we:else/>
    <we:ifMale>
      Dear Mr.<we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname" />,<br><br>
    <we:else/>
      Dear customer,<br><br>
    </we:ifMale>
  </we:ifFemale>
  Please confirm your request for our newsletter by clicking on the 
following link:
 <we:newsletterConfirmLink/><br><br>
  Many thanks from your CMS Team!
  <we:else/>
    <we:ifFemale>
      Dear Mrs.<we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname"/>,
    <we:else/>
      <we:ifMale>
        Dear Mr.<we:newsletterSalutation type="title"/> 
<we:newsletterSalutation type="lastname"/>,
      <we:else/>
        Dear customer,
      </we:ifMale>
    </we:ifFemale>
  Please confirm your request for our newsletter by clicking on the 
following link: <we:newsletterConfirmLink/><br><br>
  Many thanks from your CMS Team!
</we:ifHtmlMail>

23.6  How do I design an unsubscribe page so people can remove 
themselves from a mailing list?

If you have used the easiest method for the subscribe page, that is, with 

only one field to enter an E-mail address, you will require only one button. To create an 
unsubscribe button, use an <we:unsubscribe> tag, followed by an HTML submit button. 
For example:

<we:form id="self">
  E-Mail-Adresse:<br>
  <we:unsubscribe size="40"/><br>
  <input type="submit" name="Submit" value="send">
</we:form>

By using a single entry after the <we:addDelNewsletterEmail> tag, you can test 
whether or not the unsubscribe was successful, and if necessary, generate an error 
message. For example: 

<script language="JavaScript">
<!--
  <we:ifUnsubscribe>
    msg = 'The E-Mail address <we:var type="global" 
name="WE_NEWSLETTER_EMAIL"> was successfully removed!';
  </we:ifUnsubscribe>
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  <we:ifNotUnsubscribe>
    <we:ifEmailNotExists>
      msg = 'The E-Mail address <we:var type="global" 
name="WE_NEWSLETTER_EMAIL"> does not exist in our list and therefore 
cannot 
be removed!';
    <we:else/>
      <we:ifMailingListEmpty>
        msg = 'Please select at least one mailing list!';
      <we:else/>
        <we:ifEmailInvalid>
          msg = 'That email address is not valid!';
        <we:else/>
          msg = 'Attention: there is an error in the format of the 
email 
address <we:var type="global" name="WE_NEWSLETTER_EMAIL">! Please 
use the 
format mailaddress@mydomain.com!';
        </we:ifEmailInvalid>
      </we:ifMailingListEmpty>
    </we:ifEmailNotExists>
  </we:ifNotUnsubscribe>
  if(msg)
    alert(msg);
//-->
</script>
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24  Scheduler: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Scheduler and Scheduler PRO Modules. This chapter treats what the modules do and 
how to install them. You can also find information here about the basic layout and 
command features for these modules. These topics are treated in the following sections:
• Section 24.1,  "What are the webEdition Scheduler modules?" on page 297
• Section 24.2,  "Installation" on page 298
• Section 24.3,  "Scheduler Module: general information and navigation" on page 298

24.1  What are the webEdition Scheduler modules?
The webEdition suite offers three types of scheduling capabilities depending on the 
modules you have purchased: the basic scheduler, the Scheduler Module and the 
Scheduler PRO Module.

24.1.1  The basic scheduler
The basic version of webEdition allows you to decide whether to publish your files 
online either immediately or at a later date.

24.1.2  The Scheduler Module
The webEdition Scheduler Module is designed to help you to keep your Web site up to 
date by offering you enhanced capabilities for scheduling the publication and removal 
of material on your Web page.

24.1.3  The Scheduler PRO Module
The Scheduler PRO Module gives you complete control over the automated publication 
process.

The webEdition Scheduler PRO Module offers more flexibility than the Scheduler 
Module in helping users to determine exactly what types of automated tasks are to occur 
to your web site content (such as publishing and un-publishing a document, moving a 
document to a new directory, and deleting a document). It also offers a user-friendly 
interface allowing you to schedule individual tasks on a singular, hourly, daily, weekly, 
monthly or yearly basis.
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24.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

24.3  Scheduler Module: general information and navigation
After installing the Scheduler Module, you will find the options for scheduling 
documents in the Properties view of the Documents main screen. The task you are 
scheduling is always associated with a document, therefore you must first open a 
document in webEdition.

You can create your files in the usual fashion. However, in addition to the normal 
webEdition options (such as Path, Copy, Document, Categories and Owners), you will 
also see an area called Automatic publishing in the Properties view (see Figure 331).

Figure 331  The location of the Scheduler in the Properties view

The Automatic publishing option allows you to determine when and for how long the 
document should be published.

For details on how to schedule a task using the Scheduler Module, see Chapter 25,  
"Using the Scheduler Module for automatic publishing" on page 303.
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24.4  Scheduler PRO: general information and navigation
After installing the Scheduler PRO Module, you will see a new tab called Scheduler 
PRO in the Documents main screen. The task you are scheduling is always associated 
with a document, therefore you must first open a document in webEdition. To access 
the Scheduler PRO Module, click the (vertically-aligned) Documents tab, then click on 
a document of your choice in the explorer menu (see Figure 332):

Figure 332  Documents main screen showing the Scheduler PRO tab

24.4.1  Scheduler PRO view
The Scheduler PRO Module gives you complete control over when to publish your 
documents. Each document that you wish to schedule is defined as a task in the 
scheduler. To open the Scheduler PRO view, choose a document, and click on the 
Scheduler PRO tab. Click on the + icon to open the Scheduler PRO view and to add a 
task to the scheduler (see Figure 333).

Note:  You can add more tasks to the scheduler by clicking on the + icon.

Figure 333  Scheduler PRO view

The Scheduler PRO offers three command parameters:
• Task
• Frequency
• Date/Time
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24.4.1.1  Task commands
In the Task select box you can choose the type of operation you wish to perform (see 
Figure 334,  "Task operation select box" on page 300). 

Figure 334  Task operation select box

The Task select box offers you the following options:
• Publish
• Unpublish
• Delete
• Change document type
• Change categories
• Change directory

Activate the Active checkbox to instruct the module to follow through with the 
scheduled task. If you do not activate the checkbox the scheduled task will not be 
executed.

24.4.1.2  Frequency commands
The Frequency select box allows you to choose the time interval between scheduled 
tasks (see Figure 335).

Figure 335  The Frequency select box

The Frequency select box has the following options:
• Once 
• Hourly
• Daily 
• Weekly
• Monthly
• Yearly
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24.4.1.3  Date/Time commands
The Date/Time select boxes allow you to set the time for the execution of the scheduled 
task.

For details on how to schedule a task using the Scheduler PRO Module, see Chapter 26,  
"Using the Scheduler PRO Module" on page 305.

24.5  Date and time considerations
The Scheduler and Scheduler PRO Modules operate in accordance with the date and 
time settings on your Web server.

24.6  Summary page requirement
The scheduling functions that you use in the Scheduler and Scheduler PRO Modules 
operate in conjunction with summary pages, that is, when the <we:listview> tag is used.

Because many service providers do not allow the use of scheduling (such as cron jobs 
on UNIX systems, or schedule tasks on Windows systems), there must be a trigger for 
the scheduler so that it can publish and unpublish a document. The trigger for the 
webEdition scheduler is in the <we:listview> tag. Whenever a visitor opens a page with 
the listview, the scheduler checks the server for scheduled tasks, then it publishes and 
displays an updated listview. Thereafter, the visitor can access any new items by 
clicking on the appropriate link in the listview.
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25  Using the Scheduler Module for 
automatic publishing

This chapter describes how to use the automatic publishing feature in the Scheduler 
Module.

25.1  Publishing your document
To specify when a document should first be published, activate the From checkbox. The 
default system response is the current time on the Web server. 

When you activate the automatic publishing feature, webEdition responds by 
suggesting that the document be published at the current time. You can modify the 
suggestion using the select boxes to change the date and the time before saving your 
entries (see Figure 336). The document will appear on your Web page at the time and 
date you have specified.

Figure 336  Entering the start date/time

25.2  Taking a document off-line
To specify when your document should be taken off-line, activate the To checkbox and 
use the select boxes to set the desired date and time. webEdition will suggest the current 
time on the web server. Save your entries. The document will no longer be accessible 
on-line after the time specified, nor will it be displayed (see Figure 337).
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Figure 337  Scheduling to take a document off-line

If you do not activate the To checkbox, the document will be displayed on-line until you 
take it off-line manually.

25.3  Publishing automatically vs. publishing normally
The Scheduler Module works only if you activate the Publish after saving checkbox 
when saving your document (see Figure 338).

If you have scheduled a task and selected the Publish after saving checkbox, the 
document will not be published immediately, but rather at the scheduled time.

Figure 338  Saving and publishing a scheduled task
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26  Using the Scheduler PRO Module
This chapter describes how to use the Scheduler PRO Module. This module allows you 
to schedule several kinds of tasks including publishing, unpublishing, deleting, and 
changing the document type, category and directory of a webEdition document.

26.1  Selecting a task
The task you are scheduling is always associated with a document, therefore you must 
first open a document in webEdition, and then click the Scheduler PRO tab.

In the Scheduler PRO view, choose a task by selecting one of the following options from 
the Task select box:
• Publish. Use this item to schedule the publication of a document.
• Unpublish. Use this item to remove a page from the view of your Web page visitors.
• Delete. Use this item to delete a document at a specified time.
• Change document type. Use this item to change the document type.
• Change categories. Use this item to change the document category.
• Change directory. Use this item to move a document to another directory at a 

specified time.

After choosing one of these tasks, the options available to you vary depending on the 
choice you have made.

26.1.1  Publishing, unpublishing and deleting a document
If you choose Publish, Unpublish or Delete, you can go directly to the Frequency select 
box to determine the time span between scheduled events.

26.1.2  Changing a document type
If you choose Change document type, the Document type selection box appears under 
the Task select box (see Figure 339). Select an existing document type from your list.
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Figure 339  Document type select box

26.1.3  Changing the categories for a document 
If you choose Change categories, the Categories selection field appears under the Task 
select box (see Figure 340). Click the Add button to open the category browser. Choose 
a category. Click OK. If you wish, you can add more categories. You can also remove 
all of the associated categories by clicking the Delete all button

Figure 340  Adding or deleting categories

26.1.4  Changing the directory document 
If you choose Change directory, the Directory selection field appears under the Task 
select box (see Figure 341). Click the Select button to open the server browser. Choose 
a directory. Click OK.

Figure 341  Selecting a new directory

26.2  Scheduling a task
You use the Frequency select box to choose the frequency of a task. The options 
available to you vary depending on the choice you make.

26.2.1  Scheduling an item once
If you choose Once from the Frequency select box , the following screen appears (see 
Figure 342).
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Figure 342  Scheduled frequency: Once

Select the date at which the task is to take place, by entering the date according to day, 
month, year.

Select the time in hours and minutes.

Note:  After the completion of the scheduled task, the item will appear "inactive" on 
the main document edit page.

26.2.2  Scheduling an hourly task
If you choose Hourly from the Frequency select box , the following screen appears (see 
Figure 343):

Figure 343  Scheduled frequency: Hourly

Choose a time (in minutes) between "00" and "59". The item will be scheduled at that 
minute every hour.

26.2.3  Scheduling a daily task
If you choose Daily from the Frequency select box , the following screen appears (see 
Figure 344):

Figure 344  Scheduled frequency: Daily

Select the time in hours and minutes at which you wish the task to be completed each 
day.

26.2.4  Scheduling a weekly task
If you choose Weekly from the Frequency select box , the following screen appears (see 
Figure 345):

Figure 345  Scheduled frequency: Weekly

Select the time and the day that you wish to schedule your task. The task will be 
executed each week at the chosen time and on the chosen day.
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26.2.5  Scheduling a monthly task
If you choose Monthly from the Frequency select box , the following screen appears 
(see Figure 346):

Figure 346  Scheduled frequency: Monthly

Select the time and the date that you wish to schedule your task. The task will be 
executed each month at the chosen time and on the chosen date.

26.2.6  Scheduling a yearly task
If you choose Yearly from the Frequency select box , the following screen appears (see 
Figure 347):

Figure 347  Scheduled frequency: Yearly

Select the time, the month and the date that you wish to schedule your yearly task. The 
task will be executed once a year at the chosen time in the chosen month and on the 
chosen date.

26.3  Options when saving a scheduled task
The Scheduler PRO Module has the following save options which you access at the 
bottom of the Documents main screen (see Figure 348).

Figure 348  Saving a scheduled task

All tasks of the Scheduler PRO Module will only be completed if you activate the 
Publish after saving checkbox when saving your document.

If you have scheduled a task and selected the Publish after saving checkbox, the 
document will not be published immediately, but rather at the scheduled time.
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27  Shop Module: Introduction
This introduction is intended to help you familiarize yourself with the webEdition Shop 
Module. This chapter treats what the module does and how to install it. You can also 
find information here about the basic layout and command features for the Shop 
Module. These topics are treated in the following sections:
• Section 27.1,  "What is the webEdition Shop Module?" on page 309
• Section 27.2,  "Installation" on page 309
• Section 27.3,  "General information and navigation" on page 310

27.1  What is the webEdition Shop Module?
The webEdition Shop Module is a toolkit that can assist you to set up a Web-based 
shopping site. 

With the Shop Module you can
• create any number of items or item groups
• design item summaries (listviews) and detailed item views
• place shopping carts anywhere on your pages
• organize your order management
• perform transaction calculations (sales taxes, discounts, etc.)
• use an open interface to a payment provider
• integrate your shop data with the webEdition Customer Management Module

27.1.1  Intended users
The Shop Module is a toolkit intended for advanced users of webEdition, and those with 
a knowledge of e-commerce Web site architecture and design. Knowledge of the 
webEdition template development processes, and webEdition tags (we:tags) are 
required in order to develop an online shop.

27.1.2  Interaction with the Customer Management Module
The Shop Module needs the webEdition Customer Management (PRO) Module to be 
installed. You cannot use the Shop Module without the Customer Management Module.

27.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html
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27.3  General information and navigation
After installation, you will find a new menu item in the main menu called Modules, 
which contains all the modules in your installation of webEdition (see Figure 349).

Figure 349  Modules drop-down menu

27.3.1  Shop Module Quickstart
Click on Modules > Shop to open the module summary window containing the Shop 
Module. The Quickstart screen for the Shop Module opens (see Figure 350).

Figure 350  The Shop Module start screen with Quickstart

27.3.1.1  Preferences
The module opens with the Shop Quickstart dialog box. Click the Preferences button to 
set your initial Shop preferences. You can choose from the following options:
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Figure 351  Shop settings screen

•Currency. Select the currency of choice.
•VAT. Set the tax rate (as a percentage) that 
you are obliged to collect.
•Number format. Choose the number format 
from the select box: German, English, 
French. or Swiss
•Records per page Set the number of records 
to be dispalyed per page.
•Class-ID This field is only displayed, if the 
Database /Object Module is installed. If 
objects are to be used as  shop articles, the IDs 
of all classes containig shop articles must be 

entered here comma-separated. This includes the listing of all shop articles as well 
as the features to extend orders. In the field Class-ID many classes can be entered 
arbitrarily.

• Customer fields (Customer Module): Select here the fields to be indicated (from the 
Customer Management Module). To select several fields, please hold  the  the Shift 
key while selecting. These preferences concern the announcement within the Shop 
Module.

• Customer fields (Order): Select here the fields which should be indicated the 
customer. As a rule customer's fields of the Customer Management are used to hold 
on current dates of the customer, as for example comments to the customer of the 
web pages operating authority (payment behavior, etc. …). By contrast customer 
fields of the order are necessary, around address dates, etc. to be able to prove at the 
time of the order, so that also afterwards still valid order dates are available.

Save your preferences by clicking on the Save button.

Note:  You can change these preferences at a later date by selecting Shop > Settings... 
from the main drop-down menu.

27.3.1.2  Payment Provider
Click in the Quickstart menu on the button Payment Provider, the corresponding 
window is opened (see 
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Figure 352  Pament Provider

For more information about Payment Providers, please refer to  29,  "Linking to a 
payment provider" on page 335.

27.3.1.3  Article/Revenue
Click the Article/Revenue button to open the view of that name.. In this view, the tabs 
Article dokuments, Article objects and Revenue overview are located(see Figure 353).

Note:  Notice please that the Article objects tab only exists if you have installed the 
DB/Object Module, article properties exist and the correct Class-ID is defined in the 
preferences! (cf also Section 27.3.1.1,  "Preferences,")
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Figure 353  Article/Revenue-view: Article documents

This view displays all articles (documents and objects). If you click on an article, the 
suitable article is opened in the webEdition main window and can be edited 
immediately. The listing itself is tabular with the most important info to the suitable 
articles including the info whether the respective article has variants. The list is sortable 
by click on the suitable heading. The representation corresponds in color usual 
webEdition rules, a not published article (document or property) is displayed, for 
instance, red.

Click on the card index rider Revenue overview to let indicate the orders of a certain 
calendar year. Also here the listings can be sorted by click on a heading. Also here there 
is a color convention- paid-up or worked on orders are displayed green.
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Figure 354  Artikel/Umsatz-Ansicht: Umsatzübersicht

27.3.2  The Shop Module main screen
The Shop Module main screen has three drop-down menus: Shop, Edit, and Help.

27.3.2.1  The Shop menu
The Shop menu contains the following items (see Figure 355,  "Shop drop-down menu" 
on page 314).
• Business year. Select the year you want to be diplayed.
• Close. Use this command to exit the module.

Figure 355  Shop drop-down menu

27.3.2.2  The Edit menu
In the Edit menu, the following items can be slected (see Figure 356,  "Edit drop-down 
menu" on page 315).
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Figure 356  Edit drop-down menu

• Preferences: Opens the preferences window (see Section 27.3.1.1,  "Preferences,")
• Countries: A window is opened in which you can determine the regulations specific 

for countries with regard to the value added tax clause.

Figure 357  Value added tax regulations specific for countries

— Default value: Standard return value for <we:ifShopPayVat> in case none of the 
opposed rules applies

— Field of Country: In this field the name of the field is stored in the customer 
management which contains the origin land (invoice address).
Shop Module



316   Shop Module: Introduction 
— States liable to VAT:Customers from these countries must pay VAT.
— States not liable to VAT:Customers from these countries must not pay VAT.
— States with special rules: Customer from these countries only have to pay VAT, 

if also an additional rule matches.
— Additional rule: The field in the customer management called (e.g.: ustid) 

corresponds to a condition (e.g., blank), then the value opposed here is returned 
(e.g.: A customer must pay VAT (true) if he has none ustid (ustid is empty) and 
must come from one of the defined countries).

Example 

<we:ifShopPayVat>
  Customer has to pay VAT.
  (-> calculate VAT)
<we:else />
Customer has not to pay VAT.
</we:ifShopPayVat>

• VAT rates: The Edit VAT rate window opens (seeFigure 358)

Figure 358  Edit VAT rate

Here you can define different VATs. Select for a new tax rate a suitable name, enter 
the suitable percent number and determine whether it should concern the standard 
rate of taxation. Click then on Save
Should no value added tax clause be assigned to an article, the opposed standard 
clause is taken, if available. If still no values are entered here, the earlier entered 
VAT is used for compatibility reasons. Then the VATs entered here can be integrated 
by shop documents as well as by shop properties. Besides, during the complete 
purchasing process exclusively the  id of the VAT is used. Only if the order is closed 
and is stored in the database, the VAT valid at the time of the order is saved. 
Therefore, an additional adaptation of the VAT does not alter finished orders

• Shipping and handling: The Shipping and handling window is opened
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Figure 359  Shipping and Handling

— Field of country: In this field you select the field of the customer management 
in which the origin land of the customer is stored

— VAT: The value added tax clause which should apply to postal charges and 
packaging. This can be selected from the defined sets

— Prices are net: If the prices are net or gross. This is important especially in the 
shop backend, all these specifications are stored with the order process and are 
taken into consideration within the order view. In the Template itself these 
values can be freely used

— Existing rates: List of all defined rates
— Name: Internal used name. Is used for Existing rates
— Countries: List of countries to which this rule should apply.
— Cost: The dependence on order value and forwarding expenses can be entered 

in this list graded. In this example a purchasing to 20 euros of 10 euros of 
forwarding expenses, between 20 and 100 euros of order value 5 euros, and 
more than 100 euros costs nothing more.

— Standard: If no other rule of the forwarding expenses applies, the standard rule 
is used always.

• Payment Provider: Opens the Pament Provider window. See Section 27.3.1.2,  
"Payment Provider" on page 311
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• Articles-/Revenues: Opens the corresponding window, see Section 27.3.1.3,  
"Article/Revenue" on page 312

• Order: Has the following sub-menu items:
— Add Article Adds, from before defined articles, to the current order. You may 

perform this action also with the Quickbutton

Figure 360  Add article quickbutton

— Delete Order: dletes the selected order.You may perform this action also with 
the Quickbutton

Figure 361  Delete order quickbutton

Note:  To be able to add an article to an order or to delete a complete order, you must 
at first have selected an existing order in the explorermenu.

27.3.2.3  The Help menu
The help menu has two options:
• Info... Select this option to access information about the license holder and the 

version of webEdition you are using.
• Help... Select this option to access the webEdition Help System.

27.3.3  The Shop Module main screen
The start screen (see Figure 362,  "Shop Module main screen" on page 319), is divided 
into two parts:
• explorer menu, on the left side
• order processing screens, on the right side
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Figure 362  Shop Module main screen

27.3.3.1  The explorer menu
The explorer menu acts as a directory of all Shop Module orders in a business year. Each 
month is represented by a folder. By clicking on the "+" character to the left of the 
folder, you can open the directory for that month to view a list of all orders. The number 
in brackets adjacent to the month indicates the number of orders for that month. 

27.3.3.2  The order processing screens
The order processing screen has two views. Monthly overview, and the order processing 
screen, each of which are accessed by clicking on items in the explorer menu. 

27.3.3.2.1  Monthly overview.    If you click on a month folder itself, a summary 
appears in the right side of your screen , showing the number of processed and 
unprocessed Shop orders. Below this area is a statistical evaluation that reports the total 
sales, and the number paid/unpaid invoices for that month (see Figure 363).

Figure 363  Monthly overview
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27.3.3.2.2  The Order Data view    If you click on a specific Shop item listed in one 
of the monthly directories, webEdition will display the processing data for that order on 
the right side of the screen (see Figure 364).

Figure 364  Order Data view

The Order Data view has two areas: Order and user details and Items ordered. 

You can modify the order data by clicking on the Edit buttons. webEdition will open a 
dialogue box in which you can edit the corresponding values as seen in Figure 365. 

Figure 365  Editing an order
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27.3.3.3  Viewing all of a customer’s orders
You can view all orders placed by an individual customer by selecting the All 
Customer’s Orders tab, which is adjacent to the Order Data tab (see Figure 366). 
Thereafter, if you click on the (underlined) item number or date for an order, webEdition 
will open the corresponding Order Data screen for that order.

Figure 366  Viewing all of a customer’s orders
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28  Configuration of the Shop Module
In this chapter you find out how you configure the shop module. The following items 
are discussed:
• Section 28.1  "Variants" on page 323
• Section 28.2  "Product groups by categories" on page 325
• Section 28.3  "Freely determinable fields" on page 327
• Section 28.4  "Value added tax" on page 329
• Section 28.5  "Shipping" on page 333

28.1  Variants
From webEdition version 3.5 it is possible to use variants of articles.

28.1.1  Variants of shop articles
An improvement desired for a long time for the shop module is the possibility of 
variants for shop articles. With the sales of similar articles it is very laborious to put on 
a completely new article every time, although merely the color differs. Now from 
webEdition 3.5 it is possible to create several variants for a shop article. These own all 
properties of the original article and "overwrite" merely the varying elements. Hence, 
an article variation is dependent always from the original article and can be called only 
in its context.

At the moment only variants of shop articles can be created, i.e. the template class must 
contain the fields specific for shops: shopdescription, shoptitle and price. Only if these 
fields can be found, it is possible to create variants.

Which articles and fields own variants is set directly in the class or template. One 
creates variants on a concrete article directly within aforesaid object or document.

28.1.2  Variants in article documents
To create variants for articles based on documents, fields for the variants have to be 
specified in the template. Variants can be created only if the template contains the 
shopspecific fields shoptitle, shopdescription and price. If this is the case, the template 
has the tab "Variants". In the Variants view of a template a list of all suitable fields of 
the template is displayed which can be marced with a checkbox as active.
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Figure 367  Variant fields in the template

Note:  Variants can only be created for dynamic documents!

If variant fields are defined in a template, all documents which are based on this 
template have the new tab Variants. Here the different variants can be created and 
maintained. The editing of the variants is analogue to the editiong of blocks. In addition 
to the fields defined in the template a field required for the internal use "Name" is 
created by which the variant can be called (by request we_variant = <NAME>)

28.1.3  Variants in article-objects
If objects with variants should be used, the corresponding filed must be declared at first 
in the class. Analogously to variants with documents, a class permits only variants if the 
fields shoptitle, shopdescription and price exist. Whether and which fields should be 
used for variants, then can be determined directly at the field administration. Also here 
only picture fields or text fields can be used for variants.

Figure 368  Variant fields for objects in classe

Object variations are analogously edited to document variations. Only  the preview 
button is absent here, because it depends on the operating range which template should 
be used for the view. Object variations function only if in the template the we:tag 
<we:useShopVariant/> exists. Also here the real object is initialized and then, when 
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required (? we_variant = <NAME>),  overwritten by the data of the variant. Likewise 
<we:useShopVariant/> must be integrated , before the first field is displayed.

28.2  Product groups by categories
Online shops require gradation of the offered articles in product groups. In webEdition 
this can be realized with categories. For this pupose,  the categories were extended with 
some functions.

28.2.1  Advanced category functions
Categories can be provided from webEdition 3.5 with a title and description text. Select 
for this the menu item Options> categories in the webEdition main window (see ). If a 
category is selected, title and description can be edited.

Figure 369  Kategorie Ansicht

These fields can now be put out with a <we:listview type="category">. Thus farther 
operational areas offer. Now beside category names -  titles, heading, Id and ParentId - 
can be displayed, too. With this, these informations can also be used with a listview of 
documents or objects.

28.2.2  <we:listview type="category">
The tag <we:listview type="category"> has been added from version 3.5. With it, it is 
possible to display all entries of a category folder. 

Example 
<we:listview type="category" parentid="5"> Listview for all categories 
which are in the category folder with id 5. Beyond this, it is possible to set the 
parentId with $ _REQUEST ['we_parentid']. You can determine the name of 
these request variables for the attribute parentidname by yourself. If none is 
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specified (neither as an attribute nor as request), a Listview about the Root directory 
of the categories is created.
With the attribute categoryids one or several categories can be displayed: 
<we:listview type="category" categoryids ="7,9">. The attribute 
categoryids may also be used in a standard listview. Then it serves as a substitute for 
the attribute categories. Should  categories and categoryids be set, precedence has 
always categoryids !
Within the category Listview the single fields of the category can be displayed, as 
usual, with we:field. The following Keys (name of the fields) exist:
• ID or WE_ID = ID of the category
• Category = Name of the category
• ParentID = ID of the parent category
• Title or WE_TITLE = Title of the category
• Description or WE_DESCRIPTION = Descriptiontext of the category
• Path oder WE_PATH = pathe of the category
Here, too, the attribute hyperlink="true" may be used. Then if necessary a hyperlink 
is placed on the same document with the request variables we_parentid (or 
parentidname). Now within the <we:repeat> tag, with the tag<we:ifHasChildren>, 
can be requested, if the actual category-folder contains categories. From version 3.5 
it is possible to create interlockíng listviews! Here an example for hierarchical 
listing of categories:

<we:listview rows="2" type="category" name="outer">
  <we:repeat>
    <b><we:field name="Category" hyperlink="true"></b><br>
    <we:field name="Title"><br>
    <we:field name="Description">
    <we:setVar to="global" nameto="cat" from="listview" 
namefrom="Category" />
    <we:ifHasChildren>
      <i>The category has children</i><br>
    </we:ifHasChildren>
    <we:listview type="document" categories="\$cat" name="inner" 
rows="2">
      <we:ifFound>
        <we:repeat>
          - <we:field name="WE_PATH" type="text" 
hyperlink="true"><br />
        </we:repeat>
        - <we:back>back</we:back>
        - <we:next>next</we:next>
      </we:ifFound>
    </we:listview>
  </we:repeat>
  <we:back>back</we:back>
  <we:next>next</we:next>
</we:listview>

This makes it very easy to display multi-hierarchical product groups.

28.2.3  <we:category>
<we:category> could display up to now only information about the category(ies) of the 
current document. This was extended with the attributes field and id. The attribute field 
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permits the access to the new fields of the category, with the attribute id a certain 
category (independent of document) can be read out

Example 

• <we:category field="Title" /> displays the title of the category of the current 
document (or Listviewentry within Listviews)

• <we:category field="Description" /> displays the description of the category 
of the current document (or Listview entry within Listviews)

• <we:category id="7" /> displays the name of the category with id 7
• <we:category id="7" field="Description" /> displays the description of the 

category with id 7

28.3  Freely determinable fields
Now in the shop from webEdition version 3.5 free input fields are also realizable for 
shop articles. Thereby it is possible without variants to let adjust special values of an 
article only by the customer (e.g., sizes or colors of articles). The shop operator can 
determine for these free fields then either values (-> make available Select menu) or a 
free input field in which the customer can enter a desired text himself.

Beside free fields in shop articles the free fields can be also added to an order which are 
then displayed in the webEdition shop module. Thus, for instance, comments can be 
saved directly with the order.

28.3.1  Freely determinable fields in shop articles
With the tag <we:shopField> input fields can be generated on a shop article page. If an 
article is put  in the shopping cart, these fields are saved there. This is possible for 
document articles as well as for object articles. In addition, these free fields are saved 
in separate fields of the document (in the shopping cart) to be able to recognize them 
later again. Besides, <we:shopField> generates arbitrary input fields with a certain 
name. If the article (together with own fields) transmits then with a form to the shopping 
cart, these fields are added to the article. It is possible to define arbitrarily many free 
fields and to save them with the article. The destination page of this form must contain 
the tag <we:createShop>, so that the fields can be created.

<we:shopField> has the following parameters:
• name: Name of the field; with this name the field is saved in the article (shopping 

cart).
• reference: Determines, wether the free field belongs to an article or shopping cart.
• shopname: Name of the shop being used
• type: Set the entry field to be created
• value: preset value
• values: comma-separated list for type="choice" and "select"
• checked: Set the checkbox activated or not
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• mode: Only for type=choice. Several values can be selected, these are attached 
comma-separated

• xml: Create input field xhtml-valid

Depending on reference from we:shopField the names of the generated input fields 
vary. With reference = "article" an input field is generated which is added to an article, 
this has the name we_sacf [<name>].

These free fields are saved in every article of the shopping cart and can be displayed 
with we:field or  we:shopfield ... type = "print" within we:listview for the shopping cart.

<table>
<we:repeatShopItem shopname="demoshop">
<tr>
  <td><we:field name="shoptitle" hyperlink="true"></td>
  <td><we:field name="sort"></td>
  ...
</tr>
</we:repeatShopItem>
</table>

In the order view in the shop module these free fields are visible under the description 
of the article.

Figure 370  Freely determinable field in article

28.3.2  Freely determinable fields in orders
The free fields in orders work analogously to free fields of articles . However, besides, 
is used we:shopField reference = "cart". Also here many free fields can be added 
arbitrarily to an order. The free order fields are indicated in the order view of the shop, 
can be displayed during the order, however, also with <we:shopField type = "print" ./>. 
These fields are used for the input as follows 

Comment:
<we:shopField reference="cart" name="shop_comment" 
shopname="demoshop" type="textarea" />

If you want to display this again to send it, for example, by mail or as a control for the 
user, following syntax can be used:

Komment:
<we:shopField reference="cart" name="shop_comment" 
shopname="demoshop" type="print" />

only the field is returned.
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Also here is to be noted that the page, from which the form is sent off absolutely must 
include  we:createShop. Then the fields are listed with the accompanying order.

Figure 371  Free fields in order

These fields can be deleted or edited after click on the suitable icon .

28.4  Value added tax
28.4.1  Value added tax set associate to a document

With <we:shopVat> a certain value added tax set can be assigned to an article. Besides, 
a list with the sets entered in the shop module from which one can select the desired one 
is generated. <we:shopVat type = "select"/>, for instance, generates a dropdown menu 
for the edit mode  of the document with the pre-defined VATs

Figure 372  VATs in the dropdown menu (german example)

With <we:shopVat id = "1"/> one can display the value added tax set of the selected Id. 
This is sensible to be able to expel different VATs  in the shopping cart decollated.

28.4.2  Value added tax sets for an object
If objects are used as shop articles, these can also use the value added tax sentences 
described on top. From version 3.5 the field type shopVat (value added tax field) has 
been added to classes. The name shopvat is a constant and cannot be changed. Objects 
of a class with this field can select the value added tax set then analogously to 
documents from within the shop module to built in sets. Then the output of the VAT set 
on the web site occurs like for other elements 

<we:field type="shopVat" /> respectively <we:var type="shopVat" />

.
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Figure 373  Taxes with shopvat in a class

28.4.3  Using VATs
With <we:shopVat />  for documentc and <we:field type="shopVat" /> or <we:var 
type="shopVat" /> for objectes or Listviews (also shopping cart) the VATs are 
displayed on the website.

To allow a flawless work with value added tax sentences, these are called on the 
complete web site by their Id. This offers numerous possibilities to work with the 
different sets and enables you to change  the sets at a later time without influencing the 
functionality of the underlying templates. The tag <we:ifShopVat id = "..."> controls 
whether the current document, or the current entry has the value added tax set with the 
specified Id in a Listview. Thus, different value added tax sentences can be decollated 
and expeled easily. A shopping cart could look  as follows:

<we:repeatShopItem shopname="demoshop">
  <tr>
    <td><we:field name="shoptitle" hyperlink="true" /></td>
    <td class="shoppingCartNumber">
      <we:showShopItemNumber shopname="demoshop" />
    </td>
    <td class="shoppingCartNumber textBold">
      <we:calculate sum="totalPrice" num_format="german">
        <we:showShopItemNumber type="print" shopname="demoshop" /> *
        <we:field name="price" />
      </we:calculate> &euro;
    </td>
  </tr>
  <we:ifShopPayVat>
    <we:ifShopVat id="1">
      <we:calculate print="false" sum="totalVat1">
        <we:showShopItemNumber type="print" shopname="demoshop" /> * 
        <we:field name="price" /> /
         100 *
        <we:field type="shopVat" />
      </we:calculate>
    </we:ifShopVat>
    <we:ifShopVat id="2">
      <we:calculate print="false" sum="totalVat2">
        <we:showShopItemNumber type="print" shopname="demoshop" /> *
        <we:field name="price" /> /
        100 *
        <we:field type="shopVat" />
      </we:calculate>
    </we:ifShopVat>
  </we:ifShopPayVat>
</we:repeatShopItem>
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In the above example different sums of the complete value added tax are computed 
according to Id of the used value added tax set. Depending on which value added taxes 
exist the sums "totalVat1" and/or "totalVat2" are thereby computed.

<we:ifVarSet name="totalVat1" type="sum">
  <tr>
    <td class="shoppingCartNumber">zzgl. MwSt. <we:shopVat id="1" 
/>%</td>
    <td class="shoppingCartNumber">
      <we:sum name="totalVat1" num_format="german" /> &euro;
    </td>
  </tr>
</we:ifVarSet>
<we:ifVarSet name="totalVat2" type="sum">
  <tr>
    <td class="shoppingCartNumber">zzgl. MwSt. <we:shopVat id="2" 
/>%</td>
    <td class="shoppingCartNumber">
      <we:sum name="totalVat2" num_format="german" /> &euro;
    </td>
  </tr>
</we:ifVarSet>

Then these both sums must be added for the computed price and the shopping cart is 
finished.

<tr>
  <th class="shoppingCartNumber">Gesamtpreis</th>
  <td class="shoppingCartNumber textBold">
    <we:calculate num_format="german">
      <we:sum name="totalVat1" /> +
      <we:sum name="totalVat2" /> +
      <we:sum name="totalPrice" /></we:calculate> &euro;
  </td>
</tr>

Then the page generated looks as follows

Figure 374  Articles with VAT (german example)

28.4.4  VATs in the shopping cart
When an order is concluded, and all article data are saved in the database, also the used 
VATs are saved. Thus it is prevented that additional changes of the VAT alter already 
existing and concluded orders. In the backend of the shop module, the order can still be 
edited concerning the value added tax afterwards. An order with variants and 
user-defined fields can look as follows:
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Figure 375  VATs in the order overview

If you want to change afterwards the VAT of an article,  merely click the order and enter 
the desired new value in the opening prompt. In addition, can be decided in the order 
view afterwards whether the value added tax should be computed. Depending on 
whether the forwarding expenses were entries net or gross, or whether the data saved in 
the goods basket were built in as net/gross prices the prices are anew computed in the 
order then

28.4.5  VAT: special we:tags
28.4.5.1  we:ifShopPayVat
With <we:ifShopPayVat> the surrounded contents are only displayed if the logged in 
customer must also pay value added taxes. Whether a customer must pay taxes, depends 
primarily on the country to which the product must be delivered. In addition country 
rules can be defined in the Shop Module under edit > countries.

28.4.5.2  we:ifShopVat
With <we:ifShopVat> can be controlled whether an article has a certain VAT. This tag 
is used in shops with several VAT sets.

28.4.5.3  we:shopVat
With <we:shopVat> a value added tax set can be assigned to a shop article from the 
defined VATs. If the attribute id is assigned, merely the value added tax set with the 
given Id is returned.

28.4.5.4  we:field type="shopVat"
Delivers within a we:listview shopping cart, we:object the value added tax set of the 
current article of the entry.

28.4.5.5  we:var type="shopVat"
Analogously to we:field type = "shopVat" the accompanying value added tax set is 
returned here on a detailed page for an object
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28.4.5.6  we:writeShopData netprices="true|false" usevat="true”
With <we:writeShopData>  can be indicated whether the  passed prices are Net or 
Gross. And whether the different value added taxes should be taken into consideration, 
or not. Default value of both entries is  true, i.e. by Default prices are accepted Net and 
the value added tax with is taken into consideration..

28.4.5.7  we:ifVarSet type="sum"
Controls whether the variable of the type sum (originates by <we:calculate sum = 
"...">) is set

28.4.5.8  we:ifNotVarSet type="sum"
Analogously to we:ifVarSet type="sum"

28.5  Shipping
28.5.1  Shipping on the webseite

The defined postage and forwarding expenses can also be accessed by we:tags, 
according to order value and origin land of the logged in customer the suitable set is 
determined and returned. However, besides, only the entered costs are returned, then 
these can be used as desired on the page. These expenses are defined as shown in 
Section 27.3.2.2.

The value added tax consists of the VAT of the price and the forwarding expenses. This 
was computed in the template with <we:calculate>. The different forwarding expenses 
can be acessed by means of the <we:shipping> tag. Following example shows the 
application of <we:shipping>.

<tr>
  <th>Preis</th>
  <td><we:sum name="totalPrice" num_format="german" /> €</td>
</tr>
<tr>
  <th>Versandkosten</th>
  <td><we:shipping sum="totalPrice" num_format="german" /> €</td>
    <we:calculate print="false" sum="totalVat1">
      <we:shipping sum="totalPrice" />/100*<we:shopVat id="1" />
    </we:calculate>
</tr>
<tr>
  <th>zzgl. MwSt.</th>
  <td><we:sum name="totalVat1" num_format="german" /> €</td>
</tr>
<tr>
  <th>Gesamtpreis</th>
  <td>
    <we:calculate num_format="german">
      <we:shipping sum="totalPrice" num_format="german" />
      +  <we:sum name="totalVat1" />
      +  <we:sum name="totalPrice" />
    </we:calculate> €
  </td>
</tr>

In this example the forwarding expenses are displayed and added to the total expenses. 
In addition, the value added tax of the forwarding expenses is calculated, added up with 
the other value added tax shares and likewise opened on the whole price.
Shop Module



334   Configuration of the Shop Module 
28.5.2  Forwarding expenses with orders
With the order process the valid forwarding expenses and all accompanying 
information are determined and saved with the order. Then within the Shop Module the 
due forwarding expenses are indicated and added for the whole price. In addition, these 
postage costs can be edited afterwards, in addition one simply clicks the postage costs 
and then can edit  the postage relevant data for this order.

Figure 376  Change shipping cost in order

Note:  Tag from Version 3.5: <we:shipping>: With we:shipping tag the forwarding expenses 
entered in the Shop Module can be accessed. With the help of the order value and the origin 
land of the logged in customer the suitable forwarding expenses are determined and 
returned. Besides, the imperative parameter sum = "" passes the name we:sum which 
contains the goods value of the order. The result from we:shipping can be processed in the 
Template and be added, e.g., with we:calculate tag to the shopping cart.
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29  Linking to a payment provider
The following chapter discussed some guidlines that you can use for linking your Web 
site to a payment provider. 

Note:  Every payment provider has its own interface and requirements for the 
transfer of payment data. For this reason, webEdition does not provide an interface 
for payment providers.

29.1  Payment provider transaction model
Figure 377 shows a typical transaction arrangement.

Figure 377  On-line shop transactions

By way of example, we have described two possible ways to link your shop to a 
payment provider.
• transfer the total price 
• transmit every item individually 

29.2  Integrating PayPal
The settings dialogue for PayPal can be accessed with Edit> Payment Provider, the 
Quckickstart button of the same name or the Payment provider button. The Payment 
provider window is opened.

Your
Web Shop

Credit
Card Provider

Customer

Payment
Provider

1.

2. 3.

4.
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Figure 378  Payment Provider settings: PayPal

Figure 379  Form for personal entries

To be able to form comfortably a payment 
winding up with PayPal, some personal data 
are required . Address entries also belong to 
it. Those data which are available in this 
dialog about the select boxes (These data  
are administered in the customer 
management) and are selected, must be 
taken into consideration with the creation of 
a shop form for the purpose of the 
registration with personal data. If you select, 
e.g., for the transmission of the given name 
the option Forename in the selectbox, this 
must be also taken into consideration in the 
source program of the form in the shop with 
the field according to given name.

For the form, the following XHTML code 
was used:

<we:form id="self" pass_id="customerData" name="userform">             
<we:sessionField name="ID" type="hidden" />
<we:sessionField name="UserGroup" type="hidden" 
value="webCustomer" />
<we:sessionField name="Username" type="hidden" autofill="true" />
<we:sessionField name="Password" type="hidden" autofill="true" />
   <fieldset>
      <legend> Billing address</legend>
       <p>
        <label for="s[Salutation_Salutation]"> Salutation: </label>
      <we:sessionField name="Salutation_Salutation" type="textinput" 
class="select" choice="on" options="Mr,Mrs" 
id="s[Salutation_Salutation]" />
   </p>
   <p>
   <label for="s[Forename]"> Forename*: </label>
  <we:sessionField name="Forename" type="textinput" class="inputs" 
id="s[Forename]" />
   </p>
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   <p>
   <label for="s[Surname]"> Surname*: </label>
  <we:sessionField name="Surname" type="textinput" class="inputs" 
id="s[Surname]" />
  </p>
  <p>
   <label for="s[Contact_Company]"> Company: </label>
  <we:sessionField name="Contact_Company" type="textinput" 
class="inputs" id="s[Contact_Company]" />
  </p>
  <p>
   <label for="s[ustid]"> UST.-ID: </label>
  <we:sessionField name="ustid" type="textinput" class="inputs" 
id="s[ustid]" />
  </p>
  <p>
  <label for="s[Contact_Address1]"> Street*: </label>
 <we:sessionField name="Contact_Address1" type="textinput" 
class="inputs" id="s[Contact_Address1]" />
  </p>
  <p>
  <label for="s[Contact_Zip]"> Zip-Code*: </label>
 <we:sessionField name="Contact_Zip" type="textinput" class="zip" 
id="s[Contact_Zip]" />
  </p>
  <p>
  <label for="s[Contact_Address2]"> City*: </label>
 <we:sessionField name="Contact_Address2" type="textinput" 
class="inputs" id="s[Contact_Address2]" />
  </p>
  <p>
  <label for="s[Contact_Country]"> Country: </label>
 <we:sessionField name="Contact_Country" type="select" 
class="select" 
values="Deutschland,Schweiz,Österreich,Frankreich,Anderes" 
id="s[Contact_Country]" />
  </p>
  <p>
  <label for="s[Contact_Email]"> Email: </label>
 <we:sessionField name="Contact_Email" type="textinput" 
class="inputs" id="s[Contact_Email]" />
  </p>
  <p>
  <label for="s[Contact_Tel1]"> Phone: </label>
 <we:sessionField name="Contact_Tel1" type="textinput" 
class="inputs" id="s[Contact_Tel1]" />
  </p>
  <p>
  <label for="s[Attention]">Attention by?:</label>
 <we:sessionField name="Attention" type="textinput" choice="true" 
options="Bitte auswählen,Zeitschrift,Empfehlung eines 
Bekannten,Empfehlung auf einer Website,Sonstiges" id="s[Attention]" 
/>
  </p>
  <p>
  <label for="s[Exacting]"> How exactly?: </label>
  <we:sessionField name="Exacting" type="textinput" class="inputs" 
id="s[Exacting]" />
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   </p>
   <p>
   <label>&nbsp;</label>
  <input type="submit" class="inputButton" name="order" 
value="Weiter" />
   </p>
   <p>
   (*) Mandatory fields
   </p>
  </fieldset>
</we:form>

A correct entry leads to the fact that everything, also personal data, are validated and 
transmitted to PayPal.

PayPal needs exactly 2 entries for the correct payment winding up. This are the PayPal 
business address (email) as well as the ISO-country code  for the correct winding up of 
the payment with regard to accordingly correct currency and tax. By means of a 
selectbox  the suitable ISO-Country code is selected and the business address is given 
what is actually the PayPal email address. Optional you may choose in another 
Selectbox between the PayPal shop (live shop) and the PayPal sand box (PayPal 
integrated developing environment for testing). Further information about the sand box 
can be found in the PayPal documentation.

29.3  Using PayPal on the Website
For the data transmission to PayPal the PayPal tag can be used, if the neccessary data 
has been enetered in the backend.First of all there should be, e.g., a PayPal Buy Now 
button which links on a special PayPal page. This should be placed within the 
data-transmitting form.

Figure 380  PayPal Buy Now Button (german example)

the corresponding XHTML source code: 
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<we:a id="113"><img 
src="http://images.paypal.com/images/x-click-but01.gif" border="0" 
width="62" height="31" alt="Make Payments with PayPal - it's fast, 
free and secure!" title="Make Payments with PayPal - it's fast, free 
and secure!"></we:a>

In this example the id 113 refers to the document paypal.php.

In this file merely the paypal tag will be interpreted called with the names for the shop 
as well as price and whether the price as Net and taxshould be used. More information 
about this tag can be found in the description of the <we:paypal> tag.

The source code of the file paypal.php resp. paypal.tmpl:
<we:sessionStart /><we:createShop shopname="demoshop" 
/><we:addDelShopItem shopname="demoshop" /><!DOCTYPE HTML PUBLIC 
"-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <we:title></we:title>
  <we:description/>
  <we:keywords/>
  <we:charset defined="ISO-8859-1">ISO-8859-1</we:charset>
  <we:css id="10" />
</head>
<body>
<div class="content">
  <div class="header">
    <we:include id="46" />
  </div>
  <div class="leftNavigation">
    <we:include id="11" />
    <we:include id="3" />
  </div>
  <div class="mainContent">

    <div class="fullWidth">
      <div class="contentFirstDiv">
        <h1>Pay Pal</h1>
        <h2>powered by webEdition</h2>
        <div class="divWithPadding">
         Der Text sollte noch geschrieben werden.
        </div>
      </div>
    </div>
  
    <div class="fullWidth">
      <div class="border">
        <div class="divWithPadding">
  <we:paypal shopname="demoshop" pricename="price" netprices="true" 
usevat="true" />
        </div>
      </div>
    </div>

  </div>
</div>
<we:ifVar name="action" match="success" type="request">
<we:deleteShop shopname="demoshop" />
</we:ifVar>
</body>
</html>
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29.4  Integrating Saferpay
The settings dialogue for Saferpay can be accessed with Edit> Payment Provider, the 
Quckickstart button of the same name or the Payment provider button. The Payment 
provider window is opened.

Figure 381  Payment Provider settings: Saferpay

• Language: Saferpay accepts the language variations specified here. With this setting 
you can influence the appearance of the Saferpay terminal.

• Account-ID: In this field must be deposited the supplied Account-ID by saferpay.
• Shop Owner: The email address deposited in this field is used by Saferpay as a 

Notify email. Message is dispatched to this email in case of an order.
• allow collect?: Here can be selected whether Saferpay should permit the collecting 

of several orders before the realization of the order process with the total sum. 
Standard is a no.

• additional. Form?: Here can be selected whether Saferpay should generate an 
additional form to the registration of an address of delivery during the realization of 
the order process in the terminal. Standard is a no

• Providerset: A comma-separated list, consisting of Provider-IDs to limit the Card 
types to be used. To find out the suitable Provider-ID, please rightclick in the 
Saferpay select terminal (VT) on the suitable Card logo  and select "Properties". 
Precise information can be gathered from the saferpay documentation.

• exec-path: Path to executable command line of saferpay
• conf-path: Path to the configuration files of saferpay, e.g., the directory "saferpay" 

in the root directory of the web server.
• Description: A  description of the offer which should appear in the Saferpay 

terminal (VT).
Standard   3.5.1   December 2005  



Linking to a payment provider   341
Further informations about Saferpay and its configuration can be found in the Saferpay 
documentation.

29.5  Using Saferpay on your website
First of all, create a Saferpay button which links on a special Saferpay page. This should 
be placed within the data-transmitting form.

Figure 382  Saferpay Button in Form (german example)

The code: 
<we:a class="inputButton" id="123"> With saferpay </we:a>

In this example the id 123 refers to the document saferpay.php. In this file merely the 
saferpay tag will be interpreted after the implementing of the OpenSaferpayScript file 
called with the names for the shop as well as price and whether the price as Net and tax 
should be used. In addition, in the tag the IDs of the sequence pages (in each case for 
onsuccess, onfailure or onabortion) can be defined. Further} information on the 
<we:saferpay> tag can be found in the tag-reference.

The code for saferpay.php resp. saferpay.tmpl: 
<we:sessionStart /><we:createShop shopname="demoshop" 
/><we:addDelShopItem shopname="demoshop" /><!DOCTYPE HTML PUBLIC 
"-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <we:title></we:title>
  <we:description/>
  <we:keywords/>
  <we:charset defined="ISO-8859-1">ISO-8859-1</we:charset>
  <we:css id="10" />
</head>
<body>
<div class="content">
  <div class="header">
    <we:include id="46" />
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  </div>
  <div class="leftNavigation">
    <we:include id="11" />
    <we:include id="3" />
  </div>
  <div class="mainContent">

    <div class="fullWidth">
      <div class="contentFirstDiv">
        <h1>saferpay</h1>
        <h2>powered by webEdition</h2>
        <div class="divWithPadding">
         Der Text sollte noch geschrieben werden.
        </div>
      </div>
    </div>
  
    <div class="fullWidth">
      <div class="border">
        <div class="divWithPadding">
<script 
src="http://www.saferpay.com/OpenSaferpayScript.js"></script>
<we:saferpay shopname="demoshop" pricename="price" 
netprices="true" usevat="true" onsuccess="125" onfailure="126" 
onabortion="127" />
        </div>
      </div>
    </div>

  </div>
</div>
<we:ifVar name="action" match="success" type="request">
<we:deleteShop shopname="demoshop" />
</we:ifVar>
</body>
</html>

29.6  New or extended tags in version 3.5
For Version 3.5 of webEdition, new tags have been added as well as existing tags 
extended to better support the imporived shop functions.

29.6.1  we:paypal
With <we:paypal> module built in PayPal variables from the shop can be accessed, like 
business address (shop email), country password (Country code ISO) as well as on the 
setting whether a test account or live shop should be used. In addition, the settings used 
in a form and in PayPal for transmitting personal data are set. The mandatory parameter 
shopname = "" passes the name of the current shop, pricename = "" passes the name of 
the current prize field. netprice = "" determines whether the prices are Net or Gross 
(TRUE or FALSE) and usevat = "" investigates whether a value added tax should be 
used, or not (TRUE or FALSE).

29.6.2  we:saferpay
With <we:saferpay> you can access the Saferpay variables eneterd in the shop module 
(see Section 29.4). The settings used in a form and for transmitting personal data to 
saferpay are also set. The mandatory parameter shopname = "" passes the name of the 
current shop, pricename = "" passes the name of the current prize field. netprice = "" 
determines whether the prices are Net or Gross (TRUE or FALSE) and usevat = "" 
investigates whether a value added tax should be used, or not (TRUE or FALSE). 
onsuccess = "" links on the ID of the web edition-page in case of a successful order. 
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onfailure = "" links on the ID of the web edition-page in case of a not successful order 
if an error should have appeared. onabortion = "" links on the ID of the web edition-page 
in case of an abnormal termination of the order.

29.6.3  we:sessionField  /addition: autofill=true
This tag was extended with the attribute "autofill". This attribute will come hany 
especially while implementing a form. If a  <we:sessionField> is provides with the 
addition autofill=true, a Script is called in the background which autofills a variable 
with a value. When using this addition, e.g., within an input field to the entry of an 
username and/or password,  webEdition automatically generates a value and needs and 
e.g., the user no longer has to log in to be able to order in the shop. The XHTML code 
for such a form could look like this: 

<we:form id="self" pass_id="customerData" name="userform">             
<we:sessionField name="ID" type="hidden" />
<we:sessionField name="UserGroup" type="hidden" 
value="webCustomer" />
<we:sessionField name="Username" type="hidden" autofill="true" />
<we:sessionField name="Password" type="hidden" autofill="true" />
   <fieldset>
      <legend> Rechnungsadresse </legend>
       <p>
        <label for="s[Salutation_Salutation]"> Anrede: </label>
      <we:sessionField name="Salutation_Salutation" type="textinput" 
class="select" choice="on" options="Herr,Frau" 
id="s[Salutation_Salutation]" />
   </p>
   <p>
   <label for="s[Forename]"> Vorname*: </label>
  <we:sessionField name="Forename" type="textinput" class="inputs" 
id="s[Forename]" />
   </p>
   <p>
   <label for="s[Surname]"> Nachname*: </label>
  <we:sessionField name="Surname" type="textinput" class="inputs" 
id="s[Surname]" />
  </p>
  <p>
   <label for="s[Contact_Company]"> Firma: </label>
  <we:sessionField name="Contact_Company" type="textinput" 
class="inputs" id="s[Contact_Company]" />
  </p>
  <p>
   <label for="s[ustid]"> UST.-ID: </label>
  <we:sessionField name="ustid" type="textinput" class="inputs" 
id="s[ustid]" />
  </p>
  <p>
  <label for="s[Contact_Address1]"> Strasse*: </label>
 <we:sessionField name="Contact_Address1" type="textinput" 
class="inputs" id="s[Contact_Address1]" />
  </p>
  <p>
  <label for="s[Contact_Zip]"> PLZ*: </label>
 <we:sessionField name="Contact_Zip" type="textinput" class="zip" 
id="s[Contact_Zip]" />
  </p>
  <p>
  <label for="s[Contact_Address2]"> Ort*: </label>
 <we:sessionField name="Contact_Address2" type="textinput" 
class="inputs" id="s[Contact_Address2]" />
  </p>
  <p>
  <label for="s[Contact_Country]"> Land: </label>
Shop Module



344   Linking to a payment provider 
 <we:sessionField name="Contact_Country" type="select" 
class="select" 
values="Deutschland,Schweiz,Österreich,Frankreich,Anderes" 
id="s[Contact_Country]" />
  </p>
  <p>
  <label for="s[Contact_Email]"> Email: </label>
 <we:sessionField name="Contact_Email" type="textinput" 
class="inputs" id="s[Contact_Email]" />
  </p>
  <p>
  <label for="s[Contact_Tel1]"> Telefon: </label>
 <we:sessionField name="Contact_Tel1" type="textinput" 
class="inputs" id="s[Contact_Tel1]" />
  </p>
  <p>
  <label for="s[Attention]">Aufmerksam durch?:</label>
 <we:sessionField name="Attention" type="textinput" choice="true" 
options="Bitte auswählen,Zeitschrift,Empfehlung eines 
Bekannten,Empfehlung auf einer Website,Sonstiges" id="s[Attention]" 
/>
  </p>
  <p>
  <label for="s[Exacting]"> Wodurch genau?: </label>
  <we:sessionField name="Exacting" type="textinput" class="inputs" 
id="s[Exacting]" />
   </p>
   <p>
   <label>&nbsp;</label>
  <input type="submit" class="inputButton" name="order" 
value="Weiter" />
   </p>
   <p>
   (*) Pflichtfelder
   </p>
  </fieldset>
</we:form>
Standard   3.5.1   December 2005  



 345
30  Designing a template for the Shop 
Module

This chapter shows you how to use we:tags to create templates for your on-line shop. 
This following functions are described in this chapter:
• Section 30.1,  "Creating a detailed view of an item" on page 30-345
• Section 30.2,  "Creating item summaries" on page 30-346
• Section 30.3,  "Ordering items" on page 30-346
• Section 30.4,  "Making a shopping cart" on page 30-347
• Section 30.5,  "Special function of the <we:a> tag in the Shop Module" on page 

30-348
• Section 30.6,  "Special functions of the <we:form> tag in the Shop Module" on page 

30-348
• Section 30.7,  "Performing calculations" on page 30-349

30.1  Creating a detailed view of an item
The process of creating a template for an item summary is performed in a similar 
fashion to other webEdition functions (see "Creating Templates" in the webEdition 
User Manual). You can use any design for the detail page of an item. The only 
exceptions are the following we:tags, which must be on a Shop Detail page as there are 
fields in the Shop Module that correspond to these fields:
• A <we:input> or <we:textarea> with the name "shoptitle"
• A <we:input> or <we:textarea> with the name "shopdescription"
• A <we:input> with the price of the product. The name of this entry field is up to you, 

but it is very important because this field name must be provided later on as a price 
variable together with the <we:writeshopdata> tag.

Note 1:  Important! The article category has to be named with a starting shop. 
The category can also be named like shop_1, shop_new, shop_online or the likes. 
Else, no articles can be installed in the shop.

Note 2:  The price variable has no fixed name, since you can also work with 
various prices. The price written to the database is the one provided in the 
pricename variable in the <we:writeShopData> tag.
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Note:  Please also note that all detailed views of items must be assigned as a uniform 
document type and/or a uniform category, since item summaries are generated with 
webEdition's listview function. Ideally you will have a uniform document type (e.g. 
shop_article or the like) for all detailed views in your Shop, and will distinguish 
between the item groups according to various categories (shop_article_dvd, 
shop_article_cd, etc.), so that they generate both a general summary of all items (only 
via document types) and summaries of all item groups (document types and 
categories).

30.2  Creating item summaries
The summaries of items or item groups are generated as normal listviews. In the 
following code example, assume that you have named a document type "shop", and that 
there are two item groups, "shop_dvd" and "shop_cd":

"shop_dvd" sample item group summary:
<we:listview rows="6" doctype="shop" categories="shop_dvd">
  <table border="0" cellpadding="0" cellspacing="0" width="500">
  <we:repeat>
  <tr>
    <td class="normal">
      <b><we:field name="shoptitle" alt="we_path" 
hyperlink="on"/></b><br>
      <we:field name="shopdescription" alt="we_text" max="200"/><br>
      Price: <we:field name="prize"> Euro <we:a 
id="id_des_shopping_cartes" 
shop="on">[In den Shopping_cart]</we:a>
    </td>
  </tr>
  <tr>
    <td><img src="/root/layout_images/pixels.gif" width="500" 
height="6" 
border="0"></td>
  </tr>
  </we:repeat>
  </table>
</we:listview>

All items: 
<we:listview rows="6" doctype="shop">

30.3  Ordering items
In order to allow an on-line shopper to put an item into the shopping cart, the following 
function must be available in the detailed item view or the summary:

<we:a id="id_of_the_following_page" shop="on">[Order]</we:a>

The shop attribute was added to the <we:a> tag. This function transfers the item 
information into the shopping cart. This is only possible if the following we:tags are on 
the page specified in the id attribute of the <we:a> tag:

<we:createShop shopname="shopname"/><we:addShopitem 
shopname="shopname"/>

Only when this function is called up will the item be added to the order or put into the 
shopping cart. It is essential that you ensure that every order request with the <we:a> 
tag and the shop="on" attribute is followed by a page with <we:createShop/> and 
<we:addShopItem/> tags. The next page can be any page (even the calling page itself). 
Ideally it is the shopping cart which immediately displays the ordered item. If it is not 
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the shopping cart, the ordered item is saved and displayed the next time the shopping 
cart is called.

30.4  Making a shopping cart
In order to make a shopping cart for your Web site, you must use a webEdition list with 
the following we:tag:

<we:repeatShopItem 
shopname="shopname">.........</we:repeatShopItem>

Below is an extended example: 
<we:createShop shopname="shopers"/><we:addDelShopItem 
shopname="shopers"/>
<!—Begin header -->
<table width="100%" border="0">
<tr bgcolor="silver">
<td>Item</td>
<td width="50">Number</td>
<td>Price</td>
<td>Total price</td>
</tr>
<!-- End header -->
<!-- Begin article listing -->
<we:repeatShopItem shopname="shopers">
<tr>
<td class="normal" bgcolor="white"><table 
border="0"><tr><td><we:field 
name="Bild" type="img" hyperlink="on" border="0" height="30" 
width="30" 
align="top"/>
</td><td><b><we:field name="Title" alt="we_path" 
hyperlink="on"/></b><br><we:field name="Description" alt="we_text" 
max="200"/></td>
</tr>
</table>
<!-- Begin possible orders -->
<td align="center"><we:showShopItemNumber 
shopname="shopers"/><br>[
<we:a id="148" shop="on" amount="1">+1</we:a>
|<we:a id="148" shop="on" amount="-1">-1</we:a>]</td>
<td></td>
<td  align="right">EURO <we:calculate 
sum="waren"><we:showShopItemNumber 
shopname="shopers">*<we:field name="Price"/></we:calculate></td>
</td>
<!-- End possible orders -->
</tr>
</we:repeatShopitem>
<!—End article listing -->
<tr><td colspan="4"></td></tr>
<tr bgcolor="silver"><td colspan="3">total:</td><td align="right">
 EURO <we:sum name="waren"/>
</td></tr>
</table>

The amount attribute is a further enhancement of the <we:a> tag. Here we are using it 
in the form:

<we:a id="148" shop="on" amount="5">+five</we:a>

The ID listed is the next page is the same as the calling page in this example. The shop 
attribute specifies that this is a Shop function. The amount attribute provides a link that 
increases the item number (we:shopItemNumber) by five. Another way to allow 
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shoppers to change the item quantity is by including select boxes, as shown in the 
following example:

<!-- Begin possible orders -->
<td align="center"><we:showShopItemNumber shopname="shopers"/>
<we:form id="id_der_folgeseite" type="shopliste">
<td width="30" class="nav0" bgcolor="white">
      <select name="shop_anzahl" size="1" class="nav0">
        <option value="1">1</option>
        <option value="2">2</option>
        <option value="3">3</option>
        <option value="4">4</option>
        <option value="5">5</option>
        <option value="6">6</option>
        <option value="7">7</option>
        <option value="8">8</option>
        <option value="9">9</option>
        <option value="10">10</option>
      </select></td>
</we:form>
<!-- End possible orders -->

30.5  Special function of the <we:a> tag in the Shop Module
Within an item list in the Shop, the <we:a> tag takes on three new attributes:
• shop= "shows the tag that it is in a Shop"
• amount= "Number of items that are put into the shopping cart by clicking on the link 

created by the we:a tag"
• delarticle= "takes the corresponding item out of the shopping cart again"

The following code puts the corresponding item into the shopping cart:
<we:a id="id_der_folgeseite" shop="on" amount="1">Into the shopping 
cart</we:a>

The following code takes the item out of the shopping cart again:
<we:a id="id_der_folgeseite" delarticle="on">Out of the shopping 
cart</we:a>

The following code creates a link to delete the complete shopping cart:
<we:a id="id_der_folgeseite" delshop="on">Delete shopping 
cart</we:a>

30.6  Special functions of the <we:form> tag in the Shop Module
The we:form tag has one additional attribute in the Shop Module:

type="shopliste"

This attribute lets you use entry fields or select boxes to provide the number of items for 
ordering. In the <we:form> tag, id="self" can be omitted as omitting information in the 
id attribute always signifies a link to itself. When it is linked to another page, 
id="id_of_next_page" must always be included. For example:

<!—Begin possible orders -->
<td align="center"><we:showShopItemNumber shopname="shopers"/>
<we:form  id="id_der_folgeseite"type="shopliste">
<input type="Text" name="shop_anzahl">
<input type="submit" value="abschicken">
</we:form>
<td  align="right">EURO <we:calculate 
sum="waren"><we:showShopItemNumber 
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shopname="shopers">*<we:field name="Price"/></we:calculate></td>
</td>
<!-- End possible orders -->

30.7  Performing calculations
webEdition allows you to perform extensive calculations with the <we:calculate> and 
<we:sum> we:tags.

<we:calculate> offers you all functions that PHP generally offers:
• + Addition
• - Subtraction
• * Multiplication
• / Division
• () Nested calculations
• sqrt Square root

<we:sum name="your_sum"> adds all individual totals that are defined in the 
<we:calculate sum="your_sum"> tag.

The following is an example for <we:calculate>: 
<we:calculate name="endpreis" num_format="german" print="on"> 
(<we:session 
field name ="artikel_summe"/>*(1-<we:field 
name="rabattstufe1"/>))*(1+(<we:field 
name="mwst"/>/100))</we:calculate>

The following is a full example showing the use of <we:calculate> and <we:sum>:
<we:createShop shopname="shopers"/><we:addDelShopItem 
shopname="shopers"/>
<table width="100%" border="0">
<tr bgcolor="silver">
<td>Item</td>
<td width="50">Number</td>
<td>Price</td>
<td>Total price</td>
</tr>
<we:repeatShopItem shopname="shopers">
<tr>
<td class="normal"  bgcolor="white"><table 
border="0"><tr><td><we:field 
name="Bild" type="img" hyperlink="on" border="0" height="30" 
width="30" 
align="top"/>
</td><td><b><we:field name="Artikelname" alt="we_path" 
hyperlink="on"/></b><br><we:field name="Description" alt="we_text" 
max="200"/></td>
</tr>
</table>
<td align="center"><we:showShopItemNumber 
shopname="shopers"/><br>[<we:a 
id="148" shop="on" Number="1">+1</we:a>|<we:a id="148" shop="on" 
Number="-
1">-1</we:a>]</td>
<td><we:field name="Price"/></td>
<td  align="right">EURO 
<we:calculate sum="warenkorb" 
num_format="german"><we:showShopitemNumber 
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shopname="shopers">* <we:field name="Price"/></we:calculate></td>
</td>
</tr>
</we:repeatShopitem>
<tr><td colspan="4"></td></tr>
<tr bgcolor="silver"><td colspan="3">total:</td><td align="right">
 Euro <we:sum name="warenkorb" num_format="german"/>
</td></tr>
</table>

The code cited above produces the following output on a browser (see Figure 383):

Figure 383  Output to browser
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31  Task/Messaging: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Task/Messaging Module. This chapter treats what the module does and how to install 
it. You can also find information here about the basic layout and command features for 
the Task/Messaging Module. These topics are treated in the following sections:
• Section 31.1,  "What is the webEdition Task/Messaging Module?" on page 351
• Section 31.2,  "Installation" on page 352
• Section 31.3,  "General information and navigation" on page 352

31.1  What is the webEdition Task/Messaging Module?
webEdition offers not only the means of creating Web site content, but it also offers a 
working context in which you can administer the activities of your Web development 
team.

The webEdition Task/Messaging Module is a customized E-mail system in which you 
can send messages and administer tasks relating to Web page creation and 
administration.

All messages and tasks related to the development of your Web page content can be 
"contained" within this dedicated system. All tasks performed by users in webEdition 
can be administered and communicated without an external E-mail system or process. 
Your communiqués pertaining to development tasks are thus separated from your larger 
enterprise E-mail systems, making your process easier to monitor and administer.

Typically, the editor-in-chief (or person in charge of your Web page administration), 
uses this module to communicate work items to Web content developers. Developers, 
in turn, can use the tool to communicate among themselves, and to report on the status 
of defined tasks.

There are two types of communiqués that you can create using the Task/Messaging 
Module:
• Message communiqué.

A webEdition message is similar to a simple E-mail message. You can send 
messages to any user registered in the User Management Module of webEdition. 
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You can also send E-mail messages to external recipients. In this case, you employ 
the normal E-mail address syntax (for example, username@web_address.com).

• Task communiqué
A task communiqué instructs a webEdition user to conduct a specified task within 
webEdition. There are two ways to create a task communiqué in webEdition:
— Manual task creation. You can create a task manually that you can send to other 

users.
— Automatic task creation. If you install the webEdition Workflow Module, tasks 

can be generated automatically as soon as documents or objects are inserted in 
the workflow. Once a workflow has been defined, all functions of the workflow 
are administered automatically by the system. For more information on the 
Workflow Module, consult The Workflow Module User Guide which is available 
on our documentation page the following URL: 
http://www.webedition.de/english/downloads/Documentation.html.

31.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

31.3  General information and navigation
After you have installed the Task/Messaging Module, you will find a new menu item in 
the main menu called Modules, which contains all the modules in your installation of 
webEdition. Task/Messaging will appear as an option in the Modules drop-down menu 
(see Figure 384).

Figure 384  Modules drop-down menu

To open the module, you can click on Task/Messaging in the Modules menu, or you can 
go directly to create a new task or message by clicking on one of the icons that appears 
in the webEdition Quickstart menu (see Figure 385). 
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Figure 385  webEdition Quickstart menu

Click on Task/Messaging in the Modules menu. The Task/Messaging Module main 
screen appears (see Figure 386).

Figure 386  Task/Messaging Module main screen

31.3.1  Navigation: toggling between the tasks and messaging systems
The Task/Messaging Module is divided in two parts: tasks and messaging. There is one 
main screen for each system.

You can toggle between the main messaging screen and the main task screen by clicking 
on the "launch" button in the upper right corner of each screens.

When you are in the main task screen, a button in the form of an envelope icon appears 
in the upper right corner of the main task screen. If you click on this button, your view 
will switch to the main messaging screen (see Figure 387).

Figure 387  "Launch Messaging System" button
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Conversely, when you are in the main messaging screen, a button in the form of a check 
mark icon appears in the upper right corner of the main messaging screen. If you click 
on this button, your view will switch to the main task screen (see Figure 388).

Figure 388  "Launch Task System" button

31.3.2  The Task/Messaging File menu
The File drop-down menu has the following items (see Figure 389,  "Task/Messaging 
File menu" on page 354).
• New. You can select from the following sub-items:

— New > Message. Use this command to create a new message.
— New > Task. Use this command to create a new task.
— New > Folder. Use this command to create a new folder.

• Delete. Select Delete > Folder to delete a folder.
• Close. This command closes the application

Figure 389  Task/Messaging File menu

31.3.3  The Task/Messaging Edit menu
The Edit drop-down menu has the following items (see Figure 390,  "Task/Messaging 
Edit menu" on page 354):
• Folder. Use this item to edit or change the folder settings.
• Settings. Use this item to instruct the system to search for new messages on the 

server at defined time intervals.
• Copy, Cut, Paste. Use these commands to copy, cut and paste an item.

Figure 390  Task/Messaging Edit menu

31.3.4  Changing folder settings
By clicking Edit > Folder, the module opens a screen allowing you to change the 
parameters of the folder (see Figure 391).
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Figure 391  Change folder settings screen

Using the Change folder settings screen, you can perform the following operations:
• change the name of the folder, using the Folder name field
• assign a file to a new directory, using the Parent folder select box
• change the type of communiqué (either message or task) using the Type select box

31.3.5  Changing the update interval
By clicking Edit > Settings, the module opens a screen allowing you to change the 
parameters governing the automatic update interval. With this feature, by making a 
selection from the Check step select box, you can instruct the system to search for new 
messages on the server at defined time intervals (see Figure 392).

Figure 392  Settings: update interval screen

31.4  Function buttons
The webEdition Task/Messaging Module provides graphical buttons that you can use to 
perform actions. Both types of communiqués, that is, messages and tasks, have 
distinctive buttons.

Note:  For further information on toggling between the messaging and tasks 
modules, see Section 31.3.1,  "Navigation: toggling between the tasks and messaging 
systems" on page 353.

31.4.1  Messages buttons
Go to the messaging main screen. When the message function is active, the following 
buttons appear (see Figure 393).
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Figure 393  Messaging buttons

The following sub-sections describe each of the messaging buttons.

31.4.1.1  The Create message button
Click the button shown in Figure 394, to create a message.

Figure 394  Create message button

31.4.1.2  The Reply to message button
After opening a message, you can reply directly to the sender by clicking on the "reply 
to message" button (see Figure 395). The system automatically enters the address of the 
original sender into the to field of your reply message.

Figure 395  Reply to message button

31.4.1.3  The Copy message button
Select this button to copy a messages you have marked to another directory (see Figure 
396).

Figure 396  Copy message button

31.4.1.4  The Cut message button
Select the button shown in Figure 397, to cut selected messages. Thereafter you can 
paste the message into another file.

Figure 397  Cut message button

31.4.1.5  The Paste message button
Use the button shown in Figure 398, to insert copied or cut messages into another file.

Figure 398  Paste message button

31.4.1.6  The Delete message button
Select the button shown in Figure 399, to delete all marked messages.

Figure 399  Delete message button

31.4.1.7  The Look for new messages button
When you click on this button, the server will search for new messages (see Figure 400).
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Figure 400  Look for new messages button

31.4.2  Task buttons
Like the messaging system, the task system has a group of buttons designed to help you 
perform basic functions within the Task/Messaging Module. Some of the task buttons 
have the same icon and function as those used in the messaging main screen. See 
Section 31.4.1.3,  "The Copy message button" on page 356 through to Section 31.4.1.6,  
"The Delete message button" on page 356. The remaining task buttons are treated in the 
sub-sections that follow. 

Activate the task main screen. Once the task function is active, the following task 
buttons appear (see Figure 401):

Figure 401  Task buttons

31.4.2.1  The Create task button
Click the button shown in Figure 402, to create a new task.

Figure 402  Create task button

31.4.2.2  The Forward task button
Click the button shown in Figure 403, to forward a task to another individual on your 
Web development team.

Figure 403  Forward task button

31.4.2.3  The Reject task button
Click the button shown in Figure 404, to reject a task that has been sent to you. The task 
communiqué will be returned to the sender.

Figure 404  Reject task button

31.4.2.4  The Task Update stauts button
Select this button to check whether or not the status of a task has changed (see Figure 
405).

Figure 405  Task Update status button

31.5  The explorer menu
The explorer menu appears on the left side of the Task/Messaging main screen. The 
explorer menu offers a visual representation of the directories (folders) and files 
contained in the Task/Messaging Module (see Figure 406).
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Figure 406  Task/Messaging explorer menu

To open a folder, click the plus "+" sign on the left side of the folder. The folder symbol 
changes to "open", and the contents of the directory appears. Below the open folder are 
the files saved in the directory. Underneath the directory task, you find the sub 
directories.

31.6  The edit views of the Task/Messaging Module
There are three areas in the messaging and task edit views (see Figure 407,  "The edit 
screen (messaging module)" on page 358).
• The upper area allows you to search for messages
• The middle area provides a list of your messages or tasks
• The lower area shows the content of a marked message or task

Figure 407  The edit screen (messaging module)

31.6.1  Edit view: Search tasks/messages area
To search for a specific task or message, type a word in the search field, then click the 
Search button. The system searches the current directory for the word you have typed 
in the search field (see Figure 408). 
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Figure 408  Searching for a task/message

By clicking the Advanced button, you can extend the search area to other directories, or 
you can limit your search to parts of a message (for example, the address of sender). See 
Figure 409,  "Advanced search options" on page 359. To search multiple fields, hold 
down the Shift or Control key on your keyboard while you select each item, then click 
on OK. You can delete the search parameters by selecting the cancel button.

Figure 409  Advanced search options

You can reset the both the simple and the advanced search by clicking the Reset button.

31.6.2  Edit view: task/messages lists area
The middle area of the edit view displays a list of all the messages and tasks of the open 
directory. There are minor differences in the messages list and tasks list screens.

31.6.2.1  Messaging edit view: messages list area
The messages list area offers the following information about each message file (see 
Figure 407,  "The edit screen (messaging module)" on page 358):
• Subject. This column describes the topic of the message.
• "Checkbox". To the left of the message title is a checkbox that you can use to select 

(or "mark") a message. When you activate the checkbox, you mark the message. 
The marked message appears in blue coloured font.

• Date. This column shows the day and time that the message was composed.
• From. This column indicates the sender of the message.
• Read (or not). A blue oval appears beside messages that have not been read. Once 

read, the button changes from blue to grey.
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31.6.2.2  Task edit view: task list area
The middle part of the task edit view displays a list of all the tasks of the open directory. 
The list offers the following information about each task file (see Figure 410,  "Task list" 
on page 360):
• Subject. This item describes the subject of the task.
• "Checkbox". To the left of the task subject is a check box that you can use to select 

(or "mark") a task. When you activate the check box, you mark the task. The marked 
message appears in blue coloured font in your directory tree.

• Deadline. This column indicates the date and time by which the task is to be 
completed.

• Priority. This column indicates the importance of the task on a scale of 1 (highest) 
to 10 (lowest).

• Status. This column indicates the progress of the completion of the task.

Figure 410  Task list

31.6.2.3  Viewing the contents of marked messages
The lower part of the edit section displays the contents of a message or a task. To view 
the contents of a message or a task, you must first mark the message by selecting the 
corresponding checkbox in the message/task list (see Figure 410,  "Task list" on page 
360).
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32  Using the Task/Messaging Module
This chapter describes how to use the Task/Messaging Module. This section treats the 
following procedures, some of which are common for both tasks and messages:
• Section 32.1,  "Creating, reading and replying to a message" on page 361
• Section 32.2,  "Creating, reading, forwarding, and rejecting tasks" on page 363
• Section 32.3,  "Common procedures" on page 368

32.1  Creating, reading and replying to a message
The procedures in this section treat how to use the basic features of the Messaging 
sysem to create, read, and reply to messages.

32.1.1  Creating a new message
Use the following procedure to create a new message.

Procedure 58  Creating a new message

In the Messaging main screen
1 Click the File > New > Message, or click the create message icon.

A screen opens in which you can create your message (see Figure 411).

Figure 411  Create message screen

2 In the Recipients field, enter the E-mail address of the person to whom you wish to send the 
message. Enter the address by doing one of the following steps:
a Type an E-mail address directly in the field
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b Choose a receiver from your address book. For further information on how to use the 
address book, see Section 32.3,  "Common procedures" on page 368.

3 Type the subject of your message in the Subject field.
4 Type your message in the contents text box below the Subject field.
5 Select OK to send your message.

The system opens an information window telling you whether or not your message was 
successfully sent.

6 Click the OK button to close the window.
The message will appear in the Sent folder of the explorer menu.

7 You have completed this procedure.

32.1.2  Reading a message
Use the following procedure to read the contents of a message. To learn how message 
notification operates in webEdition, see Section 32.3.1,  "Task and message 
notification" on page 368.

Procedure 59  Reading a message

In the Messaging main screen
1 If you have not already done so, open the Messaging main screen.

All messages in the directory appear on the screen in the edit view. Each message is 
described under the headings of Subject, Date, From, and Read.

2 Click on the message to display the contents of the communiqué.
The contents of the message appears in the bottom half of your edit view.

Note:  When a message had been read, the oval in the Read column turns from blue to 
grey colour.

Figure 412  Reading a message

3 You have completed this procedure.
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32.1.3  Replying to a message
Use the following procedure to reply to a message.

Procedure 60  Replying to a message

In the Messaging main screen
1 If you have not already done so, open the message main screen. Mark the message to 

which you wish to reply by clicking in the checkbox to the left of the Subject field.
2 Click on the reply button.

A new window appears. The original sender appears automatically as the receiver and 
his/her original message appears at the top of the text box (see Figure 413).

Figure 413  Replying to a message

3 Write your reply message in the text box.
4 To send your reply, click the OK button.

The system opens a confirmation screen telling you that the message was successfully 
sent.

5 Click OK to close the confirmation screen.
6 You have completed this procedure.

32.2  Creating, reading, forwarding, and rejecting tasks
The procedures in this section describe how to use the basic features of the Task/Module 
to create, read, forward, and reject tasks. To learn how task notification operates in 
webEdition, see Section 32.3.1,  "Task and message notification" on page 368

32.2.1  Creating a new task
Use the following procedure to create a new task.

Procedure 61  Creating a new task

In the Task main screen
1 Click on the Create task button.

The New Task screen opens (see Figure 414).
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Figure 414  Creating a new task

2 Choose a recipient. Enter the address by doing the following:
a Type an E-mail address directly in the field.
b Choose a receiver from your address book. For further information on how to use the 

address book, see Section 32.3,  "Common procedures" on page 368.
3 Type the subject of your task in the Subject field.
4 Use the Deadline pick lists to define the deadline for the completion of the task. To do so, 

complete the following sub-steps:
a Enter the date (day/month/year) in the first three fields.
b Enter the time (hour/minute) in the following two fields.

5 From the Priority select box, choose a priority status, where the priority defines the 
importance of each task. Choose one (1) to designate the highest priority, ten (10) to 
designate the lowest priority.

6 Write the details about the task you wish to assign in the text field below the Priority select 
box.

7 To send your task, click the OK button on the bottom of the form. (You can also choose to 
cancel the action by clicking the Cancel button.)
The system opens a confirmation screen telling you that the task was successfully created.

8 Click the OK button to close the screen.
9 You have completed this procedure.

32.2.2  Reading a task message
Use the following procedure to read the contents of a task.

Procedure 62  Reading a task message

In the task main screen
1 If you have not already done so, open the Task main screen.

All messages or tasks in the directory appear on the screen in the edit view (see Figure 422,  
"Task waiting!" on page 369).

2 Click on the task to display the contents of the communiqué.
The description of the task appears in the bottom half of your edit view.
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Figure 415  Reading a task message from the task list

3 You have completed this procedure.

32.2.3  Rejecting a task
Use the following procedure to reject a task.

Procedure 63  Rejecting a task

In the tasks list
1 Mark the task using the checkbox adjacent to the subject of the task message (see Figure 

415,  "Reading a task message from the task list" on page 365).
2 Select the Reject task button.

A new window opens (see Figure 416).

Figure 416  Rejecting a task

3 Select the receiver.
4 Type your message in the text box.
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5 To send the rejection message, click the OK button.
6 You have completed this procedure.

The system sends the task back to the originator, who will see a task appear in the Rejected 
folder in the explorer menu.

Figure 417  Rejected task notification

32.2.4  Forwarding a task
Use the following procedure to forward a task.

Procedure 64  Forwarding a task

In the Task main screen
1 If you have not already done so, open the Task main screen.

All messages or tasks in the directory appear on the screen in the edit view (see Figure 422,  
"Task waiting!" on page 369).

2 Click on the task to display the contents of the communiqué.
The description of the task appears in the bottom half of your edit view.

3 Mark the task, using the checkbox adjacent to the subject of the task message (see Figure 
415,  "Reading a task message from the task list" on page 365).

4 Select the forward task button.
A new window opens (see Figure 418).

Figure 418  Forwarding a task

5 Select the receiver from the recipients list.
6 Enter the content of your message in the text box.
7 Click the OK button to forward the task.

The system opens a confirmation screen telling you that the task was successfully 
forwarded. 
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8 Click OK to close the confirmation screen.
9 You have completed this procedure.

32.2.5  Updating a task

Procedure 65  Reading a task message

In the task main screen
1 If you have not already done so, open the Task main screen.

All messages or tasks in the directory appear on the screen in the edit view (see Figure 415,  
"Reading a task message from the task list" on page 365).

2 Click on the task to display the contents of the communiqué.
The description of the task appears in the bottom half of your edit view.

3 You can send an update report in two ways. If you wish to include comments in your report, 
or if you are are partially finished
a If you have finished the task, you can click the 100% button in the lower register of the 

edit screen, then go to Step 7.
b If you wish to include comments in your report, or if you are are partially finished go to 

Step 4.
4 Click the Status update icon, then

The Task status update screen appears (see Figure 419).

Figure 419  Task status update screen

5 In the status field, enter a value representing the percentage of the task that is completed. 
You can also enter comments in the Comments box, if necessary.

6 Click OK.
7 You have completed this procedure. The assigner of the task will automatically be notified 

of the status update.
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32.3  Common procedures
Common procedures are those which you can use in both the task and the messaging 
portions of the Task/Messaging Module.

The following topics and procedures are treated in this section:
• Section 32.3.1,  "Task and message notification" on page 368
• Section 32.3.2,  "Using the address book feature" on page 369
• Section 32.3.3,  "Creating or changing a folder or directory" on page 371
• Section 32.3.4,  "Copying, cutting and inserting selected tasks or messages" on page 

372
• Section 32.3.5,  "Deleting a message or task" on page 372

32.3.1  Task and message notification
When you have been assigned a task, webEdition automatically notifies you. Use the 
following procedure to access tasks (and messages) that have been assigned to you.

Procedure 66  Task notification

In the webEdition main screen
1 When you log in to the webEdition main screen, there are two indicators:

a The webEdition Quickstart screen displays the number of new tasks and messages that 
await you (see Figure 420).

Figure 420  Quickstart task notification

b In the upper right corner of the webEdition main screen, there is a message and a task 
icon. The number adjacent to the icon indicates the number of items that await your 
response.

Figure 421  Task and message notification icons

2 Click on either of the task icons to launch the Task system. (Likewise, if you have received 
a message indicator, click on the message icon).
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The system opens the task view showing you your assigned tasks (see Figure 422).

Figure 422  Task waiting!

3 You have completed this procedure.
After accessing the Task system, the numeric task or message indicators described in this 
procedure in Step 1 on page 368, are reset to zero (0).

32.3.2  Using the address book feature
The address book feature relies on the user data entered into webEdition with the User 
Management Module. Hence all of your internal registered webEdition users will 
already have their profile entered into the system and you can access this data to build 
your personal address book. The following steps describe how to use the address book 
feature to add webEdition users to your address book and to select users from the 
address book

32.3.2.1  Adding an internal user to your address book

Procedure 67  Adding an internal user to your address book

In the Messaging main screen
1 Open the Create message screen by clicking File > New > Message.
2 Click on the word Recipients.

The Select recipients screen opens (see Figure 423).

Figure 423  Select recipients screen

3 Click the Select user button on the bottom of the Select recipients screen.
The Select user screen appears, offering a list of all of your webEdition registered users 
(see Figure 424).
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Figure 424  Select user screen

4 Using the checkbox beside each name, select the user(s) that you wish to add to your 
address book.

5 Click the OK button.
This action moves the data of the newly selected addresses to the Selected box on the 
Select recipients screen.

Figure 425  Selected users box

6 To move the new name(s) to the address book, highlight the name, then click on the left 
arrow.
The name appears in the Address book box.

Figure 426  New users in the address book

7 Save the address book by clicking the Save address button.
The system opens a confirmation window telling you that the address book has been saved.

8 Close the confirmation window by clicking OK.
The new address is saved in your address book.

9 You have completed this procedure.

32.3.2.2  Choosing a recipient from the address book

Procedure 68  Choosing a recipient from the address book

In the Messaging main screen
1 Open the Create message screen by clicking File > New > Message.
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2 Click on the word Recipients.
The Select recipients screen opens (see Figure 423,  "Select recipients screen" on page 
369), in the Address book box is a list of users in your address book (see Figure 426,  "New 
users in the address book" on page 370)

3 Select a recipient (or recipients) from your address book by highlighting the names from the 
Address book list.

4 Click the right arrow between the Address book and Selected box.
The recipients appear in the Selected box on the right side of the screen.

5 Click the OK button.
The Select recipients screen closes and the user appears in the Recipients field of the 
Create message screen. Thereafter, you can complete and send your message.

6 You have completed this procedure.

32.3.3  Creating or changing a folder or directory
Use the following procedure to create a new folder or directory.

Procedure 69  Creating or changing a folder or directory

In the Task or Messaging main screen 
1 Go to the File drop-down menu and click New > Folder.

The New folder view appears (see Figure 427).

Figure 427  New folder view

2 In the Folder name field, type the name of your new folder.
3 Using the Parent folder select box, choose the directory in which the folder is to be saved.

Note:  To select a top-level directory, choose None from the list.
4 Choose the type of communiqué: webEdition Message or Task.
5 Click the Save button.

The systen confirms the action. Click OK. The new folder appears in the explorer menu (see 
Figure 428).
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Figure 428  New message folder in explorer menu

6 You have completed this procedure.

32.3.4  Copying, cutting and inserting selected tasks or messages
Use the following procedure to copy or cut, and insert selected files.

Note:  To select multiple files, you must make sure that the "multiple selection" 
button at the top of the page is activated. (The select multiple files feature is activated 
when the arrow on the icon appears in black.)

Procedure 70  Copying, cutting, and inserting files

In the task or messaging edit view
1 Mark the task or message by activating the corresponding checkbox in the task or 

messaging file list.
2 Select the Copy or the Cut button.
3 In the file navigator window on the left side of the screen, highlight the directory into which 

you wish to move your file.
4 Select the Paste button to insert your file into the directory.The file appears in the new 

directory.
5 You have completed this procedure.

32.3.5  Deleting a message or task
Use the following procedure to delete selected files.

Procedure 71  Deleting a message or task

In the task or messaging edit view
1 Mark the files for deletion by activating the corresponding checkbox in the task or 

messaging file list.
2 Click the "trash can" icon.

A dialogue box opens asking you to confirm that you wish to delete the task or message.

3 Select ok to confirm the deletion, or cancel to terminate the process.
If you select ok, the selected files are deleted and will no longer appear in the file menu.

4 You have completed this procedure.
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33  User Management: Introduction
This introduction is intended to help you familiarize yourself with the webEdition User 
Management Module. This chapter treats what the module does and how to install it. 
You can also find information here about the basic layout and command features for the 
User Management Module. These topics are treated in the following sections:
• Section 33.1,  "What is the webEdition User Management Module?" on page 373
• Section 33.2,  "Installation" on page 373
• Section 33.3,  "Access control feature" on page 373
• Section 33.4,  "General information and navigation" on page 374

33.1  What is the webEdition User Management Module?
The webEdition software differentiates between the role of the administrator and the 
role of the editor. Normally, the administrator is responsible for the design and creation 
of the templates, whereas the editor creates and maintains the content. The webEdition 
User Management Module allows you to manage as many administrators and editors as 
you want. 

33.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

33.3  Access control feature
The webEdition User Management Module prevents multiple users from editing 
documents simultaneously. Thus the potential risk of over-writing is minimized.

A document can be edited by only one user at any given time. If two or more users are 
logged onto the server and attempt to open the same document, the document will only 
be made available to the user who selected it first. If any other users try to open the 
document, a dialog box will appear on their screen informing them that the document is 
currently being edited by user "XYZ". As soon as user "XYZ" closes the document, 
opens another document or logs off, another user will be allowed to edit the document.
User Management and User Management PRO Module



374   User Management: Introduction 
33.4  General information and navigation
After installation, you will find a new menu item in the webEdition main menu called 
Modules, which contains all the modules in your installation of webEdition (see Figure 
429).

Figure 429  Modules drop-down menu

33.4.1  Opening the module
Select User Management from the Modules menu to open the User Management main 
screen. The User Management Module main screen opens showing the Quickstart 
screen (see Figure 430).

Figure 430  User Management Module: main screen and Quickstart option

Using the Quickstart screen, you have the option of going directly to the add new user 
screens.
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You can return to the Quickstart screen at any time by clicking on the User Management 
tab.

33.4.2  Drop-down menu commands
On the User Management main screen, a list of users appears in the explorer menu; two 
drop-down menus appear in the upper left: User and Help, as seen in Figure 430,  "User 
Management Module: main screen and Quickstart option" on page 374.

33.4.2.1  The User menu
The User menu has the following items (see Figure 431,  "User Management User 
menu" on page 375):
• New. Use this command to create a new user (administrator or editor).
• Save. Use this command to save entries/changes made to users.
• Delete. Use this command to delete existing users (administrators or editors). You 

must confirm your deletion by clicking OK in the dialog box.
• Exit. Use this command to exit the User Management Module.

Figure 431  User Management User menu

33.4.2.2  Help menu
The main screen also has a Help menu. Use the Help command to access the help 
program for the User Management Module.
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34  Working with the User Management 
Module

The following sections describe some of the basic procedures that you can perform with 
the User Management Module:
• Section 34.1,  "Creating new users: administrators and editors" on page 377
• Section 34.2,  "Changing user settings" on page 378
• Section 34.3,  "Deleting users" on page 379

34.1  Creating new users: administrators and editors
The following procedure describes how to create new users and how to assign 
administrative or editorial prvileges to a user.

Procedure 72  Creating a new user

In the webEdition Start Screen
1 Log into webEdition as "administrator".
2 Select User Management from the Modules menu.
3 In the User Management main screen, click New user in the Quickstart menu, or click on 

User > New > User.
The user Data view appears which has two parts: User data and Permissions (see Figure 
432).

ATTENTION
Only an administrator can create or delete users and change user 
permissions. These options will not be available if you have logged into 
the webEdition system as an editor.
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Figure 432  User Data view

4 In the first two fields of the User data area, enter the following data:
a First name of the new user
b Last name of the new user

5 In the next two fields enter the following data:
a User name. The name that will identify the user in webEdition.
b Password. Enter an alphanumeric string of at least 4 characters.

6 If you wish to create an administrator, go to Step 7. If you wish to create an author, go to 
Step 8.

7 To give a user administrative permissions, click on the Administrator permissions button, 
then go to Step 11.

Note:  You cannot restrict the administrator's workspace - the option Specify/select 
workspace is inactive.

8 To give a user authoring or editing permissions, click on the User permissions button.
9 You can allocate a special workspace in webEdition to this user by clicking on the Specify 

workspace button.
10 Click on the Select button to browse and select the directories in which the author is allowed 

to work.

Note:  The next time the author or editor logs on, the templates menu will be deactivated 
and the explorer menu will display the directory allocated by the administrator as the 
editor's workspace.

11 Save your changes by clicking on the Save button.
12 You have completed this procedure.

34.2  Changing user settings
Use the following procedure to change user settings.

Procedure 73  Changing user settings

In the User Management main screen
1 Log into webEdition as "administrator".
2 Go to the user list in the explorer menu, and click on the user whose data you wish to 

change.
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The system displays the user Data view.

3 Make your changes.
4 Save your entries.
5 You have completed this procedure.

34.3  Deleting users
Use the following procedure to delete a user from webEdition.

Procedure 74  Deleting users

In the User Management main screen
1 Log into webEdition as "administrator".
2 Go to the user list in the explorer menu, and click on the user whose data you wish to 

change.
The system displays the user Data view.

3 Select the Delete command from the User menu.
4 When prompted by the system, confirm or cancel the action.

If you click OK, the selected user data will be deleted, the corresponding icon will disappear 
from the explorer menu, and the system will return to the User Management Module main 
screen.

5 You have completed this procedure.
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35  User Management PRO: Introduction
This introduction is intended to help you familiarize yourself with the webEdition User 
Management PRO Module. This chapter treats what the module does and how to install 
it. You can also find information here about the basic layout and command features for 
the User Management PRO Module. These topics are treated in the following sections:
• Section 35.1,  "What is the webEdition User Management PRO Module?" on page 

381.
• Section 35.2,  "Installation" on page 382.
• Section 35.3,  "General information and navigation" on page 382.

35.1  What is the webEdition User Management PRO Module?
The webEdition User Management PRO Module is designed to administer complex 
user structures. With this module you can set different permissions for working with 
documents, templates, directories and the system itself. Unlike the standard User 
Management Module, you can establish user groups with the PRO module. You can also 
create sub-groups on various levels. Each user can be assigned to individual or multiple 
groups. 

Each individual object (text area, images) in a document can be assigned access 
privileges so you can precisely define which individual users or group members are 
permitted to create or modify a document/object. Specific workspaces and templates (in 
whole or in part) can be allocated to users.

35.1.1  User Management PRO and your organization
The User Management PRO Module allows you to assign permissions for the editing of 
your web site in a manner that is suitable to the structures of your company. You can 
grant access permissions to specified areas of your web site to specified individuals or 
groups within your organization. For example, you can create workspaces that 
correspond to the departments in your company; you can create user groups called 
"PR", "Sales" and "Marketing" and assign workspaces and relevant templates to them. 
Each group can define a department manager as a group administrator who has more 
permissions within his or her group. Group administrators can create sub-groups or 
create new users for these sub-groups. When a template administrator creates your 
webEdition templates, you can assign users or groups to specific portions of a 
document. You can, for example, allocate a text area exclusively to the "Sales" group, 
while only the "PR" group would be permitted to edit the pictures to go with the text 
area. New attributes in the we:tags have to be defined for this to be possible.
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35.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

35.3  General information and navigation
After installing the User Management PRO Module, the command Change user 
(normally seen in the Options menu in the standard version of webEdition) will be 
replaced by the command User management in the Edit menu (see Figure 433).

Figure 433  The Options menu showing User management command

You will also see the option User management in the Modules menu (see Figure 434).

Figure 434  The Modules menu

Select User management from the Modules menu to open the User Management PRO 
main screen. The main User Management Module page opens showing the Quickstart 
screen (see Figure 435).
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Figure 435  User Management Module: Quickstart screen

Using the Quickstart screen, you have the option of going directly to a new user, a new 
group or to a new alias.

35.3.1  The User Management PRO User menu
The User Management PRO Module User menu has the following items (see Figure 
436).

Figure 436  The User menu

•Save. This command allows you to save the current 
user(s), group(s), or alias(es).
•Delete. This command allows you to delete the current 
user(s), group(s), or alias(es).
•Exit. Use this command to exit the module.

• New. The New menu has the following sub-items (see Figure 436,  "The User menu" 
on page 383):
— User. This command allows you to create an identity for a user in the system.
— Alias. This command allows you to create a copy of an individual user's main 

identity
— Group. This command allows you to create a group or sub-group of users.
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35.3.2  The User Management PRO explorer menu
The explorer menu in User Management PRO Module is structured like the menu used 
for documents and templates. There are two types of icons as seen in Figure 437: 
• icon of a group
• icon of an individual user

Figure 437  Explorer menu: individual and group icons

The group icon can represent members and sub-groups. You can view the members and 
the sub-groups of a group by clicking on the plus "+" icon next to a group symbol (see 
Figure 438). The sub-groups can also contain users and groups of their own.

Figure 438  Explorer menu users and groups

Since individual users cannot have any "sub-users", they are one-level 
in nature. Users that appear in blue colour in the explorer menu are 
"aliases".

35.3.3  The User Management PRO Module main screen
The main screen is designed to allow you to enter and change data about your users and 
groups.To access the main screen, go to the explorer menu and click on the user or group 
whose data you wish to view or change.

The edit mode of the User Management PRO Module has three tabs, Data, Permissions 
and Workspace. You can access the associated views by clicking on the respective tab 
(see Figure 439).

Figure 439  User Management PRO area tabs

Each of these views is discussed in more detail below.

35.3.3.1  The Data view
The Data view stores all the personal data of a particular user (see Figure 440). Only 
the administrator can change this information.
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Figure 440  The Data view

35.3.3.2  The Permissions view
The Permissions view allows administrators to allocate permissions for a user (see 
Figure 441). 

Note:  Your view of the Permissions will vary depending on what modules you have 
installed.

Figure 441  The Permissions view

The permissions are divided into the following options:
•"Permissions for installed modules". The webEdition 
modules have permissions that can be customized in the 
Permissions view of the User Management PRO 
Module. These options will vary depending on what 
modules you have installed. For information on how to 
set these permissions, see the documentation for the 
individual modules.

Note:  If you have not installed all modules listed in 
Figure 441,  "The Permissions view" on page 385, you 
will not be able to see these permissions in User 
Management PRO Module.

•Work permissions. In this area, you can assign any 
permissions related to working on documents and templates.

• Control permissions. In this area, you can assign any right related to the 
administration of users and groups.
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Click the arrows next to the permission options to reveal a series of check boxes 
indicating all the permissions that you can assign to your users.

35.3.3.3  The Workspace view
The Workspace view allows administrators to assign workspaces and templates to a user 
or group of users.

In the Workspace view, you can allocate users to fixed workspaces and special template 
sections. You can also assign more than one workspace or template section to a user by 
clicking on the "+" (plus) button. When users login to webEdition using the login data 
assigned to them in the Data view, the explorer menu will display only the workspaces 
allocated to them and they will only be able to use their assigned templates (see Figure 
442).

Figure 442  The Workspace view

The Workspace view has the following areas:
• Workspace documents and Workspace templates. These areas have similar user 

controls. The checkboxes in Workspace documents and Workspace templates 
sections allow you to assign to users the workspaces and templates from the groups 
in which they are members. The trash bin icon allows you to delete the access to 
workspaces and templates for a particular user.
If you activate the Default checkbox in the Workspace documents area in 
conjunction with the Database/Object Module, you can assign default status to the 
workspace for which you intend to create new objects. The default workspace is the 
only workspace in which you can create objects based on the classes allocated in the 
Database/Object Module.

• Start document for SeeMode.
The User Management PRO Module allows you to assign a start document to a user 
who logs into webEdition in Super-Easy-Edit-Mode (SeeMode). Once a specified 
document has been selected, that document will automatically open for the user as 
soon as he/she logs in. For further details about the SeeMode, see The webEdition 
User Guide.
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36  Creating users, groups and "aliases" 
in the User Management PRO Module

This chapter is intended to show you how to create new users, user groups or aliases by 
using the webEdition User Management PRO module. The following topics are treated 
in this chapter:
• Section 36.1,  "Creating a new user" on page 387
• Section 36.2,  "Creating a new group" on page 390
• Section 36.3,  "Administering group membership" on page 391
• Section 36.4,  "Creating an alias" on page 392

36.1  Creating a new user
Use the following procedure to create a new webEdition user. When creating a new user 
you will be required to enter information in each of the areas that were described in 
Section 35.3.3,  "The User Management PRO Module main screen" on page 384. This 
procedure has three parts, each part corresponds to an area (Data, Permissions or 
Workspace) in edit mode.

Procedure 75  Creating a new user

 In the User Management PRO Module main screen (Part 1: the Data view)
1 To create a new user, click User > New > User in the User Management PRO Module.
2 Select the Data tab.

The system opens the Data view (see Figure 443).

ATTENTION
Only an administrator and users who have been granted the appropriate 
permissions in the User Management PRO Module can create and 
maintain users and user groups. These options will not be available to 
you if you are not an administrator, or if you have not been given 
permission by the administrator to create, change or delete users or user 
groups.
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Figure 443  The Data view

3 Enter all user-related information in the General data area.
4 Allocate user names and passwords to new users in the User data area so that they can log 

in.
5 Assign the new user to a group in the Group section if they are to have their main identity 

within a group.
6 You have completed Part 1. Go to Part 2.

(Part 2: the Permissions view)
7 Go to the Permissions view by clicking the Permissions tab.

The system opens the Permissions view (see Figure 444).

Figure 444  The Permissions view

8 Click on the arrow next to Work permissions to reveal a series of check boxes indicating all 
the work permissions that you can assign to your users.
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9 Assign the work permissions by selecting the appropriate checkboxes (see Figure 445 for 
a partial list of work permissions).

Note:  The designation “Create” always refers to the menu item File > New. If any 
permissions are not available, the functions will be grayed out in the File menu.

Figure 445  Work permissions

10 Click on the arrow next to Work permissions to minimize the view, then click on the arrow 
next to Control permissions to reveal a series of check boxes indicating all the control 
permissions that you can assign to your users.

11 Assign the control permissions by selecting the appropriate checkboxes (see Figure 446).

Figure 446  Control permissions

12 Click on the arrow next to Control permissions to minimize the view.
13 If you wish the user to have full administrative permissions, select the Administrator 

permissions check box that appears under the permission options (Refer to Figure 444,  
"The Permissions view" on page 388). Otherwise, leave this box unchecked.

14 If you want your user to inherit the existing rights from a parent group, use the last checkbox 
in the Permissions area, otherwise, leave this box unchecked.

(Part 3: the Workspace view)
15 Click the Workspace tab.

The system opens the Workspace view as seen in Figure 447.
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Figure 447  The Workspace view

16 If you wish to assign to a user the same workspaces and templates that have been assigned 
to the group to which that user belongs, activate the checkboxes in Workspace documents 
and/or Workspace templates. Otherwise go to Step 17.

17 Click on the plus button below the checkboxes.
A field appears that allows you to select a workspace (see Figure 448).

Figure 448  Selecting a workspace

18 Click the Select button to access a list of your directories from which you can choose the 
document or template you wish to assign to your user.
The system opens a Look in server browser (see Figure 449).

Figure 449  Look in server browser

19 Click the appropriate folder name, then click the OK button.
The name of the workspace or template will appear in the field to the left of the Select 
button.

20 Click the Save button at the bottom of the page.
21 You have completed this procedure.

36.2  Creating a new group
Use the following procedures to create a new user group. As above, in Procedure 75,  
"Creating a new user" on page 387, you must enter data into each of the three areas: the 
Data, Permissions, and Workspace areas.
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Procedure 76  Creating a new group

 In the User Management PRO Module main screen (Part 1: the Data view)
1 To create a new group, click User > New > Group in the User Management PRO Module.
2 In the Data view, enter all group-related information in the Group data area (see Figure 

450).

Figure 450  Group data area

Note 1:  The new group can be assigned to an existing group as a sub-group in the 
Group section.

Note 2:  A new group will not yet have any members. Therefore the User area under the 
Group data area will be empty.

(Part 2: the Permissions view)
3 The Permissions view for the creation of a new group is the same as that for an individual 

user, with one exception: a group can never possess administrative permissions. Go to 
Procedure 75,  "Creating a new user" on page 387, and complete Step 7 to Step 14, then 
go to Step 4 of the present procedure.

(Part 3: the Workspace view)
4 The Workspace view for the creation of a new group is the same as that for an individual 

user. Go to Procedure 75,  "Creating a new user" on page 387, and complete Step 15 to 17 
then return to the present procedure.

5 Select the Save button at the bottom of the page.
6 You have completed this procedure.

36.3  Administering group membership
Use the following procedure to add, change or delete members in a group.

Procedure 77  Adding and editing group members

 In the User Management PRO Module main screen
1 You can assign new and existing users to a group. Do one of the following sub steps:

a To assign a new user to a group, see Part 1 of Procedure 75,  "Creating a new user" on 
page 387. 

b To assign an existing user to a group, go to the explorer menu and click on the icon of 
a user, then change that user’s group affiliation by clicking the Select button adjacent 
to the Group field in the Data > User data view.
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Figure 451  Assigning a user to a group

All members of this group will be listed in the User section. The icon representing the user 
also appears in the explorer menu in their assigned group folder

2 To edit the members of a group, highlight a user and click the Edit button.
The system opens the Data view for the user you have selected. There you can edit the 
user profile and change the group affiliation.

3 You have completed this procedure.

36.4  Creating an alias
Each user has only one main identity—either as an individual user or as a member of a 
group. Users whose main identity is already assigned to another group use "aliases" 
(that is, another name), to join one or several additional groups. An "alias" is a copy of 
an individual user's main identity. This copy can be assigned to the group and is 
indivisibly linked to the main identity of the user.

Procedure 78  Creating an alias

In the User Management PRO Module main screen
1 Click on User > New > Alias.

The Data view appears (see Figure 452)

Figure 452  The Alias view Data area

2 To allocate an "alias" to an existing user, use the Select button adjacent to the User field to 
browse the user list and to find the user's main identity.
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3 Create an alias for the user by assigning him or her to another group. To do so, click the 
Select button adjacent to theGroup membership to find the group that will include the new 
"alias".

4 You can use the checkboxes in the Permissions and workspaces area to assign to the 
"alias" the permissions, documents, and the templates of the parent group.

5 Click Save.
“Aliases" are displayed in blue in the explorer menu as seen in Figure 453.

Figure 453  Alias in the explorer menu

“Aliases” are displayed in square brackets in the User member summary for the groups in 
the Data view (see Figure 454)

Figure 454  Alias in a the group

6 You have completed this procedure.
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37  User Management PRO Module tags 
and functions

The following we:tags have been expanded to include a new attribute, user, for the 
User Management PRO Module:
• <we:flashmovie>

• <we:href>

• <we:img>

• <we:input> (all types)

• <we:textarea>

All these functions can be controlled directly using the User Management PRO Module. 
If you set the user attribute in these tags, you will be able to limit the function of that 
particular the we:tag to the users and groups specified in the user attribute. These 
attributes will remain in effect no matter what global permissions are assigned to 
individual users and groups in the Permissions area in User Management PRO Module. 
For example:

<we:textarea name="Text" cols="60" rows="30" dhtmledit="on"
showMenus="on" autobr="on" user="writer"/>

This example shows how you can limit the access to a single user, in this case the text 
area called Text can only be edited by the user called writer.

For further information about the advanced uses and syntax for the user attribute, 
consult the webEdition Tag Reference Manual at 
http://www.webedition.de/english/downloads/Documentation.html
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38  Voting Module: Introduction
This chapter is intended to help you familiarize with the webEdition Voting Module and 
its features. This chapter treats what the module does and how to install it. You can also 
find information here about the basic layout and command features for the Voting 
Module. These topics are treated in the following sections:
• Section 38.1,  "What is the Voting Module?" on page 397
• Section 38.2,  "Installation" on page 397.
• Section 38.3,  "General information and tips on navigation" on page 397.

38.1  What is the Voting Module?
With the webEdition Voting Module, you can easily create and maintain votings on your 
webEdition site. The installation and handling of the Voting Module corresponds to the 
webEdition Look&Feel; you therefore do not have to perform complicated 
configurations to offer this additional service to your visitors.The analysis of the votings 
is embedded seemlessly in the webEdition design philosophy and can get you and your 
customers informative insights about your web site visitors. The Votings are 
administered layout-neutrally in the webEdition GUI and are integrated with voting 
specific we:tags seemlessly into your page.

The Voting Module particularly appeals to users who want to generate day-actual 
information for themselves and their visitors from a webEdition web site.

38.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL:: http://webedition.de/en/serviceCenter/docu.php

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

38.3  General information and tips on navigation
After the installation, a new menu item appears in the webEdition Modules menu. See 
Figure 455,  "Modules Dropdown Menu" on page 398.
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Figure 455  Modules Dropdown Menu

38.4  Start Module
To open the Voting Module, click on Voting Module... from the Modules 
Dropdownmenu on the webEdition mainscreen. The Quickstart screen will appear, as 
shown in Figure 456.

Figure 456  Voting Module: Quickstart Screen

In the Quickstart screen, you can directly create a new voting or a group.

38.4.1  Voting Module Explorer menu
The explorermenu on the left hand of the screen shows a list of your votings and groups 
(see Figure 457).
Standard   3.4.1   15. July 2005  



Voting Module: Introduction   399
Figure 457  Voting module explorer menu

38.5  The menus
Click Modules > Voting Module to access the module window(see Figure 456). Here 
you can find the Voting and the Help menu.

38.5.1  The Voting dropdown menu
In the dropdownmenu Voting, the following items are located (see Figure 458).

Figure 458  Voting dropdown menu

• New (Voting/Group) Click New >Voting / Group to define a new Voting resp. a new 
group.

• Save Click Save to permanently save your voting or group.
• Delete Deletes the currently selected voting or group.
• Quit Leave the module window and return to the webEdition main screen.

38.5.2  Help-dropdown menu
In the Help-dropdownmenu you will find the following items (see Figure 459).

Figure 459  Help dropdown menu

•Help. This item provides Help screens.
•Info. This item provides information about the application.

38.6  Voting Module views
The webEdition Voting Module consists of the following views, which can be accessed 
via the respective Tabs: Properties, Inquiry and Result.

38.6.1  The Properties view
The basic settings for your voting are defined in the properties view.

Select Voting > New from the Voting menu to access the Properties view(see Figure 
460):
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Figure 460  Properties view

The Properties view consists of the areas Properties, Revote control and Validity.
• Properties: Give your Voting an unequivocal name. You can also add your voting to 

an existing group which you can select by clicking on Select. The Create Date 
dropdown menu serves to be able to enter by hand a data which can be read out and 
be used as a sort criteria; it does not schedule time-controled publication! For this 
purpose, you would have to use the webEdition Scheduler Module (PRO). To quit 
a Voting time contoled, please use the function Validity. The check box Limit access 
appears only if the User management (PRO) is installed. Activate this check box 
and select user(s) who may access the Voting to limit the access.

• Revote control: Here you can determine, whether, and if so in which intervals, users 
can vote for the Voting once more. Select your preferential method with the 
radiobuttons By Cookie or By IP and determine with the Dropdownmenu a least 
interval to a possible new voting. You find explanations to both methods in the info 
box above the radiobuttons which you can enlarge by clicking the triangle.

• Validity: The check box Active till must be activated, so that the voting on your site 
is saved and is "parked" at the end of the validity. Determine with the 
dropdownmenus the data and time to which the voting should run. No more votes 
are accepted from this time. You can, of course, switch the voting state at any time.

ATTENTION
Please note, that the method By Cookie requires the 
<we:writeVoting/> tag to be in the very first line of the 
template where it is used!
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38.6.2  The Inquiry view
This view consists of the area Inquiry Data (see Figure 461).

Figure 461  Inquiry view

In this area the following elements are loacated:
• Version dropdownmenu: You can define different versions of your voting. This 

makes sense, for example, with different language versions. Then the results of the 
different languages are evaluated together and displayed in one result overview.

• Question: Enter here the text of your question, as it should be displayed on your 
page. If you are planning to use multiple Versions, select the correct Version from 
the dropdownmenu and enter the question.

• Answers: Enter the possible answers in the text fileds. Click on the + symbol to add 
answer textfields.

Note:  At least two possible answers have to be given.

38.6.3  The Result view
This view consist of the areas Inquiry and Export. In the Inquiry area, the actual result 
of the voting is displayed. The result consits of the answers of all (language-) versions 
of the voting. Click on Reset Scores to set the voting to zero. The result is displayed in 
absolute numbers as well as in per cent. The bar chart makes it easy to rate the result.
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Figure 462  The Result view

In the Export area, you can export your voting results as a CSV file. For the exact 
procedure, please see proecedure 82.
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39  Using the Voting Module
In this chapter the following topics are treated:
• Section 39.1,  "Create a new Vote" on page 403
• Section 39.2,  "Vote groups" on page 405
• Section 39.3,  "Vote result" on page 405

39.1  Create a new Vote
Votings in the webEdition Voting Module are created very easy in the module window. 
Click Voting > New > Voting or New Voting in the Quickstart, to create a new voting.

Procedure 79  Define a new vote

In the Voting Module main screen
1 Select a name for your voting. Enter it in the corresponding field in the Porperties area
2 Press the Select Button to assignthe voting to an existing group
3 Specify now the Create Date by using the dropdown menu. Please note, that this concerns 

the date published; this is not a function for scheduld publishing of the Votings. For that 
task, please use the webEdition Scheduler (PRO) Module. You can, nontheless, determine 
the validity of the voting in the Validity area, which is treated further below.

Figure 463  Voting Properties

4 You can limit the access to the voting to certain users by using the Linit access button. You 
are then able to add users by using the Add Button.

Note:  This function is only available if the webEdition User Management (PRO) is 
installed
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Figure 464  Revote Control

5 In the Revote Contol area, you can determine whether, and in which intervals users may 
vote once more in a Voting. The setting never in the dropdownmenu means, that the user 
only may vote once, while the setting always, that he can voten as often as he wants to. In 
addition, there are the settings 1 day, 1 hour, 30 minutes and 15 minutes. 

6 With the radiobuttons By Cookie and By IP you can determine, how the interval should be 
checked. The default setting is By Cookie. In this setting, a Cookie is set for the user, which 
enables the Voting Module to identify the user. The advantage of this method is that also 
Votes of different users from a company net which presents itself outwardly with only one 
IP can be evaluated. Also it prevents in this way that, if an user gets assigned a new IP , 
e.g., by a new dialing with his provider and thereby could vote anew. The disadvantage 
consists in the fact that some users could have deactivated cookies in their browsers. You 
can handle this threat by activating By IP, then have to count, however, on abovementioned 
disadvantages.

Figure 465  The Validity area

7 Enter now the Validity of your voting and set it to Active. When the validity has ended, no 
more votes will be counted.

8 Click now on the Inquiry tab to enter your question and answers
The Inquiry view is opened

Figure 466  Inquiry view

9 Enter your voting´s question in the Question field
10 Enter the possible Answers; by clicking the “+” button, you can add additional answers.

Note:  There have to be at least two possible answers
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11 If you plan to create multiple versions of the question, e.g. to offer different language 
versions on your site, select Version 2, Version 3 ... from the dropdown menu , and enter 
the respective questions and answers.

Note:  Pay attention please to the fact that with different (Linguistic) versions the single 
responses of the versions correspond correctly, because the result would be otherwise 
falsified!

12 Click now on the Save button
13 You have successfully created your voting

39.2  Vote groups
Vote groups serve the organistaion of your votings. Thus they can be organized 
thematically coherent in groups and be evaluated better or be displayed sorted on your 
page.

Procedure 80  Creating a Vote group

In the Voting Module window
1 Select Voting > New > Group from the voting menu or New Group from the Quickstart

The Votinggroup window opens

Figure 467  Voting group

2 Enter a name for the new group.
3 Click the Select button to create the new group as a sub group of an existing one.
4 If the User Management (PRO) is installed, you can Limit access for certaon users.
5 Click the Save Button

The system confirms the storage process. The newly created group is now displayed in the 
explorermenu to the left (see Figure 468)

Figure 468  New Group in explorermenu

6 The new group is created and you can now assign your votings to this group.

39.3  Vote result
Now it is time to look at the results of your votings.
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Procedure 81  Display result

In the Voting Module window
1 Select the desired voting from the explorermenu to the left
2 Click on the Result tab

The result view opens

Figure 469  Result view - Inquiry area

3 Click on the Reset Scores button to set the result to zero again. You may also alter the 
results manually and save them by clicking Save.

To be better able to evaluate the result of your votings also graphically , an export 
function for your data in the common CSV (Comma seperated value) format is 
integrated in the webEdition Voting Module. As an example we will perform an export 
into a spreadsheet, here OpenOffice.

Procedure 82  Export the results into a spreadsheet

In the Voting Module
1 Select the desired voting from the explorermenu to the left.
2 Click on the Result tab

The result view opens

Figure 470  Result view - Export area
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3 Now set your preferences:
• Click the Select button, to choose a directory for the export. Per default the export will 

be saved in the root directory (/)

Figure 471  Select file format for the Export

• Select a File format from the dropdownmenu which corresponds with your OS
• Set the Delimiter and Enclose character settings for the Export. Usually you can 

maintain the defaults (semicolon and double qute), as you can define them at the import 
in the spreadsheet.

4 When you finsihed your settings, click the Export button
The window Download CSV file opens

Figure 472  Download CSV file

5 Use your right mouse button to click on the link and save the CSV file on your local hard 
drive

Figure 473  Save CSV file

Note:  This procedure depends on your OS and browser; in our example,we use Mozilla 
Firefox on a Windows XP Operating System

6 Select a filename and set the file extension to .csv (siehe Figure 474)
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Figure 474  Setting filename

7 Click on Save
8 Open the file in your spreadsheet (in our example we use OpenOffice)
9 Select the import options according to the choices you made during the export (see Figure 

475)

Figure 475  CSV-Import in Open Office

10 Click OK
The data of your voting is opened in the Open Office spreadsheet

11 Now you can easily save, process or evaluate graphically your data from the spreadsheet
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Figure 476  Voting data in Open Office

12 This procedure is finished

Note:  Analogously to the described approach the data takeover works of course in other 
software which can process CSV files as for example Microsoft Excel or similar
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40  Practical examples for the template 
design

This chapter shows you how you can insert Votings in your page. You can find these 
examples in the directory Demo which comes with every webEdition installation from 
version 3.4 on.

The following topics are treated in this chapter:
•  40.1  "Creating a template for a Vote" on page 411
•  40.2  "Displaying the Vote result" on page 412
•  40.3  "Summary page for multiple Votes" on page 414

40.1  Creating a template for a Vote
To display a voting on a webEdition page, the template must contain a <we:voting> 
tag. The tag <we:votingSelect/> is used to select a voting. With the 
<we:votingField> tag, you can select single fields of a voting. <we:answers> appeals 
to the answers of the voting. Please refer to the template /we_demo/voting/voting.tmpl 
in the actual we_demo.

Example 

<we:voting name="voting">

The Voting named “voting” starts here
<we:form id="240" method="post">

The result will be sent to the document with the id 240, after a vote has been cast. 
After a click on result, the document with the id 240 will be called, too

<we:votingSelect firstentry="----" submitonchange="true" />

A selectbox with your Votings is displayed for the editor to choose from
<input type="hidden" name="votingId" value="<we:votingField 
name="id" type="voting" />" />

In our example, the same page should be used for “Result” and “Send Vote ”. The 
result page thus must not be adjusted to which voting should be displayed. These are 
the possibilities: a vote was given and sent, then the fitting voting will be 
automatically selected. If no vote was cast, nothing will be sent, and thus the voting 
can not be detected automatically, thus the voting id is sent.

<h2><we:votingField name="question"></h2>

The Voting question is displayed
<we:answers>
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<li><we:votingField name="answer" type="radio" 
class="votingAnswer"><label for="<we:votingField name="id" 
type="radio">"><we:votingField name="answer" 
type="text"></label></li>
</we:answers>

The answers of the selected voting are displayed with radiobuttons for selection
<input type="submit" value="Send" />
<input type="submit" value="Result" />

Teh vote can be cast or the Result can be displayed
</we:form>
</we:voting>

Voting part of template finished
This displaysshows a simplified variantn free of layout, of the template voting.tmpl 
on which the document voting.php is based. It contains all tags which are necessary 
to give the possibility to the editor to be able to select a voting which was created 
with the Voting Module, simply in the document. See Figure 477 for a document 
which is based on the template

Figure 477  Simple Voting

40.2  Displaying the Vote result
Now we display the result of the above Voting on a result page. In this case, we keep to 
a simplistic variant of the demo template /we_demo/voting/result.php. 

Note:  Please note the <we:writeVoting /> tag has to be in the very first line of your 
template!

Example 

<we:writeVoting />

Use this tag to write a cast vote into the Database
<we:ifVarEmpty match="votingId" type="request">

If no votingId is submitted (e.g. because no voting was selected), the default voting 
is displayed

<we:setVar to="request" nameto="votingId" value="6" />
</we:ifVarEmpty>
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The default votingId is set to “6” here; this depends on your individual IDs
<we:voting name="voting" id="\$_REQUEST['votingId']">

The result of the above defined name “voting” and the submitted ID will be 
displayed here

Voting from: <we:votingField name="date" type="text" 
format="d.m.Y" />
<br />
<br />

The set date of the Voting is dispalyed
<table class="voting" summary="This table contains the 
Voting<we:votingField name="question" type="text" /> from 
<we:votingField name="date" type="text" format="d.m.Y" />">
<tr>
<th colspan="2"><we:votingField name="question" type="text" 
/></th>

The question is displayed
<tr>
<we:answers>

The answers are listed
<tr>
<td class="answer"><we:votingField name="answer" type="text" 
/></td>

The text of the answer is displayed
<td style="width: 150px;"><div style="background: yellow; width: 
<we:votingField name="result" type="percent" />%; height: 
12px;border:1px solid red;" /></div></td>

Beams are generated which show the proportional distribution on the responses
<td><we:votingField name="result" type="percent" />%</td>

The percantage is displayed
</tr>
</we:answers>
</tr>
</table>
<br />
at <we:votingField name="result" type="total" /> cast votes

The total number of cast votes is indicated
</we:voting>

Here, too, the result is a simplistic version of the result page result.php from the 
webEdition Demo
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Figure 478  Voting Result

40.3  Summary page for multiple Votes
Now we create a template with which we can display an overview of several Votings. 
Compare moreover to the template /we_demo/voting/archive.tmpl from the webEdition 
Demo

Example 

<we:votingList name="voteList" groupid="0" rows="10" desc="true" 
subgroup="false">

With the <we:votingList> Tag you create a list of your votings. In this case with the 
groupid “0”; i.e. all votings. By means of groupid you can quite simply create 
overviews of groups of summarized Votings. Use this function to be able to display 
specially themed groups separately

<we:repeat>
<br />
Umfrage vom: <we:votingField name="date" type="text" 

format="d.m.Y" />
<br />
<br />
<table class="voting" summary="This table contains the 

voting<we:votingField name="question" type="text" /> from 
<we:votingField name="date" type="text" format="d.m.Y" />">

The date of the voting is dispalyed
<tr>
<th colspan="2"><we:votingField name="question" type="text" 

/></th>

Displays the question
<tr>
<we:answers>
<tr>
<td class="answer"><we:votingField name="answer" type="text" 

/></td>

Shows the answers
<td style="width: 150px;"><div style="background: yellow; 

width: <we:votingField name="result" type="percent" />%; height: 
12px;border:1px solid red;" /></div></td>

Creates beams for the results
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<td class="result"><div 
class="resultPercent">&nbsp;<we:votingField name="result" 
type="percent" /> %</div><div class="votingBar" style="width: 
<we:votingField name="result" type="percent" />%;"></div></td>

The proportional distribution of the replys is indicated
</tr>
</we:answers>
</tr>
</table>
<br />
at <we:votingField name="result" type="total" /> cast votes

Shows the total number of votes
<br />
</div>
</we:repeat>
</we:votingList> 

Figure 479  Voting summary
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41  Workflow Module: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Workflow Module. This chapter treats what the module does and how to install it. You 
can also find information here about the basic layout and command features for the 
Workflow Module. These topics are treated in the following sections:
• Section 41.1,  "What is the webEdition Workflow Module?" on page 417
• Section 41.2,  "Installation" on page 418
• Section 41.3,  "General information and navigation" on page 418

41.1  What is the webEdition Workflow Module?
The webEdition Workflow Module allows you to create processes and to track all the 
steps required by you and your colleagues in the development of your web content.

Using the Workflow Module you can easily create sophisticated processes that 
streamline the administration of your content management operations.

You can automatically create authorization levels among the users within your 
organization, and assign to them their respective tasks. All tracking and notification 
functions are handled by the Workflow Module, removing the need for manual 
reporting using traditional methods such as E-mail, telephone or other tracking systems. 
The rights to create a workflow and to change documents in the workflow are controlled 
by the User Management Modules.

The Workflow Module complements the User Management PRO Module and the 
Task/Messaging Module.

ATTENTION
The Workflow Module requires the User Management Module (either 
the Standard or PRO version). You must install either the Standard or 
the PRO version of the User Management Module in order to use the 
Workflow Module.
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41.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.

41.3  General information and navigation
Once you have installed the Workflow Module, Workflow will appear as an option in the 
Modules drop-down menu (see Figure 480).

Figure 480  Modules drop-down menu

41.3.1  Opening the Workflow Module
From the Modules drop-down menu, click on Workflow. The main Workflow Module 
page opens showing the Quickstart screen (see Figure 481):

Figure 481  Workflowt Module: Quickstart screen

Using the Quickstart screen, you have the option of going directly to a new workflow.

41.3.2  Workflow Module drop-down menu
The following items appear under the Workflow menu (see Figure 482,  "The Workflow 
menu" on page 419):
• New. Use this command to create a new workflow process.
• Save. Select this command to save the workflow.
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• Delete. Select this command to delete the workflow.
• Empty logbook. Use this command to modify what is saved in your workflow log 

files. Each document or object has a separate log. The quantity of data can become 
very large over time. With the Empty logbook function you can administer the 
contents of the log. For example, you can delete items that are older than a defined 
date. For further information about logbooks, see Section 43.8.2,  "Using the 
logbook" on page 437.

• Close. Use this command to exit the Workflow Module.

Figure 482  The Workflow menu

41.3.3  The Workflow Module explorer menu
The Workflow Module is a stand-alone and independent element within the webEdition 
environment. Using the Workflow Module you define processes through which other 
elements in webEdition, such as documents, must pass.

The content of these documents and objects is not affected by the process of the 
workflow. Therefore, different documents and objects can be assigned to different 
workflows. You can create unlimited workflows. (In theory you can have as many 
workflows as documented objects, but ideally you define workflows and assign them to 
specified directories which are assigned to each workflow.)

Individual workflows are stored in webEdition and they appear in the explorer menu. A 
small "w" (signifying a "workflow") appears in the upper right corner of the directory 
(see Figure 483).

Figure 483  The explorer menu showing workflow items

If you click the plus "+" sign, all active documents in the workflow appear. Active 
documents are those which are not complete, and which have not yet been published.

If there are no documents or objects in a specific workflow, the workflow directory will 
appear empty.

41.3.4  The document Information view
The Information view allows you to check the status of your document. You can access 
the information about a document by going to the explorer menu, and clicking on the 
name of the document that you wish to examine. The system opens the Information 
page (see Figure 484).
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Figure 484  The Information view

The Information page records the following data:
• file type and size
• creation, modification and publication dates
• the Local path (file location on the local computer), and HTTP path (www location)
• workflow matrix (For more details about the workflow matrix, see Chapter 42,  

"Workflow design theory" on page 423.

41.3.5  The edit view of the Workflow Module
There are two views in the Workflow Module: Properties and Overview, each of which 
is accessed by its respective tab.

41.3.5.1  Properties view
Using the Properties view, you can name your workflow, and assign directories and 
document types as well as categories and objects to it (see Figure 485).
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Figure 485  The Properties view

41.3.5.2  Overview view
Overview. In the Overview view, you can define the form of the workflow as a matrix 
and the properties of each step in the workflow (see Figure 486).

Figure 486  The Overview view

The Overview area has four columns:
• The Step column shows the number of the respective serial step in the workflow.
• AND / OR signifies the Boolean operator and is used to define the relationship to 

adjacent parallel steps. Once you have more than one user assigned to a step, that is 
once you have parallel step, you must choose if the step is to adhere to AND logic 
(all named users must authorize the release of a document) or the "OR" logic (only 
one of the users needs to authorize the release).
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• Worktime (H) is the time (in hours) allotted for the completion of the task.
• User describes the user who has been assigned a task.
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42  Workflow design theory
The following chapter describe briefly the theoretical principles behind the workflow 
process under the following sub sections:
• Section 42.1,  "What are serial and parallel steps?" on page 423
• Section 42.2,  "Workflow design: a matrix" on page 424
• Section 42.3,  "What kinds of documents can be assigned to a workflow?" on page 

424
• Section 42.4,  "Who can create a workflow?" on page 425

42.1  What are serial and parallel steps?
Your business may require processes which are complex, and which include serial steps, 
or a combination of serial and parallel steps. Serial steps occur in succession; parallel 
steps occur concurrently. See, for example, Figure 487,  "Hypothetical workflow" on 
page 423.

Parallels steps have to be connected using Boolean Logic. Either you connect the two 
parallel steps with AND logic, in which case both people have to authorize the 
document before it is transferred to the next step. Or you may use OR logic, in which 
case only one of the two member needs to approve the document.

Figure 487  Hypothetical workflow
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In the example in Figure 487,  "Hypothetical workflow" on page 423:
1. The editor puts an article into the workflow.
2. The text goes to the content editor and the graphics editor. Because AND is used, 

both editors have to release the document before it can move to the next step.
3. In this step only one of the quality controllers needs to authorize the content 

(because OR logic has been selected).
4. The final decision is by the chief editor. The chief editor knows that the preceding 

steps have been accomplished according to the defined process. The chief editor 
has the right to publish the document.

42.1.1  User management
You can use the Workflow Module to define whether or not a person in the process has 
the permission to change a document. If the person to whom an item is sent does not 
have the permission to execute the request, the document is returned to the workflow 
for reassignment.

The Workflow module also allows you to generate an automatic E-mail to the person 
who has to review and release a work item.

42.2  Workflow design: a matrix 
The workflow is designed like an n by m matrix.

In theory you can define n different steps in serial (along a horizontal axis, parallel to 
the time x) and m different steps in a parallel direction (along a vertical axis, 
perpendicular to the time x). You can extend the workflow in both directions: parallel 
and serial. For example, see Figure 488.

Figure 488  An example of a 3X2 matrix

42.3  What kinds of documents can be assigned to a workflow?
Two types of webEdition documents can be assigned to a workflow:
• documents (webEdition pages, HTML pages)
• objects from the Database Object Module.
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Documents can be assigned to one of two workflow types: 
• Directory-oriented workflow. The workflow that a document needs to run through 

is defined by the directory where the document is saved. 
• Document type or a category. In this case the workflow applies to all documents of 

a given document type or category.

Objects-based workflows are always tied to an object class.

42.4  Who can create a workflow?
As noted in the introduction, the Workflow Module requires the User Management or 
the User Management PRO Module. Depending on the version of the User Management 
Module that you have installed, there are different options available to you with respect 
to who can create a workflow.

42.4.1  User Management Module (Standard version)
In the standard version only the administrator is allowed to create and change the 
workflow.

42.4.2  User Management PRO Module
User Management PRO Module allows you to assign to any user the right to create, 
change or delete a workflow (see Figure 489).

Figure 489  Permissions to define a workflow

For further information about the User Management Module and the User Management 
PRO Module, see the respective webEdition User Guides at the following URL: 
http://www.webedition.de/english/downloads/Documentation.html

42.4.3  Who has the right to publish?
The following users have the right to publish:
• users that have the right to publish according to the User Management Module

Note:  If a user has the right to publish according to the User Management 
Module, that person can publish at any time, thus finishing the workflow.

• users that are last in the workflow

Note:  The user at the last step of the workflow can publish even if this right has 
not been defined in the User Management Module.

Your ability to govern the publication rights of users varies depending on version of the 
User Management Module that you have purchased.
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The (standard) User Management Module offers the controls shown in Figure 490. You 
must determine on an individual basis, whether or not you wish to give a user the right 
to publish. You do so by clicking on the User is allowed to publish check box.

Figure 490  Publication permissions in the User Management Module

The User Management PRO Module offers a suite of control features in addition to the 
User is allowed to publish check box (see Figure 491).

Figure 491  Publication permissions in the User Management PRO Module

In the chapter that follows, we shall see how to create and manage a workflow.
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43  Creating a workflow
This chapter describes the procedures for creating a workflow and working on 
documents in a workflow. 

The rights to create a workflow and to publish a document are controlled by the User 
Management Modules. Some of the procedures described in this chapter, particularly 
those associated with creating a workflow, can only be completed if the a user has been 
assigned the appropriate permissions. For information on permissions, see Section 42.4,  
"Who can create a workflow?" on page 425.

The following procedures appear in this chapter:
• Section 43.1,  "Creating a new workflow" on page 427
• Section 43.2,  "Defining the steps of the workflow" on page 429
• Section 43.3,  "Setting the worktime variables" on page 430
• Section 43.4,  "Selecting the users in a workflow" on page 430
• Section 43.5,  "Using the in Workflow option" on page 432
• Section 43.6,  "Using E-mail messages within the workflow" on page 433
• Section 43.7,  "Using the Task/Messaging Module with the Workflow Module" on 

page 433
• Section 43.8,  "Examining the status of a document and using the logbook" on page 

436
• Section 43.9,  "Using the "Worktime exceeded" feature" on page 438

43.1  Creating a new workflow
Use the following procedure to create a new workflow.

Procedure 83  Creating a new workflow

At the Workflow drop-down menu in the Workflow Module main screen 
1 Click Workflow > New.

The system opens the Properties view as seen in Figure 492.
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Figure 492  Creating a new workflow: the Properties view

2 In the Name field of the Properties view, type the name you wish to give to your new 
workflow.

3 In the area under the Name field, define which documents or objects need to pass through 
the workflow prior to publication. There are three options: Directory-based, Document 
type/Category-based, or Object-based.
a If you wish to create a directory-based workflow, do the following sub-steps:

i Click on the button beside the words Directory-based.
ii Click on the add button in the file manager, and choose the document(s) that must 

pass through the workflow.
All documents in this directory need to pass through the workflow in order to be 
published.

Note:  You can also use this area to edit a workflow at a later date. To delete a 
directory, click on the "trash can" icon. To delete all items, click on the delete all 
button.

b If you wish to create a document-type/category-based workflow do the following 
sub-steps:
i Click on the button beside the words Document type/Category-based.
ii Choose a document type from the drop-down menu.
iii Click the add button under the Categories dialog box to access the category 

manager. The Category manager area opens and you can choose a category.

Note:  You can also use this area to edit a workflow at a later date. To delete a 
category, click on the trash bin. To delete all items, click on the delete all button.

c If you wish to create an object-based workflow, do the following substeps:
i Click on the button beside the words Object-based.
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ii Select which objects need to run through your workflow by clicking the add button.
The Object class manager window opens and you can choose the object class.

iii Click the add button under the Categories dialog box to access the category 
manager. The Category manager window opens and you can choose the category.

Note:  You can also use this screen to edit a workflow at a later date. To delete 
an object class, click on the trash bin. To delete all items, click on the delete all 
button.

4 You have completed this procedure.

43.2  Defining the steps of the workflow
The following procedure describes how to define the steps for a new workflow.

Procedure 84  Defining the steps for a new workflow

In the Workflow Module Overview view
1 If you are not already in the Overview view, go to the Overview view, by clicking on the 

Overview tab (see Figure 493).

Figure 493  The Overview view

2 Use the Overview view to define your workflow as an n X m matrix, and to define all 
functions of the workflow. Add steps to your workflow by doing the following:
a To extend the workflow by serial steps, click the plus "+" icon at the bottom left.

The workflow is now extended by one serial step (see Figure 494).

Figure 494  Adding a serial step to a workflow

b To extend the workflow in a parallel step, click on the plus "+" icon on the upper right 
corner (see Figure 495).
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Figure 495  Adding a parallel step to a workflow

3 You have completed this procedure.

43.3  Setting the worktime variables
After defining the steps in the workflow, you must assign a value to each step to indicate 
the time of its expected completion.

Procedure 85  Setting the worktime for a step

In the Workflow Module Overview view
1 In the Overview view (see Figure 493,  "The Overview view" on page 429), enter a value in 

hours in the Worktime (H) box. This value represents the maximum duration that the 
document can remain in this step.
For example, if you enter 24, the document remains for 24 hours in this position of the 
workflow.

2 If you wish the task to move to the next step (regardless of its completion), after the expiry 
of the allotted worktime, select the next step check box. If the option has not been activated 
the document will be returned to the sender.

3 You have completed this procedure.

43.4  Selecting the users in a workflow
Use the following procedure to select the users that are to be associated with each step 
in a workflow.

ATTENTION
Only users registered in the webEdition User Management Module 
can release documents.

ATTENTION: User Restrictions
If a user attempts to open a workflow document, and that user is not 
part of the workflow, he/she will be denied access to the document. A 
user that is not related to a workflow can view a document, but that 
user cannot change the document.
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Procedure 86  Selecting the users in a workflow

In the Workflow Module Overview view
1 In the Overview view (see Figure 493,  "The Overview view" on page 429), click the Select 

button to choose a user. 
The user manager area appears (see Figure 496).

Figure 496  User manager area

2 Choose a user by clicking on the appropriate name from the list of users.

Note:  If you do not want to add a user in a parallel step, leave the respective field empty. 
You must always choose a serial user.

3 Click the OK button.
The designated user appears in the workflow.

4 Choose additional users (if required) by clicking on the plus symbol at the top right side of 
the frame, and associate the users with their designated step in the workflow (see Figure 
497).

CAUTION 
 Risk of lock out
The user who creates a document is not part of the 
workflow. After he/she has put the document into the 
workflow he/she cannot make any changes to the 
document. If, however, that user has the right to publish, 
he/she can publish the document immediately.
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Figure 497  Users in a workflow

5 Select the edit check box to give a user the ability to make changes in the document or 
object associated with the workflow. If the edit check box is not activated, the user cannot 
change the document.

6 Select the send mail check box, if you want respective users to receive an E-mail as soon 
as a new document enters workflow or if the user has been sent a task. 
The E-mail is always sent to the person who is next in the release process. The system 
takes the E-mail address from the User Management or User Management PRO Module.

7 Save the workflow using the Save button on the lower left corner of the workflow screen 
(see Figure 498).

Figure 498  Saving and activating a workflow

8 Activate the workflow by selecting the Workflow is active check box (see Figure 498,  
"Saving and activating a workflow" on page 432).
If the workflow is not activated, the workflow is still saved, but it is not yet active for the 
related documents and objects. You can still publish these related documents and objects 
without the workflow. An inactive workflow appears in red.
Once the option workflow is active, all related documents can only be published after they 
run through the workflow. An active workflow appears in black in the workflow explorer 
menu. Only the user of the last workflow step can release a document for publishing.

9 You have completed this procedure.

43.5  Using the in Workflow option
After creating the steps in a workflow and assigning users to it, you need to assign a 
document to the workflow. You use the in Workflow button, which appears at the bottom 
of the webEdition main screen (see Procedure 87).

ATTENTION
The right to publish is always controlled by the User Management or User 
Management PRO modules. The last user(s) in the process hierarchy automatically 
has the permission to publish even if that right has not been defined in the User 
Management Module. In addition, if a user of a previously defined level of the 
workflow has a right to publish, he/she can publish the document in advance if the 
document object lies in his/her user space.
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Procedure 87  Using the in Workflow option

In the Documents view of the webEdition main screen
1 Click on the in Workflow button to place the document or object into a workflow.

The Document in workflow screen appears as seen in Figure 499.

Figure 499  The Document in workflow screen

2 Select the workflow from the Workflow drop-down menu.
3 In the Message field, include a short message to the person who is next in the workflow.

The person to whom you have sent the message will see your message in his/her task list.

4 Confirm by clicking OK.
If you do not confirm with OK, the object does not go into the workflow. Once you have put 
the document into the workflow, the document appears in red in the explorer menu.

5 You have completed this procedure.

43.6  Using E-mail messages within the workflow
Communication is important when using a workflow. People must be informed of their 
role in the workflow. There are two ways to communicate with your colleagues. You 
can use the following methods:
• an external E-mail system
• webEdition messaging

As discussed in Section 43.4,  "Selecting the users in a workflow" on page 430, all the 
people who have assignments in the workflow (including those who must check, 
forward, or release documents) have been designated to their tasks. You can define 
whether on not a user receives an E-mail describing their task (see Figure 497,  "Users 
in a workflow" on page 432). Once you place a document into the workflow, the system 
generates a standard E-mail message form, which includes a text box in which you write 
your message. The system also enters the E-mail address (as it is recorded in the User 
Management Module) of the next person in the workflow to whom the message is to be 
sent.

43.7  Using the Task/Messaging Module with the Workflow Module
The webEdition Workflow Module requires the Task/Messaging Module to work. The 
Task/Messaging Module helps you to send messages to the user who has been assigned 
to work on a document or object in the next step of a workflow.
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Once installed, the Task/Messaging Module produces two icons in the top right frame 
of the webEdition screen. The same icons are visible on the webEdition Quickstart 
screen (see Figure 500,  "Task/Messaging icons" on page 434):

Figure 500  Task/Messaging icons

•the envelope icon signifying a message
•the check mark icon signifying a task

If you click one of the icons, the Task/Messaging 
Module opens.

The tasks and messages of the Task/Messaging Module are used like a private E-mail 
box. The tasks and messages are intended for, and accessible to, a specific user, who has 
been registered in the User Management Module.

For a detailed description of the Task/Messaging Module and how to use it, see the The 
Task/Messaging Module User Guide at the following URL: 
http://www.webedition.de/english/downloads/Documentation.html

Using the Task file of the Task/Messaging Module, you can define all the tasks 
associated with a specific user. When a document is entered by an editor into the 
workflow, it appears in the task list of the next person in the workflow.

Procedure 88  How to process a task in the workflow

In the webEdition main screen
1 Once you log into the system you will see the number of unfinished tasks next to the task 

icon on the top right of your screen, or in the Quickstart screen as seen in Figure 500,  
"Task/Messaging icons" on page 434.
Click on the task icon.
 The system automatically opens the Task/Messaging Module, and task window appears 
with a list of your open tasks (see Figure 501).

Figure 501  Task notification

2 Click the workflow task that appears in your list.
A description of the task and a notice alert appears in the lower part of the window. A link 
to the document or object that needs to be worked on is automatically generated as seen 
in Figure 502.
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Figure 502  Details about a task

3 In the bottom frame of the page, click the Document link. 
The document (or object) opens for editing. At the bottom of the page are three option (see 
Figure 503).

Figure 503  Declining, forwarding or saving a task

4 As a recipient of a task, you have one of three choices. Do one of the following sub steps:
a Work on the task. You can work on the task in the open edit window and save your 

changes by selecting the Save button. (Thereafter you can forward the task, see Step 
c).

b Decline the task and send the task back to the originator.
i Select Decline. 

The Decline document dialogue box opens (see Figure 504).

Figure 504  Decline document dialogue box

ii Enter an explanation about why you are rejecting the task.
iii Click OK, then go to Step 5.
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When a task is declined, the system activates the task notification icon on the 
originator’s screen. When the originator opens the task, he/she sees your 
message, as shown in Figure 505.

Figure 505  Notification of a declined task

c Forward the task. 
After you have completed the work assigned to you, save your page, then select 
Forward to send the task to the next user in the workflow.
You receive an on-screen message from the system that the document has been 
passed on in the workflow. The next person in the workflow will receive a task 
notification.

5 You have completed this procedure.

Note:  If you decline or forward the document or object, a value of 100% will appear in 
the Status column of the task notification screen and the task will be saved in the Done 
folder where all tasks are saved. Rejected tasks will be saved in the Rejected folder in 
the explorer menu.

43.8  Examining the status of a document and using the logbook
There are two ways to examine the status of a document within the Workflow Module. 
You can access data about the progress of a document in the workflow by 
• checking the document Information view
• checking the log book

43.8.1  Using the Information view
The following procedure describes how to check the status of your document using the 
information view.
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Procedure 89  How to check the status of a document

In the Workflow Module
1 Go to the explorer menu and click on the name of the document that you wish to examine.
2 Click the Information tab.

The system opens the Information view (see Figure 506).

Figure 506  The Information view

3 Examine the matrix at the bottom of the Information view for the status of the document.
The matrix tells you about the steps, the user names of those involved in the workflow and 
the alloted worktime.

4 You have completed this procedure. If you wish to see details and the comments entered 
by users about completed tasks, see Section 43.8.2,  "Using the logbook" on page 437.

43.8.2  Using the logbook
The logbook is an archive of all workflow activities. It gives you information about all 
workflows so that you can always see who has done what and when. You can see the 
log report for each document by opening the Information view (as shown in Figure 506,  
"The Information view" on page 437) and selecting the logbook button at the bottom of 
the screen).

The logbook includes the following information in a tabular format (see Figure 507,  
"The logbook in the information view" on page 438):
• Action. This column describes what has happened to the document in the workflow.
• Description. This column provides a description of the task associated with the 

workflow step.
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• Time. Time of the action in the workflow.
• User. The person who performed the activity.

Figure 507  The logbook in the information view

43.9  Using the "Worktime exceeded" feature
The worktime exceeded feature informs users that they have exceeded the time allotted 
to an assigned task.

In order for the "Worktime exceeded" message feature to function, you must set up a 
PHP script on your server that will monitor the process of the tasks at regular 
intervals.You will find the script in the following directory: webEdition/we/include/ 
we_modules/workflow/weWorkflowCron.php.

If you are using a UNIX server, you set up this script using a chron job (to do so see 
Procedure 90,  "Creating a chron job on a UNIX server" on page 439). If you are using 
a windows server, use the Task Scheduler (to do so see Procedure 91,  "Creating a 
planned task using Windows" on page 439).

Note:  Not all Internet service providers offer these services. Contact your provider 
for availability.

43.9.1  Creating a chron job using UNIX
Prerequisites:
• The chron program must exists on the server
• you can run a PHP script via HTTP (that is, a text-based web browser or an HTTP 

downloader).

ATTENTION
If you do not set up the chron job or scheduled task, the automatic 
message feature informing users of the exceeded worktime will not 
function.
Standard   3.3.1   02 May 2005  



Creating a workflow   439
The chron program on a UNIX server can be lynx, wget, curl or a similar application. 
The chron job starts this program on a scheduled basis and gives it the URL of the PHP 
script. The program then starts the PHP script.

How to set up a chron job varies among Internet service providers. Many providers have 
a web interface. Contact your provider for further help, if necessary.

If your provider offers telnet or ssh or direct access via your terminal, you can set up the 
chron job by doing Procedure 90,  "Creating a chron job on a UNIX server" on page 439.

Procedure 90  Creating a chron job on a UNIX server

In a UNIX terminal window
1 At the UNIX prompt, type

crontab –e

This command opens the default editor of the server (normally a vi editor).

2 Write the following string:
0,10,20,30,40,50 * * * * Program 
http://www.YourDomain.de/webEdition/we/include/ 
we_modules/workflow/weWorkflowCron.php

In place of the variable, Program , type either lynx, curl or the name of the text-based 
browser or HTTP downloader you are using.
In the place of the variable, www.YourDomain.de variable enter your domain name.

Note:  In this example, the 0…50 indicates that the chron job will run every 10 minutes.
3 Save.
4 You have completed this procedure.

43.9.2  Creating a planned task using the Windows Task Scheduler
With a windows server you need a program that runs a PHP script or HTTP. You can 
use Internet Explorer, or another external program, such as wget.

Note:  We recommend wget for Windows. You can download it using the following 
link: http://www.interlog.com/~tcharron/wgetwin.html

Procedure 91  Creating a planned task using Windows

On your Windows desktop
1 Click on Start > Settings > Control Panel.
2 Click on Scheduled Tasks.

The task assistant opens.

3 Click continue.
4 A dialog appears where you choose the program you wish to use.
5 Select your program of choice (such as weget.exe).
6 Set up the time interval for the scheduled task.
7 Enter your user name and password, then click the Continue button.
8 Activate the check box for extended properties.
9 Click finish.
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10 Open the weget application.
11 In the weget application, insert the webEdition URL into the wget parameter settings.

http://www.YourDomain.de/webEdition/we/include/ 
we_modules/workflow/weWorkflowCron.php

12 Click on the Time plan tab.
13 Click on the Extended button, and define the following options:

a Activate the Repeat interval check box.
b Adjust the interval (for example, 10 minutes).
c Set the duration to 24 hours.
d Click OK.

14 Click on the Adjustment tab, and select the time after which the task must end (for example, 
1 minute).

15 Click OK.
The task is now defined and set up. It will appear in the Scheduled Task window.
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absolute reference
An absolute reference lists the path in webEdition starting with the HTML root 
directory. It always begins with a slash "/".

ASP
Active Server Pages.

BIN
Binary file. Also .bin.

Content image
See Layout image.

CSS
cascading style sheet.

Dynamic page generation
Dynamic page generation means that every time a page is called up, its content is 
retrieved from a database and inserted in the template. The program code of the 
page itself does not contain any text or calls to images; instead, it only contains a 
database reference. The advantage to this system is that internal links defined 
with we:tags remain current, even if the name of the linked page changes. 
Dynamic pages are generally used for summaries and search queries.

Front-end
A term user to describe the interface used by an end user such as a web content 
editor. In webEdition, the front end is what the editor sees when updating a Web 
site. In contrast, the back end refers to the operation of the MySQL database 
which stores your web content, but which is transparent to the end user.

HTML
Hyper-text markup language.

HQX
Binhex file (Macintosh). Also .hqx.

JSP
Java Script Pages.

Layout image
webEdition differentiate between layout images and images/graphics that are 
dependent on content. Layout images have no connection to the content and only 
affect the appearance of the page. Layout images that are already present in the 
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templates do not have to be imported to webEdition, since they do not have to be 
managed using the database.
Unlike layout images, content-related images or graphics (such as product photos 
or charts) are managed and edited with the webEdition system in the same way 
as texts.

PDF
Portable documentation format file (Adobe). Also .pdf.

Relative reference
HTML editing programs such as Macromedia Dreamweaver or Adobe GoLive 
generally create relative references. Relative references create URLs that always 
depend on the current directory. For example: The image has been saved 
in:C:/My Documents/html/WebEdition/images/image.gif and the page to which 
you wish to link the image has been saved in: C:/My 
Documents/html/WebEdition/news/sports/index.htm. If C:/My Documents/html 
is the root directory on the Web server (Apache, Microsoft Internet Information 
Server), then the absolute link would be: /images/image.gif, whereas the relative 
link would be ../../../images/image.gif

RTF
Rich text format file. Also .rtf.

SIT
Stuffit file. Also .sit.

Static page generation
When pages are generated statically, the actual entries are written directly to the 
program code when the page is saved. If the page is called up, it does not access 
the database. Should any changes be made to the page, the whole page will be 
re-saved. If any internal links defined in the template by we:tags change, all the 
pages based on this template must be re-saved. The advantage of static pages is 
that they do not need to access the database and can be loaded faster on 
high-traffic or slower servers. In addition, search engines always include static 
pages, whereas they occasionally omit dynamic pages. 

XML
Extensible Markup Language.
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Symbols
<we:banner> tag   159

used in banner name area   147
<we:tag> See we:tags

A
a tag

special attributes for
amount=   348
delarticle=   348
shop=   348

special functions in Shop Module   348
access controls

in the User Management Module   373
access to information

for logged-in users only   190
accessibility   49, 68, 111, 112

editing hyperlinks   105
editing table captions   107
editing tables   106
screen readers   104
validating your code   48

acronym editor for screen readers   104
Action column in logbook   437
Active Server pages. See ASP
add shop item tag   346
address book

importing an existing   266
using a CSV file   266

addressbook
User Management Module requirement   369
using   369

administrative rights   35
administrator permissions

User Management Module   377
administrators

knowledge requirements   35, 117
responsibilities   35
role of   117

Administrators role

photo album templates   131
advanced search (Customer Management PRO 
Module)   173
Advanced view

function described   45
PHP attributes in we:tags   45

set to false   45
set to true   45

alias
creating in User Management PRO Module   
392

All Customer’s Orders tab   321
all customers order’s

viewing   321
All view in customer management   169
AND /OR command   421
archiving pages   130
articleview   312
ASP

used in templates   64
attachments block   278
Attributes area in Flash movie Properties view   
93
Attributes area in images Properties view   85
Audience   29
audience profile   29
auto break settings   103
automatic E-mail function   424
automatic link to next/previous page   127
automatic naming

by day   209
by hours   209
by id   209
by month   209
by text   210
by year   209
unique   209
using   208

automatic publishing (Scheduler Module)   298, 
303

From command   303
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To command   303
automatic task generation using the Workflow 
Module   352

B
Backup

create   53
Backup recovery   53
Banner

sub-menus   143
banner campaigns

measuring the effectiveness of   141
banner code

create command   144
writing   161

banner explorer menu   144
banner groups

creating   145
multiple   148
naming   148

banner name area   147
Banner⁄Statistics Module

appearance in the Modules drop-down menu   
142
installation   142
interaction with other modules

Customer Management Module   141
interaction with the Customer Management 
Module   146
menus explained   143
opening   142
purpose of   141
user interface explained   142

banners
activating and deactivating   145
creating   149
displaying

for a specified period   146
on "external Web pages"   160
on one or more pages   147
on pages in a specified category   147
on pages in a specified directory   147
on pages in a specified document type   147
one or more specific banners on a page   160
without a link   160

formats for displaying   159
iframe in   160
ilayer in   160
JavaScript in   159
placing on a Web page   153
required we:tags   159
selecting images for   145
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setting properties for   149
viewing statistics on   153

barrier-free web sites   68
debugging code   48
features for screen readers   104, 105, 106, 107, 
111, 112
use of XHTML in   49

BIN files, importing   96
Black list

creating   287
in the Options menu   256

block types
attachment   278
described   273
document based   274
document field based   275
file based   276
object based   275
object field based   276
text based   277
URL   278

Browse Server command   53
buttons

function buttons   355
Launch Messaging System   353
Launch Task System   353
Messaging   353
messaging buttons

about   355
Copy message   356
Create message   356
Cut message   356
Delete message   356
Look for new messages   356
Paste message   356
Reply to message   356

task   353
task buttons

create new task   357
Forward task   357
Reject task   357
Task update status   357

tasks buttons
about   357

C
calculate

PHP functions   349
calculations

using we:calculate tag   349
using we:sum tag   349

cascading style sheet. See CSS
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Categories
command   54
creating   100
purpose of   54, 99

categories area   147
Categories area in Documents Properties view   
65
categories attribute used with list views   130
Categories field (Scheduler PRO Module)

changing   306
Change Change password command   55
Change directory (Scheduler PRO Module)   306
Change User Name

command   55
characters permitted in Name field   221
checkbox

for choosing email in HTML or text format   
293

checkboxes
using in templates   102

class summary
Fields view   203
Search view   205
Workspace view   202

Classes tab
and the classes explorer menu   205
Edit view   206
Information view   208
Properties view   206
using   205
Workspace view   207

class-ID   311
Clear logbook

in the Options menu   256
CMS

defined
code generation wizard   161
comma separated value file. See CSV file
common procedures

using the addressbook   369
common procedures for the task and messaging 
systems   368
confirming enrollment for a newsletter   295
confirming unsubscribe from a newsletter   295
connecting to a database   46
content images

defined   34
using   81

content management system. See CMS
converting image formats

JPEG   88
PNG   88
create shop tag   346
Create Voting   403
creating a workflow   427

directory-based   428
document-type/category-based   428
object-based   428

creating objects and classes
permissions   216

CSV data
importing   77

CSV file
creating a recipients list from   270
deleting an imported file   259
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customer management
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modifying   169
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displayed in explorer menu   73
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Properties view   74
thumbnail   46

directories area   147
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Document area in Documents Properties view   
64
document based block   274
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document type

changing   305
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Module)   305
Document types

command   54
creating   97
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deleting   99
editing   99
purpose of   54, 97
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documents
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deleting   71
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JavaScript   95
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in explorer menu   56
Properties view

Flash movie   93
HTML pages   92
JavaScript   95
Quicktime movie   95

saving and publishing   70
saving without publishing   70
searchable   65
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Preview   66
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dynamic pages

creating   64
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E
Edit CSV file
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Edit view
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with documents   65
with images   86
with templates   120

edit view
for messaging   359
for tasks   360

editing
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templates   124

Editing hyperlinks for screen readers   105
editing program

choosing a program   238
choosing an editing program   236
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changing   238
setting   238

using
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using a third-party HTML editor   242
Editing tables for screen readers   106
Editor Plug-in   44

about   235
automatically downloaded   236
license activation   44
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Editor view
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movie   57
object   57
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User Management Module   375
User Management PRO Module   384
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deleting   181, 215
modifying   169, 178
sorting   215

file based block   276
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Quickstart   54
Rebuild   53
Save   52
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files on server
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Flash movie
Edit view   93
Properties view   93

Flash movie fields
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Flash movies
fields in templates   113

folder settings
changing   354

form tag   348
formatting

thumbnails   88
Formmail recipients

function described   44
forms

emailing   138
forwarding expenses   333
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in the Scheduler PRO Module
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Frequency commands (Scheduler PRO Mod-
ule)   300

Once   306
From command (Scheduler Module)

used for automatic publishing   303
fromatting

thumbnails   88
fromatting images   88
function buttons

about   355

G
General view   168

fields in
Password   168
Username   168

graphical documents
used in webEdition   81

group administration
adding members   391

group area   145

H
Help

sub-menus   144
Help menu   55

Update   55
Help menu (User Management Module)   375
Hourly command (Scheduler PRO Module)   
307
HQX files, importing   96
HTML

br tag   103
editing programs   125
frames with seeMode   114

HTML editor. See editing program
HTML extensions   43
HTML frames

used with webEdition   139
HTML pages

Edit view   92
editing   92
Properties view   92
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HTTP
authentication   46

Http path
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Hyperlink area in images Properties view   86

I
icons

directory   56
for a group   384
for a user   384
images   57
movie   57
object   57, 197
object class   57, 205
plain text   57
search   173
templates   57
webEdition pages   57

ID numbers
in explorer menu   56
purpose   56
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used to display banners   160
ilayer

used to display banners   160
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Image path field   145
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Properties view   85
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Edit   86
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import
existing Web pages   34

Import Wizard
using   74
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Importing
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other   96
PDF   96
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ZIP   96
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data   74
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Information view

in normal mode   58, 66
with documents   66
with images   88
with templates   121

Information view described   200
input boxes

using in templates   101
input field type   169
Inquiry view   401
Standard  3.5.1  December 2005    
installation
User Management Module   373
User Management PRO Module   382
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used in templates   122
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linklists
creating   126

links
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using   165

local files
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logbook
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Action   437
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using   437
login area
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creating   190

M
Mailing list view

described   258
mailing lists

creating
by importing from an E-mail application   264
manually   264
using a CSV file
using the Customer Management Module   264

exporting a CSV file   268
main screen (User Management PRO Module)

accessing   384
tabs and views   384

main screens
Launch Messaging System button   353
Launch Task System button   353
messaging   353
task   353

marked messages ot tasks   360
maximum clicks field   146
maximum views field   145
menus

Help   256
Newsletter   255
Options   256
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creating   361
deleting   372
reading   362
replying to   363
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explained   359

meta tags
Description field   65
Keyword field   65
Title field   65

Meta Tags area in Documents Properties view   
65
Microsoft document files, importing   96
Modules menu   55

Shop Module in   310
modules menu

Customer Management Module   166
Modules preferences view   48
Monthly command (Scheduler PRO Module)   
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Monthly overview

explained   319
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use to display Period area   146

movie
icons   57

MySQL
database architecture   34
default settings   96
upload capacity   96

N
naming

thumbnails   88
navigation control elements   58
navigation system

creating using include feature   136
new users

creating (User Management Module)   377
newsletter

saving   286
sending   286

newsletter campaign
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newsletter layout
attachments   278
document based   274
document field based   275
file based   276
object based   275
object field based   276
text based   277
URL block   278

Newsletter Module
diagnostic functions   254
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explorer menu   256
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HTML   92
JavaScript   92
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views in
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Preview view   59
Properties view   58
Scheduler PRO view   59

Number format setting   311
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deleting   71
icons   57
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object class
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allocating a template for   222
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creating   222
defined   193
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process for   229
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Standard  3.5.1  December 2005    
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Document types   54, 97
Preferences   55

Lists overview   256
Preview   256
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Show logbook   256
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AND/OR command explained   421
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parallel steps   423
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payment providers

linking to   335
transaction model   335
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integration of   335

PDF files, importing   96
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permission to modify customer database   167
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in the Workflow Module.Workflow Module

interaction with the User Management 
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to change a document in the front end   136
Permissions view (User Management PRO 
Module)
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explained   46

photo album
creating templates for   131
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PHP
attributes
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PHP scripts

worktime exceeded   438
php scripts

bannerclick   160, 161
clickscript   160, 161
getBanner   160, 161
getscript   160, 161
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described   146

plain text
icons   57
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about   30
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Preferences
database connections

types of   46
System   49

preferences
accessing for Editor Plug-in   237
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Expert settings   48
HTTP authentication   46
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at startup   238, 241
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HTML extensions   43
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setting   42
start automatically   238
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User interface
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Preview
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Preview view
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with documents   66
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Properties view
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JavaScript   95
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with templates   119
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Scheduler PRO Module   308
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initial   235
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automatic publishing with   303
functions   297
installation   298
Publish after saving requirement   304
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document types   305
functions   297



Index    455
interactions with   59
Publish after saving requirement   308
scheduling a task using   306
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scheduling document publication (Scheduler 
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resetting   359
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interaction with the User Management PRO 
Module
setting start document for a user   386

seeMode
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editing documents in   115
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start document   60
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Quickstart screen   310
shopping cart   346
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page field   147
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purpose of   141
resetting   156
viewing   155
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thumbnails
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sizing   88
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Time settings for webEdition   301
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Unpublished objects   52
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User interface
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