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About this document
Purpose of this document

This document treats the webEdition Customer Management and Customer 
Management PRO Modules and how to use them.

You can use this manual to learn:
• what the Customer Management Modules are
• how to install the modules
• how to use these modules to build and maintain a customer database
• how to create customer registration forms to manage external visitors to your Web 

site

Audience
This document is intended for personnel in the following groups: 
• Web administrators
• Web editors

The webEdition customer documentation suite
The documentation team publishes new webEdition documents to support the release 
of all webEdition features, modules and enhancements. 

You can consult our documentation suite for detailed information about the modules 
you have purchased or about webEdition products that you may wish to purchase in the 
future. All customer documentation is available in portable document format (PDF) on 
the webEdition documentation Web page.

On-line reference documentation
The webEdition customer documentation suite comprises the following books, all of 
which you can obtain at URL: 
http://www.webedition.de/english/downloads/Documentation.html

Standard webEdition documentation
The following books support the webEdition Standard suite:
• The webEdition User Guide 
• The webEdition Installation Guide
• The webEdition Tag Reference
Customer Management and Customer Management PRO Modules
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Documentation for webEdition modules 
The following books support the webEdition modules:
• The Customer Management and Customer Management PRO Module User Guide
• The Database/Object Module User Guide
• The Editor Plug-in User Guide
• The Newsletter Module User Guide
• The Scheduler and Scheduler PRO Module User Guide 
• The Shop Module User Guide 
• The Task Messaging Module User Guide
• The User Management and User Management PRO Module User Guide
• The Workflow Module User Guide

What precautionary messages mean
webEdition documents include attention and caution messages, which are designed to 
draw your attention to important instructions.

Attention boxes
An attention box identifies information that is necessary for the proper performance of 
a specified task. For example:

Caution boxes
Caution messages indicate that there are possible risks to your software or database if 
you perform a specified task without taking the suggested appropriate precautions. For 
example:

How commands, system responses and we:tags are represented
The commands, system responses and webEdition tags (called we:tags) used in this 
document conform to the following conventions.

ATTENTION
You must have the appropriate permissions in your user profile to 
complete this procedure. Permissions are assigned to you by your 
webEdition system administrator. Contact your webEdition system 
administrator for further details.

CAUTION 
Database warning
If you complete this procedure, your database will be 
overwritten.
Standard   03.00   09 February 2004  
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Web interface commands
Commands performed through a Web browser are shown in italic typeface. For 
example:

Click on the Save button.

Menu-based commands performed in a Web browser are shown in italic typeface. 
Drop-down or nested menu commands are separated by an input prompt (>). For 
example:

Select Customers > New from the main menu of the Customer Management Module. 

webEdition tags and template code
The webEdition templates use a specialized set of programming tags based on the PHP 
programming language. These webEdition tags or we:tags are displayed in courier 
typeface and in angled brackets:

Opening tags appear thus: <we:tag/>

Closing tags appear thus: </we:tag>

The programming code used in webEdition templates is also represented in this 
document by courier typeface:

<we:sessionStart/>
<we:ifRegisteredUser>
Hello: <we:sessionField Last name="user name" type="print"/><br> 
Logged in
</we:ifRegisteredUser>

Attribute variables
Attributes and variables appear in courier italic typeface. For example: 

<we:hidden name="attribute1">

How to check the document version and issue
The information on the title page of this document indicates the version and issue for 
this publication. The version and issue also appear in the footer on every 
even-numbered page. 

The first two digits in the document numbering scheme indicate the version. The 
version number increases each time the document is updated to support a new software 
release. For example, the first release of a document is 01.01. In the next software 
release cycle, the first release of the same document is 02.01.

The second two digits in the document numbering scheme indicate the issue. The issue 
number increases each time the document is revised and re-released in the same 
software release cycle. For example, the second release of a document in the same 
software release cycle is 01.02.
Customer Management and Customer Management PRO Modules
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Customer service
For further information about webEdition, please consult our Web page, or contact our 
customer service department:
• Web Page:http://www.webedition.biz/
• E-mail:

— Technical support: technik@webEdition.de
— Sales: sales@webEdition.de
— Information/Help: info@webEdition.de
Standard   03.00   09 February 2004  
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1  Customer Management: Introduction
This introduction is intended to help you familiarize yourself with the webEdition 
Customer Management and Customer Management PRO Modules. This chapter treats 
what the modules do and how to install them. You can also find information here about 
the basic layout and command features for the Customer Management Module. These 
topics are treated in the following sections:
• Section 1.1,  "What is the webEdition Customer Management Module?" on page 15
• Section 1.2,  "Installation" on page 15
• Section 1.3,  "General information and navigation" on page 16

The PRO Module builds upon the standard Customer Management Module and 
therefore the information in this book pertains to both webEdition applications. 
Supplementary material describing the particular features of the Customer Management 
PRO Module is found in Chapter 4,  "The Customer Management PRO Module" on 
page 37.

1.1  What is the webEdition Customer Management Module?
The webEdition Customer Management Module is a database that allows you to register 
and manage external visitors to your web site. (These visitors are called "customers" in 
this document.) The Customer Management Module can manage customer data in two 
ways:
• You can enter customer data manually yourself.
• With the help of a registration form that you have designed for your Web site, 

customers can enter their data themselves. In this case, customers will log in by 
entering their user name and password. This feature allows you to offer registered 
customers an extended selection of information or give them access to areas from 
which non-registered users are barred.

1.2  Installation
The installation procedure for all modules is described in The webEdition Installation, 
Update and Backup Procedures. A .pdf version of this guide is available at the 
following URL: http://www.webedition.de/english/downloads/Documentation.html

Note:  You can also use the webEdition "Live update tool", which is available on the 
webEdition home page at www.webedition.de.
Customer Management and Customer Management PRO Modules



16   Customer Management: Introduction 
1.3  General information and navigation
After installation, you will find a new menu item in the main menu called Modules, 
which contains all the modules in your installation of webEdition (see Figure 1).

Figure 1  Modules drop-down menu

1.3.1  Opening the module
To open the module, select Customer Management from the Modules drop-down menu 
on the webEdition main screen. The Customer Management Quickstart screen opens as 
seen in Figure 2.

Figure 2  Customer Management Module: mainscreen with Quickstart option

Using the Quickstart screen, you have the option of going directly to a new customer 
configuration screen.
Standard   03.00   09 February 2004  
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1.3.1.1  Customer Management explorer menu
The explorer menu displays a list of icons representing the customer data you have in 
your customer database (see Figure 3). You can access and modify the profile for a 
particular customer by double clicking on the icon for that customer.

Figure 3  Customer Management explorer menu

1.3.1.2  Permissions to modify the customer database
The default user has all of the permissions to create, modify and delete the data and data 
fields in the Customer Management database. Additional flexibility is available with the 
User Management Modules.

1.3.1.2.1  Interaction with the User Management Modules    If the Standard 
User Management Module is installed, permission to set up new customers (registered 
visitors to your site), or to modify the fields in the customer database are limited to the 
administrator. If you have installed the User Management PRO Module, the 
administrator can assign to any user the permission to create, delete, edit customer or 
edit customer fields. For more information on the User Management Module, see the 
User Management Module User Guide from the webEdition web site.

1.3.2  The Customer Management menus
The Customer Management Module main screen (as seen in Figure 2,  "Customer 
Management Module: mainscreen with Quickstart option" on page 16) has two 
drop-down menus: Customer and Help, each of which is described in the subsections 
that follow.

1.3.2.1  The Customer drop-down menu
The Customer drop-down menu has the following items (see Figure 4,  "Customer 
drop-down menu" on page 17):

Figure 4  Customer 
drop-down menu

•New. This option opens a 
window that allows you to 
enter data about a new 
customer.
•Save. Use this command to 
save your data.
•Delete. Use this command 
to delete your data.

• Administration > Fields administration. This item opens a window that allows you 
to modify the database parameters used to define your customers.

• End. Use this command to exit the application.
Customer Management and Customer Management PRO Modules
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If you have installed the Customer Management PRO Module, you will see additional 
items in the Customer menu. For details, see Chapter 4,  "The Customer Management 
PRO Module" on page 37.

1.3.2.2  The Help drop-down menu
The Help drop-down menu has the following items (see Figure 5,  "Help pull-down 
menu" on page 18):

Figure 5  Help pull-down menu

•Info. This command provides information about the application.
•Help. This command gives you access to the webEdition help system.

1.3.3  About fields and views in the customer database
You can use the customer database to store and maintain all of your data about your 
customers. Typically such a database would include information under such categories 
as customer name, E-mail address, street address, telephone number, etc. 

1.3.3.1  About views
The webEdition Customer Management Module software is pre-programmed to 
provide you with the following default categories, which are displayed in the module’s 
interface in the following views: General, Other, and All. You are not limited to the 
foregoing default settings. You can modify the database to meet your own needs by 
adding new types of information. You can add, for example, a view for a salutation or 
contact information (see Section 2.4,  "Working with customized views" on page 25). 
In this manner you are free to customize the database to meet the needs of your business 
or organization.

1.3.3.1.1  The General view    The General view provides the basic interface to 
your customer database. You use this view to enter user data about a new customer.

Select Customer > New from the Customer Management Module menu to access the 
default General view (see Figure 6):

The General view has the following fields, each of which allows you to enter a 
customer’s basic data:

Figure 6  General view

•Username
•Password
•Forename
•Surname
•Member since. This is a 
read only-field which tells 
you the date and time the 

user was created in the system.
Standard   03.00   09 February 2004  
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• Last login. This is a read only-field which tells you the date and time the user was 
last logged into the system.

• Last access. This is a read only-field which tells you the date and time the user last 
accessed data from the system.

1.3.3.1.2  Other view    This view is included so that you can add miscellaneous field 
types to a default view without having to create additional views.

1.3.3.1.3  All view    This view displays all your views in succession.

1.3.3.2  About fields
Within each of these categories (views) are the data fields which contain specific 
information about your customer. You can customize these fields to meet your own 
needs. You have the option of expanding all fields and views (with the exception of the 
General data). You can give names to your field, define the field type, and assign default 
values to those fields. (These activities can be performed using the Fields 
administration command, which is discussed in detail in Section 2.3,  "Working with 
fields in the customer database" on page 22).

1.3.3.2.1  Field types    There are five default field types from which you can 
choose. Each can be assigned default values:
• input. This field type creates a text input field suitable for short text entries. You can 

enter a default value in the Default field.

Figure 7  Input text field

• select. This field type creates a select box. The default values that you enter in the 
Default field must be separated by a comma. Each of the comma-separated values 
will appear as an item in your select list.

Figure 8  select field type

• textarea. This field type creates a box in which text can be written. 
Customer Management and Customer Management PRO Modules
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Figure 9  text area field type

• date. This field type creates date and time select boxes.

Figure 10  Date field type

• password. This field type creates a text input box. For reasons of security, characters 
typed by a user in this field are masked. 

Figure 11  Password field type
Standard   03.00   09 February 2004  
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2  Using the customer database
This chapter describes how to use the Customer Management and Customer 
Management PRO Modules to create and manage a customer database. This chapter 
describes how to modify the database to meet the needs of your business or organization 
by adding new fields and views to accomodate different types of customer information.

This chapter describes how to work with the customer database under the following 
sections:
• Section 2.1,  "Creating a new customer using the Customer Management Module" 

on page 21
• Section 2.2,  "Modifying customer data" on page 22
• Section 2.3,  "Working with fields in the customer database" on page 22
• Section 2.4,  "Working with customized views" on page 25

2.1  Creating a new customer using the Customer Management Module
Use the following procedure to create a new customer.

Procedure 1  Creating a new customer

In the Customer Management Module main screen
1 Click Customer  > New.

The system opens the General view , where you can enter basic data about your customer 
(see Figure 12).

Figure 12  New customer: General view
Customer Management and Customer Management PRO Modules
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2 Enter all the customer data in the prescribed fields.
3 Save the data by clicking on the Save button at the bottom of the page.

webEdition confirms that the customer data was saved. Click OK. An icon representing the 
newly created customer appears in the explorer menu. The customer can now log onto the 
home page using the login you have assigned.

Figure 13  New customer icon in the explorer menu

Note:  To find out how to create the login mask, go to our documentation page at 
http://www.webedition.de/english/downloads/Documentation.html, and consult the 
publication titled The webEdition User Guide. 

4 You have completed this procedure.

2.2  Modifying customer data
You can modify the data for a customer by double clicking the icon listed in the explorer 
menu that signifies your customer. Thereafter, you can toggle among the tabs on the 
main screen to add or access information about the customer.

2.3  Working with fields in the customer database
The Customer Management Module allows you to change fields using the Fields 
administration feature. The following sections describe procedures for working with 
fields.

2.3.1  Adding fields to the customer database
The following procedure shows you how to add new field names to the default customer 
management database so that you can customize it for your own needs.

Procedure 2  Adding field names to the default customer database

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 14).

ATTENTION
Once you insert (or delete) field names, they will be accessible (or 
deleted) for all customers. 
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Figure 14  Fields administration screen

2 You must associate a field with an existing view. Use the Select view  select box to choose 
a view. (If you wish to create a new view first, see Section 2.4,  "Working with customized 
views" on page 25).

3 Click the Add button adjacent to the Fields area.
The Add field dialogue box appears.

Figure 15  Add field dialogue box

4 Enter a field name, select a field type from the select box, and enter a default value. (For 
information about field types, see Section 1.3.3.2.1,  "Field types" on page 19).

5 Click on the Save button.
The new field appears in the Fields list on the Fields administration screen.

Figure 16  New customer field
Customer Management and Customer Management PRO Modules
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6 You have completed this procedure.

2.3.2  Modifying fields in the customer database

Procedure 3  Changing the properties of a field

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 14,  "Fields administration screen" on 
page 23).

2 Use the Select view select box to choose the view which has the field you wish to change.
3 In the Fields area, highlight the name of the field you wish to change. See, for example, 

Figure 16,  "New customer field" on page 23.
4 Click the Edit button adjacent to the Fields area.

The Edit field dialogue box appears.

Figure 17  Edit field dialogue box

5 Change a field name, field type or default value.
6 Click on the Save button.

The modified field appears in the Fields area on the Fields administration screen.

Figure 18  Edited customer field

7 You have completed this procedure.
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2.3.3  Deleting a field

Procedure 4  Deleting the name of a view

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 14,  "Fields administration screen" on 
page 23).

2 Use the Select view select box to choose the view which has the field you wish to change.
3 In the Fields area, highlight the name of the field you wish to delete.
4 Click the Delete button.

webEdition asks you if you want to delete the chosen field.

5 Click the OK button to delete the field(s).
The system confirms the action. Click the OK button again.

Note:  If you delete the last field in a selected view, you will also delete the view.

6 Click on the Close button.
7 You have completed this procedure.

2.4  Working with customized views 
The Customer Management Module allows you to manage field types arranged in 
views. Using the Fields administration feature, you can create new views and new 
fields for each view. The following views are predefined and cannot be changed or 
deleted: General, Other, All.

2.4.1  Creating a new view 

Procedure 5  Creating a new view

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 14,  "Fields administration screen" on 
page 23).

2 To create a new view, enter a name for the new view in the View  field.
3 Click the Add button adjacent to the Fields area.

The Add field dialogue box appears.

4 Enter a field name, field type and default value and click OK.

Note:  You must create at least one field for your view.
A new view has been created. The new view name appears in the View field and also in the 
Select view select box (see Figure 19).
Customer Management and Customer Management PRO Modules
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Figure 19  Creating a new view

5 Click on the Close button.
A new tab for the view appears on the Customer Management main screen.

Figure 20  New customer tab and view

6 You have completed this procedure.

2.4.2  Editing a view

Procedure 6  Editing the name of a view

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 14,  "Fields administration screen" on 
page 23).

2 Click the pencil icon adjacent to the Select view select box.
The Edit view dialogue box appears.
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Figure 21  Edit view dialogue box

3 Enter a new name in the Name field.
4 Click the Save button.

A new name for the view appears in the View field and in the Select view select box.

Figure 22  Edited customer view tab

5 Click on the Close button.
The newly-named tab for the view appears on the Customer Management main screen.

Figure 23  Renamed customer view tab

6 You have completed this procedure.

2.4.3  Deleting a view

Procedure 7  Deleting a view

In the Customer Management Module main screen
1 Click Customer > Administration > Fields administration.

The Fields administration screen opens (see Figure 14,  "Fields administration screen" on 
page 23).

2 Highlight each of the fields in the Fields area.
3 Click the Delete button.

webEdition asks you if you want to delete the chosen field.

4 Click the OK button to delete the field(s).
The system confirms the action. Click the OK button again.

5 Click on the Close button.
Customer Management and Customer Management PRO Modules
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Once you have removed all fields associate with the view, the view and its tab disappear 
from the Customer Management main screen.

6 You have completed this procedure.
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3  Designing templates for the Customer 
Management Modules

In order to make your website accessible to registered users (or customers as we refer 
to them), you must insert the appropriate we:tags into your templates. This chapter 
shows you how to use webEdition tags (we:tags) to do the following actions:
• create registration forms so that external users can register as "customers"
• create login areas for your customers on your web site
• make information accessible only to logged-in users or customers.

The we:tags discussed in this chapter pertain to both versions of the Customer 
Management Module, hence this chapter is intended for users of both the Customer 
Management and the Customer Management PRO modules.

Those using this chapter are expected to have a knowledge of template development and 
we:tags. Moreover, webEdition users must have either administrative priveleges, or 
have the permissins to create and deploy templates in order to manage customer access.

3.1  Creating registration forms
You use a registration form to create registered users (or customers) on your web site. 
By registering visitors to your web site, you can make information available to them that 
unregistered users cannot see or access.

To create a registration form, you use the <we:sessionField/> tag. This we:tag works 
closely with the Customer Management Module. The <we:sessionField> tag draws 
fields from the Customer Management Module and places them on a Web page. 

For example, in your Customer database, if you have the field "Contact_Email", which 
is designed for the E-mail addresses of your customers, you can display this field value 
with the <we:sessionField tag> by adding the following variables: <we:sessionField 
name="Contact_Email" type="textinput"/>. This tag will produce one input box for the 
customer E-mail on the page. All field names that are in the Customer Management 
database can be used as variables with the <we:sessionField/> tag. These variables can 
be initially entered, changed or deleted by using a form containing the 
<we:sessionField..../> tag with the corresponding variable(s).

Procedure 8  Creating a registration form

In the Templates view of the webEdition main screen
1 If you are not already in the Templates view, go there by clicking on the Templates tab.
Customer Management and Customer Management PRO Modules



30   Designing templates for the Customer Management Modules 
2 Open a new template by selecting File > New > Template.
3 Go to the Properties view by clicking on the Properties tab (see Figure 24).

Figure 24  The Properties view

4 In the Path area, enter a name for the file in the Filename field, and a select a directory. 
5 Click Save.

Your new template appears in the explorer menu.

Note:  Your template will have a .tmpl file extension.

6 Click the Edit tab to open the Templates Edit view (see Figure 25).

Figure 25  Template Edit view

7 Click on the Show Tag Wizard arrow. In the Tag Wizard area, use the scroll bar to find 
sessionField tag (see Figure 26). Click the sessionField tag to highlight it.
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Figure 26  we:Tag Wizard: sessionField

8 Click the arrow to the right of the select box to open a dialogue box for the 
<we:sessionField> tag.
A "we:sessionField" dialogue box opens (see Figure 27).

Figure 27  we:sessionField dialogue box

9 Choose a value from the name attribute select box. You will see all the default field names 
(and any that you have added in the Customer Management Module) that are available for 
your form (see Figure 28).

Figure 28  Available field names for your form
Customer Management and Customer Management PRO Modules
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10  Choose the type of input field from the type select box.
11 Click Save.

The dialogue box closes and you are returned to the Edit view. The <we:session> tag with 
your newly defined attribute appears in the right -hand portion of the Tag Wizard (see Figure 
29).

Figure 29  The sessionField tag with defined attributes

12 Using your mouse, cut the newly defined tag from the right side of the Tag Wizard and paste 
it into your template. (You can also edit and add any accompanying text to the template at 
this time.)

Figure 30  The sessionField tag used in a template

13 Click Save.
14 Click on the Preview tab to view the changes to your template. 

Figure 31  Preview of 

15 You have completed this procedure.
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3.2  Creating a form to register a new customer
To allow visitors to your site to register as a new customer, you need to create a link on 
your Web site that points to a form where all required fields (or all fields listed in the 
customer management database) are called up with the <we:sessionField/> tag. Once 
the visitor has entered all the required information, the form can be saved so that all data 
will be written to the database. Thereafter the visitor becomes a “customer” and can log 
in with a user name and password. From this point on, you can view and change the data 
associated with this customer using the Customer Management Module. 

3.2.1  Designing registration forms: code example
You can design registration forms with the following we:tags:

<we:sessionStart/>
<we:saveRegisteredUser/>
<html>
<head>
  <we:title>webEdition Default-template</we:title>
  <we:description>Form</we:description>
  <we:keywords>webEdition, cms, </we:keywords>
</head>
<body>
Please enter your personal data:<br>
<we:form id="self">
  Username: <we:sessionField name="Username" type="textinput"/><br>
  Password: <we:sessionField name="Password" type="password"/><br>
  Forename: <we:sessionField name="Forename" type="textinput"/><br>
  Surname: <we:sessionField name="Surname" type="textinput"/><br>
  <we:sessionField name="ID" type="hidden"/>
  <input type="submit" value="go">
</we:form>
</body>
</html>

Figure 32 shows the output from the code noted above.

Figure 32  Example of form output

3.2.2  Explanation of code
It is essential that forms in which changes are to be made to the data always contain the 
following type of hidden field: <we:sessionField Last name="ID" type="hidden"> This 
field ensures that the session created by the <we:sessionStart/> tag is also transmitted 
and the customer is uniquely identified. The data cannot be assigned without this 
session. The following page must begin with: 
<we:sessionStart/><we:saveRegisteredUser/>. Aside from these tag conventions, you 
have complete freedom with the layout of your form.
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3.3  Creating a login area for your customers
The webEdition Customer Management Module gives you the capability to create a 
section on your Web site where your customers can log in to your site. By doing so, you 
can make whole pages or entire sections of your site accessible only to registered users.

The following sub-sections describe how to 
• generate a login section where a user can log in
• make information accessible only to logged-in users

3.3.1  Generating a login section: code example
The following code is an example of how to design a template to allow customers to log 
in to your Web site:

<we:sessionStart/>
Please log in with your user name and password
<we:a id="self">New user</we:a>
<br>
<we:form id="self">
Username: <we:sessionField name="Username" type="textinput"/><br>
Password: <we:sessionField name="Password" type="password"/><br>
<input type="submit" value="go">
</we:form>

Figure 33 shows the output from the code noted above.

Figure 33  Example of login form

3.3.2  Making information accessible only to logged-in users: code example
You can make whole pages or entire sections accessible only to registered users. You 
can implement this function by using the <we:ifRegisteredUser/> tag:

<we:sessionStart/>
<we:ifRegisteredUser>
Hello: <we:sessionField Last name="user name" type="print"/><br>
Logged in
</we:ifRegisteredUser>

3.3.2.1  Explanation of code
For all functions that you wish to control from the Customer Management Module, you 
must always include the <we:sessionStart/> tag. This tag must appear at the very 
beginning of every page that has anything to do with the Customer Management 
Module, before any other (html) tag (e.g.<html> or <body>).

The code queries whether a user is registered. If so, the user will be greeted with "Hello, 
user name". User name is a placeholder for the visitor’s actual user name as entered in 
the system.
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You can decide what is written between the <we:ifRegisteredUser> and 
</we:ifRegisteredUser> tags. It can be individual information, features, links to other 
pages, navigation or any other functions.

3.4  Creating a form to allow a customer to modify their existing 
registration data

In order to allows a customer to modify their existing registration data, you need to 
create a form that is identical to the one described in Section 3.2,  "Creating a form to 
register a new customer" on page 33, but which is located in an area of your site that can 
only be accessed by registered customers. Because this user is already registered, the 
registration information will always be called up via the <we:sessionStart/> tag. When 
the customer accesses the form, the existing data in the database will automatically be 
written to the form fields. Thereafter the customer can modify and save his/her 
registration information.
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4  The Customer Management PRO 
Module

The webEdition Customer Management PRO Module builds upon the standard 
Customer Management Module. The information in this book pertains to both of these 
webEdition applications (thus users of the PRO module must read the previous chapters 
of this manual for basic information about the features in the standard Customer 
Management Module). This chapter provides supplementary material describing the 
particular features of the Customer Management PRO Module.

4.1  What is the webEdition Customer Management PRO Module?
The Customer Management PRO Module allows you to perform all of the same 
functions as the Customer Management Module. In addition to the basic functions, the 
PRO module gives you enhanced abilities to manage your database by allowing you to:
• Sort your customers 
• Search for customers

4.2  General information and navigation
After installation, you will find a new menu item in the webEdition main screen called 
Modules, which contains all the modules in your installation of webEdition (see Figure 
34).

Figure 34  Modules drop-down menu

4.2.1  Customer Management PRO explorer menu
Like the standard Customer Management Module, the explorer menu in the PRO 
Module displays a list of icons representing the customer data you have in your 
customer database. There are two additional features visible in the PRO Module 
explorer menu (see Figure 35):
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Figure 35  Customer Management PRO explorer menu

•Sort feature. At the top of the explorer menu is the sort 
feature. The sort feature has a select box where you can 
choose from your defined sort profiles, and a pencil icon 
where you can create and/or edit the your parameters for 
your existing sort profiles. 
•Search feature. At the bottom of the explorer menu is 
the search feature which consists of a search field, and a 
search icon.

4.2.2  The Customer drop-down menu
Click on Modules > Customer management to open the Customer Management Module 
main screen (see Figure 36).

Figure 36  Customer Management main screen

In addition to those items described in Section 1.3.2.1,  "The Customer drop-down 
menu" on page 17, The Customer menu in the PRO Module has the following items (see 
Figure 37):
• Administration. The PRO Module offers two administrative features.

— Fields administration.
— Sort administration.

• Search. Use this item to access the module’s search engine 
• Settings. This item allows you to set your default sort view and your Start year for 

date sorting.
Standard   03.00   09 February 2004  



The Customer Management PRO Module   39
Figure 37  Customer drop-down menu in the PRO Module

4.2.3  Using the Search function
The Customer Management PRO Module offers advanced search capabilities, allowing 
you to find and manage the data for your customers.

You can access the search feature in the following ways:
• Click on Customer > Search
• Use the simple search option at the bottom of the explorer menu.

Procedure 9  Using the search feature

In the Customer Management Module main screen
1 Click on Customer > Search or enter a name for a customer in the search field at the bottom 

of the explorer menu and click the search icon (represented by a magnifying glass).
The Search window opens (see Figure 38).

Figure 38  Search window

2 Two types of searches are possible. Do one of the following steps:
a Simple search. 

To perform a simple search, enter the text string in the Search for field.
b Advanced search.

i Click the right arrow icon beside Advanced search.
The Advanced search fields appear as seen in Figure 39.

Figure 39  Advanced search

ii Select your search parameters from the select boxes. 
• In the first select box, choose one of the views that you have defined.
• In the second select box, choose from the fields that you have defined within 

the view.
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• In the third select box, choose a search operator.
• Enter a parameter in the text field.

3 Click the search icon (magnifying glass).
If the system finds a match for your search, the item will appear in the Result box (see 
Figure 40).

Figure 40  The Search Result box

4 To access or edit the data for an item found in the Search Result box, double click on the 
item.
webEdition opens the editing area for the customer, where you can modify the data in the 
General, Other and All views, and also those additional views (such as Salutation or 
Contact) that you have created.

5 You have completed this procedure.

4.2.4  Using the Sort function 
The Customer Management PRO Module offers advanced sorting capabilities, allowing 
you to create and save multiple sort profiles so that you can manage the data for your 
customers.

You access the sort feature by selecting an item from the sort select box at the top of the 
explorer menu. You can edit your sort parameters by clicking the edit (pencil) icon 
adjacecnt to the sort select box, or by clicking Customer > Administration > Sort 
administration.

Note:  The first time you log in to the system, there are no sort parameters defined. 
The select box has —No Sort—.

Procedure 10  Using the sort feature

In the Customer Management Module main screen
1 Click Customer > Administration > Sort administration.

The Sort administration screen opens. The first time that you use this feature, the system 
displays a plus icon.

Figure 41  Sort administration screen

2 Click on the plus (+) icon to activate Insert new group. 
The Sort area opens (see Figure 42).
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Figure 42  Sort area

3 Type a name to identify your sort group in the Name field.
4 Click the plus (+) icon to add your sort parameters. Choose the sort parameters in 

accordance with the way you wish to arrange and access your customer data.There are 
four areas, each is represented by a select box. The views, fields and functions that are 
available are determined by the views and fields that you have defined for your Customer 
Management database (see Section 2.4.1,  "Creating a new view" on page 25).
a View. Sort according to view.
b Field. The available fields are determined by the view you have chosen.
c Function. The available functions vary depending on the field type that characterises 

the field you have chosen. For example text, can be sorted by alphabetical order; dates 
by day, moth, year (etc.). 

d Order. Use this command to choose to display your sort results in ascending (ASC) and 
descending (DESC) order.

Figure 43  Sort parameters selected

5 Click Save.
The system shows you a confirmation message.

6 Click OK.
The sort group you have created appears in the sort select box in the explorer menu.

7 Click on your newly created sort group.
Your customers appear in folders that coform to the parametes you have set.
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Figure 44  New sort group

8 You have completed this procedure.
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